Re: [PATCHv2] ata: sata_mv: use devm clock helpers

Damien Le Moal <[email protected]> Sat, 18 Jul 2026 12:01:34 +0900
Newsgroups org.kernel.vger.linux-ide,org.kernel.vger.linux-kernel
Organization Western Digital Research
Message-ID <[email protected]>
On 7/13/26 07:37, Rosen Penev wrote:
> Replace clk_get/clk_prepare_enable/clk_put with
> devm_clk_get_optional_enabled for both the main clock and
> per-port clocks. This eliminates the need for manual clock
> cleanup in probe error and remove paths.
> 
> The err label is retained for phy_power_off cleanup, since
> devm_phy_optional_get does not manage phy power state.
> 
> Assisted-by: opencode:big-pickle
> Signed-off-by: Rosen Penev <[email protected]>

Applied to for-7.3. Thanks!

-- 
Damien Le Moal
Western Digital Research