Re: [PATCH] x86/cpu: Rewrite initialize_cpu_data() for clarity
Jan Beulich <[email protected]>
| Newsgroups | org.xenproject.lists.xen-devel |
|---|---|
| Message-ID | <[email protected]> |
On 13.08.2026 16:53, Andrew Cooper wrote: > Without passing opinion on the behaviour of this function, it is deceptive to > read (I've twice now mistaken it for resetting boot_cpu_data), and > inefficient. > > Instead of having a 256 byte object on the stack and a double copy, copy > boot_cpu_data directly, then reset parts of cpu_data[cpu] in place. Leave > some comments behind explaining what's happening. > > No functional change. > > Signed-off-by: Andrew Cooper <[email protected]> While I think it was good enough before, I also don't mind the change: Acked-by: Jan Beulich <[email protected]> Jan