dev.linux.lists.driver-core archive

798 archived articles, newest first (page 4 of 8). Latest articles →

Re: [PATCH v2] rust: io: Add a BigEndianMmio wrapper
Thu, 06 Aug 2026 12:44:31 +0100
"Gary Guo" <[email protected]> • #5644
Re: [PATCH] rust: dma: add `Range` type
Thu, 6 Aug 2026 12:23:32 +0100
Robin Murphy <[email protected]> • #5643
Re: [PATCH v2 3/3] debugfs: make debugfs_create_str() read-only
Thu, 6 Aug 2026 11:02:56 +0200
Greg KH <[email protected]> • #5642
Re: [PATCH v2 2/3] soundwire: debugfs: replace writable string helper
Thu, 6 Aug 2026 11:02:04 +0200
Greg KH <[email protected]> • #5641
Re: [PATCH v2 1/3] interconnect: debugfs: replace writable string helper
Thu, 6 Aug 2026 11:01:07 +0200
Greg KH <[email protected]> • #5640
[PATCH v2 3/3] debugfs: make debugfs_create_str() read-only
Thu, 6 Aug 2026 16:48:54 +0800
Yichong Chen <[email protected]> • #5639
[PATCH v2 2/3] soundwire: debugfs: replace writable string helper
Thu, 6 Aug 2026 16:48:53 +0800
Yichong Chen <[email protected]> • #5638
Re: [PATCH] drivers/base, mm: move arch_numa.c to mm/
Thu, 6 Aug 2026 09:52:44 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #5634
[PATCH] rust: dma: add `Range` type
Thu, 06 Aug 2026 09:46:14 +0200
Vasileios Almpanis <[email protected]> • #5633
Re: [PATCH] drivers/base, mm: move arch_numa.c to mm/
Thu, 6 Aug 2026 10:16:48 +0300
Mike Rapoport <[email protected]> • #5632
Re: [PATCH] drivers/base, mm: move arch_numa.c to mm/
Thu, 6 Aug 2026 08:06:12 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #5631
Re: [PATCH] drivers/base, mm: move arch_numa.c to mm/
Thu, 6 Aug 2026 09:03:35 +0200
Greg Kroah-Hartman <[email protected]> • #5630
[PATCH] drivers/base, mm: move arch_numa.c to mm/
Thu, 06 Aug 2026 09:58:38 +0300
"Mike Rapoport (Microsoft)" <[email protected]> • #5629
Re: [PATCH v2 2/3] rust: platform: wire runtime PM callbacks
Thu, 6 Aug 2026 06:45:01 +0000
Alice Ryhl <[email protected]> • #5628
Re: [PATCH v2 1/3] rust: add runtime PM support
Thu, 6 Aug 2026 06:41:36 +0000
Alice Ryhl <[email protected]> • #5627
[PATCH v2] rust: io: Add a BigEndianMmio wrapper
Thu, 6 Aug 2026 08:22:04 +0200
Link Mauve <[email protected]> • #5626
Re: [PATCH v5 25/36] mm/memory_hotplug: support N_MEMORY_PRIVATE node hotplug
Thu, 6 Aug 2026 11:30:08 +0800
Qiqi Li <[email protected]> • #5625
Re: [PATCH] rust: io: Add a BigEndianMmio wrapper
Wed, 05 Aug 2026 18:41:31 -0700
Ethan Plant <[email protected]> • #5624
Re: [PATCH v7 0/8] Transition Nova Core to TLV firmware images
Thu, 6 Aug 2026 02:12:48 +0200
Danilo Krummrich <[email protected]> • #5623
[syzbot] [kernel?] general protection fault in regmap_get_i2c_bus
Wed, 05 Aug 2026 15:46:38 -0700
syzbot <[email protected]> • #5622
[syzbot] [acpi?] general protection fault in software_node_register
Wed, 05 Aug 2026 15:45:25 -0700
syzbot <[email protected]> • #5621
[PATCH] rust: io: Add a BigEndianMmio wrapper
Thu, 6 Aug 2026 00:21:09 +0200
Link Mauve <[email protected]> • #5620
[PATCH 3/3] gpu: nova-core: gsp: map the WPR meta for streaming DMA
Wed, 05 Aug 2026 23:54:43 +0200
Maurice Hieronymus <[email protected]> • #5619
[PATCH 2/3] rust: dma: add abstraction for the single-buffer streaming DMA API
Wed, 05 Aug 2026 23:54:42 +0200
Maurice Hieronymus <[email protected]> • #5618
[PATCH 0/3] rust: dma: add the single-buffer streaming DMA API
Wed, 05 Aug 2026 23:54:40 +0200
Maurice Hieronymus <[email protected]> • #5617
[PATCH 1/3] rust: dma: add ContiguousBuffer trait for streaming DMA storage
Wed, 05 Aug 2026 23:54:41 +0200
Maurice Hieronymus <[email protected]> • #5616
Re: [PATCH v2 2/2] rust: io: gate ioremap doctests on CONFIG_HAS_IOMEM
Wed, 05 Aug 2026 23:40:17 +0200
"Arnd Bergmann" <[email protected]> • #5615
Re: [PATCH v2 1/2] rust: io: gate ioremap/iounmap on CONFIG_HAS_IOMEM
Wed, 05 Aug 2026 23:39:35 +0200
"Arnd Bergmann" <[email protected]> • #5614
[PATCH v2 2/2] rust: io: gate ioremap doctests on CONFIG_HAS_IOMEM
Wed, 5 Aug 2026 23:28:36 +0200
Danilo Krummrich <[email protected]> • #5613
[PATCH v2 1/2] rust: io: gate ioremap/iounmap on CONFIG_HAS_IOMEM
Wed, 5 Aug 2026 23:28:35 +0200
Danilo Krummrich <[email protected]> • #5612
Re: [PATCH v2 2/3] rust: dma: rename dma_handle to dma_address
Wed, 05 Aug 2026 22:39:50 +0200
"Danilo Krummrich" <[email protected]> • #5611
Re: [PATCH v7] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
Wed, 05 Aug 2026 20:29:21 +0200
Andreas Hindborg <[email protected]> • #5610
Re: [PATCH 00/15] Device Evidence and Trust for PCI Security Protocol (TDISP)
Thu, 6 Aug 2026 01:43:30 +0800
Xu Yilun <[email protected]> • #5609
Re: [PATCH v6] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
Wed, 5 Aug 2026 19:20:45 +0200
Miguel Ojeda <[email protected]> • #5608
Re: [PATCH v2 08/16] drm/tyr: specify base type for registers
Wed, 05 Aug 2026 17:59:09 +0100
"Gary Guo" <[email protected]> • #5607
[PATCH v2 16/16] rust: io: register: unify handling of register with/without bitfields
Wed, 05 Aug 2026 17:35:59 +0100
Gary Guo <[email protected]> • #5606
[PATCH v2 10/16] rust: io: register: make register have a typed base
Wed, 05 Aug 2026 17:35:53 +0100
Gary Guo <[email protected]> • #5605
[PATCH v2 15/16] rust: io: register: remove `Register` trait and cleanup macro
Wed, 05 Aug 2026 17:35:58 +0100
Gary Guo <[email protected]> • #5604
[PATCH v2 11/16] rust: io: register: support fixed offset register without bitfield
Wed, 05 Aug 2026 17:35:54 +0100
Gary Guo <[email protected]> • #5603
[PATCH v2 14/16] rust: io: register: remove relative registers
Wed, 05 Aug 2026 17:35:57 +0100
Gary Guo <[email protected]> • #5602
[PATCH v2 09/16] samples: rust: pci: specify base type for registers
Wed, 05 Aug 2026 17:35:52 +0100
Gary Guo <[email protected]> • #5601
[PATCH v2 07/16] gpu: nova-core: specify base type for registers
Wed, 05 Aug 2026 17:35:50 +0100
Gary Guo <[email protected]> • #5600
[PATCH v2 08/16] drm/tyr: specify base type for registers
Wed, 05 Aug 2026 17:35:51 +0100
Gary Guo <[email protected]> • #5599
[PATCH v2 12/16] gpu: nova-core: use projection for PFALCON and PFALCON2 registers
Wed, 05 Aug 2026 17:35:55 +0100
Gary Guo <[email protected]> • #5598
[PATCH v2 06/16] rust: io: register: allow explicit base type specification
Wed, 05 Aug 2026 17:35:49 +0100
Gary Guo <[email protected]> • #5597
[PATCH v2 05/16] rust: io: register extract offset computation to helper rules
Wed, 05 Aug 2026 17:35:48 +0100
Gary Guo <[email protected]> • #5596
[PATCH v2 13/16] gpu: nova-core: convert hshub0 from relative register to projection
Wed, 05 Aug 2026 17:35:56 +0100
Gary Guo <[email protected]> • #5595
[PATCH v2 04/16] rust: io: register: handle one register at a time
Wed, 05 Aug 2026 17:35:47 +0100
Gary Guo <[email protected]> • #5594
[PATCH v2 00/16] rust: io: support register projections and remove relative registers
Wed, 05 Aug 2026 17:35:43 +0100
Gary Guo <[email protected]> • #5593
[PATCH v2 03/16] rust: io: support register projections
Wed, 05 Aug 2026 17:35:46 +0100
Gary Guo <[email protected]> • #5592
[PATCH v2 02/16] rust: io: add `IoRepr` trait
Wed, 05 Aug 2026 17:35:45 +0100
Gary Guo <[email protected]> • #5591
[PATCH v2 01/16] rust: io: add static `cast()` method for views
Wed, 05 Aug 2026 17:35:44 +0100
Gary Guo <[email protected]> • #5590
Re: `io{re,un}map()` build error in s390 under `!CONFIG_HAS_IOMEM`
Wed, 05 Aug 2026 17:56:55 +0200
"Arnd Bergmann" <[email protected]> • #5589
Re: `io{re,un}map()` build error in s390 under `!CONFIG_HAS_IOMEM`
Wed, 05 Aug 2026 17:36:13 +0200
Niklas Schnelle <[email protected]> • #5588
Re: `io{re,un}map()` build error in s390 under `!CONFIG_HAS_IOMEM`
Wed, 05 Aug 2026 17:08:54 +0200
"Danilo Krummrich" <[email protected]> • #5587
Re: [PATCH v2 2/3] rust: dma: rename dma_handle to dma_address
Wed, 5 Aug 2026 12:32:28 +0100
Robin Murphy <[email protected]> • #5586
Re: [PATCH 01/12] rust: io: add Region::try_subregion
Wed, 05 Aug 2026 11:43:08 +0100
"Gary Guo" <[email protected]> • #5585
Re: [PATCH v6] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
Wed, 05 Aug 2026 11:26:34 +0200
Andreas Hindborg <[email protected]> • #5584
Re: [PATCH] debugfs: serialize debugfs_create_str() writers
Wed, 5 Aug 2026 10:00:05 +0200
Greg KH <[email protected]> • #5583
[PATCH] firmware_loader: Reject 0-size firmware in batched requests
Wed, 5 Aug 2026 07:05:16 +0000 (UTC)
"syzbot" <[email protected]> • #5582
Re: [PATCH v2 1/3] gpu: nova-core: falcon: remove unnecessary check
Wed, 5 Aug 2026 00:02:31 -0700
Ethan Plant <[email protected]> • #5581
[PATCH 12/12] gpu: nova-core: mm: Add PRAMIN aperture self-tests
Wed, 05 Aug 2026 14:44:59 +0900
Eliot Courtney <[email protected]> • #5580
[PATCH 11/12] gpu: nova-core: Add self-test assertion macros and config option
Wed, 05 Aug 2026 14:44:58 +0900
Eliot Courtney <[email protected]> • #5579
[PATCH 10/12] gpu: nova-core: mm: Add GpuMm centralized memory manager
Wed, 05 Aug 2026 14:44:57 +0900
Eliot Courtney <[email protected]> • #5578
[PATCH 09/12] docs: gpu: nova-core: Document the PRAMIN aperture mechanism
Wed, 05 Aug 2026 14:44:56 +0900
Eliot Courtney <[email protected]> • #5577
[PATCH 08/12] gpu: nova-core: mm: Add support to use PRAMIN windows to write to VRAM
Wed, 05 Aug 2026 14:44:55 +0900
Eliot Courtney <[email protected]> • #5576
[PATCH 07/12] gpu: nova-core: mm: Add the memory management HAL
Wed, 05 Aug 2026 14:44:54 +0900
Eliot Courtney <[email protected]> • #5575
[PATCH 06/12] gpu: nova-core: mm: Add PRAMIN window registers
Wed, 05 Aug 2026 14:44:53 +0900
Eliot Courtney <[email protected]> • #5574
[PATCH 05/12] gpu: nova-core: mm: Implement Alignable and Debug for VramAddress
Wed, 05 Aug 2026 14:44:52 +0900
Eliot Courtney <[email protected]> • #5573
[PATCH 04/12] gpu: nova-core: mm: Add VramAddress type
Wed, 05 Aug 2026 14:44:51 +0900
Eliot Courtney <[email protected]> • #5572
[PATCH 03/12] rust: num: add Bounded::shr_exact
Wed, 05 Aug 2026 14:44:50 +0900
Eliot Courtney <[email protected]> • #5571
[PATCH 02/12] rust: num: reject Bounded::shr overshifts at build time
Wed, 05 Aug 2026 14:44:49 +0900
Eliot Courtney <[email protected]> • #5570
[PATCH 01/12] rust: io: add Region::try_subregion
Wed, 05 Aug 2026 14:44:48 +0900
Eliot Courtney <[email protected]> • #5569
[PATCH 00/12] gpu: nova-core: add PRAMIN window support
Wed, 05 Aug 2026 14:44:47 +0900
Eliot Courtney <[email protected]> • #5568
[PATCH v2 3/3] gpu: nova-core: falcon: use I/O projection to check transfer bounds
Wed, 05 Aug 2026 14:01:47 +0900
Alexandre Courbot <[email protected]> • #5567
[PATCH v2 2/3] rust: dma: rename dma_handle to dma_address
Wed, 05 Aug 2026 14:01:46 +0900
Alexandre Courbot <[email protected]> • #5566
[PATCH v2 1/3] gpu: nova-core: falcon: remove unnecessary check
Wed, 05 Aug 2026 14:01:45 +0900
Alexandre Courbot <[email protected]> • #5565
[PATCH v2 0/3] gpu: nova-core: falcon: use I/O projections for DMA transfers
Wed, 05 Aug 2026 14:01:44 +0900
Alexandre Courbot <[email protected]> • #5564
Re: [PATCH 00/15] Device Evidence and Trust for PCI Security Protocol (TDISP)
Tue, 4 Aug 2026 21:55:33 -0300
Jason Gunthorpe <[email protected]> • #5563
Re: [PATCH v2] rust: irq: make Registration compatible with lifetime-bound drivers
Tue, 4 Aug 2026 23:39:16 +0200
Danilo Krummrich <[email protected]> • #5562
Re: [PATCH 00/15] Device Evidence and Trust for PCI Security Protocol (TDISP)
Tue, 4 Aug 2026 20:33:35 +0000
Ankit Agrawal <[email protected]> • #5561
[PATCH 7/7] rust: workqueue: add ScopedWork for non-'static work items
Tue, 4 Aug 2026 21:52:09 +0200
Danilo Krummrich <[email protected]> • #5560
[PATCH 6/7] rust: workqueue: add Work::cancel_work_sync()
Tue, 4 Aug 2026 21:52:08 +0200
Danilo Krummrich <[email protected]> • #5559
[PATCH 5/7] rust: workqueue: add ScopedQueue for lifetime bound items
Tue, 4 Aug 2026 21:52:07 +0200
Danilo Krummrich <[email protected]> • #5558
[PATCH 4/7] rust: workqueue: add creation of workqueues
Tue, 4 Aug 2026 21:52:06 +0200
Danilo Krummrich <[email protected]> • #5557
[PATCH 3/7] rust: workqueue: create workqueue subdirectory
Tue, 4 Aug 2026 21:52:05 +0200
Danilo Krummrich <[email protected]> • #5556
[PATCH 2/7] rust: workqueue: restrict delayed work to global wqs
Tue, 4 Aug 2026 21:52:04 +0200
Danilo Krummrich <[email protected]> • #5555
[PATCH 1/7] rust: workqueue: replace deprecated system_wq with system_{percpu,dfl}_wq
Tue, 4 Aug 2026 21:52:03 +0200
Danilo Krummrich <[email protected]> • #5554
[PATCH 0/7] workqueue OwnedQueue, ScopedQueue and ScopedWork
Tue, 4 Aug 2026 21:52:02 +0200
Danilo Krummrich <[email protected]> • #5553
Re: [syzbot] [fs?] general protection fault in __simple_recursive_removal (2)
Tue, 04 Aug 2026 10:15:39 -0700
syzbot <[email protected]> • #5552
Re: [PATCH v7 3/8] gpu: nova-core: add TLV parser for firmware files
Tue, 4 Aug 2026 17:10:24 +0000
Timur Tabi <[email protected]> • #5551
Re: `io{re,un}map()` build error in s390 under `!CONFIG_HAS_IOMEM`
Tue, 04 Aug 2026 17:52:14 +0200
"Arnd Bergmann" <[email protected]> • #5550
Re: [PATCH] firmware_loader: do not queue completed sysfs fallback requests
Tue, 4 Aug 2026 18:59:08 +0530
Mukesh Ojha <[email protected]> • #5549
Re: [PATCH v2 2/3] rust: platform: wire runtime PM callbacks
Tue, 4 Aug 2026 14:28:19 +0200
Beata Michalska <[email protected]> • #5548
Re: [PATCH v2 1/3] rust: add runtime PM support
Tue, 4 Aug 2026 14:27:55 +0200
Beata Michalska <[email protected]> • #5547
Re: [PATCH v2 1/3] rust: add runtime PM support
Tue, 4 Aug 2026 14:27:25 +0200
Beata Michalska <[email protected]> • #5546
Re: [PATCH v2 2/3] rust: platform: wire runtime PM callbacks
Tue, 4 Aug 2026 14:26:37 +0200
Beata Michalska <[email protected]> • #5545
Re: `io{re,un}map()` build error in s390 under `!CONFIG_HAS_IOMEM`
Tue, 04 Aug 2026 13:26:15 +0100
"Gary Guo" <[email protected]> • #5544
Re: `io{re,un}map()` build error in s390 under `!CONFIG_HAS_IOMEM`
Tue, 04 Aug 2026 14:21:26 +0200
Niklas Schnelle <[email protected]> • #5543
Re: `io{re,un}map()` build error in s390 under `!CONFIG_HAS_IOMEM`
Tue, 04 Aug 2026 14:02:10 +0200
"Arnd Bergmann" <[email protected]> • #5542
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.