dev.linux.lists.driver-core archive

797 archived articles, newest first (page 3 of 8). Latest articles →

[PATCH v2 1/5] rust: pci: convert IrqVectorRegistration to a lifetime-managed owning type
Wed, 12 Aug 2026 01:39:32 +0200
Danilo Krummrich <[email protected]> • #5823
[PATCH v2 0/5] Rework PCI IRQ vector code
Wed, 12 Aug 2026 01:39:31 +0200
Danilo Krummrich <[email protected]> • #5822
Re: [PATCH 4/5] PCI: add pci_irq_type() to query the allocated interrupt type
Tue, 11 Aug 2026 16:11:34 -0500
Bjorn Helgaas <[email protected]> • #5821
Re: [PATCH 2/5] rust: pci: convert IrqVectorRegistration to a lifetime-managed owning type
Tue, 11 Aug 2026 18:44:21 +0200
"Danilo Krummrich" <[email protected]> • #5820
Re: [RFC PATCH 0/4] device_schedule_reprobe(): core helper and conversions
Tue, 11 Aug 2026 11:01:58 -0400
Luiz Augusto von Dentz <[email protected]> • #5819
[PATCH DNM RFC 15/15] arm64: dts: qcom: kaanapali: Add MPAM MSC nodes for the L2 caches
Tue, 11 Aug 2026 21:30:44 +0800
Yin Li <[email protected]> • #5818
[PATCH RFC 14/15] arm_mpam: Support MSC accessibility derivation from RIS nodes
Tue, 11 Aug 2026 21:30:43 +0800
Yin Li <[email protected]> • #5817
[PATCH RFC 13/15] dt-bindings: arm: Fix MPAM MSC binding schema and examples
Tue, 11 Aug 2026 21:30:42 +0800
Yin Li <[email protected]> • #5816
[PATCH RFC 11/15] arm_mpam: Fix mpam_dt_create_foundling_msc() to create MSC platform devices
Tue, 11 Aug 2026 21:30:40 +0800
Yin Li <[email protected]> • #5815
[PATCH RFC 12/15] arm_mpam: Fix get_cpumask_from_cache() to clear mask on error
Tue, 11 Aug 2026 21:30:41 +0800
Yin Li <[email protected]> • #5814
[PATCH RFC 06/15] arm_mpam: Fix cache ID sentinel from ~0UL to U32_MAX to match u32 return type
Tue, 11 Aug 2026 21:30:35 +0800
Yin Li <[email protected]> • #5813
[PATCH RFC 09/15] arm_mpam: Fix MSC MMIO window size to use resource_size() instead of end - start
Tue, 11 Aug 2026 21:30:38 +0800
Yin Li <[email protected]> • #5812
[PATCH RFC 08/15] arm_mpam: Fix ris_idx type to prevent range check bypass on truncation
Tue, 11 Aug 2026 21:30:37 +0800
Yin Li <[email protected]> • #5811
[PATCH RFC 10/15] arm_mpam: Fix update_msc_accessibility() return type to void
Tue, 11 Aug 2026 21:30:39 +0800
Yin Li <[email protected]> • #5810
[PATCH RFC 07/15] arm_mpam: Fix the RIS index range check in mpam_ris_create_locked
Tue, 11 Aug 2026 21:30:36 +0800
Yin Li <[email protected]> • #5809
Re: [PATCH 01/12] rust: io: add Region::try_subregion
Mon, 10 Aug 2026 15:32:13 +0900
"Eliot Courtney" <[email protected]> • #5730
[syzbot] [kernel?] WARNING in wiphy_unregister
Sun, 09 Aug 2026 17:23:27 -0700
syzbot <[email protected]> • #5729
[syzbot] [kernel?] KASAN: slab-use-after-free Write in bus_for_each_drv
Sun, 09 Aug 2026 17:22:30 -0700
syzbot <[email protected]> • #5728
[syzbot] [usb?] WARNING in i2c_unregister_device
Sun, 09 Aug 2026 12:12:43 -0700
syzbot <[email protected]> • #5727
Re: [PATCH] drivers/base, mm: move arch_numa.c to mm/
Sun, 9 Aug 2026 08:51:29 +0300
Mike Rapoport <[email protected]> • #5726
Re: [PATCH 02/12] rust: num: reject Bounded::shr overshifts at build time
Sun, 09 Aug 2026 11:12:13 +0900
"Alexandre Courbot" <[email protected]> • #5725
Re: [syzbot] [kernel?] KASAN: slab-use-after-free Read in raw_process_ep_io (2)
Sat, 08 Aug 2026 11:00:23 -0700
syzbot <[email protected]> • #5724
Re: [GIT PULL] Driver core fixes for 7.2-rc7
Sat, 08 Aug 2026 14:51:26 +0000
[email protected] • #5723
[GIT PULL] Driver core fixes for 7.2-rc7
Sat, 08 Aug 2026 14:51:24 +0200
"Danilo Krummrich" <[email protected]> • #5722
Re: [PATCH 6/7] rust: workqueue: add Work::cancel_work_sync()
Fri, 7 Aug 2026 12:31:26 -0700
John Hubbard <[email protected]> • #5720
Re: [PATCH 02/12] rust: num: reject Bounded::shr overshifts at build time
Fri, 07 Aug 2026 20:14:55 +0100
"Gary Guo" <[email protected]> • #5719
Re: [PATCH v2 6/6] rust: workqueue: add ScopedWork for non-'static work items
Fri, 07 Aug 2026 20:35:15 +0200
"Danilo Krummrich" <[email protected]> • #5718
[PATCH v6 1/1] PCI: hotplug: Add 'uevent' sysfs attribute to trigger slot events
Fri, 7 Aug 2026 13:01:27 -0500
Ramesh Errabolu <[email protected]> • #5717
[PATCH v6 0/1] PCI: hotplug: Add 'uevent' sysfs attribute to trigger slot events
Fri, 7 Aug 2026 13:01:26 -0500
Ramesh Errabolu <[email protected]> • #5716
Re: [PATCH 1/1] MAINTAINERS: Remove Russ Weight from Firmware Loader
Fri, 07 Aug 2026 20:00:02 +0200
"Danilo Krummrich" <[email protected]> • #5715
Re: [PATCH 02/12] rust: num: reject Bounded::shr overshifts at build time
Fri, 7 Aug 2026 19:12:25 +0200
Miguel Ojeda <[email protected]> • #5714
[PATCH v2 6/6] rust: workqueue: add ScopedWork for non-'static work items
Fri, 7 Aug 2026 18:52:49 +0200
Danilo Krummrich <[email protected]> • #5713
[PATCH v2 5/6] rust: workqueue: add ScopedQueue for lifetime bound items
Fri, 7 Aug 2026 18:52:48 +0200
Danilo Krummrich <[email protected]> • #5712
[PATCH v2 4/6] rust: workqueue: add creation of workqueues
Fri, 7 Aug 2026 18:52:47 +0200
Danilo Krummrich <[email protected]> • #5711
[PATCH v2 3/6] rust: workqueue: create workqueue subdirectory
Fri, 7 Aug 2026 18:52:46 +0200
Danilo Krummrich <[email protected]> • #5710
[PATCH v2 2/6] rust: workqueue: restrict delayed work to global wqs
Fri, 7 Aug 2026 18:52:45 +0200
Danilo Krummrich <[email protected]> • #5709
[PATCH v2 1/6] rust: workqueue: replace deprecated system_wq with system_{percpu,dfl}_wq
Fri, 7 Aug 2026 18:52:44 +0200
Danilo Krummrich <[email protected]> • #5708
[PATCH v2 0/6] workqueue: OwnedQueue, ScopedQueue and ScopedWork
Fri, 7 Aug 2026 18:52:43 +0200
Danilo Krummrich <[email protected]> • #5707
Re: [PATCH 01/12] rust: io: add Region::try_subregion
Fri, 07 Aug 2026 15:09:58 +0100
"Gary Guo" <[email protected]> • #5706
Re: [PATCH 03/12] rust: num: add Bounded::shr_exact
Fri, 07 Aug 2026 23:04:08 +0900
"Alexandre Courbot" <[email protected]> • #5705
Re: [PATCH 02/12] rust: num: reject Bounded::shr overshifts at build time
Fri, 07 Aug 2026 23:03:28 +0900
"Alexandre Courbot" <[email protected]> • #5704
Re: [PATCH 01/12] rust: io: add Region::try_subregion
Fri, 07 Aug 2026 23:03:10 +0900
"Alexandre Courbot" <[email protected]> • #5703
Re: [PATCH v2 2/3] rust: dma: rename dma_handle to dma_address
Fri, 07 Aug 2026 14:04:47 +0100
"Gary Guo" <[email protected]> • #5702
Re: [PATCH 6/7] rust: workqueue: add Work::cancel_work_sync()
Fri, 07 Aug 2026 13:51:33 +0200
"Danilo Krummrich" <[email protected]> • #5701
Re: [PATCH 6/7] rust: workqueue: add Work::cancel_work_sync()
Fri, 07 Aug 2026 13:49:14 +0200
"Danilo Krummrich" <[email protected]> • #5700
Re: [PATCH v7 00/16] arm64: mediatek: Add M.2 E-key slot on Chromebooks
Fri, 7 Aug 2026 19:35:32 +0800
Chen-Yu Tsai <[email protected]> • #5699
[PATCH v3 0/3] debugfs: make debugfs_create_str() read-only
Fri, 7 Aug 2026 18:00:50 +0800
Yichong Chen <[email protected]> • #5698
[PATCH v3 3/3] debugfs: make debugfs_create_str() read-only
Fri, 7 Aug 2026 18:00:53 +0800
Yichong Chen <[email protected]> • #5697
[PATCH v3 2/3] soundwire: debugfs: replace writable string helper
Fri, 7 Aug 2026 18:00:52 +0800
Yichong Chen <[email protected]> • #5696
[PATCH v3 1/3] interconnect: debugfs: replace writable string helper
Fri, 7 Aug 2026 18:00:51 +0800
Yichong Chen <[email protected]> • #5695
Re: [PATCH 6/7] rust: workqueue: add Work::cancel_work_sync()
Fri, 7 Aug 2026 10:51:37 +0300
Onur Özkan <[email protected]> • #5694
[PATCH] rust: serdev: replace `__pinned_init` with `raw_try_init`
Fri, 7 Aug 2026 09:47:29 +0200
Miguel Ojeda <[email protected]> • #5693
[PATCH v5 3/3] arch_topology: Add topology_update_cpu_capacity() for runtime updates
Fri, 7 Aug 2026 14:08:48 +0800
Xueqin Luo <[email protected]> • #5692
[PATCH v5 2/3] cpufreq: cppc: Refactor autonomous perf bounds into helper
Fri, 7 Aug 2026 14:08:47 +0800
Xueqin Luo <[email protected]> • #5691
[PATCH v5 1/3] cpufreq: cppc: Add update_limits support for Highest Performance changes
Fri, 7 Aug 2026 14:08:46 +0800
Xueqin Luo <[email protected]> • #5690
[PATCH v5 0/3] cpufreq: cppc: Handle Highest Performance changes at runtime
Fri, 7 Aug 2026 14:08:45 +0800
Xueqin Luo <[email protected]> • #5689
Re: [PATCH 01/12] rust: io: add Region::try_subregion
Fri, 07 Aug 2026 14:39:17 +0900
"Eliot Courtney" <[email protected]> • #5688
Re: [PATCH 1/1] MAINTAINERS: Remove Russ Weight from Firmware Loader
Thu, 6 Aug 2026 23:24:40 -0600
Russ Weight <[email protected]> • #5687
Re: [PATCH v2 1/3] interconnect: debugfs: replace writable string helper
Fri, 7 Aug 2026 09:59:30 +0800
Yichong Chen <[email protected]> • #5686
Re: [PATCH 6/7] rust: workqueue: add Work::cancel_work_sync()
Thu, 6 Aug 2026 18:37:56 -0700
John Hubbard <[email protected]> • #5685
[syzbot] [pm?] inconsistent lock state in lock_sync
Thu, 06 Aug 2026 17:02:26 -0700
syzbot <[email protected]> • #5684
Re: [PATCH v1] firmware_loader: Unwind initialization on sysfs failure
Thu, 6 Aug 2026 19:51:26 -0400
최유호 <[email protected]> • #5683
Re: [PATCH] drivers/base, mm: move arch_numa.c to mm/
Thu, 6 Aug 2026 15:48:42 -0700
Andrew Morton <[email protected]> • #5682
Re: [PATCH] drivers/base/node: fix UAF on device_register() failure
Thu, 06 Aug 2026 23:53:39 +0200
"Danilo Krummrich" <[email protected]> • #5681
Re: [PATCH v1] firmware_loader: Unwind initialization on sysfs failure
Thu, 06 Aug 2026 23:46:32 +0200
"Danilo Krummrich" <[email protected]> • #5680
Re: [PATCH] firmware_loader: do not queue completed sysfs fallback requests
Thu, 6 Aug 2026 23:38:40 +0200
Danilo Krummrich <[email protected]> • #5679
Re: [PATCH v2 0/3] gpu: nova-core: falcon: use I/O projections for DMA transfers
Thu, 6 Aug 2026 23:25:03 +0200
Danilo Krummrich <[email protected]> • #5678
Re: [PATCH v2 2/3] rust: dma: rename dma_handle to dma_address
Thu, 06 Aug 2026 23:16:31 +0200
"Danilo Krummrich" <[email protected]> • #5677
Re: [PATCH] drivers/base, mm: move arch_numa.c to mm/
Thu, 06 Aug 2026 21:07:45 +0200
"Danilo Krummrich" <[email protected]> • #5676
Re: [PATCH 1/1] MAINTAINERS: Remove Russ Weight from Firmware Loader
Thu, 06 Aug 2026 21:01:12 +0200
"Danilo Krummrich" <[email protected]> • #5675
[PATCH net-next v2 7/7] net: xilinx: axienet: Add statistics support for XXV ethernet
Thu, 6 Aug 2026 23:41:53 +0530
Suraj Gupta <[email protected]> • #5674
[PATCH net-next v2 6/7] net: xilinx: axienet: Dispatch statistics through axienet_config ops
Thu, 6 Aug 2026 23:41:52 +0530
Suraj Gupta <[email protected]> • #5673
[PATCH net-next v2 5/7] net: xilinx: axienet: Make axienet_rmon_ranges non-static for reuse
Thu, 6 Aug 2026 23:41:51 +0530
Suraj Gupta <[email protected]> • #5672
[PATCH net-next v2 4/7] net: xilinx: axienet: Add 10G/25G (XXV) ethernet support
Thu, 6 Aug 2026 23:41:50 +0530
Suraj Gupta <[email protected]> • #5671
[PATCH net-next v2 3/7] dt-bindings: net: xlnx,xxv-ethernet: Add Xilinx XXV 10G/25G Ethernet
Thu, 6 Aug 2026 23:41:49 +0530
Suraj Gupta <[email protected]> • #5670
[PATCH net-next v2 2/7] net: xilinx: axienet: Introduce axienet_config for MAC-specific ops
Thu, 6 Aug 2026 23:41:48 +0530
Suraj Gupta <[email protected]> • #5669
[PATCH net-next v2 1/7] clk: Add devm_clk_bulk_get_enable()
Thu, 6 Aug 2026 23:41:47 +0530
Suraj Gupta <[email protected]> • #5668
[PATCH net-next v2 0/7] net: xilinx: axienet: Add 10G/25G (XXV) ethernet support
Thu, 6 Aug 2026 23:41:46 +0530
Suraj Gupta <[email protected]> • #5667
[PATCH 1/1] MAINTAINERS: Remove Russ Weight from Firmware Loader
Thu, 6 Aug 2026 11:19:15 -0600
Russ Weight <[email protected]> • #5666
[PATCH v3 8/8] drm/tyr: add gpuvas debugfs file
Fri, 07 Aug 2026 01:07:30 +0800
Alvin Sun <[email protected]> • #5665
[PATCH v3 6/8] rust: drm: gpuvm: add dump_gpuva_info to UniqueRefGpuVm
Fri, 07 Aug 2026 01:07:28 +0800
Alvin Sun <[email protected]> • #5664
[PATCH v3 7/8] drm/tyr: track VMs in a registry
Fri, 07 Aug 2026 01:07:29 +0800
Alvin Sun <[email protected]> • #5663
[PATCH v3 4/8] drm: move debugfs_init after dev->registered is set
Fri, 07 Aug 2026 01:07:26 +0800
Alvin Sun <[email protected]> • #5662
[PATCH v3 5/8] rust: drm: add debugfs_init callback to Driver trait
Fri, 07 Aug 2026 01:07:27 +0800
Alvin Sun <[email protected]> • #5661
[PATCH v3 3/8] rust: debugfs: add ScopeRef for existing dentries
Fri, 07 Aug 2026 01:07:25 +0800
Alvin Sun <[email protected]> • #5660
[PATCH v3 2/8] rust: debugfs: add seq_file support
Fri, 07 Aug 2026 01:07:24 +0800
Alvin Sun <[email protected]> • #5659
[PATCH v3 0/8] drm/tyr: add debugfs support
Fri, 07 Aug 2026 01:07:22 +0800
Alvin Sun <[email protected]> • #5658
[PATCH v3 1/8] rust: seq_file: add as_raw() method
Fri, 07 Aug 2026 01:07:23 +0800
Alvin Sun <[email protected]> • #5657
Re: [PATCH v2 9/9] drm/debugfs: hold device reference for the lifetime of open files
Fri, 7 Aug 2026 00:59:23 +0800
Alvin Sun <[email protected]> • #5656
Re: [PATCH v2 1/2] rust: io: gate ioremap/iounmap on CONFIG_HAS_IOMEM
Thu, 06 Aug 2026 18:09:35 +0200
"Arnd Bergmann" <[email protected]> • #5655
Re: [PATCH v2 1/2] rust: io: gate ioremap/iounmap on CONFIG_HAS_IOMEM
Thu, 6 Aug 2026 17:58:39 +0200
Danilo Krummrich <[email protected]> • #5654
Re: [PATCH v2 1/2] rust: io: gate ioremap/iounmap on CONFIG_HAS_IOMEM
Thu, 06 Aug 2026 17:47:28 +0200
"Danilo Krummrich" <[email protected]> • #5653
Re: `io{re,un}map()` build error in s390 under `!CONFIG_HAS_IOMEM`
Thu, 6 Aug 2026 17:21:24 +0200
Geert Uytterhoeven <[email protected]> • #5652
[syzbot] [fs?] KASAN: slab-use-after-free Read in sysfs_emit
Thu, 06 Aug 2026 08:25:33 -0700
syzbot <[email protected]> • #5651
Re: `io{re,un}map()` build error in s390 under `!CONFIG_HAS_IOMEM`
Thu, 06 Aug 2026 15:44:13 +0200
"Arnd Bergmann" <[email protected]> • #5650
Re: [PATCH] rust: dma: add `Range` type
Thu, 6 Aug 2026 15:40:38 +0200
Vasileios Almpanis <[email protected]> • #5649
Re: `io{re,un}map()` build error in s390 under `!CONFIG_HAS_IOMEM`
Thu, 06 Aug 2026 15:25:50 +0200
Niklas Schnelle <[email protected]> • #5648
Re: [PATCH 2/3] rust: dma: add abstraction for the single-buffer streaming DMA API
Thu, 6 Aug 2026 14:06:17 +0100
Robin Murphy <[email protected]> • #5647
Re: [PATCH v2] rust: io: Add a BigEndianMmio wrapper
Thu, 6 Aug 2026 14:13:33 +0200
Link Mauve <[email protected]> • #5646
Re: [PATCH] drivers/base, mm: move arch_numa.c to mm/
Thu, 6 Aug 2026 13:48:48 +0200
"David Hildenbrand (Arm)" <[email protected]> • #5645
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.