dev.linux.lists.driver-core archive

775 archived articles, newest first (page 2 of 8). Latest articles →

[PATCH net-next 2/3] of: property: link PHY package suppliers to member PHYs
Fri, 14 Aug 2026 18:46:16 -0600
James Hilliard <[email protected]> • #5915
[PATCH net-next 1/3] driver core: factor sync-state-only link cleanup
Fri, 14 Aug 2026 18:46:15 -0600
James Hilliard <[email protected]> • #5914
[PATCH net-next 0/3] of: mdio: fix fw_devlink for Ethernet PHY packages
Fri, 14 Aug 2026 18:46:14 -0600
James Hilliard <[email protected]> • #5913
Re: [PATCH v3 2/3] firmware/edd: use kobject_put() on edd_device_register() failure
Fri, 14 Aug 2026 17:06:52 -0500
Bjorn Helgaas <[email protected]> • #5912
[PATCH v3 2/3] firmware/edd: use kobject_put() on edd_device_register() failure
Fri, 14 Aug 2026 21:00:56 +0000
Tarun Sahu <[email protected]> • #5911
[PATCH v3 3/3] powerpc/ps3: use put_device() on device_register() failure in ps3_system_bus_device_register
Fri, 14 Aug 2026 21:00:57 +0000
Tarun Sahu <[email protected]> • #5910
[PATCH v3 0/3] Convert manual kfree(dev) to put_device()
Fri, 14 Aug 2026 21:00:54 +0000
Tarun Sahu <[email protected]> • #5909
[PATCH v3 1/3] ARM: locomo: use put_device() on device_register() failure
Fri, 14 Aug 2026 21:00:55 +0000
Tarun Sahu <[email protected]> • #5908
Re: [PATCH v2 16/16] rust: io: register: unify handling of register with/without bitfields
Fri, 14 Aug 2026 15:27:06 +0100
"Gary Guo" <[email protected]> • #5907
Re: [PATCH v2 16/16] rust: io: register: unify handling of register with/without bitfields
Fri, 14 Aug 2026 22:56:42 +0900
"Alexandre Courbot" <[email protected]> • #5906
Re: [PATCH v2 15/16] rust: io: register: remove `Register` trait and cleanup macro
Fri, 14 Aug 2026 22:56:36 +0900
"Alexandre Courbot" <[email protected]> • #5905
Re: [PATCH v5 00/36] Private Memory NUMA Nodes
Fri, 14 Aug 2026 09:27:09 -0400
Gregory Price <[email protected]> • #5904
Re: [PATCH v2 12/16] gpu: nova-core: use projection for PFALCON and PFALCON2 registers
Fri, 14 Aug 2026 14:05:21 +0100
"Gary Guo" <[email protected]> • #5903
[syzbot] [kernel?] INFO: task hung in usb_disable_device (2)
Fri, 14 Aug 2026 03:37:26 -0700
syzbot <[email protected]> • #5902
Re: [PATCH v2 2/3] firmware/edd: use kobject_put() on edd_device_register() failure
Fri, 14 Aug 2026 13:42:14 +0530
Sourabh Jain <[email protected]> • #5901
Re: [PATCH v2 1/3] ARM: locomo: use put_device() on device_register() failure
Fri, 14 Aug 2026 12:38:29 +0530
Sourabh Jain <[email protected]> • #5900
Re: [PATCH v2 3/3] powerpc/ps3: use put_device() on device_register() failure in ps3_system_bus_device_register
Fri, 14 Aug 2026 08:00:12 +0530
Sourabh Jain <[email protected]> • #5899
Re: [PATCH] rust: serdev: use ThisModule::as_ptr() instead of field access
Fri, 14 Aug 2026 01:20:03 +0200
Danilo Krummrich <[email protected]> • #5898
Re: [PATCH v2 01/16] rust: io: add static `cast()` method for views
Thu, 13 Aug 2026 18:29:32 +0100
"Gary Guo" <[email protected]> • #5897
Re: [PATCH v3 0/5] Rework PCI IRQ vector code
Thu, 13 Aug 2026 18:02:19 +0100
"Gary Guo" <[email protected]> • #5896
Re: [PATCH v3 2/5] rust: pci: resolve IRQ in index() and embed IrqRequest in IrqVector
Thu, 13 Aug 2026 18:00:59 +0100
"Gary Guo" <[email protected]> • #5895
[PATCH v3 5/5] rust: pci: expose the allocated interrupt type
Thu, 13 Aug 2026 18:52:05 +0200
Danilo Krummrich <[email protected]> • #5894
[PATCH v3 4/5] PCI: Add pci_irq_type() to query the allocated interrupt type
Thu, 13 Aug 2026 18:52:04 +0200
Danilo Krummrich <[email protected]> • #5893
[PATCH v3 3/5] rust: pci: remove request_irq() and request_threaded_irq() from Device
Thu, 13 Aug 2026 18:52:03 +0200
Danilo Krummrich <[email protected]> • #5892
[PATCH v3 2/5] rust: pci: resolve IRQ in index() and embed IrqRequest in IrqVector
Thu, 13 Aug 2026 18:52:02 +0200
Danilo Krummrich <[email protected]> • #5891
[PATCH v3 1/5] rust: pci: convert IrqVectorRegistration to a lifetime-managed owning type
Thu, 13 Aug 2026 18:52:01 +0200
Danilo Krummrich <[email protected]> • #5890
[PATCH v3 0/5] Rework PCI IRQ vector code
Thu, 13 Aug 2026 18:52:00 +0200
Danilo Krummrich <[email protected]> • #5889
Re: [PATCH] rust: serdev: use ThisModule::as_ptr() instead of field access
Thu, 13 Aug 2026 18:10:21 +0200
"Danilo Krummrich" <[email protected]> • #5888
Re: [PATCH] rust: serdev: use ThisModule::as_ptr() instead of field access
Thu, 13 Aug 2026 17:08:39 +0100
"Gary Guo" <[email protected]> • #5887
Re: [PATCH] rust: serdev: use ThisModule::as_ptr() instead of field access
Thu, 13 Aug 2026 17:08:32 +0100
"Gary Guo" <[email protected]> • #5886
Re: [PATCH] rust: serdev: use ThisModule::as_ptr() instead of field access
Thu, 13 Aug 2026 15:53:26 +0000
Markus Probst <[email protected]> • #5885
[PATCH] rust: serdev: use ThisModule::as_ptr() instead of field access
Thu, 13 Aug 2026 17:24:41 +0200
Danilo Krummrich <[email protected]> • #5884
Re: [PATCH V2] devtmpfs: restore mount option reconfiguration on get_tree
Thu, 13 Aug 2026 13:51:29 +0000
Simon Liebold <[email protected]> • #5883
Re: [RFC PATCH 1/4] driver core: add device_schedule_reprobe()
Thu, 13 Aug 2026 15:07:06 +0200
Marco Crivellari <[email protected]> • #5882
Re: [PATCH v10 00/10] Fix missing fops.owner in Rust DRM/misc abstractions
Thu, 13 Aug 2026 19:51:04 +0800
Alvin Sun <[email protected]> • #5881
Re: [PATCH v10 00/10] Fix missing fops.owner in Rust DRM/misc abstractions
Thu, 13 Aug 2026 12:04:04 +0200
Miguel Ojeda <[email protected]> • #5880
Re: [PATCH v10 00/10] Fix missing fops.owner in Rust DRM/misc abstractions
Thu, 13 Aug 2026 12:03:03 +0200
"Danilo Krummrich" <[email protected]> • #5879
[PATCH v2 3/3] powerpc/ps3: use put_device() on device_register() failure in ps3_system_bus_device_register
Thu, 13 Aug 2026 09:54:21 +0000
Tarun Sahu <[email protected]> • #5878
[PATCH v2 2/3] firmware/edd: use kobject_put() on edd_device_register() failure
Thu, 13 Aug 2026 09:54:20 +0000
Tarun Sahu <[email protected]> • #5877
[PATCH v2 1/3] ARM: locomo: use put_device() on device_register() failure
Thu, 13 Aug 2026 09:54:19 +0000
Tarun Sahu <[email protected]> • #5876
[PATCH v2 0/3] Convert manual kfree(dev) to put_device()
Thu, 13 Aug 2026 09:54:18 +0000
Tarun Sahu <[email protected]> • #5875
Re: [PATCH v10 00/10] Fix missing fops.owner in Rust DRM/misc abstractions
Thu, 13 Aug 2026 11:36:01 +0200
Miguel Ojeda <[email protected]> • #5874
Re: [PATCH v10 00/10] Fix missing fops.owner in Rust DRM/misc abstractions
Thu, 13 Aug 2026 11:32:42 +0200
Miguel Ojeda <[email protected]> • #5873
Re: [PATCH 3/4] EDAC/versalnet: use put_device() on device_register() failure
Thu, 13 Aug 2026 14:41:37 +0530
"Pandey, Radhey Shyam" <[email protected]> • #5872
Re: [PATCH v5 00/36] Private Memory NUMA Nodes
Thu, 13 Aug 2026 10:55:13 +0200
Pankaj Gupta <[email protected]> • #5871
Re: [PATCH v10 00/10] Fix missing fops.owner in Rust DRM/misc abstractions
Thu, 13 Aug 2026 10:19:07 +0200
Miguel Ojeda <[email protected]> • #5870
Re: [PATCH v10 00/10] Fix missing fops.owner in Rust DRM/misc abstractions
Thu, 13 Aug 2026 16:14:42 +0800
Alvin Sun <[email protected]> • #5869
Re: [PATCH v10 08/10] PCI: of: Set fwnode device of newly created PCI device nodes
Thu, 13 Aug 2026 08:17:20 +0200
Manivannan Sadhasivam <[email protected]> • #5868
Re: [PATCH v10 07/10] PCI: of: Clear fwnode->dev during root bridge node removal and error path
Thu, 13 Aug 2026 08:16:04 +0200
Manivannan Sadhasivam <[email protected]> • #5867
Re: [PATCH v10 06/10] PCI: of: Use fw_devlink_set_device()
Thu, 13 Aug 2026 08:13:58 +0200
Manivannan Sadhasivam <[email protected]> • #5866
Re: [PATCH v5 00/36] Private Memory NUMA Nodes
Wed, 12 Aug 2026 21:21:04 -0400
Gregory Price <[email protected]> • #5865
Re: [PATCH v2 0/5] Rework PCI IRQ vector code
Wed, 12 Aug 2026 18:20:46 -0700
John Hubbard <[email protected]> • #5864
Re: [PATCH v2 14/16] rust: io: register: remove relative registers
Thu, 13 Aug 2026 09:58:40 +0900
"Alexandre Courbot" <[email protected]> • #5863
Re: [PATCH v10 00/10] Fix missing fops.owner in Rust DRM/misc abstractions
Thu, 13 Aug 2026 02:18:55 +0200
"Danilo Krummrich" <[email protected]> • #5862
Re: [PATCH v10 00/10] Fix missing fops.owner in Rust DRM/misc abstractions
Thu, 13 Aug 2026 00:57:36 +0100
"Gary Guo" <[email protected]> • #5861
Re: [PATCH v2 2/3] rust: dma: rename dma_handle to dma_address
Thu, 13 Aug 2026 00:51:14 +0100
"Gary Guo" <[email protected]> • #5860
Re: [PATCH v2 2/3] rust: dma: rename dma_handle to dma_address
Thu, 13 Aug 2026 00:32:45 +0200
"Danilo Krummrich" <[email protected]> • #5859
Re: [PATCH v10 00/10] Fix missing fops.owner in Rust DRM/misc abstractions
Wed, 12 Aug 2026 23:53:34 +0200
"Danilo Krummrich" <[email protected]> • #5858
[PATCH V2] devtmpfs: restore mount option reconfiguration on get_tree
Wed, 12 Aug 2026 16:44:38 -0500
Eric Sandeen <[email protected]> • #5857
Re: [PATCH v2 5/5] rust: pci: expose the allocated interrupt type
Wed, 12 Aug 2026 22:48:36 +0200
"Danilo Krummrich" <[email protected]> • #5856
Re: [PATCH v2 12/16] gpu: nova-core: use projection for PFALCON and PFALCON2 registers
Wed, 12 Aug 2026 13:44:44 -0700
John Hubbard <[email protected]> • #5855
Re: [PATCH v2 1/5] rust: pci: convert IrqVectorRegistration to a lifetime-managed owning type
Wed, 12 Aug 2026 21:57:38 +0200
"Danilo Krummrich" <[email protected]> • #5854
Re: [PATCH v2 2/5] rust: pci: resolve IRQ in vector() and embed IrqRequest in IrqVector
Wed, 12 Aug 2026 21:31:09 +0200
"Danilo Krummrich" <[email protected]> • #5853
Re: [PATCH v2 1/5] rust: pci: convert IrqVectorRegistration to a lifetime-managed owning type
Wed, 12 Aug 2026 20:01:49 +0100
"Gary Guo" <[email protected]> • #5852
Re: [PATCH v2 1/5] rust: pci: convert IrqVectorRegistration to a lifetime-managed owning type
Wed, 12 Aug 2026 20:47:37 +0200
"Danilo Krummrich" <[email protected]> • #5851
Re: [PATCH v2 5/5] rust: pci: expose the allocated interrupt type
Wed, 12 Aug 2026 19:16:11 +0100
"Gary Guo" <[email protected]> • #5850
Re: [PATCH v2 5/5] rust: pci: expose the allocated interrupt type
Wed, 12 Aug 2026 17:44:54 +0100
"Gary Guo" <[email protected]> • #5843
Re: [PATCH v10 00/10] Fix missing fops.owner in Rust DRM/misc abstractions
Wed, 12 Aug 2026 18:33:27 +0200
Miguel Ojeda <[email protected]> • #5841
Re: [PATCH v2 12/16] gpu: nova-core: use projection for PFALCON and PFALCON2 registers
Wed, 12 Aug 2026 23:48:07 +0900
"Alexandre Courbot" <[email protected]> • #5839
Re: [PATCH v5 00/36] Private Memory NUMA Nodes
Wed, 12 Aug 2026 14:01:12 +0200
Pankaj Gupta <[email protected]> • #5838
Re: `io{re,un}map()` build error in s390 under `!CONFIG_HAS_IOMEM`
Wed, 12 Aug 2026 13:46:30 +0200
"Arnd Bergmann" <[email protected]> • #5837
Re: `io{re,un}map()` build error in s390 under `!CONFIG_HAS_IOMEM`
Wed, 12 Aug 2026 12:23:57 +0100 (BST)
"Maciej W. Rozycki" <[email protected]> • #5836
Re: [External] Re: [PATCH v3] arm64: topology: add source check in arch_cpu_idle_enter()
Wed, 12 Aug 2026 13:02:09 +0200
Beata Michalska <[email protected]> • #5834
Re: [PATCH v2 11/16] rust: io: register: support fixed offset register without bitfield
Wed, 12 Aug 2026 18:01:25 +0900
"Alexandre Courbot" <[email protected]> • #5832
RE: [External] Re: [PATCH v3] arm64: topology: add source check in arch_cpu_idle_enter()
Wed, 12 Aug 2026 07:34:52 +0000
Sean Wang1 <[email protected]> • #5831
Re: [PATCH v2 02/16] rust: io: add `IoRepr` trait
Wed, 12 Aug 2026 13:51:21 +0900
"Alexandre Courbot" <[email protected]> • #5830
Re: [PATCH net-next v2 3/7] dt-bindings: net: xlnx,xxv-ethernet: Add Xilinx XXV 10G/25G Ethernet
Tue, 11 Aug 2026 22:09:10 -0500
"Rob Herring (Arm)" <[email protected]> • #5829
Re: [PATCH v12] PCI: Add support for PCIe WAKE# interrupt
Tue, 11 Aug 2026 18:58:14 -0500
Bjorn Helgaas <[email protected]> • #5828
[PATCH v2 5/5] rust: pci: expose the allocated interrupt type
Wed, 12 Aug 2026 01:39:36 +0200
Danilo Krummrich <[email protected]> • #5827
[PATCH v2 4/5] PCI: Add pci_irq_type() to query the allocated interrupt type
Wed, 12 Aug 2026 01:39:35 +0200
Danilo Krummrich <[email protected]> • #5826
[PATCH v2 3/5] rust: pci: remove request_irq() and request_threaded_irq() from Device
Wed, 12 Aug 2026 01:39:34 +0200
Danilo Krummrich <[email protected]> • #5825
[PATCH v2 2/5] rust: pci: resolve IRQ in vector() and embed IrqRequest in IrqVector
Wed, 12 Aug 2026 01:39:33 +0200
Danilo Krummrich <[email protected]> • #5824
[PATCH v2 1/5] rust: pci: convert IrqVectorRegistration to a lifetime-managed owning type
Wed, 12 Aug 2026 01:39:32 +0200
Danilo Krummrich <[email protected]> • #5823
[PATCH v2 0/5] Rework PCI IRQ vector code
Wed, 12 Aug 2026 01:39:31 +0200
Danilo Krummrich <[email protected]> • #5822
Re: [PATCH 4/5] PCI: add pci_irq_type() to query the allocated interrupt type
Tue, 11 Aug 2026 16:11:34 -0500
Bjorn Helgaas <[email protected]> • #5821
Re: [PATCH 2/5] rust: pci: convert IrqVectorRegistration to a lifetime-managed owning type
Tue, 11 Aug 2026 18:44:21 +0200
"Danilo Krummrich" <[email protected]> • #5820
Re: [RFC PATCH 0/4] device_schedule_reprobe(): core helper and conversions
Tue, 11 Aug 2026 11:01:58 -0400
Luiz Augusto von Dentz <[email protected]> • #5819
[PATCH DNM RFC 15/15] arm64: dts: qcom: kaanapali: Add MPAM MSC nodes for the L2 caches
Tue, 11 Aug 2026 21:30:44 +0800
Yin Li <[email protected]> • #5818
[PATCH RFC 14/15] arm_mpam: Support MSC accessibility derivation from RIS nodes
Tue, 11 Aug 2026 21:30:43 +0800
Yin Li <[email protected]> • #5817
[PATCH RFC 13/15] dt-bindings: arm: Fix MPAM MSC binding schema and examples
Tue, 11 Aug 2026 21:30:42 +0800
Yin Li <[email protected]> • #5816
[PATCH RFC 11/15] arm_mpam: Fix mpam_dt_create_foundling_msc() to create MSC platform devices
Tue, 11 Aug 2026 21:30:40 +0800
Yin Li <[email protected]> • #5815
[PATCH RFC 12/15] arm_mpam: Fix get_cpumask_from_cache() to clear mask on error
Tue, 11 Aug 2026 21:30:41 +0800
Yin Li <[email protected]> • #5814
[PATCH RFC 06/15] arm_mpam: Fix cache ID sentinel from ~0UL to U32_MAX to match u32 return type
Tue, 11 Aug 2026 21:30:35 +0800
Yin Li <[email protected]> • #5813
[PATCH RFC 09/15] arm_mpam: Fix MSC MMIO window size to use resource_size() instead of end - start
Tue, 11 Aug 2026 21:30:38 +0800
Yin Li <[email protected]> • #5812
[PATCH RFC 08/15] arm_mpam: Fix ris_idx type to prevent range check bypass on truncation
Tue, 11 Aug 2026 21:30:37 +0800
Yin Li <[email protected]> • #5811
[PATCH RFC 10/15] arm_mpam: Fix update_msc_accessibility() return type to void
Tue, 11 Aug 2026 21:30:39 +0800
Yin Li <[email protected]> • #5810
[syzbot] [kernel?] WARNING in wiphy_unregister
Sun, 09 Aug 2026 17:23:27 -0700
syzbot <[email protected]> • #5729
[syzbot] [kernel?] KASAN: slab-use-after-free Write in bus_for_each_drv
Sun, 09 Aug 2026 17:22:30 -0700
syzbot <[email protected]> • #5728
[syzbot] [usb?] WARNING in i2c_unregister_device
Sun, 09 Aug 2026 12:12:43 -0700
syzbot <[email protected]> • #5727
Re: [PATCH] drivers/base, mm: move arch_numa.c to mm/
Sun, 9 Aug 2026 08:51:29 +0300
Mike Rapoport <[email protected]> • #5726
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.