org.infradead.lists.linux-snps-arc archive

412 archived articles, newest first (page 2 of 5). Latest articles →

Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Thu, 9 Jul 2026 09:41:18 +0800
Jinjie Ruan <[email protected]> • #13422
Re: [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Thu, 9 Jul 2026 09:20:32 +0800
Jinjie Ruan <[email protected]> • #13421
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Thu, 09 Jul 2026 01:14:24 +0200
Thomas Gleixner <[email protected]> • #13420
Re: [patch 09/18] entry: Remove syscall_enter_from_user_mode()
Thu, 09 Jul 2026 00:08:11 +0200
Thomas Gleixner <[email protected]> • #13419
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Wed, 08 Jul 2026 23:49:57 +0200
Thomas Gleixner <[email protected]> • #13418
Re: [patch 10/18] entry: Use syscall number instead of rereading it
Wed, 08 Jul 2026 17:39:50 -0400
Radu Rendec <[email protected]> • #13417
Re: [patch 09/18] entry: Remove syscall_enter_from_user_mode()
Wed, 08 Jul 2026 17:21:19 -0400
Radu Rendec <[email protected]> • #13416
Re: [patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 16:59:18 -0400
Radu Rendec <[email protected]> • #13415
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 16:57:51 -0400
Radu Rendec <[email protected]> • #13414
Re: [patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 16:57:00 -0400
Radu Rendec <[email protected]> • #13413
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Wed, 08 Jul 2026 22:34:38 +0200
Thomas Gleixner <[email protected]> • #13412
Re: [patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 14:37:13 -0400
Radu Rendec <[email protected]> • #13411
Re: [patch 05/18] powerpc/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 14:35:48 -0400
Radu Rendec <[email protected]> • #13410
Re: [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 13:26:19 -0400
Radu Rendec <[email protected]> • #13409
Re: [patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
Wed, 08 Jul 2026 13:24:33 -0400
Radu Rendec <[email protected]> • #13408
Re: [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Wed, 08 Jul 2026 13:22:58 -0400
Radu Rendec <[email protected]> • #13407
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Wed, 8 Jul 2026 18:04:19 +0200
Oleg Nesterov <[email protected]> • #13406
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Wed, 8 Jul 2026 17:52:42 +0200
Michal Suchánek <[email protected]> • #13405
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Wed, 8 Jul 2026 17:46:24 +0200
Oleg Nesterov <[email protected]> • #13404
Re: [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Wed, 8 Jul 2026 19:37:51 +0530
Shrikanth Hegde <[email protected]> • #13403
Re: [patch 18/18] entry, treewide: Make syscall_enter_from_user_mode[_work]() indicate syscall execution
Wed, 08 Jul 2026 11:16:25 +0200
Thomas Gleixner <[email protected]> • #13402
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Wed, 08 Jul 2026 11:15:10 +0200
Thomas Gleixner <[email protected]> • #13401
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 08:47:15 +0200
Sven Schnelle <[email protected]> • #13400
Re: [patch 18/18] entry, treewide: Make syscall_enter_from_user_mode[_work]() indicate syscall execution
Wed, 8 Jul 2026 10:51:56 +0530
Shrikanth Hegde <[email protected]> • #13399
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Wed, 8 Jul 2026 09:43:46 +0800
Jinjie Ruan <[email protected]> • #13398
[patch 18/18] entry, treewide: Make syscall_enter_from_user_mode[_work]() indicate syscall execution
Tue, 07 Jul 2026 21:07:09 +0200
Thomas Gleixner <[email protected]> • #13397
[patch 17/18] x86/entry: Simplify the syscall number logic
Tue, 07 Jul 2026 21:07:05 +0200
Thomas Gleixner <[email protected]> • #13396
[patch 16/18] x86/entry: Get rid of the sys_ni_syscall() indirection
Tue, 07 Jul 2026 21:07:01 +0200
Thomas Gleixner <[email protected]> • #13395
[patch 15/18] x86/entry: Make syscall functions static
Tue, 07 Jul 2026 21:06:57 +0200
Thomas Gleixner <[email protected]> • #13394
[patch 14/18] entry: Make return type of syscall_trace_enter() bool
Tue, 07 Jul 2026 21:06:53 +0200
Thomas Gleixner <[email protected]> • #13393
[patch 13/18] entry: Make trace_syscall_enter() return type bool
Tue, 07 Jul 2026 21:06:48 +0200
Thomas Gleixner <[email protected]> • #13392
[patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Tue, 07 Jul 2026 21:06:44 +0200
Thomas Gleixner <[email protected]> • #13391
[patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Tue, 07 Jul 2026 21:06:40 +0200
Thomas Gleixner <[email protected]> • #13390
[patch 10/18] entry: Use syscall number instead of rereading it
Tue, 07 Jul 2026 21:06:36 +0200
Thomas Gleixner <[email protected]> • #13389
[patch 09/18] entry: Remove syscall_enter_from_user_mode()
Tue, 07 Jul 2026 21:06:32 +0200
Thomas Gleixner <[email protected]> • #13388
[patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:27 +0200
Thomas Gleixner <[email protected]> • #13387
[patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:23 +0200
Thomas Gleixner <[email protected]> • #13386
[patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:19 +0200
Thomas Gleixner <[email protected]> • #13385
[patch 05/18] powerpc/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:15 +0200
Thomas Gleixner <[email protected]> • #13384
[patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:11 +0200
Thomas Gleixner <[email protected]> • #13383
[patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:07 +0200
Thomas Gleixner <[email protected]> • #13382
[patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
Tue, 07 Jul 2026 21:06:02 +0200
Thomas Gleixner <[email protected]> • #13381
[patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Tue, 07 Jul 2026 21:05:58 +0200
Thomas Gleixner <[email protected]> • #13380
[patch 00/18] entry: Consolidate and rework syscall entry handling
Tue, 07 Jul 2026 21:05:53 +0200
Thomas Gleixner <[email protected]> • #13379
Re: [PATCH v5 0/9] driver core: Fix some race conditions
Fri, 26 Jun 2026 08:21:39 +0000
[email protected] • #13378
Re: [PATCH 00/19] init: discoverable root partitions, a.k.a. an omittable "root=" cmdline option
Wed, 17 Jun 2026 22:56:00 +0200
Vincent Mailhol <[email protected]> • #13377
Re: [PATCH 00/19] init: discoverable root partitions, a.k.a. an omittable "root=" cmdline option
Wed, 17 Jun 2026 14:41:54 +0200
Christian Brauner <[email protected]> • #13376
Re: [PATCH 00/19] init: discoverable root partitions, a.k.a. an omittable "root=" cmdline option
Mon, 15 Jun 2026 22:33:11 +0200
Vincent Mailhol <[email protected]> • #13375
Re: [PATCH 00/19] init: discoverable root partitions, a.k.a. an omittable "root=" cmdline option
Mon, 15 Jun 2026 18:04:32 +0100
Al Viro <[email protected]> • #13374
[PATCH 03/19] arc: define DPS root partition type UUID
Mon, 15 Jun 2026 18:08:59 +0200
Vincent Mailhol <[email protected]> • #13373
[PATCH 00/19] init: discoverable root partitions, a.k.a. an omittable "root=" cmdline option
Mon, 15 Jun 2026 18:08:56 +0200
Vincent Mailhol <[email protected]> • #13372
Re: [PATCH] v2 Documentation: arch: fix brackets
Fri, 12 Jun 2026 13:17:14 -0600
Jonathan Corbet <[email protected]> • #13371
Re: [PATCH] v2 Documentation: arch: fix brackets
Fri, 12 Jun 2026 19:26:33 +0200
Krzysztof Kozlowski <[email protected]> • #13370
[PATCH] v2 Documentation: arch: fix brackets
Fri, 12 Jun 2026 11:54:22 +0200
Manuel Ebner <[email protected]> • #13369
Re: [PATCH] Documentation: arch: fix brackets
Thu, 11 Jun 2026 12:31:52 -0700
Randy Dunlap <[email protected]> • #13368
[PATCH] Documentation: arch: fix brackets
Thu, 11 Jun 2026 20:35:20 +0200
Manuel Ebner <[email protected]> • #13367
include/linux/atomic/atomic-arch-fallback.h:4152:16: sparse: sparse: cast truncates bits from constant value (deadbeefdeafcafe becomes deafcafe)
Wed, 03 Jun 2026 21:39:55 +0800
kernel test robot <[email protected]> • #13366
Re: [PATCH 07/14] pinctrl: Kconfig: drop unneeded dependencies on OF_GPIO
Tue, 2 Jun 2026 15:50:57 -0500
Timur Tabi <[email protected]> • #13365
include/linux/atomic/atomic-arch-fallback.h:4152:16: sparse: sparse: cast truncates bits from constant value (aaa31337c001d00d becomes c001d00d)
Wed, 13 May 2026 18:44:53 +0800
kernel test robot <[email protected]> • #13364
Re: [PATCH v3 0/4] arch, mm: consolidate empty_zero_page
Thu, 30 Apr 2026 03:25:09 +0000
[email protected] • #13363
Re: [RFC PATCH v1 8/9] arm64: Add unsafe_copy_from_user()
Wed, 29 Apr 2026 12:26:30 +0100
Will Deacon <[email protected]> • #13362
Re: [RFC PATCH v1 7/9] x86: Add unsafe_copy_from_user()
Wed, 29 Apr 2026 03:25:19 -0700
Usama Arif <[email protected]> • #13361
Re: [RFC PATCH v1 2/9] uaccess: Convert INLINE_COPY_{TO/FROM}_USER to kconfig and reduce ifdefery
Tue, 28 Apr 2026 06:34:00 -0500
Segher Boessenkool <[email protected]> • #13360
Re: [RFC PATCH v1 7/9] x86: Add unsafe_copy_from_user()
Tue, 28 Apr 2026 06:20:17 -0500
Segher Boessenkool <[email protected]> • #13359
Re: [RFC PATCH v1 2/9] uaccess: Convert INLINE_COPY_{TO/FROM}_USER to kconfig and reduce ifdefery
Tue, 28 Apr 2026 10:36:09 +0100
Andrew Cooper <[email protected]> • #13358
Re: [RFC PATCH v1 4/9] uaccess: Introduce copy_{to/from}_user_partial()
Tue, 28 Apr 2026 11:25:11 +0200
Geert Uytterhoeven <[email protected]> • #13357
Re: [RFC PATCH v1 7/9] x86: Add unsafe_copy_from_user()
Mon, 27 Apr 2026 18:30:16 -0400
Yury Norov <[email protected]> • #13356
Re: [RFC PATCH v1 7/9] x86: Add unsafe_copy_from_user()
Mon, 27 Apr 2026 14:52:05 -0700
Linus Torvalds <[email protected]> • #13355
Re: [RFC PATCH v1 5/9] uaccess: Switch to copy_{to/from}_user_partial() when relevant
Mon, 27 Apr 2026 14:39:20 -0700
Linus Torvalds <[email protected]> • #13354
Re: [RFC PATCH v1 5/9] uaccess: Switch to copy_{to/from}_user_partial() when relevant
Mon, 27 Apr 2026 22:29:14 +0100
David Laight <[email protected]> • #13353
Re: [RFC PATCH v1 2/9] uaccess: Convert INLINE_COPY_{TO/FROM}_USER to kconfig and reduce ifdefery
Mon, 27 Apr 2026 16:47:53 -0400
Yury Norov <[email protected]> • #13352
Re: [RFC PATCH v1 2/9] uaccess: Convert INLINE_COPY_{TO/FROM}_USER to kconfig and reduce ifdefery
Mon, 27 Apr 2026 21:39:33 +0100
Andrew Cooper <[email protected]> • #13351
Re: [RFC PATCH v1 9/9] uaccess: Convert small fixed size copy_{to/from}_user() to scoped user access
Mon, 27 Apr 2026 16:12:55 -0400
Yury Norov <[email protected]> • #13350
Re: [RFC PATCH v1 7/9] x86: Add unsafe_copy_from_user()
Mon, 27 Apr 2026 15:19:36 -0400
Yury Norov <[email protected]> • #13349
Re: [RFC PATCH v1 0/9] uaccess: Convert small fixed size copy_{to/from}_user() to scoped user access
Mon, 27 Apr 2026 21:01:18 +0200
Helge Deller <[email protected]> • #13348
Re: [RFC PATCH v1 5/9] uaccess: Switch to copy_{to/from}_user_partial() when relevant
Mon, 27 Apr 2026 12:01:23 -0700
Linus Torvalds <[email protected]> • #13347
Re: [RFC PATCH v1 2/9] uaccess: Convert INLINE_COPY_{TO/FROM}_USER to kconfig and reduce ifdefery
Mon, 27 Apr 2026 14:39:16 -0400
Yury Norov <[email protected]> • #13346
Re: [RFC PATCH v1 7/9] x86: Add unsafe_copy_from_user()
Mon, 27 Apr 2026 20:20:38 +0200
"Christophe Leroy (CS GROUP)" <[email protected]> • #13345
Re: [RFC PATCH v1 5/9] uaccess: Switch to copy_{to/from}_user_partial() when relevant
Mon, 27 Apr 2026 18:07:28 +0000
Alice Ryhl <[email protected]> • #13344
Re: [RFC PATCH v1 7/9] x86: Add unsafe_copy_from_user()
Mon, 27 Apr 2026 13:58:51 -0400
Yury Norov <[email protected]> • #13343
[RFC PATCH v1 9/9] uaccess: Convert small fixed size copy_{to/from}_user() to scoped user access
Mon, 27 Apr 2026 19:13:50 +0200
"Christophe Leroy (CS GROUP)" <[email protected]> • #13342
[RFC PATCH v1 8/9] arm64: Add unsafe_copy_from_user()
Mon, 27 Apr 2026 19:13:49 +0200
"Christophe Leroy (CS GROUP)" <[email protected]> • #13341
[RFC PATCH v1 7/9] x86: Add unsafe_copy_from_user()
Mon, 27 Apr 2026 19:13:48 +0200
"Christophe Leroy (CS GROUP)" <[email protected]> • #13340
[RFC PATCH v1 6/9] uaccess: Change copy_{to/from}_user to return -EFAULT
Mon, 27 Apr 2026 19:13:47 +0200
"Christophe Leroy (CS GROUP)" <[email protected]> • #13339
[RFC PATCH v1 5/9] uaccess: Switch to copy_{to/from}_user_partial() when relevant
Mon, 27 Apr 2026 19:13:46 +0200
"Christophe Leroy (CS GROUP)" <[email protected]> • #13338
[RFC PATCH v1 4/9] uaccess: Introduce copy_{to/from}_user_partial()
Mon, 27 Apr 2026 19:13:45 +0200
"Christophe Leroy (CS GROUP)" <[email protected]> • #13337
[RFC PATCH v1 3/9] x86/umip: Be stricter in fixup_umip_exception()
Mon, 27 Apr 2026 19:13:44 +0200
"Christophe Leroy (CS GROUP)" <[email protected]> • #13336
[RFC PATCH v1 2/9] uaccess: Convert INLINE_COPY_{TO/FROM}_USER to kconfig and reduce ifdefery
Mon, 27 Apr 2026 19:13:43 +0200
"Christophe Leroy (CS GROUP)" <[email protected]> • #13335
[RFC PATCH v1 1/9] uaccess: Split check_zeroed_user() out of usercopy.c
Mon, 27 Apr 2026 19:13:42 +0200
"Christophe Leroy (CS GROUP)" <[email protected]> • #13334
[RFC PATCH v1 0/9] uaccess: Convert small fixed size copy_{to/from}_user() to scoped user access
Mon, 27 Apr 2026 19:13:41 +0200
"Christophe Leroy (CS GROUP)" <[email protected]> • #13333
Re: [PATCH v2] arc: validate DT CPU map strings before parsing them
Sun, 12 Apr 2026 12:35:53 -0700
Vineet Gupta <[email protected]> • #13332
Re: [PATCH] ARC: configs: Drop redundant I2C_DESIGNWARE_PLATFORM
Sun, 12 Apr 2026 12:34:52 -0700
Vineet Gupta <[email protected]> • #13331
[PATCH] ARC: configs: Drop redundant I2C_DESIGNWARE_PLATFORM
Sun, 12 Apr 2026 19:11:11 +0200
Krzysztof Kozlowski <[email protected]> • #13330
Re: [PATCH v5 0/9] driver core: Fix some race conditions
Wed, 08 Apr 2026 00:58:28 +0200
"Danilo Krummrich" <[email protected]> • #13329
[PATCH v5 7/9] driver core: Replace dev->dma_coherent with dev_dma_coherent()
Mon, 6 Apr 2026 16:23:00 -0700
Douglas Anderson <[email protected]> • #13328
[PATCH v5 0/9] driver core: Fix some race conditions
Mon, 6 Apr 2026 16:22:53 -0700
Douglas Anderson <[email protected]> • #13327
Re: [PATCH v4 7/9] driver core: Replace dev->dma_coherent with dev_dma_coherent()
Mon, 6 Apr 2026 11:19:45 +0530
Vinod Koul <[email protected]> • #13326
[PATCH v2] arc: validate DT CPU map strings before parsing them
Mon, 6 Apr 2026 15:00:00 +0800
Pengpeng Hou <[email protected]> • #13325
Re: [PATCH] arc: validate DT CPU map strings before parsing them
Mon, 6 Apr 2026 15:20:00 +0800
Pengpeng Hou <[email protected]> • #13324
Re: [PATCH v4 0/9] driver core: Fix some race conditions
Sun, 5 Apr 2026 15:43:34 -0700
Doug Anderson <[email protected]> • #13323
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.