org.infradead.lists.linux-um archive

501 archived articles, newest first (page 3 of 6). Latest articles →

[PATCH v2 04/10] um: change machine name for uname output
Thu, 23 Jul 2026 11:35:45 +0200
Johannes Berg <[email protected]> • #29363
[PATCH v2 00/10] simplified UML/NOMMU approach
Thu, 23 Jul 2026 11:35:41 +0200
Johannes Berg <[email protected]> • #29362
[PATCH v2 01/10] x86/um: nommu: elf loader for fdpic
Thu, 23 Jul 2026 11:35:42 +0200
Johannes Berg <[email protected]> • #29361
[PATCH v2 03/10] um: nommu: memory handling
Thu, 23 Jul 2026 11:35:44 +0200
Johannes Berg <[email protected]> • #29360
[PATCH] um: fix futex implementation
Thu, 23 Jul 2026 11:31:35 +0200
Johannes Berg <[email protected]> • #29359
Re: [RFC PATCH 8/9] um: nommu: add userspace runner processes
Thu, 23 Jul 2026 09:56:29 +0200
Johannes Berg <[email protected]> • #29358
Re: [RFC PATCH 8/9] um: nommu: add userspace runner processes
Thu, 23 Jul 2026 13:47:42 +0900
Hajime Tazaki <[email protected]> • #29357
Re: [PATCH] um: vector: fix use-after-free in vector_mmsg_rx()
Wed, 22 Jul 2026 17:33:23 -0400
Michael Bommarito <[email protected]> • #29356
Re: [PATCH] um: vector: fix use-after-free in vector_mmsg_rx()
Wed, 22 Jul 2026 22:30:59 +0100
Anton Ivanov <[email protected]> • #29355
Re: [PATCH] um: ubd: validate COW header fields before use
Wed, 22 Jul 2026 23:25:06 +0200
Richard Weinberger <[email protected]> • #29354
Re: [PATCH] um: virtio_uml: fix heap overflow in vhost_user_get_config()
Wed, 22 Jul 2026 23:20:56 +0200
Richard Weinberger <[email protected]> • #29353
Re: [RFC PATCH 0/9] simplified UML/NOMMU approach
Thu, 23 Jul 2026 06:16:59 +0900
Hajime Tazaki <[email protected]> • #29352
Re: [PATCH] um: vector: fix use-after-free in vector_mmsg_rx()
Wed, 22 Jul 2026 23:13:36 +0200
Richard Weinberger <[email protected]> • #29351
Re: [PATCH] um: Allow multiple symbol definitions for GCOV builds
Wed, 22 Jul 2026 18:14:10 +0200
Johannes Berg <[email protected]> • #29350
Re: [PATCH] um: Allow multiple symbol definitions for GCOV builds
Wed, 22 Jul 2026 10:09:06 -0600
Alex Hung <[email protected]> • #29349
Re: [PATCH 1/2] um: add uml_kmalloc_array() helper to avoid potential
Wed, 22 Jul 2026 16:49:12 +0200
Johannes Berg <[email protected]> • #29348
Re: [PATCH] um: Allow multiple symbol definitions for GCOV builds
Wed, 22 Jul 2026 16:02:40 +0200
Johannes Berg <[email protected]> • #29347
Re: [RFC PATCH 8/9] um: nommu: add userspace runner processes
Wed, 22 Jul 2026 14:44:56 +0200
Johannes Berg <[email protected]> • #29346
Re: [RFC PATCH 0/9] simplified UML/NOMMU approach
Wed, 22 Jul 2026 09:46:31 +0200
Johannes Berg <[email protected]> • #29345
Re: [RFC PATCH 8/9] um: nommu: add userspace runner processes
Wed, 22 Jul 2026 10:30:16 +0900
Hajime Tazaki <[email protected]> • #29344
Re: [RFC PATCH 0/9] simplified UML/NOMMU approach
Wed, 22 Jul 2026 09:39:07 +0900
Hajime Tazaki <[email protected]> • #29343
Re: [PATCH] um: Allow multiple symbol definitions for GCOV builds
Tue, 21 Jul 2026 16:23:51 -0600
Alex Hung <[email protected]> • #29342
Re: [PATCH] um: Allow multiple symbol definitions for GCOV builds
Tue, 21 Jul 2026 23:58:37 +0200
Johannes Berg <[email protected]> • #29341
Re: [PATCH 15/22] mm: only initialise pt_share_count for user pgtables
Tue, 21 Jul 2026 17:12:13 +0200
"David Hildenbrand (Arm)" <[email protected]> • #29340
Re: [PATCH 04/22] mm: use mm_is_kernel() in generic page table code
Tue, 21 Jul 2026 17:07:22 +0200
"David Hildenbrand (Arm)" <[email protected]> • #29339
Re: [PATCH 03/22] mm: introduce MMF_KERNEL flag and set it for init_mm
Tue, 21 Jul 2026 17:04:33 +0200
"David Hildenbrand (Arm)" <[email protected]> • #29338
Re: [PATCH 02/22] mm: move mm_flags helpers to mm_types.h
Tue, 21 Jul 2026 16:57:30 +0200
"David Hildenbrand (Arm)" <[email protected]> • #29337
Re: [PATCH 01/22] mm: drop unused __mm_flags_set_mask_bits_word()
Tue, 21 Jul 2026 16:57:03 +0200
"David Hildenbrand (Arm)" <[email protected]> • #29336
Re: [RFC PATCH 0/6] um: introduce pidfd_mmap()/pidfd_munmap() syscalls
Tue, 21 Jul 2026 13:20:29 +0200
Johannes Berg <[email protected]> • #29335
Re: [RFC PATCH v2] um: fix futex implementation
Tue, 21 Jul 2026 10:40:37 +0100
Anton Ivanov <[email protected]> • #29334
[RFC PATCH v2] um: fix futex implementation
Tue, 21 Jul 2026 10:43:56 +0200
Johannes Berg <[email protected]> • #29333
[RFC PATCH] um: fix futex implementation
Tue, 21 Jul 2026 10:36:45 +0200
Johannes Berg <[email protected]> • #29332
Re: [patch 00/18] entry: Consolidate and rework syscall entry handling
Tue, 21 Jul 2026 10:17:49 +0200
Thomas Gleixner <[email protected]> • #29331
Re: [patch 00/18] entry: Consolidate and rework syscall entry handling
Tue, 21 Jul 2026 00:01:03 +0200
Magnus Lindholm <[email protected]> • #29330
Re: [patch 00/18] entry: Consolidate and rework syscall entry handling
Mon, 20 Jul 2026 21:21:07 +0200
Thomas Gleixner <[email protected]> • #29329
Re: [RFC PATCH 7/9] um: nommu: add SMP futex operations
Mon, 20 Jul 2026 21:10:01 +0200
Johannes Berg <[email protected]> • #29328
Re: [RFC PATCH 7/9] um: nommu: add SMP futex operations
Mon, 20 Jul 2026 21:06:13 +0200
Johannes Berg <[email protected]> • #29327
Re: [PATCH 14/22] mm: set page table page type when allocated
Mon, 20 Jul 2026 12:05:08 -0700
Vishal Moola <[email protected]> • #29326
[RFC PATCH 6/9] um: further decouple MMU related code
Mon, 20 Jul 2026 20:26:56 +0200
Johannes Berg <[email protected]> • #29325
[RFC PATCH 7/9] um: nommu: add SMP futex operations
Mon, 20 Jul 2026 20:26:57 +0200
Johannes Berg <[email protected]> • #29324
[RFC PATCH 9/9] um: nommu: plug nommu code into build system
Mon, 20 Jul 2026 20:26:59 +0200
Johannes Berg <[email protected]> • #29323
[RFC PATCH 8/9] um: nommu: add userspace runner processes
Mon, 20 Jul 2026 20:26:58 +0200
Johannes Berg <[email protected]> • #29322
[RFC PATCH 3/9] um: nommu: memory handling
Mon, 20 Jul 2026 20:26:53 +0200
Johannes Berg <[email protected]> • #29321
[RFC PATCH 2/9] um: decouple MMU specific code from the common part
Mon, 20 Jul 2026 20:26:52 +0200
Johannes Berg <[email protected]> • #29320
[RFC PATCH 5/9] x86/um/vdso: nommu: vdso memory update
Mon, 20 Jul 2026 20:26:55 +0200
Johannes Berg <[email protected]> • #29319
[RFC PATCH 4/9] um: change machine name for uname output
Mon, 20 Jul 2026 20:26:54 +0200
Johannes Berg <[email protected]> • #29318
[RFC PATCH 1/9] x86/um: nommu: elf loader for fdpic
Mon, 20 Jul 2026 20:26:51 +0200
Johannes Berg <[email protected]> • #29317
[RFC PATCH 0/9] simplified UML/NOMMU approach
Mon, 20 Jul 2026 20:26:50 +0200
Johannes Berg <[email protected]> • #29316
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Tue, 14 Jul 2026 10:20:20 +0200
Michal Suchánek <[email protected]> • #29315
Re: [patch 00/18] entry: Consolidate and rework syscall entry handling
Sun, 19 Jul 2026 13:25:32 +0200
Magnus Lindholm <[email protected]> • #29314
[PATCH] um: use ARRAY_SIZE macro in stub_exe.c
Fri, 17 Jul 2026 11:03:08 +0800
longlong yan <[email protected]> • #29313
Re: [PATCH 17/22] mm: pagewalk: drop redundant address check for kernel mm walks
Thu, 16 Jul 2026 12:24:18 +0200
Kevin Brodsky <[email protected]> • #29312
Re: [PATCH 14/22] mm: set page table page type when allocated
Thu, 16 Jul 2026 11:49:31 +0200
Kevin Brodsky <[email protected]> • #29311
Re: [PATCH 04/22] mm: use mm_is_kernel() in generic page table code
Thu, 16 Jul 2026 11:35:10 +0200
Kevin Brodsky <[email protected]> • #29310
Re: [PATCH 03/22] mm: introduce MMF_KERNEL flag and set it for init_mm
Thu, 16 Jul 2026 11:33:33 +0200
Kevin Brodsky <[email protected]> • #29309
Re: [PATCH 00/22] Simplify special kernel page table handling
Wed, 15 Jul 2026 17:07:02 +0200
Kevin Brodsky <[email protected]> • #29308
Re: [PATCH 19/22] x86/tboot: mark tboot_mm as a kernel mm
Tue, 14 Jul 2026 08:19:51 -0700
Dave Hansen <[email protected]> • #29307
Re: [PATCH 14/22] mm: set page table page type when allocated
Tue, 14 Jul 2026 08:16:16 -0700
Vishal Moola <[email protected]> • #29306
Re: [PATCH 12/22] x86/mm: use mm_is_kernel() for kernel mm checks
Tue, 14 Jul 2026 08:09:15 -0700
Dave Hansen <[email protected]> • #29305
Re: [PATCH 03/22] mm: introduce MMF_KERNEL flag and set it for init_mm
Tue, 14 Jul 2026 16:04:52 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #29304
Re: [PATCH 03/22] mm: introduce MMF_KERNEL flag and set it for init_mm
Tue, 14 Jul 2026 07:47:43 -0700
Dave Hansen <[email protected]> • #29303
[PATCH 22/22] riscv: mm: drop ctor/dtor calls for kernel page tables
Tue, 14 Jul 2026 15:04:11 +0100
Kevin Brodsky <[email protected]> • #29302
[PATCH 21/22] arm: mm: drop ctor call for kernel page tables
Tue, 14 Jul 2026 15:04:10 +0100
Kevin Brodsky <[email protected]> • #29301
[PATCH 20/22] arm64: mm: drop ctor/dtor calls for kernel page tables
Tue, 14 Jul 2026 15:04:09 +0100
Kevin Brodsky <[email protected]> • #29300
[PATCH 19/22] x86/tboot: mark tboot_mm as a kernel mm
Tue, 14 Jul 2026 15:04:08 +0100
Kevin Brodsky <[email protected]> • #29299
[PATCH 18/22] arm64: mm: drop explicit mm_is_efi() check in contpte
Tue, 14 Jul 2026 15:04:07 +0100
Kevin Brodsky <[email protected]> • #29298
[PATCH 17/22] mm: pagewalk: drop redundant address check for kernel mm walks
Tue, 14 Jul 2026 15:04:06 +0100
Kevin Brodsky <[email protected]> • #29297
[PATCH 16/22] efi: mark efi_mm as a kernel mm
Tue, 14 Jul 2026 15:04:05 +0100
Kevin Brodsky <[email protected]> • #29296
[PATCH 15/22] mm: only initialise pt_share_count for user pgtables
Tue, 14 Jul 2026 15:04:04 +0100
Kevin Brodsky <[email protected]> • #29295
[PATCH 14/22] mm: set page table page type when allocated
Tue, 14 Jul 2026 15:04:03 +0100
Kevin Brodsky <[email protected]> • #29294
[PATCH 13/22] mm: account page table pages when allocated
Tue, 14 Jul 2026 15:04:02 +0100
Kevin Brodsky <[email protected]> • #29293
[PATCH 12/22] x86/mm: use mm_is_kernel() for kernel mm checks
Tue, 14 Jul 2026 15:04:01 +0100
Kevin Brodsky <[email protected]> • #29292
[PATCH 11/22] um: mm: use mm_is_kernel() in TLB sync
Tue, 14 Jul 2026 15:04:00 +0100
Kevin Brodsky <[email protected]> • #29291
[PATCH 10/22] sparc: mm: use mm_is_kernel() for kernel mm checks
Tue, 14 Jul 2026 15:03:59 +0100
Kevin Brodsky <[email protected]> • #29290
[PATCH 09/22] s390: mm: use mm_is_kernel() for kernel mm checks
Tue, 14 Jul 2026 15:03:58 +0100
Kevin Brodsky <[email protected]> • #29289
[PATCH 08/22] powerpc: mm: use mm_is_kernel() for kernel mm checks
Tue, 14 Jul 2026 15:03:57 +0100
Kevin Brodsky <[email protected]> • #29288
[PATCH 07/22] parisc: mm: use mm_is_kernel() for kernel mm checks
Tue, 14 Jul 2026 15:03:56 +0100
Kevin Brodsky <[email protected]> • #29287
[PATCH 06/22] loongarch: mm: use mm_is_kernel() in switch_mm_irqs_off()
Tue, 14 Jul 2026 15:03:55 +0100
Kevin Brodsky <[email protected]> • #29286
[PATCH 05/22] arm64: mm: use mm_is_kernel() for kernel mm checks
Tue, 14 Jul 2026 15:03:54 +0100
Kevin Brodsky <[email protected]> • #29285
[PATCH 04/22] mm: use mm_is_kernel() in generic page table code
Tue, 14 Jul 2026 15:03:53 +0100
Kevin Brodsky <[email protected]> • #29284
[PATCH 03/22] mm: introduce MMF_KERNEL flag and set it for init_mm
Tue, 14 Jul 2026 15:03:52 +0100
Kevin Brodsky <[email protected]> • #29283
[PATCH 02/22] mm: move mm_flags helpers to mm_types.h
Tue, 14 Jul 2026 15:03:51 +0100
Kevin Brodsky <[email protected]> • #29282
[PATCH 01/22] mm: drop unused __mm_flags_set_mask_bits_word()
Tue, 14 Jul 2026 15:03:50 +0100
Kevin Brodsky <[email protected]> • #29281
[PATCH 00/22] Simplify special kernel page table handling
Tue, 14 Jul 2026 15:03:49 +0100
Kevin Brodsky <[email protected]> • #29280
Re: [PATCH v16 01/18] seccomp: Convert __secure_computing() to return boolean
Fri, 3 Jul 2026 09:51:04 +0200
Michal Suchánek <[email protected]> • #29279
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Fri, 10 Jul 2026 17:20:03 +0200
Michal Suchánek <[email protected]> • #29278
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Fri, 10 Jul 2026 12:42:29 +0200
Michal Suchánek <[email protected]> • #29277
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Fri, 10 Jul 2026 13:01:02 +0200
Michal Suchánek <[email protected]> • #29276
Re: [patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Mon, 13 Jul 2026 15:06:10 +0800
Guo Ren <[email protected]> • #29275
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Sat, 11 Jul 2026 22:33:16 +0200
Thomas Gleixner <[email protected]> • #29274
Re: [patch 00/18] entry: Consolidate and rework syscall entry handling
Sat, 11 Jul 2026 14:29:12 +0200
Magnus Lindholm <[email protected]> • #29273
[RFC PATCH 6/6] selftests/pidfd: add pidfd_mmap()/pidfd_munmap() tests
Fri, 10 Jul 2026 13:53:24 -0700
Cong Wang <[email protected]> • #29272
[RFC PATCH 5/6] um: install guest mappings via pidfd_mmap() in both modes
Fri, 10 Jul 2026 13:53:23 -0700
Cong Wang <[email protected]> • #29271
[RFC PATCH 4/6] um: forbid mmap/munmap in the stub seccomp filter
Fri, 10 Jul 2026 13:53:22 -0700
Cong Wang <[email protected]> • #29270
[RFC PATCH 3/6] um: install guest mappings via pidfd_mmap() in seccomp mode
Fri, 10 Jul 2026 13:53:21 -0700
Cong Wang <[email protected]> • #29269
[RFC PATCH 2/6] um: acquire a stub pidfd via CLONE_PIDFD in seccomp mode
Fri, 10 Jul 2026 13:53:20 -0700
Cong Wang <[email protected]> • #29268
[RFC PATCH 1/6] pidfd: add pidfd_mmap()/pidfd_munmap() syscalls
Fri, 10 Jul 2026 13:53:19 -0700
Cong Wang <[email protected]> • #29267
[RFC PATCH 0/6] um: introduce pidfd_mmap()/pidfd_munmap() syscalls
Fri, 10 Jul 2026 13:53:18 -0700
Cong Wang <[email protected]> • #29266
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Fri, 10 Jul 2026 14:52:40 +0200
Oleg Nesterov <[email protected]> • #29265
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Fri, 10 Jul 2026 14:32:13 +0200
Michal Suchánek <[email protected]> • #29264
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.