org.infradead.lists.linux-um archive

501 archived articles, newest first (page 4 of 6). Latest articles →

Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Fri, 10 Jul 2026 13:40:43 +0200
Oleg Nesterov <[email protected]> • #29263
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Fri, 10 Jul 2026 13:16:20 +0200
Oleg Nesterov <[email protected]> • #29262
Re: [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 01:46:15 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #29261
Re: [patch 00/18] entry: Consolidate and rework syscall entry handling
Fri, 10 Jul 2026 01:45:19 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #29260
Re: [patch 18/18] entry, treewide: Make syscall_enter_from_user_mode[_work]() indicate syscall execution
Fri, 10 Jul 2026 01:19:28 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #29259
Re: [patch 15/18] x86/entry: Make syscall functions static
Fri, 10 Jul 2026 01:13:15 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #29258
Re: [patch 14/18] entry: Make return type of syscall_trace_enter() bool
Fri, 10 Jul 2026 01:06:23 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #29257
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Fri, 10 Jul 2026 00:52:35 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #29256
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Fri, 10 Jul 2026 00:40:00 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #29255
Re: [patch 10/18] entry: Use syscall number instead of rereading it
Fri, 10 Jul 2026 00:20:46 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #29254
Re: [patch 09/18] entry: Remove syscall_enter_from_user_mode()
Fri, 10 Jul 2026 00:19:18 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #29253
Re: [patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 00:15:39 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #29252
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 00:13:32 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #29251
Re: [patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 00:12:23 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #29250
Re: [patch 05/18] powerpc/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 00:11:04 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #29249
Re: [patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 00:10:01 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #29248
Re: [patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
Fri, 10 Jul 2026 00:04:21 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #29247
Re: [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Fri, 10 Jul 2026 00:02:27 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #29246
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Thu, 09 Jul 2026 13:03:28 -0400
Radu Rendec <[email protected]> • #29245
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Thu, 9 Jul 2026 17:26:59 +0100
David Laight <[email protected]> • #29244
Re: [patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
Thu, 9 Jul 2026 09:23:47 -0700
Kees Cook <[email protected]> • #29243
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Thu, 9 Jul 2026 09:22:06 -0700
Kees Cook <[email protected]> • #29242
Re: [patch 10/18] entry: Use syscall number instead of rereading it
Thu, 9 Jul 2026 13:22:26 +0200
Philippe Mathieu-Daudé <[email protected]> • #29241
Re: [patch 10/18] entry: Use syscall number instead of rereading it
Thu, 9 Jul 2026 13:20:43 +0200
Philippe Mathieu-Daudé <[email protected]> • #29240
Re: [patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:18:04 +0200
Philippe Mathieu-Daudé <[email protected]> • #29239
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:17:17 +0200
Philippe Mathieu-Daudé <[email protected]> • #29238
Re: [patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:16:51 +0200
Philippe Mathieu-Daudé <[email protected]> • #29237
Re: [patch 05/18] powerpc/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:16:21 +0200
Philippe Mathieu-Daudé <[email protected]> • #29236
Re: [patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:15:55 +0200
Philippe Mathieu-Daudé <[email protected]> • #29235
Re: [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:15:11 +0200
Philippe Mathieu-Daudé <[email protected]> • #29234
Re: [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Thu, 9 Jul 2026 13:12:57 +0200
Philippe Mathieu-Daudé <[email protected]> • #29233
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Thu, 9 Jul 2026 10:41:56 +0200
Geert Uytterhoeven <[email protected]> • #29232
Re: [PATCH v16 18/18] arm64: vdso: Expose sigreturn address on vdso to the kernel
Thu, 9 Jul 2026 10:27:59 +0200
Thomas Weißschuh <[email protected]> • #29231
Re: [PATCH v16 18/18] arm64: vdso: Expose sigreturn address on vdso to the kernel
Thu, 9 Jul 2026 16:15:15 +0800
Jinjie Ruan <[email protected]> • #29230
Re: [PATCH v16 18/18] arm64: vdso: Expose sigreturn address on vdso to the kernel
Thu, 9 Jul 2026 09:17:33 +0200
Thomas Weißschuh <[email protected]> • #29229
Re: [PATCH v16 18/18] arm64: vdso: Expose sigreturn address on vdso to the kernel
Thu, 9 Jul 2026 14:37:05 +0800
Jinjie Ruan <[email protected]> • #29228
Re: [PATCH v16 02/18] syscall_user_dispatch: Introduce a weak fallback for arch_syscall_is_vdso_sigreturn()
Thu, 9 Jul 2026 14:30:11 +0800
Jinjie Ruan <[email protected]> • #29227
Re: [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 11:46:07 +0800
Jinjie Ruan <[email protected]> • #29226
Re: [patch 10/18] entry: Use syscall number instead of rereading it
Thu, 9 Jul 2026 10:55:27 +0800
Jinjie Ruan <[email protected]> • #29225
Re: [patch 09/18] entry: Remove syscall_enter_from_user_mode()
Thu, 9 Jul 2026 10:49:49 +0800
Jinjie Ruan <[email protected]> • #29224
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:46:44 +0800
Jinjie Ruan <[email protected]> • #29223
Re: [patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:44:48 +0800
Jinjie Ruan <[email protected]> • #29222
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:39:17 +0800
Jinjie Ruan <[email protected]> • #29221
Re: [patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:38:38 +0800
Jinjie Ruan <[email protected]> • #29220
Re: [patch 05/18] powerpc/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:38:16 +0800
Jinjie Ruan <[email protected]> • #29219
Re: [patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:37:44 +0800
Jinjie Ruan <[email protected]> • #29218
Re: [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:34:22 +0800
Jinjie Ruan <[email protected]> • #29217
Re: [patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
Thu, 9 Jul 2026 10:13:11 +0800
Jinjie Ruan <[email protected]> • #29216
Re: [patch 16/18] x86/entry: Get rid of the sys_ni_syscall() indirection
Thu, 9 Jul 2026 10:03:49 +0800
Jinjie Ruan <[email protected]> • #29215
Re: [patch 15/18] x86/entry: Make syscall functions static
Thu, 9 Jul 2026 09:47:56 +0800
Jinjie Ruan <[email protected]> • #29214
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Thu, 9 Jul 2026 09:41:18 +0800
Jinjie Ruan <[email protected]> • #29213
Re: [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Thu, 9 Jul 2026 09:20:32 +0800
Jinjie Ruan <[email protected]> • #29212
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Thu, 09 Jul 2026 01:14:24 +0200
Thomas Gleixner <[email protected]> • #29211
[PATCH] um: Allow multiple symbol definitions for GCOV builds
Wed, 8 Jul 2026 16:40:06 -0600
Alex Hung <[email protected]> • #29210
Re: [patch 09/18] entry: Remove syscall_enter_from_user_mode()
Thu, 09 Jul 2026 00:08:11 +0200
Thomas Gleixner <[email protected]> • #29209
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Wed, 08 Jul 2026 23:49:57 +0200
Thomas Gleixner <[email protected]> • #29208
Re: [PATCH 1/1[RFC] um: include .fini_array.* in linker scripts
Wed, 8 Jul 2026 15:42:11 -0600
Alex Hung <[email protected]> • #29207
Re: [patch 10/18] entry: Use syscall number instead of rereading it
Wed, 08 Jul 2026 17:39:50 -0400
Radu Rendec <[email protected]> • #29206
Re: [patch 09/18] entry: Remove syscall_enter_from_user_mode()
Wed, 08 Jul 2026 17:21:19 -0400
Radu Rendec <[email protected]> • #29205
Re: [patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 16:59:18 -0400
Radu Rendec <[email protected]> • #29204
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 16:57:51 -0400
Radu Rendec <[email protected]> • #29203
Re: [patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 16:57:00 -0400
Radu Rendec <[email protected]> • #29202
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Wed, 08 Jul 2026 22:34:38 +0200
Thomas Gleixner <[email protected]> • #29201
Re: [patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 14:37:13 -0400
Radu Rendec <[email protected]> • #29200
Re: [patch 05/18] powerpc/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 14:35:48 -0400
Radu Rendec <[email protected]> • #29199
Re: [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 13:26:19 -0400
Radu Rendec <[email protected]> • #29198
Re: [patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
Wed, 08 Jul 2026 13:24:33 -0400
Radu Rendec <[email protected]> • #29197
Re: [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Wed, 08 Jul 2026 13:22:58 -0400
Radu Rendec <[email protected]> • #29196
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Wed, 8 Jul 2026 18:04:19 +0200
Oleg Nesterov <[email protected]> • #29195
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Wed, 8 Jul 2026 17:52:42 +0200
Michal Suchánek <[email protected]> • #29194
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Wed, 8 Jul 2026 17:46:24 +0200
Oleg Nesterov <[email protected]> • #29193
Re: [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Wed, 8 Jul 2026 19:37:51 +0530
Shrikanth Hegde <[email protected]> • #29192
Re: [patch 18/18] entry, treewide: Make syscall_enter_from_user_mode[_work]() indicate syscall execution
Wed, 08 Jul 2026 11:16:25 +0200
Thomas Gleixner <[email protected]> • #29191
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Wed, 08 Jul 2026 11:15:10 +0200
Thomas Gleixner <[email protected]> • #29190
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 08:47:15 +0200
Sven Schnelle <[email protected]> • #29189
Re: [patch 18/18] entry, treewide: Make syscall_enter_from_user_mode[_work]() indicate syscall execution
Wed, 8 Jul 2026 10:51:56 +0530
Shrikanth Hegde <[email protected]> • #29188
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Wed, 8 Jul 2026 09:43:46 +0800
Jinjie Ruan <[email protected]> • #29187
[patch 18/18] entry, treewide: Make syscall_enter_from_user_mode[_work]() indicate syscall execution
Tue, 07 Jul 2026 21:07:09 +0200
Thomas Gleixner <[email protected]> • #29186
[patch 17/18] x86/entry: Simplify the syscall number logic
Tue, 07 Jul 2026 21:07:05 +0200
Thomas Gleixner <[email protected]> • #29185
[patch 16/18] x86/entry: Get rid of the sys_ni_syscall() indirection
Tue, 07 Jul 2026 21:07:01 +0200
Thomas Gleixner <[email protected]> • #29184
[patch 15/18] x86/entry: Make syscall functions static
Tue, 07 Jul 2026 21:06:57 +0200
Thomas Gleixner <[email protected]> • #29183
[patch 14/18] entry: Make return type of syscall_trace_enter() bool
Tue, 07 Jul 2026 21:06:53 +0200
Thomas Gleixner <[email protected]> • #29182
[patch 13/18] entry: Make trace_syscall_enter() return type bool
Tue, 07 Jul 2026 21:06:48 +0200
Thomas Gleixner <[email protected]> • #29181
[patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Tue, 07 Jul 2026 21:06:44 +0200
Thomas Gleixner <[email protected]> • #29180
[patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Tue, 07 Jul 2026 21:06:40 +0200
Thomas Gleixner <[email protected]> • #29179
[patch 10/18] entry: Use syscall number instead of rereading it
Tue, 07 Jul 2026 21:06:36 +0200
Thomas Gleixner <[email protected]> • #29178
[patch 09/18] entry: Remove syscall_enter_from_user_mode()
Tue, 07 Jul 2026 21:06:32 +0200
Thomas Gleixner <[email protected]> • #29177
[patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:27 +0200
Thomas Gleixner <[email protected]> • #29176
[patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:23 +0200
Thomas Gleixner <[email protected]> • #29175
[patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:19 +0200
Thomas Gleixner <[email protected]> • #29174
[patch 05/18] powerpc/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:15 +0200
Thomas Gleixner <[email protected]> • #29173
[patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:11 +0200
Thomas Gleixner <[email protected]> • #29172
[patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:07 +0200
Thomas Gleixner <[email protected]> • #29171
[patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
Tue, 07 Jul 2026 21:06:02 +0200
Thomas Gleixner <[email protected]> • #29170
[patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Tue, 07 Jul 2026 21:05:58 +0200
Thomas Gleixner <[email protected]> • #29169
[patch 00/18] entry: Consolidate and rework syscall entry handling
Tue, 07 Jul 2026 21:05:53 +0200
Thomas Gleixner <[email protected]> • #29168
Re: [PATCH v16 01/18] seccomp: Convert __secure_computing() to return boolean
Mon, 6 Jul 2026 10:41:16 +0800
Jinjie Ruan <[email protected]> • #29167
Re: [PATCH v16 01/18] seccomp: Convert __secure_computing() to return boolean
Fri, 3 Jul 2026 23:32:21 +0200
Linus Walleij <[email protected]> • #29166
Re: [PATCH v16 01/18] seccomp: Convert __secure_computing() to return boolean
Fri, 03 Jul 2026 14:01:29 -0700
"H. Peter Anvin" <[email protected]> • #29165
Re: [PATCH v16 01/18] seccomp: Convert __secure_computing() to return boolean
Fri, 03 Jul 2026 22:52:43 +0200
Thomas Gleixner <[email protected]> • #29164
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.