org.kernel.vger.initramfs archive

398 archived articles, newest first (page 2 of 4). Latest articles →

Re: [PATCH RESEND 00/62] initrd: remove classic initrd support
Mon, 15 Sep 2025 15:34:26 +0200
Christian Brauner <[email protected]> • #5113
Re: [PATCH RESEND 06/62] arm: init: remove special logic for setting brd.rd_size
Mon, 15 Sep 2025 13:57:29 +0200
Christophe Leroy <[email protected]> • #5112
Re: [PATCH RESEND 05/62] init: remove "ramdisk_start" command line parameter, which controls starting block number of initrd
Mon, 15 Sep 2025 13:48:08 +0200
Christophe Leroy <[email protected]> • #5111
Re: [PATCH RESEND 16/62] brd: remove "ramdisk_size" command line parameter
Mon, 15 Sep 2025 13:48:39 +0200
Christophe Leroy <[email protected]> • #5110
Re: [PATCH RESEND 08/62] arm: init: remove FLAG_RDLOAD and FLAG_RDPROMPT
Mon, 15 Sep 2025 13:54:36 +0200
Christophe Leroy <[email protected]> • #5109
Re: [PATCH RESEND 06/62] arm: init: remove special logic for setting brd.rd_size
Mon, 15 Sep 2025 13:53:26 +0200
Christophe Leroy <[email protected]> • #5108
Re: [PATCH RESEND 02/62] init: remove deprecated "prompt_ramdisk" command line parameter, which does nothing
Mon, 15 Sep 2025 13:16:49 +0200
Christophe Leroy <[email protected]> • #5107
Re: [PATCH RESEND 01/62] init: remove deprecated "load_ramdisk" command line parameter, which does nothing
Mon, 15 Sep 2025 13:17:11 +0200
Christophe Leroy <[email protected]> • #5106
Re: [PATCH RESEND 03/62] init: sh, sparc, x86: remove unused constants RAMDISK_PROMPT_FLAG and RAMDISK_LOAD_FLAG
Mon, 15 Sep 2025 13:19:26 +0200
Christophe Leroy <[email protected]> • #5105
Re: [PATCH RESEND 04/62] init: x86, arm, sh, sparc: remove variable rd_image_start, which controls starting block number of initrd
Mon, 15 Sep 2025 13:43:43 +0200
Christophe Leroy <[email protected]> • #5104
Re: [PATCH RESEND 13/62] ext2: remove ext2_image_size and associated code
Mon, 15 Sep 2025 11:19:38 +0200
Jan Kara <[email protected]> • #5103
Re: [PATCH RESEND 21/62] init: remove all mentions of root=/dev/ram*
Mon, 15 Sep 2025 06:41:45 +0200
Krzysztof Kozlowski <[email protected]> • #5102
Re: [PATCH RESEND 21/62] init: remove all mentions of root=/dev/ram*
Sun, 14 Sep 2025 13:13:21 -0700
Andrew Morton <[email protected]> • #5101
Re: [PATCH RESEND 00/62] initrd: remove classic initrd support
Sun, 14 Sep 2025 12:08:04 +0200
Krzysztof Kozlowski <[email protected]> • #5100
Re: [PATCH RESEND 21/62] init: remove all mentions of root=/dev/ram*
Sun, 14 Sep 2025 12:06:24 +0200
Krzysztof Kozlowski <[email protected]> • #5099
Re: [PATCH RESEND 00/62] initrd: remove classic initrd support
Sun, 14 Sep 2025 07:19:23 +0300
Askar Safin <[email protected]> • #5098
[PATCH RESEND 62/62] init: rename CONFIG_RD_ZSTD to CONFIG_INITRAMFS_DECOMPRESS_ZSTD
Sun, 14 Sep 2025 07:04:51 +0300
Askar Safin <[email protected]> • #5097
[PATCH RESEND 61/62] init: rename CONFIG_RD_LZ4 to CONFIG_INITRAMFS_DECOMPRESS_LZ4
Sun, 14 Sep 2025 07:04:15 +0300
Askar Safin <[email protected]> • #5096
[PATCH RESEND 60/62] init: rename CONFIG_RD_LZO to CONFIG_INITRAMFS_DECOMPRESS_LZO
Sun, 14 Sep 2025 07:03:39 +0300
Askar Safin <[email protected]> • #5095
[PATCH RESEND 59/62] init: rename CONFIG_RD_XZ to CONFIG_INITRAMFS_DECOMPRESS_XZ
Sun, 14 Sep 2025 07:03:03 +0300
Askar Safin <[email protected]> • #5094
[PATCH RESEND 58/62] init: rename CONFIG_RD_LZMA to CONFIG_INITRAMFS_DECOMPRESS_LZMA
Sun, 14 Sep 2025 07:02:27 +0300
Askar Safin <[email protected]> • #5093
[PATCH RESEND 57/62] init: rename CONFIG_RD_BZIP2 to CONFIG_INITRAMFS_DECOMPRESS_BZIP2
Sun, 14 Sep 2025 07:01:51 +0300
Askar Safin <[email protected]> • #5092
[PATCH RESEND 56/62] init: rename CONFIG_RD_GZIP to CONFIG_INITRAMFS_DECOMPRESS_GZIP
Sun, 14 Sep 2025 07:01:13 +0300
Askar Safin <[email protected]> • #5091
[PATCH RESEND 55/62] init: rename CONFIG_BLK_DEV_INITRD to CONFIG_INITRAMFS
Sun, 14 Sep 2025 07:00:37 +0300
Askar Safin <[email protected]> • #5090
[PATCH RESEND 54/62] init: arm, x86: deal with some references to initrd
Sun, 14 Sep 2025 07:00:01 +0300
Askar Safin <[email protected]> • #5089
[PATCH RESEND 53/62] init: rename kexec_free_initrd to kexec_free_initramfs
Sun, 14 Sep 2025 06:59:26 +0300
Askar Safin <[email protected]> • #5088
[PATCH RESEND 52/62] init: rename do_retain_initrd to retain_initramfs
Sun, 14 Sep 2025 06:58:50 +0300
Askar Safin <[email protected]> • #5087
[PATCH RESEND 51/62] init: rename get_boot_config_from_initrd to get_boot_config_from_initramfs
Sun, 14 Sep 2025 06:58:14 +0300
Askar Safin <[email protected]> • #5086
[PATCH RESEND 50/62] init: rename ramdisk_command_access to initramfs_command_access
Sun, 14 Sep 2025 06:57:38 +0300
Askar Safin <[email protected]> • #5085
[PATCH RESEND 49/62] init: rename ramdisk_execute_command to initramfs_execute_command
Sun, 14 Sep 2025 06:57:03 +0300
Askar Safin <[email protected]> • #5084
[PATCH RESEND 48/62] init: fix comment
Sun, 14 Sep 2025 06:56:26 +0300
Askar Safin <[email protected]> • #5083
[PATCH RESEND 47/62] init: fix typo: virtul => virtual
Sun, 14 Sep 2025 06:55:50 +0300
Askar Safin <[email protected]> • #5082
[PATCH RESEND 46/62] init: edit docs for initramfs-related configs
Sun, 14 Sep 2025 06:55:13 +0300
Askar Safin <[email protected]> • #5081
[PATCH RESEND 45/62] doc: kernel-parameters: replace [RAM] with [INITRAMFS]
Sun, 14 Sep 2025 06:54:38 +0300
Askar Safin <[email protected]> • #5080
[PATCH RESEND 44/62] doc: kernel-parameters: remove [RAM] from reserve_mem=
Sun, 14 Sep 2025 06:54:02 +0300
Askar Safin <[email protected]> • #5079
[PATCH RESEND 43/62] setsid: inline ksys_setsid into the only caller
Sun, 14 Sep 2025 06:53:26 +0300
Askar Safin <[email protected]> • #5078
[PATCH RESEND 42/62] init: rename <linux/initrd.h> to <linux/initramfs.h>
Sun, 14 Sep 2025 06:52:50 +0300
Askar Safin <[email protected]> • #5077
[PATCH RESEND 41/62] init: rename reserve_initrd_mem to reserve_initramfs_mem
Sun, 14 Sep 2025 06:52:15 +0300
Askar Safin <[email protected]> • #5076
[PATCH RESEND 40/62] init: rename free_initrd_mem to free_initramfs_mem
Sun, 14 Sep 2025 06:51:38 +0300
Askar Safin <[email protected]> • #5075
[PATCH RESEND 39/62] init: make console_on_rootfs static
Sun, 14 Sep 2025 06:51:03 +0300
Askar Safin <[email protected]> • #5074
[PATCH RESEND 38/62] init: remove most headers from init/do_mounts.h
Sun, 14 Sep 2025 06:50:27 +0300
Askar Safin <[email protected]> • #5073
[PATCH RESEND 37/62] init: remove root_mountflags from init/do_mounts.h
Sun, 14 Sep 2025 06:43:35 +0300
Askar Safin <[email protected]> • #5072
Re: [PATCH RESEND 00/62] initrd: remove classic initrd support
Sat, 13 Sep 2025 08:58:34 +0000
Julian Stecklina <[email protected]> • #5071
Re: [PATCH RESEND 28/62] init: alpha, arc, arm, arm64, csky, m68k, microblaze, mips, nios2, openrisc, parisc, powerpc, s390, sh, sparc, um, x86, xtensa: rename initrd_{start,end} to virt_external_initramfs_{start,end}
Sat, 13 Sep 2025 07:59:45 +0200
Borislav Petkov <[email protected]> • #5070
Re: [PATCH RESEND 28/62] init: alpha, arc, arm, arm64, csky, m68k, microblaze, mips, nios2, openrisc, parisc, powerpc, s390, sh, sparc, um, x86, xtensa: rename initrd_{start,end} to virt_external_initramfs_{start,end}
Sat, 13 Sep 2025 07:48:37 +0200
Borislav Petkov <[email protected]> • #5069
[PATCH RESEND 36/62] init: make mount_root static
Sat, 13 Sep 2025 00:38:15 +0000
Askar Safin <[email protected]> • #5068
[PATCH RESEND 35/62] init: make mount_root_generic static
Sat, 13 Sep 2025 00:38:14 +0000
Askar Safin <[email protected]> • #5067
[PATCH RESEND 34/62] init: inline create_dev into the only caller
Sat, 13 Sep 2025 00:38:13 +0000
Askar Safin <[email protected]> • #5066
[PATCH RESEND 33/62] init: remove init/do_mounts_initrd.c
Sat, 13 Sep 2025 00:38:12 +0000
Askar Safin <[email protected]> • #5065
[PATCH RESEND 32/62] init: move initramfs_below_start_ok to init/initramfs.c
Sat, 13 Sep 2025 00:38:11 +0000
Askar Safin <[email protected]> • #5064
[PATCH RESEND 31/62] init: rename initrd_below_start_ok to initramfs_below_start_ok
Sat, 13 Sep 2025 00:38:10 +0000
Askar Safin <[email protected]> • #5063
[PATCH RESEND 30/62] doc: remove documentation for block device 4 0
Sat, 13 Sep 2025 00:38:09 +0000
Askar Safin <[email protected]> • #5062
[PATCH RESEND 29/62] init: move virt_external_initramfs_{start,end} to init/initramfs.c
Sat, 13 Sep 2025 00:38:08 +0000
Askar Safin <[email protected]> • #5061
[PATCH RESEND 28/62] init: alpha, arc, arm, arm64, csky, m68k, microblaze, mips, nios2, openrisc, parisc, powerpc, s390, sh, sparc, um, x86, xtensa: rename initrd_{start,end} to virt_external_initramfs_{start,end}
Sat, 13 Sep 2025 00:38:07 +0000
Askar Safin <[email protected]> • #5060
[PATCH RESEND 27/62] init: alpha: remove "extern unsigned long initrd_start, initrd_end"
Sat, 13 Sep 2025 00:38:06 +0000
Askar Safin <[email protected]> • #5059
[PATCH RESEND 26/62] init: move phys_external_initramfs_{start,size} to init/initramfs.c
Sat, 13 Sep 2025 00:38:05 +0000
Askar Safin <[email protected]> • #5058
[PATCH RESEND 25/62] init: rename phys_initrd_{start,size} to phys_external_initramfs_{start,size}
Sat, 13 Sep 2025 00:38:04 +0000
Askar Safin <[email protected]> • #5057
[PATCH RESEND 24/62] init: remove wrong comment
Sat, 13 Sep 2025 00:38:03 +0000
Askar Safin <[email protected]> • #5056
[PATCH RESEND 23/62] init: rename __initramfs_{start,size} to __builtin_initramfs_{start,size}
Sat, 13 Sep 2025 00:38:02 +0000
Askar Safin <[email protected]> • #5055
[PATCH RESEND 22/62] doc: remove obsolete mentions of pivot_root
Sat, 13 Sep 2025 00:38:01 +0000
Askar Safin <[email protected]> • #5054
[PATCH RESEND 21/62] init: remove all mentions of root=/dev/ram*
Sat, 13 Sep 2025 00:38:00 +0000
Askar Safin <[email protected]> • #5053
[PATCH RESEND 20/62] doc: remove Documentation/power/swsusp-dmcrypt.rst
Sat, 13 Sep 2025 00:37:59 +0000
Askar Safin <[email protected]> • #5052
[PATCH RESEND 19/62] init: remove mentions of "ramdisk=" command line parameter
Sat, 13 Sep 2025 00:37:58 +0000
Askar Safin <[email protected]> • #5051
[PATCH RESEND 18/62] doc: modernize Documentation/driver-api/early-userspace/early_userspace_support.rst
Sat, 13 Sep 2025 00:37:57 +0000
Askar Safin <[email protected]> • #5050
[PATCH RESEND 17/62] doc: modernize Documentation/filesystems/ramfs-rootfs-initramfs.rst
Sat, 13 Sep 2025 00:37:56 +0000
Askar Safin <[email protected]> • #5049
[PATCH RESEND 16/62] brd: remove "ramdisk_size" command line parameter
Sat, 13 Sep 2025 00:37:55 +0000
Askar Safin <[email protected]> • #5048
[PATCH RESEND 15/62] doc: modernize Documentation/admin-guide/blockdev/ramdisk.rst
Sat, 13 Sep 2025 00:37:54 +0000
Askar Safin <[email protected]> • #5047
[PATCH RESEND 14/62] init: m68k, mips, powerpc, s390, sh: remove Root_RAM0
Sat, 13 Sep 2025 00:37:53 +0000
Askar Safin <[email protected]> • #5046
[PATCH RESEND 13/62] ext2: remove ext2_image_size and associated code
Sat, 13 Sep 2025 00:37:52 +0000
Askar Safin <[email protected]> • #5045
[PATCH RESEND 12/62] init: remove /proc/sys/kernel/real-root-dev
Sat, 13 Sep 2025 00:37:51 +0000
Askar Safin <[email protected]> • #5044
[PATCH RESEND 11/62] init, efi: remove "noinitrd" command line parameter
Sat, 13 Sep 2025 00:37:50 +0000
Askar Safin <[email protected]> • #5043
[PATCH RESEND 10/62] initrd: remove initrd (initial RAM disk) support
Sat, 13 Sep 2025 00:37:49 +0000
Askar Safin <[email protected]> • #5042
[PATCH RESEND 09/62] arm: init: document rd_start (in param_struct) as obsolete
Sat, 13 Sep 2025 00:37:48 +0000
Askar Safin <[email protected]> • #5041
[PATCH RESEND 08/62] arm: init: remove FLAG_RDLOAD and FLAG_RDPROMPT
Sat, 13 Sep 2025 00:37:47 +0000
Askar Safin <[email protected]> • #5040
[PATCH RESEND 07/62] arm: init: remove ATAG_RAMDISK
Sat, 13 Sep 2025 00:37:46 +0000
Askar Safin <[email protected]> • #5039
[PATCH RESEND 06/62] arm: init: remove special logic for setting brd.rd_size
Sat, 13 Sep 2025 00:37:45 +0000
Askar Safin <[email protected]> • #5038
[PATCH RESEND 05/62] init: remove "ramdisk_start" command line parameter, which controls starting block number of initrd
Sat, 13 Sep 2025 00:37:44 +0000
Askar Safin <[email protected]> • #5037
[PATCH RESEND 04/62] init: x86, arm, sh, sparc: remove variable rd_image_start, which controls starting block number of initrd
Sat, 13 Sep 2025 00:37:43 +0000
Askar Safin <[email protected]> • #5036
[PATCH RESEND 03/62] init: sh, sparc, x86: remove unused constants RAMDISK_PROMPT_FLAG and RAMDISK_LOAD_FLAG
Sat, 13 Sep 2025 00:37:42 +0000
Askar Safin <[email protected]> • #5035
[PATCH RESEND 02/62] init: remove deprecated "prompt_ramdisk" command line parameter, which does nothing
Sat, 13 Sep 2025 00:37:41 +0000
Askar Safin <[email protected]> • #5034
[PATCH RESEND 01/62] init: remove deprecated "load_ramdisk" command line parameter, which does nothing
Sat, 13 Sep 2025 00:37:40 +0000
Askar Safin <[email protected]> • #5033
[PATCH RESEND 00/62] initrd: remove classic initrd support
Sat, 13 Sep 2025 00:37:39 +0000
Askar Safin <[email protected]> • #5032
[PATCH 03/62] init: sh, sparc, x86: remove unused constants RAMDISK_PROMPT_FLAG and RAMDISK_LOAD_FLAG
Fri, 12 Sep 2025 22:38:38 +0000
Askar Safin <[email protected]> • #5031
[PATCH 02/62] init: remove deprecated "prompt_ramdisk" command line parameter, which does nothing
Fri, 12 Sep 2025 22:38:37 +0000
Askar Safin <[email protected]> • #5030
[PATCH 01/62] init: remove deprecated "load_ramdisk" command line parameter, which does nothing
Fri, 12 Sep 2025 22:38:36 +0000
Askar Safin <[email protected]> • #5029
[PATCH 00/62] initrd: remove classic initrd support
Fri, 12 Sep 2025 22:38:35 +0000
Askar Safin <[email protected]> • #5028
Re: [PATCH v2] fs: Add 'rootfsflags' to set rootfs mount options
Fri, 22 Aug 2025 23:25:11 +1000
Aleksa Sarai <[email protected]> • #5027
Re: [PATCH v2] fs: Add 'rootfsflags' to set rootfs mount options
Fri, 22 Aug 2025 20:48:20 +0800
Lichen Liu <[email protected]> • #5026
Re: [PATCH v2] fs: Add 'rootfsflags' to set rootfs mount options
Thu, 21 Aug 2025 17:44:29 -0700
Randy Dunlap <[email protected]> • #5025
Re: [PATCH v2] fs: Add 'rootfsflags' to set rootfs mount options
Thu, 21 Aug 2025 14:02:00 -0500
Rob Landley <[email protected]> • #5024
Re: [PATCH v2] fs: Add 'rootfsflags' to set rootfs mount options
Thu, 21 Aug 2025 17:04:33 +0400
Askar Safin <[email protected]> • #5023
Re: [PATCH v2] fs: Add 'rootfsflags' to set rootfs mount options
Thu, 21 Aug 2025 10:24:11 +0200
Christian Brauner <[email protected]> • #5022
Re: [PATCH v2] fs: Add 'rootfsflags' to set rootfs mount options
Wed, 20 Aug 2025 23:17:20 +0800
Lichen Liu <[email protected]> • #5021
[PATCH v2] fs: Add 'rootfsflags' to set rootfs mount options
Fri, 15 Aug 2025 20:14:59 +0800
Lichen Liu <[email protected]> • #5020
Re: [PATCH RESEND] fs: Add 'rootfsflags' to set rootfs mount options
Fri, 15 Aug 2025 20:12:30 +0800
Lichen Liu <[email protected]> • #5019
Re: [PATCH RESEND] fs: Add 'rootfsflags' to set rootfs mount options
Thu, 14 Aug 2025 09:23:52 -0700
Randy Dunlap <[email protected]> • #5018
[PATCH RESEND] fs: Add 'rootfsflags' to set rootfs mount options
Thu, 14 Aug 2025 18:34:25 +0800
Lichen Liu <[email protected]> • #5017
Re: [PATCH] fs: Add 'rootfsflags' to set rootfs mount options
Thu, 14 Aug 2025 18:25:41 +0800
Lichen Liu <[email protected]> • #5016
Re: [PATCH] fs: Add 'rootfsflags' to set rootfs mount options
Thu, 14 Aug 2025 11:13:32 +0300
Askar Safin <[email protected]> • #5015
initramfs-tools 0.150 release
Tue, 12 Aug 2025 23:23:12 +0200
Ben Hutchings <[email protected]> • #5014
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.