org.kernel.vger.linux-arch archive

679 archived articles, newest first (page 4 of 7). Latest articles →

Re: [PATCH RFC 07/11] mm/mremap: use ptep_get() for the destination PTE
Thu, 30 Jul 2026 13:59:24 +0100
Muhammad Usama Anjum <[email protected]> • #153555
Re: [PATCH RFC 07/11] mm/mremap: use ptep_get() for the destination PTE
Thu, 30 Jul 2026 13:29:24 +0200
Alexander Gordeev <[email protected]> • #153554
Re: [PATCH RFC 06/11] mm/kasan: use hw_pte_t for the early shadow PTE table
Thu, 30 Jul 2026 13:26:12 +0200
Alexander Gordeev <[email protected]> • #153553
Re: [PATCH RFC 05/11] mm: convert PTE table entries in ptep_get()
Thu, 30 Jul 2026 11:25:29 +0100
Muhammad Usama Anjum <[email protected]> • #153552
Re: [PATCH RFC 05/11] mm: convert PTE table entries in ptep_get()
Thu, 30 Jul 2026 12:24:17 +0200
Alexander Gordeev <[email protected]> • #153551
Re: [PATCH RFC 05/11] mm: convert PTE table entries in ptep_get()
Thu, 30 Jul 2026 11:11:35 +0100
Muhammad Usama Anjum <[email protected]> • #153550
Re: [PATCH RFC 05/11] mm: convert PTE table entries in ptep_get()
Thu, 30 Jul 2026 12:08:20 +0200
Alexander Gordeev <[email protected]> • #153549
Re: [PATCH v8 7/9] x86/string: extend memcpy_flushcache() fixed-size fastpaths
Thu, 30 Jul 2026 09:14:55 +0100
David Laight <[email protected]> • #153548
Re: [PATCH v8 7/9] x86/string: extend memcpy_flushcache() fixed-size fastpaths
Thu, 30 Jul 2026 16:05:36 +0800
"Li Zhe" <[email protected]> • #153547
Re: [PATCH v7 9/9] mm: always use the zone-device template init path
Thu, 30 Jul 2026 15:58:06 +0800
"Li Zhe" <[email protected]> • #153546
Re: [PATCH v7 0/9] mm: optimize zone-device memmap initialization
Thu, 30 Jul 2026 15:53:22 +0800
"Li Zhe" <[email protected]> • #153545
Re: [PATCH v8 7/9] x86/string: extend memcpy_flushcache() fixed-size fastpaths
Wed, 29 Jul 2026 16:48:42 -0700
Borislav Petkov <[email protected]> • #153544
Re: [PATCH RFC 09/11] misc/sgi-gru: use ptep_get() for page-table reads
Wed, 29 Jul 2026 18:03:19 +0100
Muhammad Usama Anjum <[email protected]> • #153543
Re: [PATCH V5] riscv: errata: Add ERRATA_THEAD_WRITE_ONCE fixup
Wed, 29 Jul 2026 06:43:22 -0700
Drew Fustini <[email protected]> • #153542
Re: [PATCH RFC 09/11] misc/sgi-gru: use ptep_get() for page-table reads
Wed, 29 Jul 2026 14:42:30 +0200
"David Hildenbrand (Arm)" <[email protected]> • #153541
Re: [PATCH RFC 09/11] misc/sgi-gru: use ptep_get() for page-table reads
Wed, 29 Jul 2026 13:36:58 +0100
Pedro Falcato <[email protected]> • #153540
Re: [PATCH RFC 00/11] mm: distinguish PTE table storage from PTE values
Wed, 29 Jul 2026 14:28:25 +0200
"David Hildenbrand (Arm)" <[email protected]> • #153539
Re: [PATCH RFC 00/11] mm: distinguish PTE table storage from PTE values
Wed, 29 Jul 2026 13:21:29 +0100
Muhammad Usama Anjum <[email protected]> • #153538
Re: [PATCH RFC 00/11] mm: distinguish PTE table storage from PTE values
Wed, 29 Jul 2026 13:52:39 +0200
"David Hildenbrand (Arm)" <[email protected]> • #153537
Re: [PATCH RFC 00/11] mm: distinguish PTE table storage from PTE values
Wed, 29 Jul 2026 13:44:17 +0200
Alexander Gordeev <[email protected]> • #153536
Re: [PATCH RFC 00/11] mm: distinguish PTE table storage from PTE values
Wed, 29 Jul 2026 13:51:17 +0200
"David Hildenbrand (Arm)" <[email protected]> • #153535
Re: [PATCH RFC 00/11] mm: distinguish PTE table storage from PTE values
Wed, 29 Jul 2026 12:33:57 +0100
Muhammad Usama Anjum <[email protected]> • #153534
Re: [PATCH RFC 00/11] mm: distinguish PTE table storage from PTE values
Wed, 29 Jul 2026 12:18:30 +0100
Muhammad Usama Anjum <[email protected]> • #153533
Re: [PATCH RFC 00/11] mm: distinguish PTE table storage from PTE values
Wed, 29 Jul 2026 13:05:35 +0200
"David Hildenbrand (Arm)" <[email protected]> • #153532
Re: [PATCH RFC 00/11] mm: distinguish PTE table storage from PTE values
Wed, 29 Jul 2026 12:13:18 +0200
Alexander Gordeev <[email protected]> • #153531
Re: [PATCH v6 8/8] futex: Use runtime constants for __futex_hash() hot path
Wed, 29 Jul 2026 12:19:06 +0530
K Prateek Nayak <[email protected]> • #153530
Re: [PATCH v14 00/15] barrier: Add smp_cond_load_{relaxed,acquire}_timeout()
Tue, 28 Jul 2026 16:34:31 -0700
Ankur Arora <[email protected]> • #153529
Re: [PATCH v14 13/15] arm64/delay: enable testing smp_cond_load_relaxed_timeout()
Tue, 28 Jul 2026 16:06:23 -0700
Ankur Arora <[email protected]> • #153528
[PATCH v7 4/4] arm64: vdso32: Implement __vdso_futex_robust_try_unlock()
Tue, 28 Jul 2026 17:24:04 -0300
André Almeida <[email protected]> • #153527
[PATCH v7 2/4] arm64: vdso: Implement __vdso_futex_robust_try_unlock()
Tue, 28 Jul 2026 17:24:02 -0300
André Almeida <[email protected]> • #153526
[PATCH v7 0/4] arm64: vdso: Implement __vdso_futex_robust_try_unlock()
Tue, 28 Jul 2026 17:24:00 -0300
André Almeida <[email protected]> • #153525
[PATCH v7 3/4] arm64: vdso32: Bring vdso32-offsets.h back
Tue, 28 Jul 2026 17:24:03 -0300
André Almeida <[email protected]> • #153524
[PATCH v7 1/4] arm64: vdso: Prepare for robust futex unlock support
Tue, 28 Jul 2026 17:24:01 -0300
André Almeida <[email protected]> • #153523
Re: [PATCH RFC 00/11] mm: distinguish PTE table storage from PTE values
Tue, 28 Jul 2026 21:26:06 +0200
"David Hildenbrand (Arm)" <[email protected]> • #153522
Re: [PATCH v7 9/9] mm: always use the zone-device template init path
Tue, 28 Jul 2026 19:48:40 +0300
Mike Rapoport <[email protected]> • #153521
Re: [PATCH v7 0/9] mm: optimize zone-device memmap initialization
Tue, 28 Jul 2026 19:48:40 +0300
Mike Rapoport <[email protected]> • #153520
Re: [PATCH v14 13/15] arm64/delay: enable testing smp_cond_load_relaxed_timeout()
Tue, 28 Jul 2026 12:36:58 +0100
Will Deacon <[email protected]> • #153519
Re: [PATCH v6 5/7] locking: Add contended_release tracepoint to qspinlock
Tue, 28 Jul 2026 11:08:17 +0000
Dmitry Ilvokhin <[email protected]> • #153518
Re: [PATCH v6 8/8] futex: Use runtime constants for __futex_hash() hot path
Tue, 28 Jul 2026 13:08:06 +0200
Peter Zijlstra <[email protected]> • #153517
Re: [PATCH v6 8/8] futex: Use runtime constants for __futex_hash() hot path
Tue, 28 Jul 2026 12:46:53 +0200
Peter Zijlstra <[email protected]> • #153516
Re: [PATCH v8 0/9] mm: optimize zone-device memmap initialization
Tue, 28 Jul 2026 14:18:44 +0800
"Li Zhe" <[email protected]> • #153515
[PATCH v6 8/8] futex: Use runtime constants for __futex_hash() hot path
Tue, 28 Jul 2026 05:25:40 +0000
K Prateek Nayak <[email protected]> • #153514
[PATCH v6 7/8] asm-generic/runtime-const: Add dummy runtime_const_mask_32()
Tue, 28 Jul 2026 05:25:39 +0000
K Prateek Nayak <[email protected]> • #153513
[PATCH v6 6/8] s390/runtime-const: Introduce runtime_const_mask_32()
Tue, 28 Jul 2026 05:25:38 +0000
K Prateek Nayak <[email protected]> • #153512
[PATCH v6 5/8] riscv/runtime-const: Introduce runtime_const_mask_32()
Tue, 28 Jul 2026 05:25:37 +0000
K Prateek Nayak <[email protected]> • #153511
[PATCH v6 4/8] riscv/runtime-const: Replace open-coded placeholder with RUNTIME_MAGIC
Tue, 28 Jul 2026 05:25:36 +0000
K Prateek Nayak <[email protected]> • #153510
[PATCH v6 3/8] arm64/runtime-const: Introduce runtime_const_mask_32()
Tue, 28 Jul 2026 05:25:35 +0000
K Prateek Nayak <[email protected]> • #153509
[PATCH v6 2/8] arm64/runtime-const: Use aarch64_insn_patch_text_nosync() for patching
Tue, 28 Jul 2026 05:25:34 +0000
K Prateek Nayak <[email protected]> • #153508
[PATCH v6 0/8] futex: Use runtime constants for futex_hash computation
Tue, 28 Jul 2026 05:25:32 +0000
K Prateek Nayak <[email protected]> • #153507
[PATCH v6 1/8] x86/runtime-const: Introduce runtime_const_mask_32()
Tue, 28 Jul 2026 05:25:33 +0000
K Prateek Nayak <[email protected]> • #153506
[PATCH v2] asm-generic/io.h: fix grammar typos
Mon, 27 Jul 2026 17:46:29 -0700
Randy Dunlap <[email protected]> • #153505
Re: [PATCH v8 0/9] mm: optimize zone-device memmap initialization
Mon, 27 Jul 2026 13:57:25 -0700
Andrew Morton <[email protected]> • #153504
Re: [PATCH RFC v2 12/20] x86: mm: define pudp_set_access_flags() when CONFIG_HAVE_ARCH_TRANSPARENT_HUGEPAGE_PUD is enabled only.
Mon, 27 Jul 2026 19:06:29 +0100
Yeoreum Yun <[email protected]> • #153503
[PATCH RFC 11/11] xen: use hw_pte_t for PTE range callbacks
Mon, 27 Jul 2026 17:47:02 +0100
Muhammad Usama Anjum <[email protected]> • #153502
[PATCH RFC 10/11] parisc: use hw_pte_t for the data-break callback
Mon, 27 Jul 2026 17:47:01 +0100
Muhammad Usama Anjum <[email protected]> • #153501
[PATCH RFC 09/11] misc/sgi-gru: use ptep_get() for page-table reads
Mon, 27 Jul 2026 17:47:00 +0100
Muhammad Usama Anjum <[email protected]> • #153500
[PATCH RFC 08/11] drm/i915: use hw_pte_t for PTE range callbacks
Mon, 27 Jul 2026 17:46:59 +0100
Muhammad Usama Anjum <[email protected]> • #153499
[PATCH RFC 07/11] mm/mremap: use ptep_get() for the destination PTE
Mon, 27 Jul 2026 17:46:58 +0100
Muhammad Usama Anjum <[email protected]> • #153498
[PATCH RFC 06/11] mm/kasan: use hw_pte_t for the early shadow PTE table
Mon, 27 Jul 2026 17:46:57 +0100
Muhammad Usama Anjum <[email protected]> • #153497
[PATCH RFC 04/11] mm: use hw_pte_t for generic PTE table storage
Mon, 27 Jul 2026 17:46:55 +0100
Muhammad Usama Anjum <[email protected]> • #153496
[PATCH RFC 05/11] mm: convert PTE table entries in ptep_get()
Mon, 27 Jul 2026 17:46:56 +0100
Muhammad Usama Anjum <[email protected]> • #153495
[PATCH RFC 03/11] mm: name pointers to copied PTE values ptentp
Mon, 27 Jul 2026 17:46:54 +0100
Muhammad Usama Anjum <[email protected]> • #153494
[PATCH RFC 02/11] mm: make hw_pte_t visible to generic PTE interfaces
Mon, 27 Jul 2026 17:46:53 +0100
Muhammad Usama Anjum <[email protected]> • #153493
[PATCH RFC 01/11] mm: introduce hw_pte_t for PTE table storage
Mon, 27 Jul 2026 17:46:52 +0100
Muhammad Usama Anjum <[email protected]> • #153492
[PATCH RFC 00/11] mm: distinguish PTE table storage from PTE values
Mon, 27 Jul 2026 17:46:51 +0100
Muhammad Usama Anjum <[email protected]> • #153491
Re: [PATCH RFC v2 00/20] mm: optimize unnecessary loads due to ptep_get() and friends out
Mon, 27 Jul 2026 16:50:52 +0100
Yeoreum Yun <[email protected]> • #153490
Re: [PATCH RFC v2 13/20] x86: mm: carve out the generic compile-time folded pgtable case in effective_prot()
Mon, 27 Jul 2026 16:36:23 +0100
Yeoreum Yun <[email protected]> • #153489
Re: [PATCH RFC v2 13/20] x86: mm: carve out the generic compile-time folded pgtable case in effective_prot()
Mon, 27 Jul 2026 17:27:52 +0200
"David Hildenbrand (Arm)" <[email protected]> • #153488
Re: [PATCH RFC v2 00/20] mm: optimize unnecessary loads due to ptep_get() and friends out
Mon, 27 Jul 2026 17:18:00 +0200
"David Hildenbrand (Arm)" <[email protected]> • #153487
Re: [PATCH RFC v2 12/20] x86: mm: define pudp_set_access_flags() when CONFIG_HAVE_ARCH_TRANSPARENT_HUGEPAGE_PUD is enabled only.
Mon, 27 Jul 2026 17:02:00 +0200
"David Hildenbrand (Arm)" <[email protected]> • #153486
Re: [PATCH RFC v2 10/20] riscv: kvm: remove stack copy address of pXd in pXd_offset()
Mon, 27 Jul 2026 16:53:20 +0200
"David Hildenbrand (Arm)" <[email protected]> • #153485
Re: [PATCH RFC v2 09/20] loongarch: kvm: remove stack copy address of pXd in pXd_offset()
Mon, 27 Jul 2026 16:53:03 +0200
"David Hildenbrand (Arm)" <[email protected]> • #153484
[PATCH v8 9/9] mm: always use the zone-device template init path
Mon, 27 Jul 2026 20:34:29 +0800
"Li Zhe" <[email protected]> • #153483
[PATCH v8 8/9] mm: use memcpy_nontemporal() in zone-device template copies
Mon, 27 Jul 2026 20:34:28 +0800
"Li Zhe" <[email protected]> • #153482
[PATCH v8 7/9] x86/string: extend memcpy_flushcache() fixed-size fastpaths
Mon, 27 Jul 2026 20:34:27 +0800
"Li Zhe" <[email protected]> • #153481
[PATCH v8 6/9] string: introduce memcpy_nontemporal()
Mon, 27 Jul 2026 20:34:26 +0800
"Li Zhe" <[email protected]> • #153480
[PATCH v8 1/9] mm: fix stale ZONE_DEVICE refcount comment
Mon, 27 Jul 2026 20:34:21 +0800
"Li Zhe" <[email protected]> • #153479
[PATCH v8 5/9] mm: extend the template fast path to zone-device compound tails
Mon, 27 Jul 2026 20:34:25 +0800
"Li Zhe" <[email protected]> • #153478
[PATCH v8 0/9] mm: optimize zone-device memmap initialization
Mon, 27 Jul 2026 20:34:20 +0800
"Li Zhe" <[email protected]> • #153477
[PATCH v8 4/9] mm: add a template-based fast path for zone-device page init
Mon, 27 Jul 2026 20:34:24 +0800
"Li Zhe" <[email protected]> • #153476
[PATCH v8 3/9] mm: add a set_page_section_from_pfn() helper
Mon, 27 Jul 2026 20:34:23 +0800
"Li Zhe" <[email protected]> • #153475
[PATCH v8 2/9] mm: factor zone-device page init helpers out of __init_zone_device_page
Mon, 27 Jul 2026 20:34:22 +0800
"Li Zhe" <[email protected]> • #153474
Re: [PATCH V4 1/9] mshv: Provide a way to get partition ID if running in a VMM process
Fri, 24 Jul 2026 18:48:55 -0700
Mukesh R <[email protected]> • #153473
Re: [PATCH V4 1/9] mshv: Provide a way to get partition ID if running in a VMM process
Fri, 24 Jul 2026 15:08:24 -0700
Jacob Pan <[email protected]> • #153472
Re: [PATCH V4 4/9] mshv: Add ioctl support for MSHV-VFIO bridge device
Fri, 24 Jul 2026 14:27:09 -0700
Mukesh R <[email protected]> • #153471
Re: [PATCH V4 1/9] mshv: Provide a way to get partition ID if running in a VMM process
Fri, 24 Jul 2026 12:14:08 -0700
Mukesh R <[email protected]> • #153470
Re: [PATCH V4 4/9] mshv: Add ioctl support for MSHV-VFIO bridge device
Fri, 24 Jul 2026 10:20:29 -0700
Jacob Pan <[email protected]> • #153469
Re: [PATCH 14/22] mm: set page table page type when allocated
Fri, 24 Jul 2026 18:31:32 +0200
Kevin Brodsky <[email protected]> • #153468
Re: [PATCH 15/22] mm: only initialise pt_share_count for user pgtables
Fri, 24 Jul 2026 18:25:35 +0200
Kevin Brodsky <[email protected]> • #153467
Re: [PATCH 04/22] mm: use mm_is_kernel() in generic page table code
Fri, 24 Jul 2026 18:22:40 +0200
Kevin Brodsky <[email protected]> • #153466
Re: [PATCH 03/22] mm: introduce MMF_KERNEL flag and set it for init_mm
Fri, 24 Jul 2026 18:22:26 +0200
Kevin Brodsky <[email protected]> • #153465
Re: [PATCH v4 0/7] vDSO: Remove CONFIG_GENERIC_GETTIMEOFDAY ifdeffery
Fri, 24 Jul 2026 17:35:54 +0200
"Arnd Bergmann" <[email protected]> • #153464
Re: [PATCH v4 2/7] vDSO: Make clockmode constants available without CONFIG_GENERIC_GETTIMEOFDAY
Fri, 24 Jul 2026 17:31:16 +0200
"Arnd Bergmann" <[email protected]> • #153463
[PATCH v4 6/7] clocksource/drivers/timer-riscv: Remove CONFIG_GENERIC_GETTIMEOFDAY ifdeffery
Fri, 24 Jul 2026 15:36:23 +0200
Thomas Weißschuh <[email protected]> • #153462
[PATCH v4 5/7] clocksource/drivers/arm_arch_timer: Remove CONFIG_GENERIC_GETTIMEOFDAY ifdeffery
Fri, 24 Jul 2026 15:36:22 +0200
Thomas Weißschuh <[email protected]> • #153461
[PATCH v4 7/7] LoongArch: Remove CONFIG_GENERIC_GETTIMEOFDAY ifdeffery
Fri, 24 Jul 2026 15:36:24 +0200
Thomas Weißschuh <[email protected]> • #153460
[PATCH v4 4/7] clocksource/drivers/mips-gic-timer: Remove CONFIG_GENERIC_GETTIMEOFDAY ifdeffery
Fri, 24 Jul 2026 15:36:21 +0200
Thomas Weißschuh <[email protected]> • #153459
[PATCH v4 3/7] MIPS: csrc-r4k: Remove CONFIG_GENERIC_GETTIMEOFDAY ifdeffery
Fri, 24 Jul 2026 15:36:20 +0200
Thomas Weißschuh <[email protected]> • #153458
[PATCH v4 2/7] vDSO: Make clockmode constants available without CONFIG_GENERIC_GETTIMEOFDAY
Fri, 24 Jul 2026 15:36:19 +0200
Thomas Weißschuh <[email protected]> • #153457
[PATCH v4 0/7] vDSO: Remove CONFIG_GENERIC_GETTIMEOFDAY ifdeffery
Fri, 24 Jul 2026 15:36:17 +0200
Thomas Weißschuh <[email protected]> • #153456
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.