org.kernel.vger.linux-arch archive

689 archived articles, newest first (page 5 of 7). Latest articles →

Re: [PATCH 03/22] mm: introduce MMF_KERNEL flag and set it for init_mm
Fri, 24 Jul 2026 18:22:26 +0200
Kevin Brodsky <[email protected]> • #153465
Re: [PATCH v4 0/7] vDSO: Remove CONFIG_GENERIC_GETTIMEOFDAY ifdeffery
Fri, 24 Jul 2026 17:35:54 +0200
"Arnd Bergmann" <[email protected]> • #153464
Re: [PATCH v4 2/7] vDSO: Make clockmode constants available without CONFIG_GENERIC_GETTIMEOFDAY
Fri, 24 Jul 2026 17:31:16 +0200
"Arnd Bergmann" <[email protected]> • #153463
[PATCH v4 6/7] clocksource/drivers/timer-riscv: Remove CONFIG_GENERIC_GETTIMEOFDAY ifdeffery
Fri, 24 Jul 2026 15:36:23 +0200
Thomas Weißschuh <[email protected]> • #153462
[PATCH v4 5/7] clocksource/drivers/arm_arch_timer: Remove CONFIG_GENERIC_GETTIMEOFDAY ifdeffery
Fri, 24 Jul 2026 15:36:22 +0200
Thomas Weißschuh <[email protected]> • #153461
[PATCH v4 7/7] LoongArch: Remove CONFIG_GENERIC_GETTIMEOFDAY ifdeffery
Fri, 24 Jul 2026 15:36:24 +0200
Thomas Weißschuh <[email protected]> • #153460
[PATCH v4 4/7] clocksource/drivers/mips-gic-timer: Remove CONFIG_GENERIC_GETTIMEOFDAY ifdeffery
Fri, 24 Jul 2026 15:36:21 +0200
Thomas Weißschuh <[email protected]> • #153459
[PATCH v4 3/7] MIPS: csrc-r4k: Remove CONFIG_GENERIC_GETTIMEOFDAY ifdeffery
Fri, 24 Jul 2026 15:36:20 +0200
Thomas Weißschuh <[email protected]> • #153458
[PATCH v4 2/7] vDSO: Make clockmode constants available without CONFIG_GENERIC_GETTIMEOFDAY
Fri, 24 Jul 2026 15:36:19 +0200
Thomas Weißschuh <[email protected]> • #153457
[PATCH v4 0/7] vDSO: Remove CONFIG_GENERIC_GETTIMEOFDAY ifdeffery
Fri, 24 Jul 2026 15:36:17 +0200
Thomas Weißschuh <[email protected]> • #153456
[PATCH v4 1/7] kbuild: support generated asm-headers in subdirectories
Fri, 24 Jul 2026 15:36:18 +0200
Thomas Weißschuh <[email protected]> • #153455
Re: [PATCH RFC v2 14/20] x86: mm: skip pud setup when using generic compile-time folded pagetable
Fri, 24 Jul 2026 12:49:45 +0100
Yeoreum Yun <[email protected]> • #153454
Re: [PATCH RFC v2 08/20] mm: vmscan: remove stack copy address of pud pass in wallk_pud_range()
Fri, 24 Jul 2026 11:38:40 +0100
Usama Anjum <[email protected]> • #153453
Re: [RFC] Null Namespaces
Fri, 24 Jul 2026 10:04:21 +0200
Christian Brauner <[email protected]> • #153452
[PATCH v8 2/2] module: Rename module_blacklist to module_denylist
Thu, 23 Jul 2026 22:47:44 -0400
Aaron Tomlin <[email protected]> • #153451
[PATCH v8 1/2] module: Extend module_blacklist parameter to built-in modules
Thu, 23 Jul 2026 22:47:43 -0400
Aaron Tomlin <[email protected]> • #153450
[PATCH v8 0/2] module: Rename module_blacklist to module_denylist
Thu, 23 Jul 2026 22:47:42 -0400
Aaron Tomlin <[email protected]> • #153449
Re: [PATCH v7 1/2] module: Extend module_blacklist parameter to built-in modules
Thu, 23 Jul 2026 22:35:14 -0400
Aaron Tomlin <[email protected]> • #153448
[RFC PATCH v2 1/3] error-injection: Introduce EI_ETYPE_FALSE for fail_function
Fri, 24 Jul 2026 10:12:27 +0800
Song Chen <[email protected]> • #153447
[RFC PATCH v2 3/3] error-injection: Introduce parent in fei_attr
Fri, 24 Jul 2026 10:12:29 +0800
Song Chen <[email protected]> • #153446
[RFC PATCH v2 2/3] btrfs: Allow error injection on btrfs_data_csum_ok
Fri, 24 Jul 2026 10:12:28 +0800
Song Chen <[email protected]> • #153445
[RFC PATCH v2 0/3] btrfs: add error injection support for checksum verification
Fri, 24 Jul 2026 10:12:26 +0800
Song Chen <[email protected]> • #153444
[PATCH v7 2/2] module: Rename module_blacklist to module_denylist
Thu, 23 Jul 2026 21:43:45 -0400
Aaron Tomlin <[email protected]> • #153443
[PATCH v7 1/2] module: Extend module_blacklist parameter to built-in modules
Thu, 23 Jul 2026 21:43:44 -0400
Aaron Tomlin <[email protected]> • #153442
[PATCH v7 0/2] module: Extend blacklist parameter to support built-in modules
Thu, 23 Jul 2026 21:43:43 -0400
Aaron Tomlin <[email protected]> • #153441
Re: [PATCH v6 1/2] module: Extend module_blacklist parameter to built-in modules
Thu, 23 Jul 2026 20:46:54 -0400
Aaron Tomlin <[email protected]> • #153440
Re: [PATCH V4 1/9] mshv: Provide a way to get partition ID if running in a VMM process
Thu, 23 Jul 2026 15:21:32 -0700
Jacob Pan <[email protected]> • #153439
RE: [PATCH v3 0/6] arm64: hyperv: Add Realm support for Hyper-V
Thu, 23 Jul 2026 16:26:05 +0000
Michael Kelley <[email protected]> • #153438
RE: [PATCH v2 4/6] Drivers: hv: Mark shared memory as decrypted for CCA Realms
Thu, 23 Jul 2026 16:23:51 +0000
Michael Kelley <[email protected]> • #153437
Re: [PATCH v6 4/4] arm64: vdso32: Implement __vdso_futex_robust_try_unlock()
Thu, 23 Jul 2026 12:57:10 -0300
André Almeida <[email protected]> • #153436
Re: [INTERNAL REVIEW] [RFC PATCH v3 01/20] mm: change behavior of pXdp_get()/pXd_page() in compile-time folded pgtable
Thu, 23 Jul 2026 09:41:33 +0100
Yeoreum Yun <[email protected]> • #153435
[INTERNAL REVIEW] [RFC PATCH v3 01/20] mm: change behavior of pXdp_get()/pXd_page() in compile-time folded pgtable
Thu, 23 Jul 2026 09:10:16 +0100
Yeoreum Yun <[email protected]> • #153434
Re: [PATCH RFC v2 13/20] x86: mm: carve out the generic compile-time folded pgtable case in effective_prot()
Wed, 22 Jul 2026 22:00:17 +0100
Yeoreum Yun <[email protected]> • #153433
Re: [PATCH RFC v2 14/20] x86: mm: skip pud setup when using generic compile-time folded pagetable
Wed, 22 Jul 2026 21:40:42 +0100
Yeoreum Yun <[email protected]> • #153432
Re: [PATCH RFC v2 14/20] x86: mm: skip pud setup when using generic compile-time folded pagetable
Wed, 22 Jul 2026 13:28:40 -0700
"H. Peter Anvin" <[email protected]> • #153431
Re: [PATCH RFC v2 14/20] x86: mm: skip pud setup when using generic compile-time folded pagetable
Wed, 22 Jul 2026 13:22:04 -0700
Dave Hansen <[email protected]> • #153430
Re: [PATCH RFC v2 13/20] x86: mm: carve out the generic compile-time folded pgtable case in effective_prot()
Wed, 22 Jul 2026 13:20:39 -0700
Dave Hansen <[email protected]> • #153429
Re: [PATCH RFC v2 14/20] x86: mm: skip pud setup when using generic compile-time folded pagetable
Wed, 22 Jul 2026 21:18:36 +0100
Yeoreum Yun <[email protected]> • #153428
Re: [PATCH RFC v2 14/20] x86: mm: skip pud setup when using generic compile-time folded pagetable
Wed, 22 Jul 2026 13:02:53 -0700
Dave Hansen <[email protected]> • #153427
Re: [PATCH RFC v2 13/20] x86: mm: carve out the generic compile-time folded pgtable case in effective_prot()
Wed, 22 Jul 2026 18:37:42 +0100
Yeoreum Yun <[email protected]> • #153426
Re: [PATCH RFC v2 00/20] mm: optimize unnecessary loads due to ptep_get() and friends out
Wed, 22 Jul 2026 18:30:52 +0100
Yeoreum Yun <[email protected]> • #153425
Re: [PATCH RFC v2 12/20] x86: mm: define pudp_set_access_flags() when CONFIG_HAVE_ARCH_TRANSPARENT_HUGEPAGE_PUD is enabled only.
Wed, 22 Jul 2026 18:27:36 +0100
Yeoreum Yun <[email protected]> • #153424
Re: [PATCH v3 1/7] kbuild: support generated asm-headers in subdirectories
Wed, 22 Jul 2026 10:21:40 -0700
Nathan Chancellor <[email protected]> • #153423
Re: [PATCH RFC v2 14/20] x86: mm: skip pud setup when using generic compile-time folded pagetable
Wed, 22 Jul 2026 18:18:33 +0100
Yeoreum Yun <[email protected]> • #153422
Re: [PATCH RFC v2 00/20] mm: optimize unnecessary loads due to ptep_get() and friends out
Wed, 22 Jul 2026 09:40:03 -0700
Dave Hansen <[email protected]> • #153421
Re: [PATCH RFC v2 14/20] x86: mm: skip pud setup when using generic compile-time folded pagetable
Wed, 22 Jul 2026 09:33:55 -0700
Dave Hansen <[email protected]> • #153420
Re: [PATCH RFC v2 13/20] x86: mm: carve out the generic compile-time folded pgtable case in effective_prot()
Wed, 22 Jul 2026 17:28:18 +0100
Yeoreum Yun <[email protected]> • #153419
Re: [PATCH RFC v2 13/20] x86: mm: carve out the generic compile-time folded pgtable case in effective_prot()
Wed, 22 Jul 2026 09:11:04 -0700
Dave Hansen <[email protected]> • #153418
Re: [PATCH RFC v2 12/20] x86: mm: define pudp_set_access_flags() when CONFIG_HAVE_ARCH_TRANSPARENT_HUGEPAGE_PUD is enabled only.
Wed, 22 Jul 2026 09:02:17 -0700
Dave Hansen <[email protected]> • #153417
[PATCH RFC v2 20/20] arm64: pgtable: convert pte_present() from macro to static inline
Wed, 22 Jul 2026 16:30:28 +0100
Yeoreum Yun <[email protected]> • #153416
[PATCH RFC v2 19/20] openrisc/pgtable: drop __pmd_offset()
Wed, 22 Jul 2026 16:30:27 +0100
Yeoreum Yun <[email protected]> • #153415
[PATCH RFC v2 18/20] mm/pgtable: disallow calling folded set_pgd/set_p4d/set_pud with dummy
Wed, 22 Jul 2026 16:30:26 +0100
Yeoreum Yun <[email protected]> • #153414
[PATCH RFC v2 17/20] mm/pgtable: disallow calling (pgd|p4d|pud)_page, pgd_page_vaddr() and (p4d|pud)_pgtable with dummy
Wed, 22 Jul 2026 16:30:25 +0100
Yeoreum Yun <[email protected]> • #153413
[PATCH RFC v2 16/20] mm/pgtable: catch abuse of folded dummy pgd_t/p4d_t/pud_t
Wed, 22 Jul 2026 16:30:24 +0100
Yeoreum Yun <[email protected]> • #153412
[PATCH RFC v2 15/20] mm/pgtable: optimize pmdp_get() and friends for folded pagetable levels
Wed, 22 Jul 2026 16:30:23 +0100
Yeoreum Yun <[email protected]> • #153411
[PATCH RFC v2 14/20] x86: mm: skip pud setup when using generic compile-time folded pagetable
Wed, 22 Jul 2026 16:30:22 +0100
Yeoreum Yun <[email protected]> • #153410
[PATCH RFC v2 13/20] x86: mm: carve out the generic compile-time folded pgtable case in effective_prot()
Wed, 22 Jul 2026 16:30:21 +0100
Yeoreum Yun <[email protected]> • #153409
[PATCH RFC v2 12/20] x86: mm: define pudp_set_access_flags() when CONFIG_HAVE_ARCH_TRANSPARENT_HUGEPAGE_PUD is enabled only.
Wed, 22 Jul 2026 16:30:20 +0100
Yeoreum Yun <[email protected]> • #153408
[PATCH RFC v2 11/20] riscv: mm: use proper set_pXd() for generic compile-time folded patable in vmalloc_fault()
Wed, 22 Jul 2026 16:30:19 +0100
Yeoreum Yun <[email protected]> • #153407
[PATCH RFC v2 10/20] riscv: kvm: remove stack copy address of pXd in pXd_offset()
Wed, 22 Jul 2026 16:30:18 +0100
Yeoreum Yun <[email protected]> • #153406
[PATCH RFC v2 09/20] loongarch: kvm: remove stack copy address of pXd in pXd_offset()
Wed, 22 Jul 2026 16:30:17 +0100
Yeoreum Yun <[email protected]> • #153405
[PATCH RFC v2 08/20] mm: vmscan: remove stack copy address of pud pass in wallk_pud_range()
Wed, 22 Jul 2026 16:30:16 +0100
Yeoreum Yun <[email protected]> • #153404
[PATCH RFC v2 07/20] mm/pgtable: define (pgd|p4d|pud)_offset_lockless() for folded page tables
Wed, 22 Jul 2026 16:30:15 +0100
Yeoreum Yun <[email protected]> • #153403
[PATCH RFC v2 06/20] mm/pgtable: define (pgd|p4d|pud)_leaf() for folded page tables
Wed, 22 Jul 2026 16:30:14 +0100
Yeoreum Yun <[email protected]> • #153402
[PATCH RFC v2 05/20] MIPS: mm: define pud_leaf() only when PUD exists
Wed, 22 Jul 2026 16:30:13 +0100
Yeoreum Yun <[email protected]> • #153401
[PATCH RFC v2 04/20] LoongArch: mm: define pud_leaf() only when PUD exists
Wed, 22 Jul 2026 16:30:12 +0100
Yeoreum Yun <[email protected]> • #153400
[PATCH RFC v2 03/20] ARM: mm: remove custom pgdp_get()
Wed, 22 Jul 2026 16:30:11 +0100
Yeoreum Yun <[email protected]> • #153399
[PATCH RFC v2 02/20] ARM: mm: make 2-level pgd_t a scalar
Wed, 22 Jul 2026 16:30:10 +0100
Yeoreum Yun <[email protected]> • #153398
[PATCH RFC v2 01/20] ARM: mm: make nommu pgd_t a scalar
Wed, 22 Jul 2026 16:30:09 +0100
Yeoreum Yun <[email protected]> • #153397
[PATCH RFC v2 00/20] mm: optimize unnecessary loads due to ptep_get() and friends out
Wed, 22 Jul 2026 16:30:08 +0100
Yeoreum Yun <[email protected]> • #153396
Re: [PATCH v6 1/2] module: Extend module_blacklist parameter to built-in modules
Wed, 22 Jul 2026 15:57:54 +0200
Petr Pavlu <[email protected]> • #153395
Re: [PATCH v7 0/9] mm: optimize zone-device memmap initialization
Wed, 22 Jul 2026 16:18:00 +0800
"Li Zhe" <[email protected]> • #153394
Re: [PATCH v3 5/7] clocksource/drivers/arm_arch_timer: Remove CONFIG_GENERIC_GETTIMEOFDAY ifdeffery
Wed, 22 Jul 2026 09:10:14 +0100
Marc Zyngier <[email protected]> • #153393
[PATCH v3 7/7] LoongArch: Remove CONFIG_GENERIC_GETTIMEOFDAY ifdeffery
Wed, 22 Jul 2026 09:53:33 +0200
Thomas Weißschuh <[email protected]> • #153392
[PATCH v3 6/7] clocksource/drivers/timer-riscv: Remove CONFIG_GENERIC_GETTIMEOFDAY ifdeffery
Wed, 22 Jul 2026 09:53:32 +0200
Thomas Weißschuh <[email protected]> • #153391
[PATCH v3 4/7] clocksource/drivers/mips-gic-timer: Remove CONFIG_GENERIC_GETTIMEOFDAY ifdeffery
Wed, 22 Jul 2026 09:53:30 +0200
Thomas Weißschuh <[email protected]> • #153390
[PATCH v3 5/7] clocksource/drivers/arm_arch_timer: Remove CONFIG_GENERIC_GETTIMEOFDAY ifdeffery
Wed, 22 Jul 2026 09:53:31 +0200
Thomas Weißschuh <[email protected]> • #153389
[PATCH v3 3/7] MIPS: csrc-r4k: Remove CONFIG_GENERIC_GETTIMEOFDAY ifdeffery
Wed, 22 Jul 2026 09:53:29 +0200
Thomas Weißschuh <[email protected]> • #153388
[PATCH v3 2/7] vDSO: Make clockmode constants available without CONFIG_GENERIC_GETTIMEOFDAY
Wed, 22 Jul 2026 09:53:28 +0200
Thomas Weißschuh <[email protected]> • #153387
[PATCH v3 1/7] kbuild: support generated asm-headers in subdirectories
Wed, 22 Jul 2026 09:53:27 +0200
Thomas Weißschuh <[email protected]> • #153386
[PATCH v3 0/7] vDSO: Remove CONFIG_GENERIC_GETTIMEOFDAY ifdeffery
Wed, 22 Jul 2026 09:53:26 +0200
Thomas Weißschuh <[email protected]> • #153385
Re: [PATCH v7 0/9] mm: optimize zone-device memmap initialization
Wed, 22 Jul 2026 12:00:19 +0800
"Li Zhe" <[email protected]> • #153384
[PATCH v7 28/29] dyndbg-API: replace DECLARE_DYNDBG_CLASSMAP
Tue, 21 Jul 2026 14:57:17 -0600
Jim Cromie <[email protected]> • #153383
[PATCH v7 29/29] selftests/dyndbg: enable FT_classmap_inheritance
Tue, 21 Jul 2026 14:57:18 -0600
Jim Cromie <[email protected]> • #153382
[PATCH v7 27/29] dyndbg: hoist classmap-filter-by-modname up to ddebug_add_module
Tue, 21 Jul 2026 14:57:16 -0600
Jim Cromie <[email protected]> • #153381
[PATCH v7 26/29] dyndbg: move mod_name down from struct ddebug_table to _ddebug_info
Tue, 21 Jul 2026 14:57:15 -0600
Jim Cromie <[email protected]> • #153380
[PATCH v7 25/29] dyndbg,module: make proper substructs in _ddebug_info
Tue, 21 Jul 2026 14:57:14 -0600
Jim Cromie <[email protected]> • #153379
[PATCH v7 24/29] dyndbg: pin class param storage to u32
Tue, 21 Jul 2026 14:57:13 -0600
Jim Cromie <[email protected]> • #153378
[PATCH v7 23/29] dyndbg: macrofy a 2-index for-loop pattern
Tue, 21 Jul 2026 14:57:12 -0600
Jim Cromie <[email protected]> • #153377
[PATCH v7 22/29] dyndbg: replace classmap list with an array-slice
Tue, 21 Jul 2026 14:57:11 -0600
Jim Cromie <[email protected]> • #153376
[PATCH v7 20/29] dyndbg: refactor param_set_dyndbg_classes and below
Tue, 21 Jul 2026 14:57:09 -0600
Jim Cromie <[email protected]> • #153375
[PATCH v7 21/29] dyndbg: tighten fn-sig of ddebug_apply_class_bitmap
Tue, 21 Jul 2026 14:57:10 -0600
Jim Cromie <[email protected]> • #153374
[PATCH v7 19/29] dyndbg: use KBUILD_MODFILE for unique builtin module names
Tue, 21 Jul 2026 14:57:08 -0600
Jim Cromie <[email protected]> • #153373
[PATCH v7 17/29] dyndbg: reduce verbose/debug clutter
Tue, 21 Jul 2026 14:57:06 -0600
Jim Cromie <[email protected]> • #153372
[PATCH v7 18/29] lib/parser: add match_wildcard_hyphen() for agnostic matching
Tue, 21 Jul 2026 14:57:07 -0600
Jim Cromie <[email protected]> • #153371
[PATCH v7 14/29] dyndbg-API: remove DD_CLASS_TYPE_(DISJOINT|LEVEL)_NAMES and code
Tue, 21 Jul 2026 14:57:03 -0600
Jim Cromie <[email protected]> • #153370
[PATCH v7 16/29] dyndbg: bump num-tokens in a query-cmd from 9 to 15
Tue, 21 Jul 2026 14:57:05 -0600
Jim Cromie <[email protected]> • #153369
[PATCH v7 15/29] dyndbg: drop NUM_TYPE_ARGS
Tue, 21 Jul 2026 14:57:04 -0600
Jim Cromie <[email protected]> • #153368
[PATCH v7 13/29] dyndbg: reword "class unknown," to "class:_UNKNOWN_"
Tue, 21 Jul 2026 14:57:02 -0600
Jim Cromie <[email protected]> • #153367
[PATCH v7 12/29] dyndbg: add stub macro for DECLARE_DYNDBG_CLASSMAP
Tue, 21 Jul 2026 14:57:01 -0600
Jim Cromie <[email protected]> • #153366
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.