org.kernel.vger.linux-arch archive

696 archived articles, newest first (page 6 of 7). Latest articles →

[PATCH v7 16/29] dyndbg: bump num-tokens in a query-cmd from 9 to 15
Tue, 21 Jul 2026 14:57:05 -0600
Jim Cromie <[email protected]> • #153369
[PATCH v7 15/29] dyndbg: drop NUM_TYPE_ARGS
Tue, 21 Jul 2026 14:57:04 -0600
Jim Cromie <[email protected]> • #153368
[PATCH v7 13/29] dyndbg: reword "class unknown," to "class:_UNKNOWN_"
Tue, 21 Jul 2026 14:57:02 -0600
Jim Cromie <[email protected]> • #153367
[PATCH v7 12/29] dyndbg: add stub macro for DECLARE_DYNDBG_CLASSMAP
Tue, 21 Jul 2026 14:57:01 -0600
Jim Cromie <[email protected]> • #153366
[PATCH v7 11/29] dyndbg: factor ddebug_match_desc out from ddebug_change
Tue, 21 Jul 2026 14:57:00 -0600
Jim Cromie <[email protected]> • #153365
[PATCH v7 10/29] dyndbg.lds.S: fix lost dyndbg sections in modules
Tue, 21 Jul 2026 14:56:59 -0600
Jim Cromie <[email protected]> • #153364
[PATCH v7 09/29] vmlinux.lds.h: remove redundant ALIGN(8) directives
Tue, 21 Jul 2026 14:56:58 -0600
Jim Cromie <[email protected]> • #153363
[PATCH v7 08/29] vmlinux.lds.h: Fix ALIGN(8) omission causing NULL ptr on i386
Tue, 21 Jul 2026 14:56:57 -0600
Jim Cromie <[email protected]> • #153362
[PATCH v7 07/29] vmlinux.lds.h: drop unused HEADERED_SECTION* macros
Tue, 21 Jul 2026 14:56:56 -0600
Jim Cromie <[email protected]> • #153361
[PATCH v7 06/29] vmlinux.lds.h: refactor BOUNDED_SECTION_* macros into bounded_sections.lds.h
Tue, 21 Jul 2026 14:56:55 -0600
Jim Cromie <[email protected]> • #153360
[PATCH v7 05/29] drm: Mark CONFIG_DRM_USE_DYNAMIC_DEBUG as unBROKEN
Tue, 21 Jul 2026 14:56:54 -0600
Jim Cromie <[email protected]> • #153359
[PATCH v7 02/29] selftests/dyndbg: Add kselftest script to verify dynamic-debug
Tue, 21 Jul 2026 14:56:51 -0600
Jim Cromie <[email protected]> • #153358
[PATCH v7 04/29] drm: fix config dependent unused variable warning.
Tue, 21 Jul 2026 14:56:53 -0600
Jim Cromie <[email protected]> • #153357
[PATCH v7 03/29] drm: Fix incorrect ccflags-y spelling inside Makefile
Tue, 21 Jul 2026 14:56:52 -0600
Jim Cromie <[email protected]> • #153356
[PATCH v7 01/29] params: fix a pr_debug(" %p ") use - already in MM-*
Tue, 21 Jul 2026 14:56:50 -0600
Jim Cromie <[email protected]> • #153355
[PATCH v7 00/29] fix dynamic-debug classmaps API for DRM
Tue, 21 Jul 2026 14:56:49 -0600
Jim Cromie <[email protected]> • #153354
[PATCH v3 5/6] arm64: hyperv: Route hypercalls through RSI host call in CCA Realms
Tue, 21 Jul 2026 13:11:47 -0700
Kameron Carr <[email protected]> • #153353
[PATCH v3 6/6] arm64: hyperv: Implement hv_is_isolation_supported() for CCA Realms
Tue, 21 Jul 2026 13:11:48 -0700
Kameron Carr <[email protected]> • #153352
[PATCH v3 4/6] Drivers: hv: Mark shared memory as decrypted for CCA Realms
Tue, 21 Jul 2026 13:11:46 -0700
Kameron Carr <[email protected]> • #153351
[PATCH v3 3/6] arm64: hyperv: Add per-CPU RSI host call infrastructure for CCA Realms
Tue, 21 Jul 2026 13:11:45 -0700
Kameron Carr <[email protected]> • #153350
[PATCH v3 2/6] firmware: smccc: Detect hypervisor via RSI host call in CCA Realms
Tue, 21 Jul 2026 13:11:44 -0700
Kameron Carr <[email protected]> • #153349
[PATCH v3 1/6] arm64: rsi: Add RSI host call structure and helper function
Tue, 21 Jul 2026 13:11:43 -0700
Kameron Carr <[email protected]> • #153348
[PATCH v3 0/6] arm64: hyperv: Add Realm support for Hyper-V
Tue, 21 Jul 2026 13:11:42 -0700
Kameron Carr <[email protected]> • #153347
RE: [PATCH v2 4/6] Drivers: hv: Mark shared memory as decrypted for CCA Realms
Tue, 21 Jul 2026 11:43:45 -0700
"Kameron Carr" <[email protected]> • #153346
Re: [RFC PATCH 10/34] x86: mm: carve out the generic compile-time folded pgtable case in effective_prot()
Tue, 21 Jul 2026 20:21:03 +0200
"David Hildenbrand (Arm)" <[email protected]> • #153345
Re: [RFC PATCH 10/34] x86: mm: carve out the generic compile-time folded pgtable case in effective_prot()
Tue, 21 Jul 2026 18:45:17 +0100
Yeoreum Yun <[email protected]> • #153344
Re: [PATCH 15/22] mm: only initialise pt_share_count for user pgtables
Tue, 21 Jul 2026 17:12:13 +0200
"David Hildenbrand (Arm)" <[email protected]> • #153343
Re: [PATCH 04/22] mm: use mm_is_kernel() in generic page table code
Tue, 21 Jul 2026 17:07:22 +0200
"David Hildenbrand (Arm)" <[email protected]> • #153342
Re: [PATCH 03/22] mm: introduce MMF_KERNEL flag and set it for init_mm
Tue, 21 Jul 2026 17:04:33 +0200
"David Hildenbrand (Arm)" <[email protected]> • #153341
Re: [PATCH 02/22] mm: move mm_flags helpers to mm_types.h
Tue, 21 Jul 2026 16:57:30 +0200
"David Hildenbrand (Arm)" <[email protected]> • #153340
Re: [PATCH 01/22] mm: drop unused __mm_flags_set_mask_bits_word()
Tue, 21 Jul 2026 16:57:03 +0200
"David Hildenbrand (Arm)" <[email protected]> • #153339
Re: [RFC] signal: per-thread control over alternate signal stack delivery for selected signals
Tue, 21 Jul 2026 09:08:22 +0000
Tim Parth <[email protected]> • #153338
Re: [patch 00/18] entry: Consolidate and rework syscall entry handling
Tue, 21 Jul 2026 10:17:49 +0200
Thomas Gleixner <[email protected]> • #153337
Re: [PATCH v7 0/9] mm: optimize zone-device memmap initialization
Mon, 20 Jul 2026 15:43:34 -0700
Andrew Morton <[email protected]> • #153336
Re: [patch 00/18] entry: Consolidate and rework syscall entry handling
Tue, 21 Jul 2026 00:01:03 +0200
Magnus Lindholm <[email protected]> • #153335
Re: [patch 00/18] entry: Consolidate and rework syscall entry handling
Mon, 20 Jul 2026 21:21:07 +0200
Thomas Gleixner <[email protected]> • #153334
Re: [PATCH 14/22] mm: set page table page type when allocated
Mon, 20 Jul 2026 12:05:08 -0700
Vishal Moola <[email protected]> • #153333
Re: [PATCH v10 0/2] Add AMD I3C master controller driver and bindings
Mon, 20 Jul 2026 18:50:47 +0200
Alexandre Belloni <[email protected]> • #153332
[PATCH v6 4/4] arm64: vdso32: Implement __vdso_futex_robust_try_unlock()
Mon, 20 Jul 2026 13:03:04 -0300
André Almeida <[email protected]> • #153331
[PATCH v6 3/4] arm64: vdso32: Bring vdso32-offsets.h back
Mon, 20 Jul 2026 13:03:03 -0300
André Almeida <[email protected]> • #153330
[PATCH v6 0/4] arm64: vdso: Implement __vdso_futex_robust_try_unlock()
Mon, 20 Jul 2026 13:03:00 -0300
André Almeida <[email protected]> • #153329
[PATCH v6 2/4] arm64: vdso: Implement __vdso_futex_robust_try_unlock()
Mon, 20 Jul 2026 13:03:02 -0300
André Almeida <[email protected]> • #153328
[PATCH v6 1/4] arm64: vdso: Prepare for robust futex unlock support
Mon, 20 Jul 2026 13:03:01 -0300
André Almeida <[email protected]> • #153327
Re: [PATCH v7 0/9] mm: optimize zone-device memmap initialization
Mon, 20 Jul 2026 06:05:06 -0700
Dave Hansen <[email protected]> • #153326
[PATCH v7 9/9] mm: always use the zone-device template init path
Mon, 20 Jul 2026 20:02:59 +0800
"Li Zhe" <[email protected]> • #153325
[PATCH v7 8/9] mm: use memcpy_nontemporal() in zone-device template copies
Mon, 20 Jul 2026 20:02:58 +0800
"Li Zhe" <[email protected]> • #153324
[PATCH v7 7/9] x86/string: extend memcpy_flushcache() fixed-size fastpaths
Mon, 20 Jul 2026 20:02:57 +0800
"Li Zhe" <[email protected]> • #153323
[PATCH v7 6/9] string: introduce memcpy_nontemporal()
Mon, 20 Jul 2026 20:02:56 +0800
"Li Zhe" <[email protected]> • #153322
[PATCH v7 5/9] mm: extend the template fast path to zone-device compound tails
Mon, 20 Jul 2026 20:02:55 +0800
"Li Zhe" <[email protected]> • #153321
[PATCH v7 4/9] mm: add a template-based fast path for zone-device page init
Mon, 20 Jul 2026 20:02:54 +0800
"Li Zhe" <[email protected]> • #153320
[PATCH v7 3/9] mm: add a set_page_section_from_pfn() helper
Mon, 20 Jul 2026 20:02:53 +0800
"Li Zhe" <[email protected]> • #153319
[PATCH v7 2/9] mm: factor zone-device page init helpers out of __init_zone_device_page
Mon, 20 Jul 2026 20:02:52 +0800
"Li Zhe" <[email protected]> • #153318
[PATCH v7 1/9] mm: fix stale ZONE_DEVICE refcount comment
Mon, 20 Jul 2026 20:02:51 +0800
"Li Zhe" <[email protected]> • #153317
[PATCH v7 0/9] mm: optimize zone-device memmap initialization
Mon, 20 Jul 2026 20:02:50 +0800
"Li Zhe" <[email protected]> • #153316
[PATCH v7 0/9] mm: optimize zone-device memmap initialization
Mon, 20 Jul 2026 20:02:49 +0800
"Li Zhe" <[email protected]> • #153315
[PATCH v2] x86/serial: Use generic BASE_BAUD in asm/serial.h
Mon, 20 Jul 2026 12:33:00 +0200
Thorsten Blum <[email protected]> • #153314
Re: [patch 00/18] entry: Consolidate and rework syscall entry handling
Sun, 19 Jul 2026 13:25:32 +0200
Magnus Lindholm <[email protected]> • #153313
Re: [RFC] Null Namespaces
Sat, 18 Jul 2026 12:39:39 -0700
Andy Lutomirski <[email protected]> • #153312
[PATCH v6 2/2] module: Rename module_blacklist to module_denylist
Sat, 18 Jul 2026 15:01:21 -0400
Aaron Tomlin <[email protected]> • #153311
[PATCH v6 1/2] module: Extend module_blacklist parameter to built-in modules
Sat, 18 Jul 2026 15:01:20 -0400
Aaron Tomlin <[email protected]> • #153310
[PATCH v6 0/2] module: Extend blacklist parameter to support built-in modules
Sat, 18 Jul 2026 15:01:19 -0400
Aaron Tomlin <[email protected]> • #153309
Re: [PATCH v5 1/2] module: Extend module_blacklist parameter to built-in modules
Sat, 18 Jul 2026 10:26:34 -0400
Aaron Tomlin <[email protected]> • #153308
[PATCH v5 2/2] module: Rename module_blacklist to module_denylist
Sat, 18 Jul 2026 01:13:50 -0400
Aaron Tomlin <[email protected]> • #153307
[PATCH v5 1/2] module: Extend module_blacklist parameter to built-in modules
Sat, 18 Jul 2026 01:13:49 -0400
Aaron Tomlin <[email protected]> • #153306
[PATCH v5 0/2] module: Extend blacklist parameter to support built-in modules
Sat, 18 Jul 2026 01:13:48 -0400
Aaron Tomlin <[email protected]> • #153305
Re: [PATCH v4] module: Extend module_blacklist parameter to built-in modules
Sat, 18 Jul 2026 00:03:20 -0400
Aaron Tomlin <[email protected]> • #153304
[PATCH V4 7/9] x86/hyperv: Implement Hyper-V virtual IOMMU
Fri, 17 Jul 2026 19:19:47 -0700
Mukesh R <[email protected]> • #153303
[PATCH V4 9/9] mshv: Disable movable regions upfront if device passthru
Fri, 17 Jul 2026 19:19:49 -0700
Mukesh R <[email protected]> • #153302
[PATCH V4 8/9] mshv: Populate mmio mappings for PCI passthru
Fri, 17 Jul 2026 19:19:48 -0700
Mukesh R <[email protected]> • #153301
[PATCH V4 4/9] mshv: Add ioctl support for MSHV-VFIO bridge device
Fri, 17 Jul 2026 19:19:44 -0700
Mukesh R <[email protected]> • #153300
[PATCH V4 5/9] mshv: Import data structs around device passthru from hyperv headers
Fri, 17 Jul 2026 19:19:45 -0700
Mukesh R <[email protected]> • #153299
[PATCH V4 6/9] PCI: hv: Export hv_build_devid_type_pci() and change return type
Fri, 17 Jul 2026 19:19:46 -0700
Mukesh R <[email protected]> • #153298
[PATCH V4 3/9] mshv: Introduce basic mshv bridge device for VFIO to build upon
Fri, 17 Jul 2026 19:19:43 -0700
Mukesh R <[email protected]> • #153297
[PATCH V4 2/9] mshv: Add declarations and definitions for VFIO-MSHV bridge device
Fri, 17 Jul 2026 19:19:42 -0700
Mukesh R <[email protected]> • #153296
[PATCH V4 1/9] mshv: Provide a way to get partition ID if running in a VMM process
Fri, 17 Jul 2026 19:19:41 -0700
Mukesh R <[email protected]> • #153295
[PATCH V4 0/9] PCI passthru on Hyper-V
Fri, 17 Jul 2026 19:19:40 -0700
Mukesh R <[email protected]> • #153294
Re: [PATCH v4] module: Extend module_blacklist parameter to built-in modules
Fri, 17 Jul 2026 21:58:16 -0400
Aaron Tomlin <[email protected]> • #153293
Re: [PATCH v4] module: Extend module_blacklist parameter to built-in modules
Fri, 17 Jul 2026 21:39:56 -0400
Aaron Tomlin <[email protected]> • #153292
[PATCH] percpu: Add missing DECLARE_PER_CPU_DECRYPTED
Fri, 17 Jul 2026 14:33:43 -0700
Namhyung Kim <[email protected]> • #153291
Re: [PATCH v5 2/4] arm64: vdso: Implement __vdso_futex_robust_try_unlock()
Fri, 17 Jul 2026 19:31:09 +0100
Mark Rutland <[email protected]> • #153290
Re: [PATCH v5 1/4] arm64: vdso: Prepare for robust futex unlock support
Fri, 17 Jul 2026 19:05:14 +0100
Mark Rutland <[email protected]> • #153289
[PATCH v5 4/4] arm64: vdso32: Implement __vdso_futex_robust_try_unlock()
Fri, 17 Jul 2026 11:41:43 -0300
André Almeida <[email protected]> • #153288
[PATCH v5 2/4] arm64: vdso: Implement __vdso_futex_robust_try_unlock()
Fri, 17 Jul 2026 11:41:41 -0300
André Almeida <[email protected]> • #153287
[PATCH v5 3/4] arm64: vdso32: Bring vdso32-offsets.h back
Fri, 17 Jul 2026 11:41:42 -0300
André Almeida <[email protected]> • #153286
[PATCH v5 0/4] arm64: vdso: Implement __vdso_futex_robust_try_unlock()
Fri, 17 Jul 2026 11:41:39 -0300
André Almeida <[email protected]> • #153285
[PATCH v5 1/4] arm64: vdso: Prepare for robust futex unlock support
Fri, 17 Jul 2026 11:41:40 -0300
André Almeida <[email protected]> • #153284
Re: [PATCH] x86/serial: Use generic BASE_BAUD in asm/serial.h
Fri, 17 Jul 2026 11:06:03 +0200
"Arnd Bergmann" <[email protected]> • #153283
Re: [RFC PATCH 02/34] ARM: mm: make 2-level pgd_t a scalar
Fri, 17 Jul 2026 08:55:34 +0100
Yeoreum Yun <[email protected]> • #153282
[PATCH] x86/serial: Use generic BASE_BAUD in asm/serial.h
Fri, 17 Jul 2026 09:31:50 +0200
Thorsten Blum <[email protected]> • #153281
Re: [RFC PATCH 02/34] ARM: mm: make 2-level pgd_t a scalar
Fri, 17 Jul 2026 08:16:55 +0200
"Arnd Bergmann" <[email protected]> • #153280
[PATCH v2 7/7] LoongArch: Remove CONFIG_GENERIC_GETTIMEOFDAY ifdeffery
Fri, 17 Jul 2026 08:14:51 +0200
Thomas Weißschuh <[email protected]> • #153279
[PATCH v2 5/7] clocksource/drivers/arm_arch_timer: Remove CONFIG_GENERIC_GETTIMEOFDAY ifdeffery
Fri, 17 Jul 2026 08:14:49 +0200
Thomas Weißschuh <[email protected]> • #153278
[PATCH v2 6/7] clocksource/drivers/timer-riscv: Remove CONFIG_GENERIC_GETTIMEOFDAY ifdeffery
Fri, 17 Jul 2026 08:14:50 +0200
Thomas Weißschuh <[email protected]> • #153277
[PATCH v2 3/7] MIPS: csrc-r4k: Remove CONFIG_GENERIC_GETTIMEOFDAY ifdeffery
Fri, 17 Jul 2026 08:14:47 +0200
Thomas Weißschuh <[email protected]> • #153276
[PATCH v2 4/7] clocksource/drivers/mips-gic-timer: Remove CONFIG_GENERIC_GETTIMEOFDAY ifdeffery
Fri, 17 Jul 2026 08:14:48 +0200
Thomas Weißschuh <[email protected]> • #153275
[PATCH v2 1/7] kbuild: support generated asm-headers in subdirectories
Fri, 17 Jul 2026 08:14:45 +0200
Thomas Weißschuh <[email protected]> • #153274
[PATCH v2 2/7] vDSO: Make clockmode constants available without CONFIG_GENERIC_GETTIMEOFDAY
Fri, 17 Jul 2026 08:14:46 +0200
Thomas Weißschuh <[email protected]> • #153273
[PATCH v2 0/7] vDSO: Remove CONFIG_GENERIC_GETTIMEOFDAY ifdeffery
Fri, 17 Jul 2026 08:14:44 +0200
Thomas Weißschuh <[email protected]> • #153272
Re: [RFC PATCH 02/34] ARM: mm: make 2-level pgd_t a scalar
Thu, 16 Jul 2026 20:04:56 +0100
Yeoreum Yun <[email protected]> • #153271
Re: [RFC PATCH 12/24] fork: let kernel callers create embryonic tasks
Thu, 16 Jul 2026 08:57:58 -0700
Andy Lutomirski <[email protected]> • #153270
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.