org.kernel.vger.linux-kselftest archive

1736 archived articles, newest first (page 15 of 18). Latest articles →

[PATCH v2] kunit: tool: fix _list_tests filtering wrong variable when list has TAP prefix
Mon, 3 Aug 2026 19:02:17 +0000
Mohammad abukhader <[email protected]> • #131331
[PATCH 7.1.y] selftests/bpf: Add tests for sleepable tracepoint programs
Mon, 03 Aug 2026 15:57:32 -0300
Ricardo B. Marlière (SUSE) <[email protected]> • #131330
Re: [PATCH v5 3/4] perf/arm64: Add BRBE support for bpf_get_branch_snapshot()
Mon, 3 Aug 2026 19:54:33 +0100
Puranjay Mohan <[email protected]> • #131329
Re: [PATCH net-next] selftests: drv-net: enable devmem TCP in the test config
Mon, 3 Aug 2026 11:28:52 -0700
Mina Almasry <[email protected]> • #131328
[PATCH net-next v2 2/2] selftests: drv-net: ncdevmem: gracefully retry bind()
Mon, 3 Aug 2026 18:18:26 +0000
Mina Almasry <[email protected]> • #131327
[PATCH net-next v2 1/2] selftests: drv-net: devmem: fix 5-tuple flow steering
Mon, 3 Aug 2026 18:18:25 +0000
Mina Almasry <[email protected]> • #131326
Re: [PATCH 1/2] x86/shstk: support via prctl
Mon, 3 Aug 2026 18:14:10 +0000
"Edgecombe, Rick P" <[email protected]> • #131325
Re: [PATCH 2/2] selftests/x86: add generic prctl shadow stack test
Mon, 3 Aug 2026 12:50:16 -0500
Bill Roberts <[email protected]> • #131324
Re: [PATCH 1/2] x86/shstk: support via prctl
Mon, 3 Aug 2026 12:41:34 -0500
Bill Roberts <[email protected]> • #131323
Re: [PATCH] selftests/cgroup: test_zswap: skip test_no_kmem_bypass if debugfs is unavailable
Mon, 3 Aug 2026 10:31:39 -0700
Yosry Ahmed <[email protected]> • #131322
[PATCH v2] KVM: selftests: Replace ulong with unsigned long
Mon, 3 Aug 2026 22:08:28 +0500
Hisam Mehboob <[email protected]> • #131321
[PATCH net v2 5/8] selftests: mptcp: join: mark tests with data corruption as failed
Mon, 03 Aug 2026 18:16:37 +0200
"Matthieu Baerts (NGI0)" <[email protected]> • #131320
[PATCH net v2 0/8] mptcp: misc fixes for v7.2-rc6
Mon, 03 Aug 2026 18:16:32 +0200
"Matthieu Baerts (NGI0)" <[email protected]> • #131319
Re: [PATCH] kunit: tool: fix _list_tests filtering wrong variable when list has TAP prefix
Mon, 3 Aug 2026 09:56:06 -0600
Shuah Khan <[email protected]> • #131318
Re: [PATCH v9 10/41] KVM: guest_memfd: Add base support for KVM_SET_MEMORY_ATTRIBUTES2
Mon, 3 Aug 2026 16:53:41 +0100
Suzuki K Poulose <[email protected]> • #131317
Re: [PATCH net-next v4 01/10] ipv6: add ip6_del_rt_reason()
Mon, 3 Aug 2026 18:50:27 +0300
Ido Schimmel <[email protected]> • #131316
Re: [PATCH v9 07/41] KVM: guest_memfd: Wire up core private/shared attribute interfaces
Mon, 3 Aug 2026 08:33:14 -0700
Sean Christopherson <[email protected]> • #131315
Re: [PATCH v9 14/41] mm: swap: Introduce lru_add_drain_progressive()
Mon, 3 Aug 2026 17:12:13 +0200
"David Hildenbrand (Arm)" <[email protected]> • #131314
[PATCH v3 2/2] selftests/filesystems: skip listxattr kernfs test if xattrs are present
Mon, 3 Aug 2026 20:38:37 +0530
Disha Goel <[email protected]> • #131313
Re: [PATCH v9 14/41] mm: swap: Introduce lru_add_drain_progressive()
Mon, 3 Aug 2026 08:03:41 -0700
Sean Christopherson <[email protected]> • #131312
[PATCH v3 1/2] selftests/filesystems: Move file_stressor to dedicated subdirectory
Mon, 3 Aug 2026 20:27:19 +0530
Disha Goel <[email protected]> • #131311
Re: [PATCH] selftests/futex: Correct pthread_create return value check
Mon, 3 Aug 2026 11:54:11 -0300
André Almeida <[email protected]> • #131310
Re: [PATCH v3 07/15] mm/rmap: track whether the page VMA mapped pgoff is anonymous
Mon, 3 Aug 2026 15:32:57 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #131309
Re: [PATCH v3 09/15] mm/rmap: use anon pgoff to track MAP_PRIVATE file-backed anon folios
Mon, 3 Aug 2026 15:30:53 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #131308
Re: [PATCH v3 08/15] mm: introduce and use linear_folio_page_index()
Mon, 3 Aug 2026 15:30:00 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #131307
Re: [PATCH v3 07/15] mm/rmap: track whether the page VMA mapped pgoff is anonymous
Mon, 3 Aug 2026 16:02:45 +0200
"David Hildenbrand (Arm)" <[email protected]> • #131306
Re: [PATCH bpf v3 2/4] selftests/bpf: Test refcount_acquire return nullability
Mon, 3 Aug 2026 06:59:49 -0700
Amery Hung <[email protected]> • #131305
Re: [PATCH v3 07/15] mm/rmap: track whether the page VMA mapped pgoff is anonymous
Mon, 3 Aug 2026 14:51:28 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #131304
Re: [PATCH v2 3/3] selftests/mm: kmemleak: drop stale min_unref_scans default from comments
Mon, 3 Aug 2026 14:49:25 +0100
Catalin Marinas <[email protected]> • #131303
Re: [PATCH v2 2/3] Documentation: kmemleak: document the conditional min_unref_scans default
Mon, 3 Aug 2026 14:49:03 +0100
Catalin Marinas <[email protected]> • #131302
Re: [PATCH v2 1/3] mm: kmemleak: default min_unref_scans to 2 for verbose auto-scan
Mon, 3 Aug 2026 14:47:30 +0100
Catalin Marinas <[email protected]> • #131301
Re: [PATCH v3 06/15] mm: propagate VMA anonymous page offset on map, remap, split + merge
Mon, 3 Aug 2026 14:46:32 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #131300
Re: [PATCH net-next v4 01/10] ipv6: add ip6_del_rt_reason()
Mon, 3 Aug 2026 22:00:12 +0900
Yuyang Huang <[email protected]> • #131299
[PATCH 2/2] selftests/membarrier: Skip unpermitted membarrier command test if preregistered by libc
Mon, 3 Aug 2026 14:49:00 +0200
Chris Gellermann <[email protected]> • #131298
[PATCH 1/2] selftests/membarrier: Introduce helper to get membarrier command registrations
Mon, 3 Aug 2026 14:48:59 +0200
Chris Gellermann <[email protected]> • #131297
[PATCH 0/2] selftests/membarrier: Skip an unregistered memory barrier test on Musl
Mon, 3 Aug 2026 14:48:58 +0200
Chris Gellermann <[email protected]> • #131296
Re: [PATCH v6 3/6] tools/lib/mm: move hugepage_settings out of selftests
Mon, 3 Aug 2026 13:44:56 +0100
Mark Brown <[email protected]> • #131295
Re: [PATCH bpf-next 3/3] selftests/bpf: Add a test for arena fault-in under memory.max
Mon, 3 Aug 2026 19:42:19 +0800
Jiayuan Chen <[email protected]> • #131294
Re: [PATCH v3 09/15] mm/rmap: use anon pgoff to track MAP_PRIVATE file-backed anon folios
Mon, 3 Aug 2026 13:32:50 +0200
"David Hildenbrand (Arm)" <[email protected]> • #131293
[PATCH net-next 2/2] selftests: netconsole: add a userdata torture test
Mon, 03 Aug 2026 04:30:04 -0700
Breno Leitao <[email protected]> • #131292
[PATCH net-next 1/2] netconsole: publish the userdata payload with RCU
Mon, 03 Aug 2026 04:30:03 -0700
Breno Leitao <[email protected]> • #131291
[PATCH net-next 0/2] netconsole: replace target_list_lock by RCU on userdata hot path
Mon, 03 Aug 2026 04:30:02 -0700
Breno Leitao <[email protected]> • #131290
Re: [PATCH v3 08/15] mm: introduce and use linear_folio_page_index()
Mon, 3 Aug 2026 13:27:09 +0200
"David Hildenbrand (Arm)" <[email protected]> • #131289
[PATCH bpf-next v2 2/2] selftests/bpf: Test RCU pointer invalidation after spin unlock
Mon, 3 Aug 2026 04:26:09 -0700
Ning Ding <[email protected]> • #131288
[PATCH bpf v3 4/4] selftests/bpf: Test untrusted allocated-object pointers
Mon, 3 Aug 2026 04:22:11 -0700
Ning Ding <[email protected]> • #131287
[PATCH bpf v3 2/4] selftests/bpf: Test refcount_acquire return nullability
Mon, 3 Aug 2026 04:22:09 -0700
Ning Ding <[email protected]> • #131286
Re: [PATCH v5 3/4] perf/arm64: Add BRBE support for bpf_get_branch_snapshot()
Mon, 3 Aug 2026 12:07:02 +0100
James Clark <[email protected]> • #131285
Re: [PATCH 09/16] selftests/mm: skip khugepaged swap tests when no swap is configured
Mon, 03 Aug 2026 14:04:23 +0300
Mike Rapoport <[email protected]> • #131284
Re: [PATCH 06/16] selftests/mm: add khugepaged race harness
Mon, 03 Aug 2026 14:04:23 +0300
Mike Rapoport <[email protected]> • #131283
Re: [PATCH 05/16] selftests/mm: add khugepaged completion barrier helper
Mon, 03 Aug 2026 14:04:23 +0300
Mike Rapoport <[email protected]> • #131282
Re: [PATCH 04/16] selftests/mm: add order-parameterized khugepaged collapse cases
Mon, 03 Aug 2026 14:04:23 +0300
Mike Rapoport <[email protected]> • #131281
Re: [PATCH 03/16] selftests/mm: add folio-order detection self-check
Mon, 03 Aug 2026 14:04:23 +0300
Mike Rapoport <[email protected]> • #131280
Re: [PATCH 02/16] selftests/mm: add folio-order check for VA ranges
Mon, 03 Aug 2026 14:04:23 +0300
Mike Rapoport <[email protected]> • #131279
Re: [PATCH 01/16] selftests/mm: move is_backed_by_folio() into vm_util
Mon, 03 Aug 2026 14:04:23 +0300
Mike Rapoport <[email protected]> • #131278
Re: [PATCH 00/16] selftests/mm: improve khugepaged coverage
Mon, 03 Aug 2026 14:04:23 +0300
Mike Rapoport <[email protected]> • #131277
Re: [PATCH v3 07/15] mm/rmap: track whether the page VMA mapped pgoff is anonymous
Mon, 3 Aug 2026 12:57:44 +0200
"David Hildenbrand (Arm)" <[email protected]> • #131276
Re: [PATCH v3 06/15] mm: propagate VMA anonymous page offset on map, remap, split + merge
Mon, 3 Aug 2026 12:52:42 +0200
"David Hildenbrand (Arm)" <[email protected]> • #131275
[PATCH] selftests/prctl: Fix non-anonymous VMA mapping in set-anon-vma-name test
Mon, 3 Aug 2026 18:30:46 +0800
Hongfu Li <[email protected]> • #131274
Re: [PATCH v3 04/15] mm: update print_bad_page_map() to show anonymous page index
Mon, 3 Aug 2026 11:19:17 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #131273
Re: [PATCH v3 05/15] mm: introduce and use vma_filebacked_address()
Mon, 3 Aug 2026 11:15:08 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #131272
Re: [PATCH v3 01/15] mm/vma: introduce VMA anon page offset field and add helpers
Mon, 3 Aug 2026 11:13:11 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #131271
Re: [PATCH v3 02/15] mm: introduce linear_anon_page_index()
Mon, 3 Aug 2026 11:10:07 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #131270
[PATCH v2 16/17] selftests: timers: nsleep-lat: Reuse kselftest error numbers
Mon, 03 Aug 2026 12:04:47 +0200
Thomas Weißschuh (Schneider Electric) <[email protected]> • #131269
[PATCH v2 17/17] selftests: timers: nsleep-lat: Check all calls to clock_nanosleep() and clock_gettime()
Mon, 03 Aug 2026 12:04:48 +0200
Thomas Weißschuh (Schneider Electric) <[email protected]> • #131268
[PATCH v2 13/17] selftests: timers: nanosleep: Report each test separately
Mon, 03 Aug 2026 12:04:44 +0200
Thomas Weißschuh (Schneider Electric) <[email protected]> • #131267
[PATCH v2 15/17] selftests: timers: nsleep-lat: Explicitly list the tested clocks
Mon, 03 Aug 2026 12:04:46 +0200
Thomas Weißschuh (Schneider Electric) <[email protected]> • #131266
[PATCH v2 12/17] selftests: timers: nanosleep: Explicitly handle timer_delete() failure
Mon, 03 Aug 2026 12:04:43 +0200
Thomas Weißschuh (Schneider Electric) <[email protected]> • #131265
[PATCH v2 14/17] selftests: timers: nsleep-lat: Use NSEC_PER_MSEC define for unreasonable latency
Mon, 03 Aug 2026 12:04:45 +0200
Thomas Weißschuh (Schneider Electric) <[email protected]> • #131264
[PATCH v2 11/17] selftests: timers: nanosleep: Move all single clock tests out of the loop in main()
Mon, 03 Aug 2026 12:04:42 +0200
Thomas Weißschuh (Schneider Electric) <[email protected]> • #131263
[PATCH v2 07/17] selftests: timers: Use clock_name() and constants from clock-helpers.h
Mon, 03 Aug 2026 12:04:38 +0200
Thomas Weißschuh (Schneider Electric) <[email protected]> • #131262
[PATCH v2 10/17] selftests: timers: nanosleep: Reuse kselftest error numbers
Mon, 03 Aug 2026 12:04:41 +0200
Thomas Weißschuh (Schneider Electric) <[email protected]> • #131261
[PATCH v2 09/17] selftests: timers: nanosleep: Explicitly list the tested clocks
Mon, 03 Aug 2026 12:04:40 +0200
Thomas Weißschuh (Schneider Electric) <[email protected]> • #131260
[PATCH v2 05/17] timer_list: Use ktime_t over nanoseconds
Mon, 03 Aug 2026 12:04:36 +0200
Thomas Weißschuh (Schneider Electric) <[email protected]> • #131259
[PATCH v2 08/17] selftests: timers: nanosleep: Drop output alignment
Mon, 03 Aug 2026 12:04:39 +0200
Thomas Weißschuh (Schneider Electric) <[email protected]> • #131258
[PATCH v2 06/17] selftests: add clock-helpers.h
Mon, 03 Aug 2026 12:04:37 +0200
Thomas Weißschuh (Schneider Electric) <[email protected]> • #131257
[PATCH v2 04/17] timer_list: Use standard 'long long' format placeholders
Mon, 03 Aug 2026 12:04:35 +0200
Thomas Weißschuh (Schneider Electric) <[email protected]> • #131256
[PATCH v2 03/17] hrtimer: Add a lockdep assertion to hrtimer_update_base()
Mon, 03 Aug 2026 12:04:34 +0200
Thomas Weißschuh (Schneider Electric) <[email protected]> • #131255
[PATCH v2 02/17] timekeeping: Use u32 for clock_was_set_seq
Mon, 03 Aug 2026 12:04:33 +0200
Thomas Weißschuh (Schneider Electric) <[email protected]> • #131254
[PATCH v2 00/17] timekeeping, hrtimer: Assorted cleanups
Mon, 03 Aug 2026 12:04:31 +0200
Thomas Weißschuh (Schneider Electric) <[email protected]> • #131253
[PATCH v2 01/17] timekeeping: Rename clockid_aux_valid() to clockid_is_aux_clock()
Mon, 03 Aug 2026 12:04:32 +0200
Thomas Weißschuh (Schneider Electric) <[email protected]> • #131252
Re: [PATCH v5 2/4] perf/core: Clear the whole branch entry in perf_clear_branch_entry()
Mon, 3 Aug 2026 11:00:44 +0100
James Clark <[email protected]> • #131251
Re: [PATCH v3 01/15] mm/vma: introduce VMA anon page offset field and add helpers
Mon, 3 Aug 2026 11:58:02 +0200
"David Hildenbrand (Arm)" <[email protected]> • #131250
Re: [PATCH v3 05/15] mm: introduce and use vma_filebacked_address()
Mon, 3 Aug 2026 11:54:31 +0200
"David Hildenbrand (Arm)" <[email protected]> • #131249
Re: [PATCH v3 01/15] mm/vma: introduce VMA anon page offset field and add helpers
Mon, 3 Aug 2026 10:46:35 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #131248
Re: [PATCH v3 04/15] mm: update print_bad_page_map() to show anonymous page index
Mon, 3 Aug 2026 11:39:18 +0200
"David Hildenbrand (Arm)" <[email protected]> • #131247
Re: [PATCH v3 04/15] mm: update print_bad_page_map() to show anonymous page index
Mon, 3 Aug 2026 11:39:11 +0200
"David Hildenbrand (Arm)" <[email protected]> • #131246
Re: [PATCH v3 03/15] mm: abstract vma_address() and introduce vma_anon_address()
Mon, 3 Aug 2026 11:37:30 +0200
"David Hildenbrand (Arm)" <[email protected]> • #131245
Re: [PATCH v3 02/15] mm: introduce linear_anon_page_index()
Mon, 3 Aug 2026 11:34:32 +0200
"David Hildenbrand (Arm)" <[email protected]> • #131244
Re: [PATCH v3 01/15] mm/vma: introduce VMA anon page offset field and add helpers
Mon, 3 Aug 2026 11:28:28 +0200
"David Hildenbrand (Arm)" <[email protected]> • #131243
Re: [PATCH v9 00/10] Fix missing fops.owner in Rust DRM/misc abstractions
Mon, 3 Aug 2026 11:10:02 +0200
Petr Pavlu <[email protected]> • #131242
Re: [PATCH v9 09/10] rust: macros: remove `THIS_MODULE` static from `module!`
Mon, 3 Aug 2026 11:01:14 +0200
Petr Pavlu <[email protected]> • #131241
Re: [PATCH v6 6/6] selftests/mm: add a GUP selftest
Mon, 03 Aug 2026 12:00:01 +0300
Mike Rapoport <[email protected]> • #131240
Re: [PATCH v6 5/6] tools/mm: make gup_bench a benchmark only tool
Mon, 03 Aug 2026 12:00:01 +0300
Mike Rapoport <[email protected]> • #131239
Re: [PATCH v6 3/6] tools/lib/mm: move hugepage_settings out of selftests
Mon, 03 Aug 2026 12:00:01 +0300
Mike Rapoport <[email protected]> • #131238
Re: [PATCH v6 2/6] tools/lib/mm: add shared file helpers
Mon, 03 Aug 2026 12:00:01 +0300
Mike Rapoport <[email protected]> • #131237
Re: [PATCH v9 02/10] rust: module: add `THIS_MODULE` const to `ModuleMetadata` trait
Mon, 3 Aug 2026 11:00:14 +0200
Petr Pavlu <[email protected]> • #131236
Re: [PATCH v6 1/6] selftests/mm: make file helpers return errors
Mon, 03 Aug 2026 12:00:01 +0300
Mike Rapoport <[email protected]> • #131235
Re: [PATCH v6 0/6] selftests/mm: separate GUP microbenchmarking from functional testing
Mon, 03 Aug 2026 12:00:01 +0300
Mike Rapoport <[email protected]> • #131234
Re: [PATCH v9 01/10] rust: module: move module types into `module.rs`
Mon, 3 Aug 2026 10:58:59 +0200
Petr Pavlu <[email protected]> • #131233
Re: [PATCH v9 10/10] rust: module: update MAINTAINERS to cover module.rs
Mon, 3 Aug 2026 10:54:13 +0200
Petr Pavlu <[email protected]> • #131232
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.