org.kernel.vger.linux-m68k archive

588 archived articles, newest first (page 4 of 6). Latest articles →

[RFC PATCH 28/34] arm: mm: use proper pgtable APIs for generic compile-time folded patable in kasan_init()
Mon, 13 Jul 2026 14:56:07 +0100
Yeoreum Yun <[email protected]> • #24736
[RFC PATCH 27/34] m68k: mm: remove usage of pgd_page_vaddr() for CONFIG_PGTABLE_LEVELS=3
Mon, 13 Jul 2026 14:56:06 +0100
Yeoreum Yun <[email protected]> • #24735
[RFC PATCH 26/34] x86: mm: define pudp_set_access_flags() when CONFIG_HAVE_ARCH_TRANSPARENT_HUGEPAGE_PUD is enabled only.
Mon, 13 Jul 2026 14:56:05 +0100
Yeoreum Yun <[email protected]> • #24734
[RFC PATCH 25/34] x86: mm: remove usage of pgd_page_vaddr() for CONFIG_x86_PAE
Mon, 13 Jul 2026 14:56:04 +0100
Yeoreum Yun <[email protected]> • #24733
[RFC PATCH 24/34] x86: mm: call try_to_free_pmd_page() when CONFIG_PGTABLE_LEVELS > 2
Mon, 13 Jul 2026 14:56:03 +0100
Yeoreum Yun <[email protected]> • #24732
[RFC PATCH 23/34] x86: mm: skip pud setup when using generic compile-time folded pagetable
Mon, 13 Jul 2026 14:56:02 +0100
Yeoreum Yun <[email protected]> • #24731
[RFC PATCH 22/34] x86: mm: use proper set_pXd() for generic compile-time folded patable in one_md_table_init()
Mon, 13 Jul 2026 14:56:01 +0100
Yeoreum Yun <[email protected]> • #24730
[RFC PATCH 21/34] x86: platform: use proper set_pXd() for generic compile-time folded patable in setup_olpc_ofw_pgd()
Mon, 13 Jul 2026 14:56:00 +0100
Yeoreum Yun <[email protected]> • #24729
[RFC PATCH 20/34] x86: kexec: use proper set_pXd() for generic compile-time folded patable in machine_kexec_page_table_set_one()
Mon, 13 Jul 2026 14:55:59 +0100
Yeoreum Yun <[email protected]> • #24728
[RFC PATCH 19/34] x86: power: use proper set_pXd() for generic compile-time folded patable in resume_one_md_table_init()
Mon, 13 Jul 2026 14:55:58 +0100
Yeoreum Yun <[email protected]> • #24727
[RFC PATCH 18/34] riscv: mm: use proper set_pXd() for generic compile-time folded patable in setup_vm_final()
Mon, 13 Jul 2026 14:55:57 +0100
Yeoreum Yun <[email protected]> • #24726
[RFC PATCH 17/34] riscv: mm: use proper set_pXd() for generic compile-time folded patable in vmalloc_fault()
Mon, 13 Jul 2026 14:55:56 +0100
Yeoreum Yun <[email protected]> • #24725
[RFC PATCH 16/34] nios2: mm: use proper set_pXd() for generic compile-time folded patable in vmalloc_fault path
Mon, 13 Jul 2026 14:55:55 +0100
Yeoreum Yun <[email protected]> • #24724
[RFC PATCH 15/34] mips: mm: use proper set_pXd() for generic compile-time folded patable in vmalloc_fault path
Mon, 13 Jul 2026 14:55:54 +0100
Yeoreum Yun <[email protected]> • #24723
[RFC PATCH 14/34] csky: mm: use proper set_pXd() for generic compile-time folded patable in vmalloc_fault()
Mon, 13 Jul 2026 14:55:53 +0100
Yeoreum Yun <[email protected]> • #24722
[RFC PATCH 13/34] arm64: mm: define pud_set_huge() when __PGTABLE_PMD_FOLDED not defined
Mon, 13 Jul 2026 14:55:52 +0100
Yeoreum Yun <[email protected]> • #24721
[RFC PATCH 12/34] arm64: mm: use proper set_pXd() for generic compile-time folded patable in kasan_early_init()
Mon, 13 Jul 2026 14:55:51 +0100
Yeoreum Yun <[email protected]> • #24720
[RFC PATCH 11/34] mm: vmscan: remove stack copy address of pud pass in wallk_pud_range()
Mon, 13 Jul 2026 14:55:50 +0100
Yeoreum Yun <[email protected]> • #24719
[RFC PATCH 10/34] x86: mm: carve out the generic compile-time folded pgtable case in effective_prot()
Mon, 13 Jul 2026 14:55:49 +0100
Yeoreum Yun <[email protected]> • #24718
[RFC PATCH 09/34] riscv: kvm: remove stack copy address of pXd in pXd_offset()
Mon, 13 Jul 2026 14:55:48 +0100
Yeoreum Yun <[email protected]> • #24717
[RFC PATCH 08/34] loongarch: kvm: remove stack copy address of pXd in pXd_offset()
Mon, 13 Jul 2026 14:55:47 +0100
Yeoreum Yun <[email protected]> • #24716
[RFC PATCH 07/34] mm/pgtable: define (pgd|p4d|pud)_offset_lockless() for folded page tables
Mon, 13 Jul 2026 14:55:46 +0100
Yeoreum Yun <[email protected]> • #24715
[RFC PATCH 06/34] mm/pgtable: define (pgd|p4d|pud)_leaf() for folded page tables
Mon, 13 Jul 2026 14:55:45 +0100
Yeoreum Yun <[email protected]> • #24714
[RFC PATCH 05/34] MIPS: mm: define pud_leaf() only when PUD exists
Mon, 13 Jul 2026 14:55:44 +0100
Yeoreum Yun <[email protected]> • #24713
[RFC PATCH 04/34] LoongArch: mm: define pud_leaf() only when PUD exists
Mon, 13 Jul 2026 14:55:43 +0100
Yeoreum Yun <[email protected]> • #24712
[RFC PATCH 03/34] ARM: mm: remove custom pgdp_get()
Mon, 13 Jul 2026 14:55:42 +0100
Yeoreum Yun <[email protected]> • #24711
[RFC PATCH 02/34] ARM: mm: make 2-level pgd_t a scalar
Mon, 13 Jul 2026 14:55:41 +0100
Yeoreum Yun <[email protected]> • #24710
[RFC PATCH 01/34] ARM: mm: make nommu pgd_t a scalar
Mon, 13 Jul 2026 14:55:40 +0100
Yeoreum Yun <[email protected]> • #24709
[RFC PATCH 00/34] mm: optimize unnecessary loads due to ptep_get() and friends out
Mon, 13 Jul 2026 14:55:39 +0100
Yeoreum Yun <[email protected]> • #24708
[PATCH] m68k: defconfig: Update defconfigs for v7.2-rc1
Mon, 13 Jul 2026 12:19:47 +0200
Geert Uytterhoeven <[email protected]> • #24707
Re: [patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Mon, 13 Jul 2026 15:06:10 +0800
Guo Ren <[email protected]> • #24706
Re: [git pull] m68knommu fixes for v7.2
Sun, 12 Jul 2026 19:13:06 +0000
[email protected] • #24705
[git pull] m68knommu fixes for v7.2
Sun, 12 Jul 2026 22:46:24 +1000
Greg Ungerer <[email protected]> • #24704
Re: [PATCH v2 02/10] m68k/coldfire: replace linux/gpio.h inclusions
Sun, 12 Jul 2026 22:27:19 +1000
Greg Ungerer <[email protected]> • #24703
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Sat, 11 Jul 2026 22:33:16 +0200
Thomas Gleixner <[email protected]> • #24702
Re: [PATCH v2 00/10] treewide: replace linux/gpio.h
Sat, 11 Jul 2026 17:56:40 +0200
Linus Walleij <[email protected]> • #24701
Re: [PATCH v2 06/10] ASoC: replace linux/gpio.h inclusions
Sat, 11 Jul 2026 13:57:39 +0100
Charles Keepax <[email protected]> • #24700
Re: [PATCH v2 05/10] mfd: replace linux/gpio.h inclusions
Sat, 11 Jul 2026 13:56:52 +0100
Charles Keepax <[email protected]> • #24699
Re: [patch 00/18] entry: Consolidate and rework syscall entry handling
Sat, 11 Jul 2026 14:29:12 +0200
Magnus Lindholm <[email protected]> • #24698
Re: [PATCH v2 06/10] ASoC: replace linux/gpio.h inclusions
Sat, 11 Jul 2026 10:34:19 +0300
Sergey Shtylyov <[email protected]> • #24697
Re: [PATCH v2 09/10] Input: matrix_keyboard - replace linux/gpio.h inclusion
Fri, 10 Jul 2026 21:49:31 -0700
Dmitry Torokhov <[email protected]> • #24696
[PATCH v2 09/10] Input: matrix_keyboard - replace linux/gpio.h inclusion
Fri, 10 Jul 2026 23:19:54 +0200
Arnd Bergmann <[email protected]> • #24695
[PATCH v2 08/10] phy: replace linux/gpio.h inclusions
Fri, 10 Jul 2026 23:19:53 +0200
Arnd Bergmann <[email protected]> • #24694
[PATCH v2 07/10] pcmcia: replace linux/gpio.h inclusions
Fri, 10 Jul 2026 23:19:52 +0200
Arnd Bergmann <[email protected]> • #24693
[PATCH v2 06/10] ASoC: replace linux/gpio.h inclusions
Fri, 10 Jul 2026 23:19:51 +0200
Arnd Bergmann <[email protected]> • #24692
[PATCH v2 05/10] mfd: replace linux/gpio.h inclusions
Fri, 10 Jul 2026 23:19:50 +0200
Arnd Bergmann <[email protected]> • #24691
[PATCH v2 04/10] sh: replace linux/gpio.h inclusions
Fri, 10 Jul 2026 23:19:49 +0200
Arnd Bergmann <[email protected]> • #24690
[PATCH v2 03/10] mips: replace linux/gpio.h inclusions
Fri, 10 Jul 2026 23:19:48 +0200
Arnd Bergmann <[email protected]> • #24689
[PATCH v2 02/10] m68k/coldfire: replace linux/gpio.h inclusions
Fri, 10 Jul 2026 23:19:47 +0200
Arnd Bergmann <[email protected]> • #24688
[PATCH v2 01/10] ARM: replace linux/gpio.h inclusions
Fri, 10 Jul 2026 23:19:46 +0200
Arnd Bergmann <[email protected]> • #24687
[PATCH v2 00/10] treewide: replace linux/gpio.h
Fri, 10 Jul 2026 23:19:45 +0200
Arnd Bergmann <[email protected]> • #24686
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Fri, 10 Jul 2026 17:20:03 +0200
Michal Suchánek <[email protected]> • #24685
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Fri, 10 Jul 2026 14:52:40 +0200
Oleg Nesterov <[email protected]> • #24684
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Fri, 10 Jul 2026 14:32:13 +0200
Michal Suchánek <[email protected]> • #24683
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Fri, 10 Jul 2026 13:40:43 +0200
Oleg Nesterov <[email protected]> • #24682
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Fri, 10 Jul 2026 13:16:20 +0200
Oleg Nesterov <[email protected]> • #24681
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Fri, 10 Jul 2026 13:01:02 +0200
Michal Suchánek <[email protected]> • #24680
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Fri, 10 Jul 2026 12:42:29 +0200
Michal Suchánek <[email protected]> • #24679
Re: [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 01:46:15 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #24678
Re: [patch 00/18] entry: Consolidate and rework syscall entry handling
Fri, 10 Jul 2026 01:45:19 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #24677
Re: [patch 18/18] entry, treewide: Make syscall_enter_from_user_mode[_work]() indicate syscall execution
Fri, 10 Jul 2026 01:19:28 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #24676
Re: [patch 15/18] x86/entry: Make syscall functions static
Fri, 10 Jul 2026 01:13:15 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #24675
Re: [patch 14/18] entry: Make return type of syscall_trace_enter() bool
Fri, 10 Jul 2026 01:06:23 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #24674
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Fri, 10 Jul 2026 00:52:35 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #24673
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Fri, 10 Jul 2026 00:40:00 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #24672
Re: [patch 10/18] entry: Use syscall number instead of rereading it
Fri, 10 Jul 2026 00:20:46 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #24671
Re: [patch 09/18] entry: Remove syscall_enter_from_user_mode()
Fri, 10 Jul 2026 00:19:18 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #24670
Re: [patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 00:15:39 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #24669
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 00:13:32 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #24668
Re: [patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 00:12:23 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #24667
Re: [patch 05/18] powerpc/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 00:11:04 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #24666
Re: [patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 00:10:01 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #24665
Re: [patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
Fri, 10 Jul 2026 00:04:21 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #24664
Re: [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Fri, 10 Jul 2026 00:02:27 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #24663
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Thu, 09 Jul 2026 13:03:28 -0400
Radu Rendec <[email protected]> • #24662
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Thu, 9 Jul 2026 17:26:59 +0100
David Laight <[email protected]> • #24661
Re: [patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
Thu, 9 Jul 2026 09:23:47 -0700
Kees Cook <[email protected]> • #24660
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Thu, 9 Jul 2026 09:22:06 -0700
Kees Cook <[email protected]> • #24659
Re: [patch 10/18] entry: Use syscall number instead of rereading it
Thu, 9 Jul 2026 13:22:26 +0200
Philippe Mathieu-Daudé <[email protected]> • #24658
Re: [patch 10/18] entry: Use syscall number instead of rereading it
Thu, 9 Jul 2026 13:20:43 +0200
Philippe Mathieu-Daudé <[email protected]> • #24657
Re: [patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:18:04 +0200
Philippe Mathieu-Daudé <[email protected]> • #24656
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:17:17 +0200
Philippe Mathieu-Daudé <[email protected]> • #24655
Re: [patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:16:51 +0200
Philippe Mathieu-Daudé <[email protected]> • #24654
Re: [patch 05/18] powerpc/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:16:21 +0200
Philippe Mathieu-Daudé <[email protected]> • #24653
Re: [patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:15:55 +0200
Philippe Mathieu-Daudé <[email protected]> • #24652
Re: [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:15:11 +0200
Philippe Mathieu-Daudé <[email protected]> • #24651
Re: [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Thu, 9 Jul 2026 13:12:57 +0200
Philippe Mathieu-Daudé <[email protected]> • #24650
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Thu, 9 Jul 2026 10:41:56 +0200
Geert Uytterhoeven <[email protected]> • #24649
Re: [PATCH v16 18/18] arm64: vdso: Expose sigreturn address on vdso to the kernel
Thu, 9 Jul 2026 10:27:59 +0200
Thomas Weißschuh <[email protected]> • #24648
Re: [PATCH v16 18/18] arm64: vdso: Expose sigreturn address on vdso to the kernel
Thu, 9 Jul 2026 16:15:15 +0800
Jinjie Ruan <[email protected]> • #24647
Re: [PATCH v16 18/18] arm64: vdso: Expose sigreturn address on vdso to the kernel
Thu, 9 Jul 2026 09:17:33 +0200
Thomas Weißschuh <[email protected]> • #24646
Re: [PATCH v16 18/18] arm64: vdso: Expose sigreturn address on vdso to the kernel
Thu, 9 Jul 2026 14:37:05 +0800
Jinjie Ruan <[email protected]> • #24645
Re: [PATCH v16 02/18] syscall_user_dispatch: Introduce a weak fallback for arch_syscall_is_vdso_sigreturn()
Thu, 9 Jul 2026 14:30:11 +0800
Jinjie Ruan <[email protected]> • #24644
Re: [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 11:46:07 +0800
Jinjie Ruan <[email protected]> • #24643
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:39:17 +0800
Jinjie Ruan <[email protected]> • #24642
Re: [patch 10/18] entry: Use syscall number instead of rereading it
Thu, 9 Jul 2026 10:55:27 +0800
Jinjie Ruan <[email protected]> • #24641
Re: [patch 09/18] entry: Remove syscall_enter_from_user_mode()
Thu, 9 Jul 2026 10:49:49 +0800
Jinjie Ruan <[email protected]> • #24640
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:46:44 +0800
Jinjie Ruan <[email protected]> • #24639
Re: [patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:44:48 +0800
Jinjie Ruan <[email protected]> • #24638
Re: [patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:38:38 +0800
Jinjie Ruan <[email protected]> • #24637
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.