org.kernel.vger.linux-parisc archive

554 archived articles, newest first (page 3 of 6). Latest articles →

[PATCH RFC 06/11] mm/kasan: use hw_pte_t for the early shadow PTE table
Mon, 27 Jul 2026 17:46:57 +0100
Muhammad Usama Anjum <[email protected]> • #46767
[PATCH RFC 05/11] mm: convert PTE table entries in ptep_get()
Mon, 27 Jul 2026 17:46:56 +0100
Muhammad Usama Anjum <[email protected]> • #46766
[PATCH RFC 04/11] mm: use hw_pte_t for generic PTE table storage
Mon, 27 Jul 2026 17:46:55 +0100
Muhammad Usama Anjum <[email protected]> • #46765
[PATCH RFC 03/11] mm: name pointers to copied PTE values ptentp
Mon, 27 Jul 2026 17:46:54 +0100
Muhammad Usama Anjum <[email protected]> • #46764
[PATCH RFC 02/11] mm: make hw_pte_t visible to generic PTE interfaces
Mon, 27 Jul 2026 17:46:53 +0100
Muhammad Usama Anjum <[email protected]> • #46763
[PATCH RFC 01/11] mm: introduce hw_pte_t for PTE table storage
Mon, 27 Jul 2026 17:46:52 +0100
Muhammad Usama Anjum <[email protected]> • #46762
[PATCH RFC 00/11] mm: distinguish PTE table storage from PTE values
Mon, 27 Jul 2026 17:46:51 +0100
Muhammad Usama Anjum <[email protected]> • #46761
Re: [PATCH 1/5] mm: constify generic pte_get*()
Mon, 27 Jul 2026 15:44:25 +0200
"David Hildenbrand (Arm)" <[email protected]> • #46760
Re: [PATCH 3/5] mm/parisc: constify ptep_get() argument
Mon, 27 Jul 2026 10:14:54 +0100
Pedro Falcato <[email protected]> • #46759
[PATCH] Input: gscps2 - supply PA-RISC keyboard keymap via device property
Sun, 26 Jul 2026 17:37:56 -0700
Dmitry Torokhov <[email protected]> • #46758
Re: [PATCH] parisc: superio: Spelling s/Peterson/Petersen/
Sat, 25 Jul 2026 22:07:50 +0200
Helge Deller <[email protected]> • #46757
Re: [PATCH 2/2] parisc: Remove unnecessary NULL check of the kstat_irqs field
Sat, 25 Jul 2026 22:04:20 +0200
Helge Deller <[email protected]> • #46756
[PATCH 2/2] parisc: Drop redundant implementation of ptep_set_wrprotect()
Sat, 25 Jul 2026 21:02:07 +0200
Helge Deller <[email protected]> • #46755
[PATCH 1/2] parisc: Drop redundant implementation of pte_same()
Sat, 25 Jul 2026 21:02:06 +0200
Helge Deller <[email protected]> • #46754
[PATCH] parisc: Drop own implementations for ptep_get() and ptep_test_and_clear_young()
Sat, 25 Jul 2026 19:40:02 +0200
Helge Deller <[email protected]> • #46753
Re: [PATCH 3/5] mm/parisc: constify ptep_get() argument
Sat, 25 Jul 2026 19:38:23 +0200
Helge Deller <[email protected]> • #46752
Re: [PATCH 3/5] mm/parisc: constify ptep_get() argument
Sat, 25 Jul 2026 13:00:55 -0400
John David Anglin <[email protected]> • #46751
Re: [PATCH 3/5] mm/parisc: constify ptep_get() argument
Sat, 25 Jul 2026 18:27:36 +0200
Helge Deller <[email protected]> • #46750
Re: [PATCH 14/22] mm: set page table page type when allocated
Fri, 24 Jul 2026 18:31:32 +0200
Kevin Brodsky <[email protected]> • #46749
Re: [PATCH 15/22] mm: only initialise pt_share_count for user pgtables
Fri, 24 Jul 2026 18:25:35 +0200
Kevin Brodsky <[email protected]> • #46748
Re: [PATCH 04/22] mm: use mm_is_kernel() in generic page table code
Fri, 24 Jul 2026 18:22:40 +0200
Kevin Brodsky <[email protected]> • #46747
Re: [PATCH 03/22] mm: introduce MMF_KERNEL flag and set it for init_mm
Fri, 24 Jul 2026 18:22:26 +0200
Kevin Brodsky <[email protected]> • #46746
Re: [PATCH 3/5] mm/parisc: constify ptep_get() argument
Fri, 24 Jul 2026 16:48:50 +0100
Usama Arif <[email protected]> • #46745
Re: [PATCH 3/5] mm/parisc: constify ptep_get() argument
Fri, 24 Jul 2026 16:32:43 +0100
Pedro Falcato <[email protected]> • #46744
Re: [PATCH 3/5] mm/parisc: constify ptep_get() argument
Fri, 24 Jul 2026 16:03:44 +0100
Usama Arif <[email protected]> • #46743
Re: Crash building vtk9 9.6.2+dfsg1-2 on mx3210
Fri, 24 Jul 2026 16:57:48 +0200
Helge Deller <[email protected]> • #46742
Re: [PATCH 3/5] mm/parisc: constify ptep_get() argument
Fri, 24 Jul 2026 15:14:05 +0100
Matthew Wilcox <[email protected]> • #46741
Re: [PATCH 3/5] mm/parisc: constify ptep_get() argument
Fri, 24 Jul 2026 14:39:08 +0100
Usama Arif <[email protected]> • #46740
Re: [PATCH 3/5] mm/parisc: constify ptep_get() argument
Fri, 24 Jul 2026 14:36:59 +0100
Usama Arif <[email protected]> • #46739
Re: Crash building vtk9 9.6.2+dfsg1-2 on mx3210
Fri, 24 Jul 2026 08:09:09 -0400
John David Anglin <[email protected]> • #46738
[PATCH 3/5] mm/parisc: constify ptep_get() argument
Fri, 24 Jul 2026 11:20:15 +0100
Pedro Falcato <[email protected]> • #46737
[PATCH 5/5] mm: constify the pte_offset_map_ro_nolock() return value
Fri, 24 Jul 2026 11:20:17 +0100
Pedro Falcato <[email protected]> • #46736
[PATCH 2/5] mm/arm64: constify pte_get*() and contpte get logic
Fri, 24 Jul 2026 11:20:14 +0100
Pedro Falcato <[email protected]> • #46735
[PATCH 4/5] mm/powerpc/8xx: constify ptep_get() argument
Fri, 24 Jul 2026 11:20:16 +0100
Pedro Falcato <[email protected]> • #46734
[PATCH 1/5] mm: constify generic pte_get*()
Fri, 24 Jul 2026 11:20:13 +0100
Pedro Falcato <[email protected]> • #46733
[PATCH 0/5] mm: add basic PTE const type-safety
Fri, 24 Jul 2026 11:20:12 +0100
Pedro Falcato <[email protected]> • #46732
Re: [PATCH v2 14/33] mm/vma: clean up anon_vma_compatible()
Wed, 22 Jul 2026 22:42:45 -0400
"Zi Yan" <[email protected]> • #46731
Re: [PATCH v2 13/33] mm/vma: introduce and use vmg_pages(), vmg_[start, end]_pgoff()
Wed, 22 Jul 2026 22:40:28 -0400
"Zi Yan" <[email protected]> • #46730
Re: [PATCH 15/22] mm: only initialise pt_share_count for user pgtables
Tue, 21 Jul 2026 17:12:13 +0200
"David Hildenbrand (Arm)" <[email protected]> • #46729
Re: [PATCH 04/22] mm: use mm_is_kernel() in generic page table code
Tue, 21 Jul 2026 17:07:22 +0200
"David Hildenbrand (Arm)" <[email protected]> • #46728
Re: [PATCH 03/22] mm: introduce MMF_KERNEL flag and set it for init_mm
Tue, 21 Jul 2026 17:04:33 +0200
"David Hildenbrand (Arm)" <[email protected]> • #46727
Re: [PATCH 02/22] mm: move mm_flags helpers to mm_types.h
Tue, 21 Jul 2026 16:57:30 +0200
"David Hildenbrand (Arm)" <[email protected]> • #46726
Re: [PATCH 01/22] mm: drop unused __mm_flags_set_mask_bits_word()
Tue, 21 Jul 2026 16:57:03 +0200
"David Hildenbrand (Arm)" <[email protected]> • #46725
Re: [patch 00/18] entry: Consolidate and rework syscall entry handling
Tue, 21 Jul 2026 10:17:49 +0200
Thomas Gleixner <[email protected]> • #46724
Re: [patch 00/18] entry: Consolidate and rework syscall entry handling
Tue, 21 Jul 2026 00:01:03 +0200
Magnus Lindholm <[email protected]> • #46723
Re: [patch 00/18] entry: Consolidate and rework syscall entry handling
Mon, 20 Jul 2026 21:21:07 +0200
Thomas Gleixner <[email protected]> • #46722
Re: [PATCH 14/22] mm: set page table page type when allocated
Mon, 20 Jul 2026 12:05:08 -0700
Vishal Moola <[email protected]> • #46721
Re: [PATCH v2 08/33] mm/rmap: rename vma_interval_tree_*() to mapping_rmap_tree_*()
Mon, 20 Jul 2026 08:20:01 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #46720
Re: [PATCH v2 12/33] MAINTAINERS: Move mm/interval_tree.c to rmap section
Sun, 19 Jul 2026 19:27:23 -0400
"Liam R. Howlett" <[email protected]> • #46719
Re: Crash building vtk9 9.6.2+dfsg1-2 on mx3210
Sun, 19 Jul 2026 18:18:31 +0200
Helge Deller <[email protected]> • #46718
Crash building vtk9 9.6.2+dfsg1-2 on mx3210
Sun, 19 Jul 2026 08:50:12 -0400
John David Anglin <[email protected]> • #46717
Re: [patch 00/18] entry: Consolidate and rework syscall entry handling
Sun, 19 Jul 2026 13:25:32 +0200
Magnus Lindholm <[email protected]> • #46716
Re: [PATCH v2 12/33] MAINTAINERS: Move mm/interval_tree.c to rmap section
Fri, 17 Jul 2026 22:59:11 -0400
"Zi Yan" <[email protected]> • #46715
Re: [PATCH v2 11/33] mm/rmap: rename anon_vma_interval_tree_*() to anon_rmap_tree_*()
Fri, 17 Jul 2026 22:58:49 -0400
"Zi Yan" <[email protected]> • #46714
Re: [PATCH v2 10/33] mm/rmap: rename anon_vma_interval_tree_*() params and use pgoff_t
Fri, 17 Jul 2026 22:57:58 -0400
"Zi Yan" <[email protected]> • #46713
Re: [PATCH v2 09/33] mm/rmap: parameterise anon_vma_interval_tree_*() by anon_vma
Fri, 17 Jul 2026 22:56:44 -0400
"Zi Yan" <[email protected]> • #46712
Re: [PATCH v2 08/33] mm/rmap: rename vma_interval_tree_*() to mapping_rmap_tree_*()
Fri, 17 Jul 2026 22:54:24 -0400
"Zi Yan" <[email protected]> • #46711
Re: [PATCH v2 07/33] mm/rmap: elide unnecessary static inline's in interval_tree.c
Fri, 17 Jul 2026 22:46:28 -0400
"Zi Yan" <[email protected]> • #46710
Re: [PATCH v2 06/33] mm/rmap: parameterise vma_interval_tree_*() by address_space
Fri, 17 Jul 2026 22:46:01 -0400
"Zi Yan" <[email protected]> • #46709
Re: [PATCH v2 05/33] mm/rmap: update mm/interval_tree.c comments
Fri, 17 Jul 2026 22:37:21 -0400
"Zi Yan" <[email protected]> • #46708
Re: [PATCH v2 04/33] mm: introduce and use vma_end_pgoff()
Fri, 17 Jul 2026 22:35:08 -0400
"Zi Yan" <[email protected]> • #46707
Re: [PATCH v2 03/33] tools/testing/vma: use vma_start_pgoff() in merge tests
Fri, 17 Jul 2026 22:32:47 -0400
"Zi Yan" <[email protected]> • #46706
Re: [PATCH v2 02/33] mm: add kdoc comments for vma_start/last_pgoff()
Fri, 17 Jul 2026 22:32:04 -0400
"Zi Yan" <[email protected]> • #46705
Re: [PATCH v2 01/33] mm: move vma_start_pgoff() into mm.h and clean up
Fri, 17 Jul 2026 22:29:09 -0400
"Zi Yan" <[email protected]> • #46704
Re: [PATCH bpf-next 1/2] bpf, parisc: Add support for BPF_SDIV and BPF_SMOD in the parisc64 JIT
Fri, 17 Jul 2026 18:27:17 -0400
Nicholas Dudar <[email protected]> • #46703
Re: [PATCH bpf-next 1/2] bpf, parisc: Add support for BPF_SDIV and BPF_SMOD in the parisc64 JIT
Fri, 17 Jul 2026 16:58:27 -0400
Nicholas Dudar <[email protected]> • #46702
Re: [PATCH bpf-next 1/2] bpf, parisc: Add support for BPF_SDIV and BPF_SMOD in the parisc64 JIT
Fri, 17 Jul 2026 19:52:25 +0000 (UTC)
[email protected] • #46701
[PATCH bpf-next 2/2] bpf, parisc: Add support for BPF_SDIV and BPF_SMOD in the parisc32 JIT
Fri, 17 Jul 2026 15:05:44 -0400
Nicholas Dudar <[email protected]> • #46700
[PATCH bpf-next 1/2] bpf, parisc: Add support for BPF_SDIV and BPF_SMOD in the parisc64 JIT
Fri, 17 Jul 2026 15:05:43 -0400
Nicholas Dudar <[email protected]> • #46699
[PATCH bpf-next 0/2] bpf, parisc: Add support for BPF_SDIV and BPF_SMOD in the parisc JITs
Fri, 17 Jul 2026 15:05:42 -0400
Nicholas Dudar <[email protected]> • #46698
Re: [PATCH v2 00/33] mm: make VMA page offset handling more consistent
Thu, 16 Jul 2026 14:31:43 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #46697
Re: [PATCH 17/22] mm: pagewalk: drop redundant address check for kernel mm walks
Thu, 16 Jul 2026 12:24:18 +0200
Kevin Brodsky <[email protected]> • #46696
Re: [PATCH v2 00/33] mm: make VMA page offset handling more consistent
Thu, 16 Jul 2026 12:03:41 +0200
Christian König <[email protected]> • #46695
Re: [PATCH 14/22] mm: set page table page type when allocated
Thu, 16 Jul 2026 11:49:31 +0200
Kevin Brodsky <[email protected]> • #46694
Re: [PATCH v2 18/33] mm/vma: use vma_start_pgoff(), linear_page_index() in mm code
Thu, 16 Jul 2026 10:46:34 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #46693
Re: [PATCH v2 01/33] mm: move vma_start_pgoff() into mm.h and clean up
Thu, 16 Jul 2026 10:44:14 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #46692
Re: [PATCH v2 18/33] mm/vma: use vma_start_pgoff(), linear_page_index() in mm code
Thu, 16 Jul 2026 11:43:35 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #46691
Re: [PATCH v2 30/33] mm/vma: correct incorrect vma.h inclusion
Thu, 16 Jul 2026 10:42:12 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #46690
Re: [PATCH v2 25/33] mm/vma: make vma_set_range() static, drop insert_vm_struct() decl
Thu, 16 Jul 2026 10:36:05 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #46689
Re: [PATCH 04/22] mm: use mm_is_kernel() in generic page table code
Thu, 16 Jul 2026 11:35:10 +0200
Kevin Brodsky <[email protected]> • #46688
Re: [PATCH v2 23/33] mm/vma: add and use vma_[add/sub]_pgoff()
Thu, 16 Jul 2026 10:33:51 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #46687
Re: [PATCH 03/22] mm: introduce MMF_KERNEL flag and set it for init_mm
Thu, 16 Jul 2026 11:33:33 +0200
Kevin Brodsky <[email protected]> • #46686
Re: [PATCH v2 18/33] mm/vma: use vma_start_pgoff(), linear_page_index() in mm code
Thu, 16 Jul 2026 10:27:33 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #46685
Re: [PATCH v2 31/33] mm/vma: use guard clauses in can_vma_merge_[before, after]()
Thu, 16 Jul 2026 10:39:54 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #46684
Re: [PATCH v2 30/33] mm/vma: correct incorrect vma.h inclusion
Thu, 16 Jul 2026 10:38:00 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #46683
Re: [PATCH v2 29/33] mm/vma: introduce and use vma_set_pgoff()
Thu, 16 Jul 2026 10:28:37 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #46682
Re: [PATCH v2 28/33] mm/vma: slightly rework the anonymous check in __mmap_new_vma()
Thu, 16 Jul 2026 10:22:51 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #46681
Re: [PATCH v2 27/33] mm/vma: update vmg_adjust_set_range() to offset pgoff instead
Thu, 16 Jul 2026 10:20:50 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #46680
Re: [PATCH v2 26/33] mm/vma: update vma_shrink() to not pass start, pgoff parameters
Thu, 16 Jul 2026 09:47:05 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #46679
Re: [PATCH v2 03/33] tools/testing/vma: use vma_start_pgoff() in merge tests
Wed, 15 Jul 2026 15:53:23 -0400
"Liam R. Howlett" <[email protected]> • #46678
Re: [PATCH v2 02/33] mm: add kdoc comments for vma_start/last_pgoff()
Wed, 15 Jul 2026 15:51:01 -0400
"Liam R. Howlett" <[email protected]> • #46677
Re: [PATCH v2 01/33] mm: move vma_start_pgoff() into mm.h and clean up
Wed, 15 Jul 2026 14:05:42 -0400
"Liam R. Howlett" <[email protected]> • #46676
Re: [PATCH v2 25/33] mm/vma: make vma_set_range() static, drop insert_vm_struct() decl
Wed, 15 Jul 2026 19:45:59 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #46675
Re: [PATCH v2 24/33] mm/vma: move __install_special_mapping() to vma.c
Wed, 15 Jul 2026 19:39:53 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #46674
Re: [PATCH v2 23/33] mm/vma: add and use vma_[add/sub]_pgoff()
Wed, 15 Jul 2026 19:38:38 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #46673
Re: [PATCH v2 22/33] mm/vma: introduce vma_assert_can_modify()
Wed, 15 Jul 2026 19:33:00 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #46672
Re: [PATCH v2 21/33] mm: use linear_page_[index, delta]() consistently
Wed, 15 Jul 2026 19:30:34 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #46671
Re: [PATCH v2 20/33] mm/vma: remove duplicative vma_pgoff_offset() helper
Wed, 15 Jul 2026 19:28:00 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #46670
Re: [PATCH v2 19/33] mm: prefer vma_[start,end]_pgoff() to vma->vm_pgoff in kernel/
Wed, 15 Jul 2026 18:44:49 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #46669
Re: [PATCH v2 18/33] mm/vma: use vma_start_pgoff(), linear_page_index() in mm code
Wed, 15 Jul 2026 17:23:09 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #46668
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.