org.kernel.vger.linux-parisc archive

554 archived articles, newest first (page 4 of 6). Latest articles →

Re: [PATCH 00/22] Simplify special kernel page table handling
Wed, 15 Jul 2026 17:07:02 +0200
Kevin Brodsky <[email protected]> • #46667
Re: [PATCH v2 17/33] mm: introduce and use linear_page_delta()
Wed, 15 Jul 2026 16:57:29 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #46666
Re: [PATCH v2 16/33] mm/vma: minor cleanup of expand_[upwards, downwards]()
Wed, 15 Jul 2026 16:53:57 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #46665
Re: [PATCH v2 15/33] mm/vma: refactor vmg_adjust_set_range() for clarity
Wed, 15 Jul 2026 16:49:21 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #46664
Re: [PATCH 19/22] x86/tboot: mark tboot_mm as a kernel mm
Tue, 14 Jul 2026 08:19:51 -0700
Dave Hansen <[email protected]> • #46663
Re: [PATCH 14/22] mm: set page table page type when allocated
Tue, 14 Jul 2026 08:16:16 -0700
Vishal Moola <[email protected]> • #46662
Re: [PATCH 12/22] x86/mm: use mm_is_kernel() for kernel mm checks
Tue, 14 Jul 2026 08:09:15 -0700
Dave Hansen <[email protected]> • #46661
Re: [PATCH 03/22] mm: introduce MMF_KERNEL flag and set it for init_mm
Tue, 14 Jul 2026 16:04:52 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #46660
Re: [PATCH 03/22] mm: introduce MMF_KERNEL flag and set it for init_mm
Tue, 14 Jul 2026 07:47:43 -0700
Dave Hansen <[email protected]> • #46659
[PATCH 22/22] riscv: mm: drop ctor/dtor calls for kernel page tables
Tue, 14 Jul 2026 15:04:11 +0100
Kevin Brodsky <[email protected]> • #46658
[PATCH 21/22] arm: mm: drop ctor call for kernel page tables
Tue, 14 Jul 2026 15:04:10 +0100
Kevin Brodsky <[email protected]> • #46657
[PATCH 20/22] arm64: mm: drop ctor/dtor calls for kernel page tables
Tue, 14 Jul 2026 15:04:09 +0100
Kevin Brodsky <[email protected]> • #46656
[PATCH 19/22] x86/tboot: mark tboot_mm as a kernel mm
Tue, 14 Jul 2026 15:04:08 +0100
Kevin Brodsky <[email protected]> • #46655
[PATCH 18/22] arm64: mm: drop explicit mm_is_efi() check in contpte
Tue, 14 Jul 2026 15:04:07 +0100
Kevin Brodsky <[email protected]> • #46654
[PATCH 17/22] mm: pagewalk: drop redundant address check for kernel mm walks
Tue, 14 Jul 2026 15:04:06 +0100
Kevin Brodsky <[email protected]> • #46653
[PATCH 16/22] efi: mark efi_mm as a kernel mm
Tue, 14 Jul 2026 15:04:05 +0100
Kevin Brodsky <[email protected]> • #46652
[PATCH 15/22] mm: only initialise pt_share_count for user pgtables
Tue, 14 Jul 2026 15:04:04 +0100
Kevin Brodsky <[email protected]> • #46651
[PATCH 14/22] mm: set page table page type when allocated
Tue, 14 Jul 2026 15:04:03 +0100
Kevin Brodsky <[email protected]> • #46650
[PATCH 13/22] mm: account page table pages when allocated
Tue, 14 Jul 2026 15:04:02 +0100
Kevin Brodsky <[email protected]> • #46649
[PATCH 12/22] x86/mm: use mm_is_kernel() for kernel mm checks
Tue, 14 Jul 2026 15:04:01 +0100
Kevin Brodsky <[email protected]> • #46648
[PATCH 11/22] um: mm: use mm_is_kernel() in TLB sync
Tue, 14 Jul 2026 15:04:00 +0100
Kevin Brodsky <[email protected]> • #46647
[PATCH 10/22] sparc: mm: use mm_is_kernel() for kernel mm checks
Tue, 14 Jul 2026 15:03:59 +0100
Kevin Brodsky <[email protected]> • #46646
[PATCH 09/22] s390: mm: use mm_is_kernel() for kernel mm checks
Tue, 14 Jul 2026 15:03:58 +0100
Kevin Brodsky <[email protected]> • #46645
[PATCH 08/22] powerpc: mm: use mm_is_kernel() for kernel mm checks
Tue, 14 Jul 2026 15:03:57 +0100
Kevin Brodsky <[email protected]> • #46644
[PATCH 07/22] parisc: mm: use mm_is_kernel() for kernel mm checks
Tue, 14 Jul 2026 15:03:56 +0100
Kevin Brodsky <[email protected]> • #46643
[PATCH 06/22] loongarch: mm: use mm_is_kernel() in switch_mm_irqs_off()
Tue, 14 Jul 2026 15:03:55 +0100
Kevin Brodsky <[email protected]> • #46642
[PATCH 05/22] arm64: mm: use mm_is_kernel() for kernel mm checks
Tue, 14 Jul 2026 15:03:54 +0100
Kevin Brodsky <[email protected]> • #46641
[PATCH 04/22] mm: use mm_is_kernel() in generic page table code
Tue, 14 Jul 2026 15:03:53 +0100
Kevin Brodsky <[email protected]> • #46640
[PATCH 03/22] mm: introduce MMF_KERNEL flag and set it for init_mm
Tue, 14 Jul 2026 15:03:52 +0100
Kevin Brodsky <[email protected]> • #46639
[PATCH 02/22] mm: move mm_flags helpers to mm_types.h
Tue, 14 Jul 2026 15:03:51 +0100
Kevin Brodsky <[email protected]> • #46638
[PATCH 01/22] mm: drop unused __mm_flags_set_mask_bits_word()
Tue, 14 Jul 2026 15:03:50 +0100
Kevin Brodsky <[email protected]> • #46637
[PATCH 00/22] Simplify special kernel page table handling
Tue, 14 Jul 2026 15:03:49 +0100
Kevin Brodsky <[email protected]> • #46636
Re: [PATCH v2 13/33] mm/vma: introduce and use vmg_pages(), vmg_[start, end]_pgoff()
Tue, 14 Jul 2026 11:17:11 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #46635
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Tue, 14 Jul 2026 10:20:20 +0200
Michal Suchánek <[email protected]> • #46634
[PATCH] parisc: superio: Spelling s/Peterson/Petersen/
Tue, 14 Jul 2026 09:02:52 +0200
Geert Uytterhoeven <[email protected]> • #46633
Re: [PATCH v2 14/33] mm/vma: clean up anon_vma_compatible()
Mon, 13 Jul 2026 20:18:54 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #46632
Re: [PATCH v2 13/33] mm/vma: introduce and use vmg_pages(), vmg_[start, end]_pgoff()
Mon, 13 Jul 2026 20:12:24 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #46631
Re: [PATCH v2 12/33] MAINTAINERS: Move mm/interval_tree.c to rmap section
Mon, 13 Jul 2026 20:07:25 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #46630
Re: [PATCH v2 11/33] mm/rmap: rename anon_vma_interval_tree_*() to anon_rmap_tree_*()
Mon, 13 Jul 2026 20:06:19 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #46629
Re: [PATCH v2 10/33] mm/rmap: rename anon_vma_interval_tree_*() params and use pgoff_t
Mon, 13 Jul 2026 20:05:19 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #46628
Re: [PATCH v2 09/33] mm/rmap: parameterise anon_vma_interval_tree_*() by anon_vma
Mon, 13 Jul 2026 20:04:07 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #46627
Re: [PATCH v2 08/33] mm/rmap: rename vma_interval_tree_*() to mapping_rmap_tree_*()
Mon, 13 Jul 2026 20:03:02 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #46626
Re: [PATCH v2 07/33] mm/rmap: elide unnecessary static inline's in interval_tree.c
Mon, 13 Jul 2026 19:59:21 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #46625
Re: [PATCH v2 06/33] mm/rmap: parameterise vma_interval_tree_*() by address_space
Mon, 13 Jul 2026 19:56:52 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #46624
Re: [PATCH v2 05/33] mm/rmap: update mm/interval_tree.c comments
Mon, 13 Jul 2026 19:48:18 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #46623
Re: [patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Mon, 13 Jul 2026 15:06:10 +0800
Guo Ren <[email protected]> • #46622
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Sat, 11 Jul 2026 22:33:16 +0200
Thomas Gleixner <[email protected]> • #46621
Re: [patch 00/18] entry: Consolidate and rework syscall entry handling
Sat, 11 Jul 2026 14:29:12 +0200
Magnus Lindholm <[email protected]> • #46620
Re: [PATCH v2 00/33] mm: make VMA page offset handling more consistent
Sat, 11 Jul 2026 07:29:47 +0100
Lorenzo Stoakes <[email protected]> • #46619
Re: [PATCH 30/30] tools/testing/vma: output compared expression on ASSERT_[EQ, NE]()
Sat, 11 Jul 2026 07:26:27 +0100
Lorenzo Stoakes <[email protected]> • #46618
Re: [PATCH 27/30] mm/vma: correct incorrect vma.h inclusion
Sat, 11 Jul 2026 07:21:43 +0100
Lorenzo Stoakes <[email protected]> • #46617
Re: [PATCH v2 00/33] mm: make VMA page offset handling more consistent
Fri, 10 Jul 2026 15:45:21 -0700
Andrew Morton <[email protected]> • #46616
Re: [PATCH v2 28/33] mm/vma: slightly rework the anonymous check in __mmap_new_vma()
Fri, 10 Jul 2026 17:39:19 -0400
Gregory Price <[email protected]> • #46615
Re: [PATCH v2 29/33] mm/vma: introduce and use vma_set_pgoff()
Fri, 10 Jul 2026 17:26:59 -0400
Gregory Price <[email protected]> • #46614
Re: [PATCH v2 22/33] mm/vma: introduce vma_assert_can_modify()
Fri, 10 Jul 2026 17:24:03 -0400
Gregory Price <[email protected]> • #46613
Re: [PATCH v2 26/33] mm/vma: update vma_shrink() to not pass start, pgoff parameters
Fri, 10 Jul 2026 17:20:56 -0400
Gregory Price <[email protected]> • #46612
Re: [PATCH v2 23/33] mm/vma: add and use vma_[add/sub]_pgoff()
Fri, 10 Jul 2026 17:17:45 -0400
Gregory Price <[email protected]> • #46611
Re: [PATCH v2 11/33] mm/rmap: rename anon_vma_interval_tree_*() to anon_rmap_tree_*()
Fri, 10 Jul 2026 17:16:51 -0400
Gregory Price <[email protected]> • #46610
Re: [PATCH v2 10/33] mm/rmap: rename anon_vma_interval_tree_*() params and use pgoff_t
Fri, 10 Jul 2026 17:14:03 -0400
Gregory Price <[email protected]> • #46609
Re: [PATCH v2 09/33] mm/rmap: parameterise anon_vma_interval_tree_*() by anon_vma
Fri, 10 Jul 2026 17:12:07 -0400
Gregory Price <[email protected]> • #46608
Re: [PATCH 27/30] mm/vma: correct incorrect vma.h inclusion
Fri, 10 Jul 2026 17:03:58 -0400
Gregory Price <[email protected]> • #46607
Re: [PATCH 30/30] tools/testing/vma: output compared expression on ASSERT_[EQ, NE]()
Fri, 10 Jul 2026 16:48:58 -0400
Gregory Price <[email protected]> • #46606
[PATCH v2 33/33] tools/testing/vma: output compared expression on ASSERT_[EQ, NE]()
Fri, 10 Jul 2026 21:17:14 +0100
Lorenzo Stoakes <[email protected]> • #46605
[PATCH v2 32/33] tools/testing/vma: default VMA, mm flag bits to 64-bit
Fri, 10 Jul 2026 21:17:13 +0100
Lorenzo Stoakes <[email protected]> • #46604
[PATCH v2 31/33] mm/vma: use guard clauses in can_vma_merge_[before, after]()
Fri, 10 Jul 2026 21:17:12 +0100
Lorenzo Stoakes <[email protected]> • #46603
[PATCH v2 30/33] mm/vma: correct incorrect vma.h inclusion
Fri, 10 Jul 2026 21:17:11 +0100
Lorenzo Stoakes <[email protected]> • #46602
[PATCH v2 29/33] mm/vma: introduce and use vma_set_pgoff()
Fri, 10 Jul 2026 21:17:10 +0100
Lorenzo Stoakes <[email protected]> • #46601
[PATCH v2 28/33] mm/vma: slightly rework the anonymous check in __mmap_new_vma()
Fri, 10 Jul 2026 21:17:09 +0100
Lorenzo Stoakes <[email protected]> • #46600
[PATCH v2 27/33] mm/vma: update vmg_adjust_set_range() to offset pgoff instead
Fri, 10 Jul 2026 21:17:08 +0100
Lorenzo Stoakes <[email protected]> • #46599
[PATCH v2 26/33] mm/vma: update vma_shrink() to not pass start, pgoff parameters
Fri, 10 Jul 2026 21:17:07 +0100
Lorenzo Stoakes <[email protected]> • #46598
[PATCH v2 25/33] mm/vma: make vma_set_range() static, drop insert_vm_struct() decl
Fri, 10 Jul 2026 21:17:06 +0100
Lorenzo Stoakes <[email protected]> • #46597
[PATCH v2 24/33] mm/vma: move __install_special_mapping() to vma.c
Fri, 10 Jul 2026 21:17:05 +0100
Lorenzo Stoakes <[email protected]> • #46596
[PATCH v2 23/33] mm/vma: add and use vma_[add/sub]_pgoff()
Fri, 10 Jul 2026 21:17:04 +0100
Lorenzo Stoakes <[email protected]> • #46595
Re: [PATCH 29/30] tools/testing/vma: default VMA flag bits to 64-bit
Fri, 10 Jul 2026 21:25:47 +0100
Lorenzo Stoakes <[email protected]> • #46594
[PATCH v2 22/33] mm/vma: introduce vma_assert_can_modify()
Fri, 10 Jul 2026 21:17:03 +0100
Lorenzo Stoakes <[email protected]> • #46593
[PATCH v2 21/33] mm: use linear_page_[index, delta]() consistently
Fri, 10 Jul 2026 21:17:02 +0100
Lorenzo Stoakes <[email protected]> • #46592
[PATCH v2 20/33] mm/vma: remove duplicative vma_pgoff_offset() helper
Fri, 10 Jul 2026 21:17:01 +0100
Lorenzo Stoakes <[email protected]> • #46591
[PATCH v2 19/33] mm: prefer vma_[start,end]_pgoff() to vma->vm_pgoff in kernel/
Fri, 10 Jul 2026 21:17:00 +0100
Lorenzo Stoakes <[email protected]> • #46590
[PATCH v2 18/33] mm/vma: use vma_start_pgoff(), linear_page_index() in mm code
Fri, 10 Jul 2026 21:16:59 +0100
Lorenzo Stoakes <[email protected]> • #46589
[PATCH v2 17/33] mm: introduce and use linear_page_delta()
Fri, 10 Jul 2026 21:16:58 +0100
Lorenzo Stoakes <[email protected]> • #46588
[PATCH v2 16/33] mm/vma: minor cleanup of expand_[upwards, downwards]()
Fri, 10 Jul 2026 21:16:57 +0100
Lorenzo Stoakes <[email protected]> • #46587
[PATCH v2 15/33] mm/vma: refactor vmg_adjust_set_range() for clarity
Fri, 10 Jul 2026 21:16:56 +0100
Lorenzo Stoakes <[email protected]> • #46586
[PATCH v2 14/33] mm/vma: clean up anon_vma_compatible()
Fri, 10 Jul 2026 21:16:55 +0100
Lorenzo Stoakes <[email protected]> • #46585
[PATCH v2 13/33] mm/vma: introduce and use vmg_pages(), vmg_[start, end]_pgoff()
Fri, 10 Jul 2026 21:16:54 +0100
Lorenzo Stoakes <[email protected]> • #46584
[PATCH v2 12/33] MAINTAINERS: Move mm/interval_tree.c to rmap section
Fri, 10 Jul 2026 21:16:53 +0100
Lorenzo Stoakes <[email protected]> • #46583
[PATCH v2 11/33] mm/rmap: rename anon_vma_interval_tree_*() to anon_rmap_tree_*()
Fri, 10 Jul 2026 21:16:52 +0100
Lorenzo Stoakes <[email protected]> • #46582
[PATCH v2 10/33] mm/rmap: rename anon_vma_interval_tree_*() params and use pgoff_t
Fri, 10 Jul 2026 21:16:51 +0100
Lorenzo Stoakes <[email protected]> • #46581
[PATCH v2 09/33] mm/rmap: parameterise anon_vma_interval_tree_*() by anon_vma
Fri, 10 Jul 2026 21:16:50 +0100
Lorenzo Stoakes <[email protected]> • #46580
[PATCH v2 08/33] mm/rmap: rename vma_interval_tree_*() to mapping_rmap_tree_*()
Fri, 10 Jul 2026 21:16:49 +0100
Lorenzo Stoakes <[email protected]> • #46579
[PATCH v2 07/33] mm/rmap: elide unnecessary static inline's in interval_tree.c
Fri, 10 Jul 2026 21:16:48 +0100
Lorenzo Stoakes <[email protected]> • #46578
Re: [PATCH 29/30] tools/testing/vma: default VMA flag bits to 64-bit
Fri, 10 Jul 2026 16:19:58 -0400
Gregory Price <[email protected]> • #46577
[PATCH v2 06/33] mm/rmap: parameterise vma_interval_tree_*() by address_space
Fri, 10 Jul 2026 21:16:47 +0100
Lorenzo Stoakes <[email protected]> • #46576
[PATCH v2 05/33] mm/rmap: update mm/interval_tree.c comments
Fri, 10 Jul 2026 21:16:46 +0100
Lorenzo Stoakes <[email protected]> • #46575
[PATCH v2 04/33] mm: introduce and use vma_end_pgoff()
Fri, 10 Jul 2026 21:16:45 +0100
Lorenzo Stoakes <[email protected]> • #46574
[PATCH v2 03/33] tools/testing/vma: use vma_start_pgoff() in merge tests
Fri, 10 Jul 2026 21:16:44 +0100
Lorenzo Stoakes <[email protected]> • #46573
[PATCH v2 02/33] mm: add kdoc comments for vma_start/last_pgoff()
Fri, 10 Jul 2026 21:16:43 +0100
Lorenzo Stoakes <[email protected]> • #46572
[PATCH v2 01/33] mm: move vma_start_pgoff() into mm.h and clean up
Fri, 10 Jul 2026 21:16:42 +0100
Lorenzo Stoakes <[email protected]> • #46571
[PATCH v2 00/33] mm: make VMA page offset handling more consistent
Fri, 10 Jul 2026 21:16:41 +0100
Lorenzo Stoakes <[email protected]> • #46570
Re: [PATCH 28/30] mm/vma: use guard clauses in can_vma_merge_[before, after]()
Fri, 10 Jul 2026 15:38:40 -0400
Gregory Price <[email protected]> • #46569
Re: [PATCH 27/30] mm/vma: correct incorrect vma.h inclusion
Fri, 10 Jul 2026 20:35:43 +0100
Lorenzo Stoakes <[email protected]> • #46568
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.