org.kernel.vger.linux-parisc archive

554 archived articles, newest first (page 5 of 6). Latest articles →

Re: [PATCH 27/30] mm/vma: correct incorrect vma.h inclusion
Fri, 10 Jul 2026 15:25:59 -0400
Gregory Price <[email protected]> • #46567
Re: [PATCH 26/30] mm/vma: introduce and use vma_set_pgoff()
Fri, 10 Jul 2026 15:20:43 -0400
Gregory Price <[email protected]> • #46566
Re: [PATCH 25/30] mm/vma: update vmg_adjust_set_range() to offset pgoff instead
Fri, 10 Jul 2026 15:12:57 -0400
Gregory Price <[email protected]> • #46565
Re: [PATCH 22/30] mm/vma: move __install_special_mapping() to vma.c
Fri, 10 Jul 2026 15:08:31 -0400
Gregory Price <[email protected]> • #46564
Re: [PATCH 20/30] mm/vma: introduce vma_assert_can_modify()
Fri, 10 Jul 2026 15:05:27 -0400
Gregory Price <[email protected]> • #46563
Re: [PATCH 21/30] mm/vma: add and use vma_[add/sub]_pgoff()
Fri, 10 Jul 2026 15:01:49 -0400
Gregory Price <[email protected]> • #46562
Re: [PATCH 24/30] mm/vma: update vma_shrink() to not pass unnecessary pgoff parameter
Fri, 10 Jul 2026 14:59:16 -0400
Gregory Price <[email protected]> • #46561
Re: [PATCH 23/30] mm/vma: make vma_set_range() static, drop insert_vm_struct() decl
Fri, 10 Jul 2026 14:57:21 -0400
Gregory Price <[email protected]> • #46560
Re: [PATCH 06/30] mm/rmap: parameterise vma_interval_tree_*() by address_space
Fri, 10 Jul 2026 14:55:45 -0400
Gregory Price <[email protected]> • #46559
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Fri, 10 Jul 2026 17:20:03 +0200
Michal Suchánek <[email protected]> • #46558
Re: [PATCH 17/30] mm: prefer vma_[start,end]_pgoff() to vma->vm_pgoff in kernel/
Fri, 10 Jul 2026 16:15:46 +0100
Lorenzo Stoakes <[email protected]> • #46557
Re: [PATCH 28/30] mm/vma: use guard clauses in can_vma_merge_[before, after]()
Fri, 10 Jul 2026 16:14:00 +0100
Lorenzo Stoakes <[email protected]> • #46556
Re: [PATCH 17/30] mm: prefer vma_[start,end]_pgoff() to vma->vm_pgoff in kernel/
Fri, 10 Jul 2026 11:09:02 -0400
Gregory Price <[email protected]> • #46555
Re: [PATCH 19/30] mm: use linear_page_[index, delta]() consistently
Fri, 10 Jul 2026 16:01:32 +0100
Lorenzo Stoakes <[email protected]> • #46554
Re: [PATCH 17/30] mm: prefer vma_[start,end]_pgoff() to vma->vm_pgoff in kernel/
Fri, 10 Jul 2026 15:56:33 +0100
Lorenzo Stoakes <[email protected]> • #46553
Re: [PATCH 16/30] mm/vma: use vma_start_pgoff(), linear_page_index() in mm code
Fri, 10 Jul 2026 15:52:40 +0100
Lorenzo Stoakes <[email protected]> • #46552
Re: [PATCH 13/30] mm/vma: refactor vmg_adjust_set_range() for clarity
Fri, 10 Jul 2026 15:50:44 +0100
Lorenzo Stoakes <[email protected]> • #46551
Re: [PATCH 02/30] mm: add kdoc comments for vma_start/last_pgoff()
Fri, 10 Jul 2026 14:38:58 +0100
Lorenzo Stoakes <[email protected]> • #46550
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Fri, 10 Jul 2026 14:52:40 +0200
Oleg Nesterov <[email protected]> • #46549
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Fri, 10 Jul 2026 14:32:13 +0200
Michal Suchánek <[email protected]> • #46548
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Fri, 10 Jul 2026 13:40:43 +0200
Oleg Nesterov <[email protected]> • #46547
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Fri, 10 Jul 2026 13:16:20 +0200
Oleg Nesterov <[email protected]> • #46546
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Fri, 10 Jul 2026 13:01:02 +0200
Michal Suchánek <[email protected]> • #46545
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Fri, 10 Jul 2026 12:42:29 +0200
Michal Suchánek <[email protected]> • #46544
Re: [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 01:46:15 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #46543
Re: [patch 00/18] entry: Consolidate and rework syscall entry handling
Fri, 10 Jul 2026 01:45:19 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #46542
Re: [patch 18/18] entry, treewide: Make syscall_enter_from_user_mode[_work]() indicate syscall execution
Fri, 10 Jul 2026 01:19:28 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #46541
Re: [patch 15/18] x86/entry: Make syscall functions static
Fri, 10 Jul 2026 01:13:15 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #46540
Re: [patch 14/18] entry: Make return type of syscall_trace_enter() bool
Fri, 10 Jul 2026 01:06:23 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #46539
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Fri, 10 Jul 2026 00:52:35 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #46538
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Fri, 10 Jul 2026 00:40:00 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #46537
Re: [patch 10/18] entry: Use syscall number instead of rereading it
Fri, 10 Jul 2026 00:20:46 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #46536
Re: [patch 09/18] entry: Remove syscall_enter_from_user_mode()
Fri, 10 Jul 2026 00:19:18 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #46535
Re: [patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 00:15:39 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #46534
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 00:13:32 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #46533
Re: [patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 00:12:23 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #46532
Re: [patch 05/18] powerpc/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 00:11:04 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #46531
Re: [patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 00:10:01 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #46530
Re: [patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
Fri, 10 Jul 2026 00:04:21 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #46529
Re: [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Fri, 10 Jul 2026 00:02:27 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #46528
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Thu, 09 Jul 2026 13:03:28 -0400
Radu Rendec <[email protected]> • #46527
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Thu, 9 Jul 2026 17:26:59 +0100
David Laight <[email protected]> • #46526
Re: [patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
Thu, 9 Jul 2026 09:23:47 -0700
Kees Cook <[email protected]> • #46525
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Thu, 9 Jul 2026 09:22:06 -0700
Kees Cook <[email protected]> • #46524
Re: [PATCH 19/30] mm: use linear_page_[index, delta]() consistently
Thu, 9 Jul 2026 11:57:09 -0400
Gregory Price <[email protected]> • #46523
Re: [PATCH 19/30] mm: use linear_page_[index, delta]() consistently
Thu, 9 Jul 2026 11:55:54 -0400
Gregory Price <[email protected]> • #46522
Re: [PATCH 18/30] mm/vma: remove duplicative vma_pgoff_offset() helper
Thu, 9 Jul 2026 11:50:40 -0400
Gregory Price <[email protected]> • #46521
Re: [PATCH 17/30] mm: prefer vma_[start,end]_pgoff() to vma->vm_pgoff in kernel/
Thu, 9 Jul 2026 11:49:51 -0400
Gregory Price <[email protected]> • #46520
Re: [PATCH 17/30] mm: prefer vma_[start,end]_pgoff() to vma->vm_pgoff in kernel/
Thu, 9 Jul 2026 11:49:18 -0400
Gregory Price <[email protected]> • #46519
Re: [PATCH 16/30] mm/vma: use vma_start_pgoff(), linear_page_index() in mm code
Thu, 9 Jul 2026 11:29:58 -0400
Gregory Price <[email protected]> • #46518
Re: [PATCH 15/30] mm: introduce and use linear_page_delta()
Thu, 9 Jul 2026 11:22:47 -0400
Gregory Price <[email protected]> • #46517
Re: [PATCH 14/30] mm/vma: minor cleanup of expand_[upwards, downwards]()
Thu, 9 Jul 2026 11:20:44 -0400
Gregory Price <[email protected]> • #46516
Re: [PATCH 13/30] mm/vma: refactor vmg_adjust_set_range() for clarity
Thu, 9 Jul 2026 11:18:40 -0400
Gregory Price <[email protected]> • #46515
Re: [patch 10/18] entry: Use syscall number instead of rereading it
Thu, 9 Jul 2026 13:22:26 +0200
Philippe Mathieu-Daudé <[email protected]> • #46514
Re: [patch 10/18] entry: Use syscall number instead of rereading it
Thu, 9 Jul 2026 13:20:43 +0200
Philippe Mathieu-Daudé <[email protected]> • #46513
Re: [patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:18:04 +0200
Philippe Mathieu-Daudé <[email protected]> • #46512
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:17:17 +0200
Philippe Mathieu-Daudé <[email protected]> • #46511
Re: [patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:16:51 +0200
Philippe Mathieu-Daudé <[email protected]> • #46510
Re: [patch 05/18] powerpc/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:16:21 +0200
Philippe Mathieu-Daudé <[email protected]> • #46509
Re: [patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:15:55 +0200
Philippe Mathieu-Daudé <[email protected]> • #46508
Re: [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:15:11 +0200
Philippe Mathieu-Daudé <[email protected]> • #46507
Re: [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Thu, 9 Jul 2026 13:12:57 +0200
Philippe Mathieu-Daudé <[email protected]> • #46506
Re: [PATCH 19/30] mm: use linear_page_[index, delta]() consistently
Thu, 9 Jul 2026 10:07:15 +0000
"Huang, Kai" <[email protected]> • #46505
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Thu, 9 Jul 2026 10:41:56 +0200
Geert Uytterhoeven <[email protected]> • #46504
Re: [PATCH v16 18/18] arm64: vdso: Expose sigreturn address on vdso to the kernel
Thu, 9 Jul 2026 10:27:59 +0200
Thomas Weißschuh <[email protected]> • #46503
Re: [PATCH v16 18/18] arm64: vdso: Expose sigreturn address on vdso to the kernel
Thu, 9 Jul 2026 16:15:15 +0800
Jinjie Ruan <[email protected]> • #46502
Re: [PATCH v16 18/18] arm64: vdso: Expose sigreturn address on vdso to the kernel
Thu, 9 Jul 2026 09:17:33 +0200
Thomas Weißschuh <[email protected]> • #46501
Re: [PATCH v16 18/18] arm64: vdso: Expose sigreturn address on vdso to the kernel
Thu, 9 Jul 2026 14:37:05 +0800
Jinjie Ruan <[email protected]> • #46500
Re: [PATCH v16 02/18] syscall_user_dispatch: Introduce a weak fallback for arch_syscall_is_vdso_sigreturn()
Thu, 9 Jul 2026 14:30:11 +0800
Jinjie Ruan <[email protected]> • #46499
Re: [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 11:46:07 +0800
Jinjie Ruan <[email protected]> • #46498
Re: [patch 10/18] entry: Use syscall number instead of rereading it
Thu, 9 Jul 2026 10:55:27 +0800
Jinjie Ruan <[email protected]> • #46497
Re: [patch 09/18] entry: Remove syscall_enter_from_user_mode()
Thu, 9 Jul 2026 10:49:49 +0800
Jinjie Ruan <[email protected]> • #46496
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:46:44 +0800
Jinjie Ruan <[email protected]> • #46495
Re: [patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:44:48 +0800
Jinjie Ruan <[email protected]> • #46494
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:39:17 +0800
Jinjie Ruan <[email protected]> • #46493
Re: [patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:38:38 +0800
Jinjie Ruan <[email protected]> • #46492
Re: [patch 05/18] powerpc/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:38:16 +0800
Jinjie Ruan <[email protected]> • #46491
Re: [patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:37:44 +0800
Jinjie Ruan <[email protected]> • #46490
Re: [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:34:22 +0800
Jinjie Ruan <[email protected]> • #46489
Re: [patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
Thu, 9 Jul 2026 10:13:11 +0800
Jinjie Ruan <[email protected]> • #46488
Re: [patch 16/18] x86/entry: Get rid of the sys_ni_syscall() indirection
Thu, 9 Jul 2026 10:03:49 +0800
Jinjie Ruan <[email protected]> • #46487
Re: [patch 15/18] x86/entry: Make syscall functions static
Thu, 9 Jul 2026 09:47:56 +0800
Jinjie Ruan <[email protected]> • #46486
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Thu, 9 Jul 2026 09:41:18 +0800
Jinjie Ruan <[email protected]> • #46485
Re: [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Thu, 9 Jul 2026 09:20:32 +0800
Jinjie Ruan <[email protected]> • #46484
Re: [PATCH 19/30] mm: use linear_page_[index, delta]() consistently
Wed, 8 Jul 2026 17:06:09 -0700
Ackerley Tng <[email protected]> • #46483
Re: [PATCH 15/30] mm: introduce and use linear_page_delta()
Wed, 8 Jul 2026 17:06:03 -0700
Ackerley Tng <[email protected]> • #46482
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Thu, 09 Jul 2026 01:14:24 +0200
Thomas Gleixner <[email protected]> • #46481
Re: [patch 09/18] entry: Remove syscall_enter_from_user_mode()
Thu, 09 Jul 2026 00:08:11 +0200
Thomas Gleixner <[email protected]> • #46480
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Wed, 08 Jul 2026 23:49:57 +0200
Thomas Gleixner <[email protected]> • #46479
Re: [patch 10/18] entry: Use syscall number instead of rereading it
Wed, 08 Jul 2026 17:39:50 -0400
Radu Rendec <[email protected]> • #46478
Re: [patch 09/18] entry: Remove syscall_enter_from_user_mode()
Wed, 08 Jul 2026 17:21:19 -0400
Radu Rendec <[email protected]> • #46477
Re: [patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 16:59:18 -0400
Radu Rendec <[email protected]> • #46476
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 16:57:51 -0400
Radu Rendec <[email protected]> • #46475
Re: [patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 16:57:00 -0400
Radu Rendec <[email protected]> • #46474
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Wed, 08 Jul 2026 22:34:38 +0200
Thomas Gleixner <[email protected]> • #46473
Re: [patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 14:37:13 -0400
Radu Rendec <[email protected]> • #46472
Re: [patch 05/18] powerpc/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 14:35:48 -0400
Radu Rendec <[email protected]> • #46471
Re: [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 13:26:19 -0400
Radu Rendec <[email protected]> • #46470
Re: [patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
Wed, 08 Jul 2026 13:24:33 -0400
Radu Rendec <[email protected]> • #46469
Re: [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Wed, 08 Jul 2026 13:22:58 -0400
Radu Rendec <[email protected]> • #46468
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.