org.kernel.vger.linux-parisc archive

554 archived articles, newest first (page 6 of 6). Latest articles →

Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Wed, 8 Jul 2026 18:04:19 +0200
Oleg Nesterov <[email protected]> • #46467
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Wed, 8 Jul 2026 17:52:42 +0200
Michal Suchánek <[email protected]> • #46466
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Wed, 8 Jul 2026 17:46:24 +0200
Oleg Nesterov <[email protected]> • #46465
Re: [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Wed, 8 Jul 2026 19:37:51 +0530
Shrikanth Hegde <[email protected]> • #46464
Re: [patch 18/18] entry, treewide: Make syscall_enter_from_user_mode[_work]() indicate syscall execution
Wed, 08 Jul 2026 11:16:25 +0200
Thomas Gleixner <[email protected]> • #46463
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Wed, 08 Jul 2026 11:15:10 +0200
Thomas Gleixner <[email protected]> • #46462
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 08:47:15 +0200
Sven Schnelle <[email protected]> • #46461
Re: [patch 18/18] entry, treewide: Make syscall_enter_from_user_mode[_work]() indicate syscall execution
Wed, 8 Jul 2026 10:51:56 +0530
Shrikanth Hegde <[email protected]> • #46460
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Wed, 8 Jul 2026 09:43:46 +0800
Jinjie Ruan <[email protected]> • #46459
[patch 18/18] entry, treewide: Make syscall_enter_from_user_mode[_work]() indicate syscall execution
Tue, 07 Jul 2026 21:07:09 +0200
Thomas Gleixner <[email protected]> • #46458
[patch 17/18] x86/entry: Simplify the syscall number logic
Tue, 07 Jul 2026 21:07:05 +0200
Thomas Gleixner <[email protected]> • #46457
[patch 16/18] x86/entry: Get rid of the sys_ni_syscall() indirection
Tue, 07 Jul 2026 21:07:01 +0200
Thomas Gleixner <[email protected]> • #46456
[patch 15/18] x86/entry: Make syscall functions static
Tue, 07 Jul 2026 21:06:57 +0200
Thomas Gleixner <[email protected]> • #46455
[patch 14/18] entry: Make return type of syscall_trace_enter() bool
Tue, 07 Jul 2026 21:06:53 +0200
Thomas Gleixner <[email protected]> • #46454
[patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Tue, 07 Jul 2026 21:06:44 +0200
Thomas Gleixner <[email protected]> • #46453
[patch 13/18] entry: Make trace_syscall_enter() return type bool
Tue, 07 Jul 2026 21:06:48 +0200
Thomas Gleixner <[email protected]> • #46452
[patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Tue, 07 Jul 2026 21:06:40 +0200
Thomas Gleixner <[email protected]> • #46451
[patch 10/18] entry: Use syscall number instead of rereading it
Tue, 07 Jul 2026 21:06:36 +0200
Thomas Gleixner <[email protected]> • #46450
[patch 09/18] entry: Remove syscall_enter_from_user_mode()
Tue, 07 Jul 2026 21:06:32 +0200
Thomas Gleixner <[email protected]> • #46449
[patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:27 +0200
Thomas Gleixner <[email protected]> • #46448
[patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:23 +0200
Thomas Gleixner <[email protected]> • #46447
[patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:19 +0200
Thomas Gleixner <[email protected]> • #46446
[patch 05/18] powerpc/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:15 +0200
Thomas Gleixner <[email protected]> • #46445
[patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:11 +0200
Thomas Gleixner <[email protected]> • #46444
[patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:07 +0200
Thomas Gleixner <[email protected]> • #46443
[patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
Tue, 07 Jul 2026 21:06:02 +0200
Thomas Gleixner <[email protected]> • #46442
[patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Tue, 07 Jul 2026 21:05:58 +0200
Thomas Gleixner <[email protected]> • #46441
[patch 00/18] entry: Consolidate and rework syscall entry handling
Tue, 07 Jul 2026 21:05:53 +0200
Thomas Gleixner <[email protected]> • #46440
Re: [PATCH 12/30] mm/vma: clean up anon_vma_compatible()
Tue, 7 Jul 2026 12:26:43 -0400
Gregory Price <[email protected]> • #46439
Re: [PATCH 11/30] mm/vma: introduce and use vmg_pages(), vmg_[start, end]_pgoff()
Tue, 7 Jul 2026 12:25:58 -0400
Gregory Price <[email protected]> • #46438
Re: [PATCH 02/30] mm: add kdoc comments for vma_start/last_pgoff()
Tue, 7 Jul 2026 16:46:13 +0200
"David Hildenbrand (Arm)" <[email protected]> • #46437
Re: [PATCH 01/30] mm: move vma_start_pgoff() into mm.h and clean up
Tue, 7 Jul 2026 16:41:14 +0200
"David Hildenbrand (Arm)" <[email protected]> • #46436
Re: [PATCH 29/30] tools/testing/vma: default VMA flag bits to 64-bit
Tue, 7 Jul 2026 11:47:16 +0100
Lorenzo Stoakes <[email protected]> • #46435
Re: [PATCH 27/30] mm/vma: correct incorrect vma.h inclusion
Tue, 7 Jul 2026 11:41:00 +0100
Lorenzo Stoakes <[email protected]> • #46434
Re: [PATCH 25/30] mm/vma: update vmg_adjust_set_range() to offset pgoff instead
Tue, 7 Jul 2026 11:35:27 +0100
Lorenzo Stoakes <[email protected]> • #46433
Re: [PATCH 22/30] mm/vma: move __install_special_mapping() to vma.c
Tue, 7 Jul 2026 11:31:37 +0100
Lorenzo Stoakes <[email protected]> • #46432
Re: [PATCH 21/30] mm/vma: add and use vma_[add/sub]_pgoff()
Tue, 7 Jul 2026 11:22:41 +0100
Lorenzo Stoakes <[email protected]> • #46431
Re: [PATCH 17/30] mm: prefer vma_[start,end]_pgoff() to vma->vm_pgoff in kernel/
Tue, 7 Jul 2026 12:20:33 +0200
Marek Szyprowski <[email protected]> • #46430
Re: [PATCH v16 01/18] seccomp: Convert __secure_computing() to return boolean
Mon, 6 Jul 2026 10:41:16 +0800
Jinjie Ruan <[email protected]> • #46429
[PATCH 2/2] parisc: Remove unnecessary NULL check of the kstat_irqs field
Sun, 5 Jul 2026 17:09:51 -0400
Radu Rendec <[email protected]> • #46428
[PATCH 1/2] genirq: Remove unnecessary NULL check of the kstat_irqs field
Sun, 5 Jul 2026 17:09:50 -0400
Radu Rendec <[email protected]> • #46427
[PATCH 0/2] Remove unnecessary NULL check of the kstat_irqs field
Sun, 5 Jul 2026 17:09:49 -0400
Radu Rendec <[email protected]> • #46426
Re: [PATCH v16 01/18] seccomp: Convert __secure_computing() to return boolean
Fri, 3 Jul 2026 23:32:21 +0200
Linus Walleij <[email protected]> • #46425
Re: [PATCH v16 01/18] seccomp: Convert __secure_computing() to return boolean
Fri, 03 Jul 2026 14:01:29 -0700
"H. Peter Anvin" <[email protected]> • #46424
Re: [PATCH v16 01/18] seccomp: Convert __secure_computing() to return boolean
Fri, 03 Jul 2026 22:52:43 +0200
Thomas Gleixner <[email protected]> • #46423
Re: [PATCH 04/30] mm: introduce and use vma_end_pgoff()
Fri, 3 Jul 2026 16:38:12 +0200
Vlastimil Babka <[email protected]> • #46422
Re: [PATCH 03/30] tools/testing/vma: use vma_start_pgoff() in merge tests
Fri, 3 Jul 2026 16:34:14 +0200
Vlastimil Babka <[email protected]> • #46421
Re: [PATCH 02/30] mm: add kdoc comments for vma_start/last_pgoff()
Fri, 3 Jul 2026 16:19:28 +0200
Vlastimil Babka <[email protected]> • #46420
Re: [PATCH 01/30] mm: move vma_start_pgoff() into mm.h and clean up
Fri, 3 Jul 2026 15:36:00 +0200
Vlastimil Babka <[email protected]> • #46419
Re: [PATCH v16 01/18] seccomp: Convert __secure_computing() to return boolean
Fri, 3 Jul 2026 13:59:21 +0200
Kevin Brodsky <[email protected]> • #46418
Re: [PATCH v16 02/18] syscall_user_dispatch: Introduce a weak fallback for arch_syscall_is_vdso_sigreturn()
Fri, 3 Jul 2026 12:43:53 +0100
Mark Rutland <[email protected]> • #46417
Re: [PATCH v16 02/18] syscall_user_dispatch: Introduce a weak fallback for arch_syscall_is_vdso_sigreturn()
Fri, 3 Jul 2026 16:43:11 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #46416
Re: [PATCH v16 01/18] seccomp: Convert __secure_computing() to return boolean
Fri, 3 Jul 2026 12:27:26 +0200
Michal Suchánek <[email protected]> • #46415
Re: [PATCH v16 01/18] seccomp: Convert __secure_computing() to return boolean
Fri, 3 Jul 2026 11:00:11 +0100
Mark Rutland <[email protected]> • #46414
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.