org.kernel.vger.linux-sgx archive

374 archived articles, newest first (page 4 of 4). Latest articles →

Re: [PATCH v1 11/16] mm/memory: inline unmap_page_range() into __zap_vma_range()
Mon, 9 Mar 2026 13:46:27 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #10632
Re: [PATCH v1 11/16] mm/memory: inline unmap_page_range() into __zap_vma_range()
Fri, 6 Mar 2026 14:16:26 +0100
"David Hildenbrand (Arm)" <[email protected]> • #10631
Re: [PATCH v1 16/16] mm/memory: support VM_MIXEDMAP in zap_special_vma_range()
Fri, 6 Mar 2026 12:43:21 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #10630
Re: [PATCH v1 15/16] mm: rename zap_vma_ptes() to zap_special_vma_range()
Fri, 6 Mar 2026 12:41:11 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #10629
Re: [PATCH v1 08/16] mm/memory: move adjusting of address range to unmap_vmas()
Fri, 6 Mar 2026 12:40:07 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #10628
Re: [PATCH v1 14/16] mm: rename zap_page_range_single() to zap_vma_range()
Fri, 6 Mar 2026 12:32:40 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #10627
Re: [PATCH v1 13/16] mm: rename zap_page_range_single_batched() to zap_vma_range_batched()
Fri, 6 Mar 2026 12:31:18 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #10626
Re: [PATCH v1 12/16] mm: rename zap_vma_pages() to zap_vma()
Fri, 6 Mar 2026 12:30:10 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #10625
Re: [PATCH v1 11/16] mm/memory: inline unmap_page_range() into __zap_vma_range()
Fri, 6 Mar 2026 12:29:28 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #10624
Re: [PATCH v1 10/16] mm/memory: use __zap_vma_range() in zap_vma_for_reaping()
Fri, 6 Mar 2026 12:26:31 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #10623
Re: [PATCH v1 09/16] mm/memory: convert details->even_cows into details->skip_cows
Fri, 6 Mar 2026 12:21:45 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #10622
Re: [PATCH v1 07/16] mm/memory: rename unmap_single_vma() to __zap_vma_range()
Fri, 6 Mar 2026 12:17:55 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #10621
Re: [PATCH v1 06/16] mm/oom_kill: factor out zapping of VMA into zap_vma_for_reaping()
Fri, 6 Mar 2026 12:17:03 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #10620
Re: [PATCH v1 05/16] mm/oom_kill: use MMU_NOTIFY_CLEAR in __oom_reap_task_mm()
Fri, 6 Mar 2026 12:14:02 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #10619
Re: [PATCH v1 04/16] mm/memory: simplify calculation in unmap_mapping_range_tree()
Fri, 6 Mar 2026 12:12:42 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #10618
Re: [PATCH v1 03/16] mm/memory: inline unmap_mapping_range_vma() into unmap_mapping_range_tree()
Fri, 6 Mar 2026 12:07:52 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #10617
Re: [PATCH v1 02/16] mm/memory: remove "zap_details" parameter from zap_page_range_single()
Fri, 6 Mar 2026 12:06:54 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #10616
Re: [PATCH v1 01/16] mm/madvise: drop range checks in madvise_free_single_vma()
Fri, 6 Mar 2026 12:03:24 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #10615
答复: [PATCH][v2] x86/sgx: Use list_for_each_ entry_srcu() for mm_list traversal
Thu, 5 Mar 2026 08:43:15 +0000
"Li,Rongqing(ACG CCN)" <[email protected]> • #10614
Re: [PATCH v1 15/16] mm: rename zap_vma_ptes() to zap_special_vma_range()
Wed, 4 Mar 2026 17:26:52 +0200
Leon Romanovsky <[email protected]> • #10613
Re: [PATCH v1 02/16] mm/memory: remove "zap_details" parameter from zap_page_range_single()
Wed, 4 Mar 2026 09:47:06 +0100
"David Hildenbrand (Arm)" <[email protected]> • #10612
Re: [PATCH v1 02/16] mm/memory: remove "zap_details" parameter from zap_page_range_single()
Tue, 3 Mar 2026 21:49:06 +0100
Miguel Ojeda <[email protected]> • #10611
Re: [PATCH v1 00/16] mm: cleanups around unmapping / zapping
Mon, 2 Mar 2026 15:29:34 -0800
Andrew Morton <[email protected]> • #10610
Re: [PATCH v1 02/16] mm/memory: remove "zap_details" parameter from zap_page_range_single()
Mon, 2 Mar 2026 15:41:42 +0000
Alice Ryhl <[email protected]> • #10609
Re: [PATCH v1 02/16] mm/memory: remove "zap_details" parameter from zap_page_range_single()
Mon, 2 Mar 2026 16:01:44 +0100
"David Hildenbrand (Arm)" <[email protected]> • #10608
Re: [PATCH v1 02/16] mm/memory: remove "zap_details" parameter from zap_page_range_single()
Mon, 2 Mar 2026 10:33:45 +0000
Alice Ryhl <[email protected]> • #10607
Re: [PATCH v1 02/16] mm/memory: remove "zap_details" parameter from zap_page_range_single()
Mon, 2 Mar 2026 11:27:40 +0100
"David Hildenbrand (Arm)" <[email protected]> • #10606
Re: [PATCH v1 02/16] mm/memory: remove "zap_details" parameter from zap_page_range_single()
Mon, 2 Mar 2026 10:01:10 +0000
Alice Ryhl <[email protected]> • #10605
Re: [PATCH v1 14/16] mm: rename zap_page_range_single() to zap_vma_range()
Mon, 2 Mar 2026 09:22:31 +0100
"David Hildenbrand (Arm)" <[email protected]> • #10604
Re: [PATCH v1 02/16] mm/memory: remove "zap_details" parameter from zap_page_range_single()
Mon, 2 Mar 2026 09:18:45 +0100
"David Hildenbrand (Arm)" <[email protected]> • #10603
Re: [PATCH v1 14/16] mm: rename zap_page_range_single() to zap_vma_range()
Sat, 28 Feb 2026 12:44:27 +0000
Alice Ryhl <[email protected]> • #10602
Re: [PATCH v1 02/16] mm/memory: remove "zap_details" parameter from zap_page_range_single()
Sat, 28 Feb 2026 12:38:48 +0000
Alice Ryhl <[email protected]> • #10601
[PATCH v1 16/16] mm/memory: support VM_MIXEDMAP in zap_special_vma_range()
Fri, 27 Feb 2026 21:08:47 +0100
"David Hildenbrand (Arm)" <[email protected]> • #10600
[PATCH v1 15/16] mm: rename zap_vma_ptes() to zap_special_vma_range()
Fri, 27 Feb 2026 21:08:46 +0100
"David Hildenbrand (Arm)" <[email protected]> • #10599
[PATCH v1 14/16] mm: rename zap_page_range_single() to zap_vma_range()
Fri, 27 Feb 2026 21:08:45 +0100
"David Hildenbrand (Arm)" <[email protected]> • #10598
[PATCH v1 13/16] mm: rename zap_page_range_single_batched() to zap_vma_range_batched()
Fri, 27 Feb 2026 21:08:44 +0100
"David Hildenbrand (Arm)" <[email protected]> • #10597
[PATCH v1 12/16] mm: rename zap_vma_pages() to zap_vma()
Fri, 27 Feb 2026 21:08:43 +0100
"David Hildenbrand (Arm)" <[email protected]> • #10596
[PATCH v1 11/16] mm/memory: inline unmap_page_range() into __zap_vma_range()
Fri, 27 Feb 2026 21:08:42 +0100
"David Hildenbrand (Arm)" <[email protected]> • #10595
[PATCH v1 10/16] mm/memory: use __zap_vma_range() in zap_vma_for_reaping()
Fri, 27 Feb 2026 21:08:41 +0100
"David Hildenbrand (Arm)" <[email protected]> • #10594
[PATCH v1 09/16] mm/memory: convert details->even_cows into details->skip_cows
Fri, 27 Feb 2026 21:08:40 +0100
"David Hildenbrand (Arm)" <[email protected]> • #10593
[PATCH v1 08/16] mm/memory: move adjusting of address range to unmap_vmas()
Fri, 27 Feb 2026 21:08:39 +0100
"David Hildenbrand (Arm)" <[email protected]> • #10592
[PATCH v1 07/16] mm/memory: rename unmap_single_vma() to __zap_vma_range()
Fri, 27 Feb 2026 21:08:38 +0100
"David Hildenbrand (Arm)" <[email protected]> • #10591
[PATCH v1 06/16] mm/oom_kill: factor out zapping of VMA into zap_vma_for_reaping()
Fri, 27 Feb 2026 21:08:37 +0100
"David Hildenbrand (Arm)" <[email protected]> • #10590
[PATCH v1 05/16] mm/oom_kill: use MMU_NOTIFY_CLEAR in __oom_reap_task_mm()
Fri, 27 Feb 2026 21:08:36 +0100
"David Hildenbrand (Arm)" <[email protected]> • #10589
[PATCH v1 04/16] mm/memory: simplify calculation in unmap_mapping_range_tree()
Fri, 27 Feb 2026 21:08:35 +0100
"David Hildenbrand (Arm)" <[email protected]> • #10588
[PATCH v1 03/16] mm/memory: inline unmap_mapping_range_vma() into unmap_mapping_range_tree()
Fri, 27 Feb 2026 21:08:34 +0100
"David Hildenbrand (Arm)" <[email protected]> • #10587
[PATCH v1 02/16] mm/memory: remove "zap_details" parameter from zap_page_range_single()
Fri, 27 Feb 2026 21:08:33 +0100
"David Hildenbrand (Arm)" <[email protected]> • #10586
[PATCH v1 01/16] mm/madvise: drop range checks in madvise_free_single_vma()
Fri, 27 Feb 2026 21:08:32 +0100
"David Hildenbrand (Arm)" <[email protected]> • #10585
[PATCH v1 00/16] mm: cleanups around unmapping / zapping
Fri, 27 Feb 2026 21:08:31 +0100
"David Hildenbrand (Arm)" <[email protected]> • #10584
[PATCH][v2] x86/sgx: Use list_for_each_entry_srcu() for mm_list traversal
Wed, 25 Feb 2026 20:40:14 -0500
lirongqing <[email protected]> • #10583
答复: 答复: [外部邮件] Re: [PATCH] x8 6/sgx: Fix SRCU list traversal
Tue, 24 Feb 2026 02:51:49 +0000
"Li,Rongqing(ACG CCN)" <[email protected]> • #10582
Re: 答复: [外部邮件] Re: [PATCH] x86 /sgx: Fix SRCU list traversal
Mon, 23 Feb 2026 17:14:34 -0800
Dave Hansen <[email protected]> • #10581
答复: [外部邮件] Re: [PATCH] x86/sgx: F ix SRCU list traversal
Tue, 24 Feb 2026 00:30:13 +0000
"Li,Rongqing(ACG CCN)" <[email protected]> • #10580
Re: [PATCH] x86/sgx: Fix SRCU list traversal
Wed, 11 Feb 2026 10:38:53 +0000
"Huang, Kai" <[email protected]> • #10579
Re: [PATCH v2 11/13] tools/testing/vma: separate VMA userland tests into separate files
Tue, 10 Feb 2026 17:44:55 +0000
Lorenzo Stoakes <[email protected]> • #10578
Re: [PATCH v4.1 06/10] x86/entry/vdso32: remove open-coded DWARF in sigreturn.S
Mon, 9 Feb 2026 21:24:00 -0800
"H. Peter Anvin" <[email protected]> • #10577
Re: [PATCH v4.1 06/10] x86/entry/vdso32: remove open-coded DWARF in sigreturn.S
Tue, 10 Feb 2026 12:56:39 +0800
Xi Ruoyao <[email protected]> • #10576
Re: [PATCH v4.1 06/10] x86/entry/vdso32: remove open-coded DWARF in sigreturn.S
Mon, 9 Feb 2026 20:53:37 -0800
"H. Peter Anvin" <[email protected]> • #10575
Re: [PATCH v4.1 06/10] x86/entry/vdso32: remove open-coded DWARF in sigreturn.S
Mon, 9 Feb 2026 20:51:45 -0800
"H. Peter Anvin" <[email protected]> • #10574
Re: [PATCH v4.1 06/10] x86/entry/vdso32: remove open-coded DWARF in sigreturn.S
Tue, 10 Feb 2026 12:45:53 +0800
Xi Ruoyao <[email protected]> • #10573
Re: [PATCH v4.1 06/10] x86/entry/vdso32 : remove open-coded DWARF in sigreturn.S
Mon, 09 Feb 2026 20:15:46 -0800
"H. Peter Anvin" <[email protected]> • #10572
Re: [PATCH v4.1 06/10] x86/entry/vdso32: remove open-coded DWARF in sigreturn.S
Tue, 10 Feb 2026 11:11:25 +0800
Xi Ruoyao <[email protected]> • #10571
Re: [PATCH v2 13/13] tools/testing/vma: add VMA userland tests for VMA flag functions
Mon, 9 Feb 2026 20:23:04 +0000
"Liam R. Howlett" <[email protected]> • #10570
Re: [PATCH v2 12/13] tools/testing/vma: separate out vma_internal.h into logical headers
Mon, 9 Feb 2026 20:18:26 +0000
"Liam R. Howlett" <[email protected]> • #10569
Re: [PATCH v2 11/13] tools/testing/vma: separate VMA userland tests into separate files
Mon, 9 Feb 2026 19:58:22 +0000
"Liam R. Howlett" <[email protected]> • #10568
Re: [PATCH v2 10/13] mm: make vm_area_desc utilise vma_flags_t only
Mon, 9 Feb 2026 19:32:55 +0000
"Liam R. Howlett" <[email protected]> • #10567
Re: [PATCH v2 09/13] mm: update all remaining mmap_prepare users to use vma_flags_t
Mon, 9 Feb 2026 19:27:46 +0000
"Liam R. Howlett" <[email protected]> • #10566
Re: [PATCH v2 08/13] mm: update shmem_[kernel]_file_*() functions to use vma_flags_t
Mon, 9 Feb 2026 19:13:31 +0000
"Liam R. Howlett" <[email protected]> • #10565
Re: [PATCH v2 07/13] mm: update secretmem to use VMA flags on mmap_prepare
Mon, 9 Feb 2026 19:06:18 +0000
"Liam R. Howlett" <[email protected]> • #10564
Re: [PATCH v2 06/13] mm: update hugetlbfs to use VMA flags on mmap_prepare
Mon, 9 Feb 2026 19:03:22 +0000
"Liam R. Howlett" <[email protected]> • #10563
Re: [PATCH v2 05/13] mm: add basic VMA flag operation helper functions
Mon, 9 Feb 2026 18:53:24 +0000
"Liam R. Howlett" <[email protected]> • #10562
Re: [PATCH v2 04/13] tools: bitmap: add missing bitmap_[subset(), andnot()]
Mon, 9 Feb 2026 18:45:22 +0000
"Liam R. Howlett" <[email protected]> • #10561
Re: [PATCH v2 03/13] mm: add mk_vma_flags() bitmap flag macro helper
Mon, 9 Feb 2026 18:44:20 +0000
"Liam R. Howlett" <[email protected]> • #10560
Re: [PATCH v2 02/13] mm: rename vma_flag_test/set_atomic() to vma_test/set_atomic_flag()
Mon, 9 Feb 2026 18:40:19 +0000
"Liam R. Howlett" <[email protected]> • #10559
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.