org.kernel.vger.linux-trace-kernel archive

1401 archived articles, newest first (page 4 of 15). Latest articles →

[PATCH v5 07/16] mm/vma: fix self-merge check in copy_vma()
Thu, 13 Aug 2026 18:32:24 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #40400
[PATCH v5 06/16] mm: introduce and use vma_filebacked_address()
Thu, 13 Aug 2026 18:32:23 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #40399
Re: [PATCH 2/2] dmaengine: add union chan_dev for dma_chan::dev for clarity
Thu, 13 Aug 2026 11:33:22 -0600
Logan Gunthorpe <[email protected]> • #40398
[PATCH v5 05/16] mm: update print_bad_page_map() to show anon index if appropriate
Thu, 13 Aug 2026 18:32:22 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #40397
[PATCH v5 04/16] mm: abstract vma_address() and introduce vma_anon_address()
Thu, 13 Aug 2026 18:32:21 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #40396
[PATCH v5 03/16] mm: introduce linear_anon_page_index()
Thu, 13 Aug 2026 18:32:20 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #40395
[PATCH v5 02/16] mm: provide vma_[flags_]is_cow_mapping() and remove is_cow_mapping()
Thu, 13 Aug 2026 18:32:19 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #40394
[PATCH v5 01/16] mm/vma: introduce VMA anon page offset field and add helpers
Thu, 13 Aug 2026 18:32:18 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #40393
[PATCH v5 00/16] mm/rmap: index MAP_PRIVATE file-backed folios by anonymous pgoff
Thu, 13 Aug 2026 18:32:17 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #40392
Re: [PATCH 1/2] dmaengine: use dma_chan_name() helper to get per-channel device name
Thu, 13 Aug 2026 11:28:43 -0600
Logan Gunthorpe <[email protected]> • #40391
Re: [PATCH 0/1] ring-buffer: Fix sub-buffer order updates and free_page leaks
Thu, 13 Aug 2026 18:25:32 +0100
Vincent Donnefort <[email protected]> • #40390
Re: [PATCH] ring-buffer: Fix race between ring_buffer_subbuf_order_set() and readers
Thu, 13 Aug 2026 16:30:10 +0000
[email protected] • #40389
Re: [PATCH RFC 7/7] tracing: Parse filter from event string
Fri, 14 Aug 2026 01:22:24 +0900
Masami Hiramatsu (Google) <[email protected]> • #40388
Re: [PATCH v5 01/10] ring-buffer: Free cpu_buffer::free_page with subbuf_order
Fri, 14 Aug 2026 01:18:45 +0900
Masami Hiramatsu (Google) <[email protected]> • #40387
[PATCH] ring-buffer: Fix race between ring_buffer_subbuf_order_set() and readers
Fri, 14 Aug 2026 01:16:13 +0900
"Masami Hiramatsu (Google)" <[email protected]> • #40386
[PATCH 0/1] ring-buffer: Fix sub-buffer order updates and free_page leaks
Fri, 14 Aug 2026 01:16:03 +0900
"Masami Hiramatsu (Google)" <[email protected]> • #40385
Re: [PATCH v5 01/10] ring-buffer: Free cpu_buffer::free_page with subbuf_order
Thu, 13 Aug 2026 17:03:55 +0100
Vincent Donnefort <[email protected]> • #40384
Re: [PATCH v5 01/10] ring-buffer: Free cpu_buffer::free_page with subbuf_order
Thu, 13 Aug 2026 17:02:54 +0100
Vincent Donnefort <[email protected]> • #40383
Re: [PATCH v10 12/41] KVM: guest_memfd: Call arch make_shared callback for to-shared conversion
Thu, 13 Aug 2026 08:55:14 -0700
Sean Christopherson <[email protected]> • #40382
Re: [PATCH v5 01/10] ring-buffer: Free cpu_buffer::free_page with subbuf_order
Fri, 14 Aug 2026 00:49:32 +0900
Masami Hiramatsu (Google) <[email protected]> • #40381
Re: [PATCH net-next 02/11] mptcp: remove unused data_ack from struct mptcp_ext
Thu, 13 Aug 2026 14:56:33 +0000
[email protected] • #40380
Re: [PATCH RFC 3/7] tracing: Stop modifying the input buffer in ftrace_set_clr_event()
Thu, 13 Aug 2026 10:45:17 -0400
Steven Rostedt <[email protected]> • #40379
Re: [PATCH RFC 3/7] tracing: Stop modifying the input buffer in ftrace_set_clr_event()
Thu, 13 Aug 2026 16:40:48 +0200
Thomas Weißschuh <[email protected]> • #40378
Re: [PATCH RFC 3/7] tracing: Stop modifying the input buffer in ftrace_set_clr_event()
Thu, 13 Aug 2026 10:38:21 -0400
Steven Rostedt <[email protected]> • #40377
Re: [PATCH RFC 7/7] tracing: Parse filter from event string
Thu, 13 Aug 2026 14:22:58 +0000
[email protected] • #40376
Re: [PATCH v5 16/18] tracing/remotes: Add trace_remote cmdline options
Thu, 13 Aug 2026 15:21:26 +0100
Vincent Donnefort <[email protected]> • #40375
Re: [PATCH v5 15/18] tracing/remotes: Add poll_ms tracefs file
Thu, 13 Aug 2026 15:20:33 +0100
Vincent Donnefort <[email protected]> • #40374
Re: [PATCH RFC 3/7] tracing: Stop modifying the input buffer in ftrace_set_clr_event()
Thu, 13 Aug 2026 14:15:00 +0000
[email protected] • #40373
Re: [PATCH RFC 5/7] tracing: Add a test for ftrace_parse_event_string()
Thu, 13 Aug 2026 14:14:49 +0000
[email protected] • #40372
[PATCH RFC 7/7] tracing: Parse filter from event string
Thu, 13 Aug 2026 16:07:20 +0200
Thomas Weißschuh <[email protected]> • #40371
[PATCH RFC 6/7] tracing: Add a filter argument to __ftrace_set_clr_event()
Thu, 13 Aug 2026 16:07:19 +0200
Thomas Weißschuh <[email protected]> • #40370
[PATCH RFC 5/7] tracing: Add a test for ftrace_parse_event_string()
Thu, 13 Aug 2026 16:07:18 +0200
Thomas Weißschuh <[email protected]> • #40369
[PATCH RFC 4/7] tracing: Split the event string parsing logic into a dedicated function
Thu, 13 Aug 2026 16:07:17 +0200
Thomas Weißschuh <[email protected]> • #40368
[PATCH RFC 3/7] tracing: Stop modifying the input buffer in ftrace_set_clr_event()
Thu, 13 Aug 2026 16:07:16 +0200
Thomas Weißschuh <[email protected]> • #40367
[PATCH RFC 2/7] tracing: Remove duplicate declaration of ftrace_set_clr_event()
Thu, 13 Aug 2026 16:07:15 +0200
Thomas Weißschuh <[email protected]> • #40366
[PATCH RFC 1/7] tracing: Restore :mod: trailer after parsing in ftrace_set_clr_event()
Thu, 13 Aug 2026 16:07:14 +0200
Thomas Weißschuh <[email protected]> • #40365
[PATCH RFC 0/7] tracing: Parse filter from event string
Thu, 13 Aug 2026 16:07:13 +0200
Thomas Weißschuh <[email protected]> • #40364
Re: [PATCH v5 07/18] tracing/remotes: selftests: Add a test for the dmesg tracefs file
Thu, 13 Aug 2026 15:06:15 +0100
Vincent Donnefort <[email protected]> • #40363
Re: [PATCH v5 06/18] tracing/remotes: Add dmesg tracefs file
Thu, 13 Aug 2026 15:02:20 +0100
Vincent Donnefort <[email protected]> • #40362
Re: [PATCH v5 02/10] ring-buffer: Hold cpu_buffer::lock when resizing a subbuf
Thu, 13 Aug 2026 14:01:01 +0000
[email protected] • #40361
Re: [PATCH v5 05/18] tracing/simple_ring_buffer: Add support for compressed length
Thu, 13 Aug 2026 15:00:41 +0100
Vincent Donnefort <[email protected]> • #40360
Re: [PATCH v5 03/10] ring-buffer: Make cpu_buffer::free_page a buffer_data_read_page
Thu, 13 Aug 2026 13:56:13 +0000
[email protected] • #40359
Re: [PATCH v5 10/10] ring-buffer: Make nr_pages unsigned int
Thu, 13 Aug 2026 13:55:26 +0000
[email protected] • #40358
Re: [PATCH v5 01/10] ring-buffer: Free cpu_buffer::free_page with subbuf_order
Thu, 13 Aug 2026 13:54:39 +0000
[email protected] • #40357
Re: [PATCH v5 06/10] tracing: Fix subbuf resize races with trace_pipe_raw readers
Thu, 13 Aug 2026 13:53:31 +0000
[email protected] • #40356
Re: [PATCH v5 04/10] ring-buffer: Fix subbuf resize race with ring buffer readers
Thu, 13 Aug 2026 13:51:42 +0000
[email protected] • #40355
Re: [PATCH v5 02/18] tracing/remotes: Release tracefs,eventfs on registration failure
Thu, 13 Aug 2026 14:25:42 +0100
Vincent Donnefort <[email protected]> • #40354
Re: [PATCH v5 01/18] tracing/remotes: Gate tracefs files opening on trace remote registration
Thu, 13 Aug 2026 14:16:18 +0100
Vincent Donnefort <[email protected]> • #40353
[PATCH v5 10/10] ring-buffer: Make nr_pages unsigned int
Thu, 13 Aug 2026 14:11:52 +0100
Vincent Donnefort <[email protected]> • #40352
[PATCH v5 09/10] ring-buffer: Remove ring_buffer_per_cpu::mapped
Thu, 13 Aug 2026 14:11:51 +0100
Vincent Donnefort <[email protected]> • #40351
[PATCH v5 05/10] ring-buffer: Fix subbuf resize race with ring_buffer_alloc_read_page()
Thu, 13 Aug 2026 14:11:47 +0100
Vincent Donnefort <[email protected]> • #40350
[PATCH v5 08/10] ring-buffer: Remove trace_buffer::cpus
Thu, 13 Aug 2026 14:11:50 +0100
Vincent Donnefort <[email protected]> • #40349
[PATCH v5 04/10] ring-buffer: Fix subbuf resize race with ring buffer readers
Thu, 13 Aug 2026 14:11:46 +0100
Vincent Donnefort <[email protected]> • #40348
[PATCH v5 07/10] ring-buffer: Dynamically calculate max_data_size
Thu, 13 Aug 2026 14:11:49 +0100
Vincent Donnefort <[email protected]> • #40347
[PATCH v5 06/10] tracing: Fix subbuf resize races with trace_pipe_raw readers
Thu, 13 Aug 2026 14:11:48 +0100
Vincent Donnefort <[email protected]> • #40346
[PATCH v5 03/10] ring-buffer: Make cpu_buffer::free_page a buffer_data_read_page
Thu, 13 Aug 2026 14:11:45 +0100
Vincent Donnefort <[email protected]> • #40345
[PATCH v5 02/10] ring-buffer: Hold cpu_buffer::lock when resizing a subbuf
Thu, 13 Aug 2026 14:11:44 +0100
Vincent Donnefort <[email protected]> • #40344
[PATCH v5 01/10] ring-buffer: Free cpu_buffer::free_page with subbuf_order
Thu, 13 Aug 2026 14:11:43 +0100
Vincent Donnefort <[email protected]> • #40343
[PATCH v5 00/10] ring-buffer: Fixes for subbuf resizing and persistent buffers
Thu, 13 Aug 2026 14:11:42 +0100
Vincent Donnefort <[email protected]> • #40342
Re: [PATCH v2] perf/bpf: Fix data races in BPF perf event handling
Thu, 13 Aug 2026 13:05:22 +0200
Peter Zijlstra <[email protected]> • #40341
Re: [PATCH 9/9] xen: use hw_pte_t for PTE range callbacks
Thu, 13 Aug 2026 12:39:50 +0200
Juergen Gross <[email protected]> • #40340
Re: [PATCH v4 17/20] mm/vma: only permit MAP_PRIVATE /dev/zero to be mapped anonymous
Thu, 13 Aug 2026 10:36:20 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #40339
Re: [PATCH v4 18/20] mm/vma: make MAP_PRIVATE-mapped /dev/zero mappings truly anonymous
Thu, 13 Aug 2026 10:34:00 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #40338
Re: [PATCH v4 18/20] mm/vma: make MAP_PRIVATE-mapped /dev/zero mappings truly anonymous
Thu, 13 Aug 2026 11:29:43 +0200
"David Hildenbrand (Arm)" <[email protected]> • #40337
Re: [PATCH v4 17/20] mm/vma: only permit MAP_PRIVATE /dev/zero to be mapped anonymous
Thu, 13 Aug 2026 11:18:13 +0200
"David Hildenbrand (Arm)" <[email protected]> • #40336
Re: [PATCH v2] perf/bpf: Fix data races in BPF perf event handling
Thu, 13 Aug 2026 07:11:01 +0000 (UTC)
[email protected] • #40335
Re: [RFC PATCH v2 3/4] arm64/kprobes: Make the entire Kprobe noinstr
Thu, 13 Aug 2026 07:00:06 +0000
[email protected] • #40334
Re: [PATCH v10 12/41] KVM: guest_memfd: Call arch make_shared callback for to-shared conversion
Thu, 13 Aug 2026 14:56:12 +0800
Binbin Wu <[email protected]> • #40333
Re: [PATCH bpf-next v5 0/2] bpf: Fix trampoline image UAF on multi detach failure
Thu, 13 Aug 2026 03:01:48 +0200
"Kumar Kartikeya Dwivedi" <[email protected]> • #40318
Re: [PATCH v4 3/9] ring-buffer: Fix subbuf resize race with ring buffer readers
Thu, 13 Aug 2026 08:41:48 +0900
Masami Hiramatsu (Google) <[email protected]> • #40317
Re: [PATCH v4 2/9] ring-buffer: Hold cpu_buffer::lock when resizing a subbuf
Thu, 13 Aug 2026 08:39:16 +0900
Masami Hiramatsu (Google) <[email protected]> • #40316
Re: [PATCH] percpu: Drop CONFIG_DEBUG_FORCE_WEAK_PER_CPU
Wed, 12 Aug 2026 16:33:55 -0700
Suren Baghdasaryan <[email protected]> • #40315
Re: [PATCH v4 03/10] dt-bindings: gpu: host1x: Document memory-regions for NVDEC
Wed, 12 Aug 2026 17:34:14 -0500
"Rob Herring (Arm)" <[email protected]> • #40314
Re: [PATCH v4 02/10] dt-bindings: display: tegra: Document memory regions
Wed, 12 Aug 2026 17:33:36 -0500
"Rob Herring (Arm)" <[email protected]> • #40313
Re: [PATCH v10 07/41] KVM: guest_memfd: Stub in ability to enable in-place shared<=>private conversion
Wed, 12 Aug 2026 14:34:53 -0700
Sean Christopherson <[email protected]> • #40312
Re: [PATCH 1/2] dmaengine: use dma_chan_name() helper to get per-channel device name
Wed, 12 Aug 2026 21:34:03 +0000
[email protected] • #40311
[PATCH 2/2] dmaengine: add union chan_dev for dma_chan::dev for clarity
Wed, 12 Aug 2026 17:24:09 -0400
[email protected] • #40310
[PATCH 1/2] dmaengine: use dma_chan_name() helper to get per-channel device name
Wed, 12 Aug 2026 17:24:08 -0400
[email protected] • #40309
[PATCH 0/2] dmaengine: rename dma_chan::dev to dma_chan::chan_dev for clarity
Wed, 12 Aug 2026 17:24:07 -0400
[email protected] • #40308
Re: [PATCH RFC 14/14] mm/page-flags: remove PG_private
Wed, 12 Aug 2026 16:10:07 -0400
"Zi Yan" <[email protected]> • #40307
Re: [PATCH RFC 10/14] mm/page-flags: introduce folio_test_fs_private()
Wed, 12 Aug 2026 15:56:16 -0400
"Zi Yan" <[email protected]> • #40306
[PATCH] percpu: Drop CONFIG_DEBUG_FORCE_WEAK_PER_CPU
Wed, 12 Aug 2026 09:47:43 -1000
Tejun Heo <[email protected]> • #40305
Re: [PATCH RFC 09/14] mm/page-flags: check page/folio->private instead of PG_private
Wed, 12 Aug 2026 15:54:52 -0400
"Zi Yan" <[email protected]> • #40304
Re: [PATCH v4 19/20] tools/testing/vma: add test to assert MAP_PRIVATE-/dev/zero is anon
Wed, 12 Aug 2026 19:08:29 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #40303
Re: [PATCH v4 17/20] mm/vma: only permit MAP_PRIVATE /dev/zero to be mapped anonymous
Wed, 12 Aug 2026 19:05:21 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #40302
Re: [PATCH] eventfs: Add warning for out of bounds pos in __eventfs_iterate()
Wed, 12 Aug 2026 13:38:35 -0400
Steven Rostedt <[email protected]> • #40301
Re: [PATCH v4 16/20] tools/testing/selftests/mm: test anonymous page offset merge behaviour
Wed, 12 Aug 2026 18:24:27 +0100
"Lorenzo Stoakes (ARM)" <[email protected]> • #40300
Re: [PATCH v4 3/9] ring-buffer: Fix subbuf resize race with ring buffer readers
Wed, 12 Aug 2026 13:24:57 -0400
Steven Rostedt <[email protected]> • #40299
Re: [PATCH v4 19/20] tools/testing/vma: add test to assert MAP_PRIVATE-/dev/zero is anon
Wed, 12 Aug 2026 19:18:56 +0200
"David Hildenbrand (Arm)" <[email protected]> • #40298
Re: [PATCH v4 19/20] tools/testing/vma: add test to assert MAP_PRIVATE-/dev/zero is anon
Wed, 12 Aug 2026 19:17:39 +0200
"David Hildenbrand (Arm)" <[email protected]> • #40297
Re: [PATCH v4 17/20] mm/vma: only permit MAP_PRIVATE /dev/zero to be mapped anonymous
Wed, 12 Aug 2026 19:15:05 +0200
"David Hildenbrand (Arm)" <[email protected]> • #40296
Re: [PATCH v4 9/9] ring-buffer: Make nr_pages unsigned int
Wed, 12 Aug 2026 18:15:11 +0100
Vincent Donnefort <[email protected]> • #40295
Re: [PATCH v5 15/18] tracing/remotes: Add poll_ms tracefs file
Wed, 12 Aug 2026 17:13:04 +0000
[email protected] • #40294
Re: [PATCH v4 6/9] ring-buffer: Dynamically calculate max_data_size
Wed, 12 Aug 2026 18:12:02 +0100
Vincent Donnefort <[email protected]> • #40293
Re: [PATCH v5 16/18] tracing/remotes: Add trace_remote cmdline options
Wed, 12 Aug 2026 17:11:48 +0000
[email protected] • #40292
Re: [PATCH v5 13/18] tracing/remotes: Add dump_on_panic tracefs file
Wed, 12 Aug 2026 17:08:26 +0000
[email protected] • #40291
Re: [PATCH v5 14/18] tracing/remotes: selftests: Add a test for the dump_on_panic tracefs file
Wed, 12 Aug 2026 17:02:22 +0000
[email protected] • #40290
Re: [PATCH v4 5/9] tracing: Fix subbuf resize races in trace_pipe_raw readers
Wed, 12 Aug 2026 17:57:49 +0100
Vincent Donnefort <[email protected]> • #40289
Re: [PATCH v5 10/18] ring-buffer: Use panic-friendly locking in ring_buffer_iter interface
Wed, 12 Aug 2026 16:54:11 +0000
[email protected] • #40288
Re: [PATCH v5 08/18] tracing/remotes: selftests: Prefix hypervisor folder
Wed, 12 Aug 2026 16:52:34 +0000
[email protected] • #40287
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.