org.kernel.vger.rust-for-linux archive

1331 archived articles, newest first (page 6 of 14). Latest articles →

[PATCH 0/3] rust: macros: vtable: add `#[optional]` attribute
Tue, 11 Aug 2026 14:55:54 +0100
Gary Guo <[email protected]> • #50755
[PATCH 3/3] rust: misc: use `#[optional]` attribute of `#[vtable]` macro
Tue, 11 Aug 2026 14:55:57 +0100
Gary Guo <[email protected]> • #50754
Re: [PATCH] rust: block: gen_disk: set fops.owner from driver module pointer
Tue, 11 Aug 2026 21:53:54 +0800
Alvin Sun <[email protected]> • #50753
Re: [PATCH v4 0/5] Rate limited printing for Rust
Tue, 11 Aug 2026 14:36:29 +0200
Miguel Ojeda <[email protected]> • #50752
Re: [PATCH v2 00/12] gpu: nova-core: add PRAMIN window support
Tue, 11 Aug 2026 14:31:48 +0200
Miguel Ojeda <[email protected]> • #50751
Re: [PATCH v2 00/12] gpu: nova-core: add PRAMIN window support
Tue, 11 Aug 2026 14:31:21 +0200
Miguel Ojeda <[email protected]> • #50750
[PATCH 2/4] rust: build_assert: remove macro from crate root
Tue, 11 Aug 2026 13:25:54 +0100
Gary Guo <[email protected]> • #50749
[PATCH 4/4] rust: io: convert to use `#[macro_export_scoped]`
Tue, 11 Aug 2026 13:25:56 +0100
Gary Guo <[email protected]> • #50748
[PATCH 3/4] rust: list: convert to use `#[macro_export_scoped]`
Tue, 11 Aug 2026 13:25:55 +0100
Gary Guo <[email protected]> • #50747
[PATCH 1/4] rust: macros: add `#[macro_export_scoped]`
Tue, 11 Aug 2026 13:25:53 +0100
Gary Guo <[email protected]> • #50746
[PATCH 0/4] rust: add `#[macro_export_scoped]` for scoped declarative macro
Tue, 11 Aug 2026 13:25:52 +0100
Gary Guo <[email protected]> • #50745
Re: [PATCH] rust: block: gen_disk: set fops.owner from driver module pointer
Tue, 11 Aug 2026 14:20:50 +0200
Miguel Ojeda <[email protected]> • #50744
Re: [PATCH V2] rust: uapi: replace direct asm-generic/ioctl.h include with linux/ioctl.h
Tue, 11 Aug 2026 14:18:34 +0200
Miguel Ojeda <[email protected]> • #50743
Re: [PATCH 1/2] rust: mm: add VmaRef range query helpers
Tue, 11 Aug 2026 21:12:35 +0900
"Alexandre Courbot" <[email protected]> • #50742
Re: [PATCH v6 0/7] rust: use Delta instead of raw jiffies for timeouts and delays
Tue, 11 Aug 2026 14:12:07 +0200
Miguel Ojeda <[email protected]> • #50741
Re: [PATCH v2] rust: time: fix as_micros_ceil() rounding near i64::MAX
Tue, 11 Aug 2026 14:07:35 +0200
Miguel Ojeda <[email protected]> • #50740
Re: [PATCH v3 0/7] rust: use vertical import style and remove redundant imports
Tue, 11 Aug 2026 14:04:03 +0200
Miguel Ojeda <[email protected]> • #50739
Re: [PATCH v6 4/7] rust: time: add Delta::to_jiffies_timeout() for timeout conversion
Tue, 11 Aug 2026 13:51:09 +0200
Miguel Ojeda <[email protected]> • #50738
Re: [PATCH v6 1/1] rust: pci: add extended capability and SR-IOV support
Sun, 09 Aug 2026 11:28:08 +0900
"Alexandre Courbot" <[email protected]> • #50565
Re: [PATCH] rust: bitfield: always inline test conversions
Sun, 09 Aug 2026 11:11:55 +0900
"Alexandre Courbot" <[email protected]> • #50562
Re: [PATCH] rust: bug: fix `dead_code` warning in `warn_on!`
Sun, 09 Aug 2026 09:50:41 +0900 (JST)
FUJITA Tomonori <[email protected]> • #50561
Re: [PATCH v1] rust: bug: prevent dead_code warning from warn_on!'s flags constant
Sun, 09 Aug 2026 09:34:15 +0900 (JST)
FUJITA Tomonori <[email protected]> • #50560
Re: [PATCH] rust: bug: fix `dead_code` warning in `warn_on!`
Sat, 8 Aug 2026 21:40:49 +0200
Miguel Ojeda <[email protected]> • #50559
Re: [PATCH v1] rust: bug: prevent dead_code warning from warn_on!'s flags constant
Sat, 8 Aug 2026 20:19:25 +0200
Miguel Ojeda <[email protected]> • #50558
[GIT PULL] DRM Rust changes for v7.3-rc1
Sat, 08 Aug 2026 19:33:31 +0200
"Danilo Krummrich" <[email protected]> • #50557
Re: [GIT PULL] Driver core fixes for 7.2-rc7
Sat, 08 Aug 2026 14:51:26 +0000
[email protected] • #50556
Re: [PATCH] rust: miscdevice: add registration data to MiscDevice
Sat, 8 Aug 2026 13:53:16 +0000
Alice Ryhl <[email protected]> • #50555
[GIT PULL] Driver core fixes for 7.2-rc7
Sat, 08 Aug 2026 14:51:24 +0200
"Danilo Krummrich" <[email protected]> • #50554
[PATCH v6 7/7] rust: time: remove unused Jiffies/Msecs helpers
Sat, 8 Aug 2026 15:28:39 +0900
FUJITA Tomonori <[email protected]> • #50553
[PATCH v6 6/7] rust: sync: condvar: use Delta<Jiffy> for timeout and result
Sat, 8 Aug 2026 15:28:38 +0900
FUJITA Tomonori <[email protected]> • #50552
[PATCH v6 5/7] rust: workqueue: take a Delta<Jiffy> for the enqueue delay
Sat, 8 Aug 2026 15:28:37 +0900
FUJITA Tomonori <[email protected]> • #50551
[PATCH v6 4/7] rust: time: add Delta::to_jiffies_timeout() for timeout conversion
Sat, 8 Aug 2026 15:28:36 +0900
FUJITA Tomonori <[email protected]> • #50550
[PATCH v6 3/7] rust: time: add Delta::as_millis_ceil()
Sat, 8 Aug 2026 15:28:35 +0900
FUJITA Tomonori <[email protected]> • #50549
[PATCH v6 2/7] rust: time: add jiffies time unit for Delta
Sat, 8 Aug 2026 15:28:34 +0900
FUJITA Tomonori <[email protected]> • #50548
[PATCH v6 1/7] rust: time: make Delta generic over its time unit
Sat, 8 Aug 2026 15:28:33 +0900
FUJITA Tomonori <[email protected]> • #50547
[PATCH v6 0/7] rust: use Delta instead of raw jiffies for timeouts and delays
Sat, 8 Aug 2026 15:28:32 +0900
FUJITA Tomonori <[email protected]> • #50546
Re: [PATCH] rust: bug: fix `dead_code` warning in `warn_on!`
Sat, 08 Aug 2026 14:30:13 +0900 (JST)
FUJITA Tomonori <[email protected]> • #50545
[PATCH] rust: uapi: replace direct asm-generic/ioctl.h include with linux/ioctl.h
Sat, 8 Aug 2026 08:51:43 +0530
"Mukesh Kumar Chaurasiya (IBM)" <[email protected]> • #50544
Re: [PATCH v2] x86/build/64: Prevent native builds from generating APX instructions
Fri, 7 Aug 2026 20:21:18 -0700
"Chang S. Bae" <[email protected]> • #50543
[PATCH v1] rust: bug: skip arch-specific asm in `testlib` builds
Sat, 8 Aug 2026 11:26:08 +0900
FUJITA Tomonori <[email protected]> • #50542
[PATCH v4 2/2] rust: hrtimer: Make HrTimer repr(transparent)
Sat, 8 Aug 2026 08:30:39 +0900
FUJITA Tomonori <[email protected]> • #50541
[PATCH v4 1/2] rust: hrtimer: Restrict expires() to safe contexts
Sat, 8 Aug 2026 08:30:38 +0900
FUJITA Tomonori <[email protected]> • #50540
Re: [PATCH] rust: bug: fix `dead_code` warning in `warn_on!`
Sat, 8 Aug 2026 01:21:23 +0200
Miguel Ojeda <[email protected]> • #50539
Re: [PATCH] rust: bug: fix `dead_code` warning in `warn_on!`
Sat, 08 Aug 2026 07:43:41 +0900 (JST)
FUJITA Tomonori <[email protected]> • #50538
Re: [PATCH v2 4/6] rust: workqueue: add creation of workqueues
Sat, 08 Aug 2026 00:39:59 +0200
"Danilo Krummrich" <[email protected]> • #50537
Re: [PATCH] rust: bug: fix `dead_code` warning in `warn_on!`
Sat, 8 Aug 2026 00:19:13 +0200
Miguel Ojeda <[email protected]> • #50536
[PATCH] rust: bug: fix `dead_code` warning in `warn_on!`
Sat, 8 Aug 2026 00:14:29 +0200
Miguel Ojeda <[email protected]> • #50535
Re: [PATCHES 00/12] pahole: Support more rust tags and references to dwz alternate debug files
Fri, 7 Aug 2026 17:30:53 -0300
Arnaldo Carvalho de Melo <[email protected]> • #50534
Re: [PATCH 6/7] rust: workqueue: add Work::cancel_work_sync()
Fri, 7 Aug 2026 12:31:26 -0700
John Hubbard <[email protected]> • #50533
Re: [PATCHES 00/12] pahole: Support more rust tags and references to dwz alternate debug files
Fri, 07 Aug 2026 20:26:32 +0100
"Gary Guo" <[email protected]> • #50532
Re: [PATCH 02/12] rust: num: reject Bounded::shr overshifts at build time
Fri, 07 Aug 2026 20:14:55 +0100
"Gary Guo" <[email protected]> • #50531
Re: [PATCH] rust: bitfield: always inline test conversions
Fri, 07 Aug 2026 20:14:27 +0100
"Gary Guo" <[email protected]> • #50530
Re: [PATCHES 00/12] pahole: Support more rust tags and references to dwz alternate debug files
Fri, 7 Aug 2026 15:53:53 -0300
Arnaldo Carvalho de Melo <[email protected]> • #50529
Re: [PATCH v2 6/6] rust: workqueue: add ScopedWork for non-'static work items
Fri, 07 Aug 2026 20:35:15 +0200
"Danilo Krummrich" <[email protected]> • #50528
Re: [PATCH] rust: bitfield: always inline test conversions
Fri, 07 Aug 2026 20:11:43 +0200
"Danilo Krummrich" <[email protected]> • #50527
[PATCH] rust: bitfield: always inline test conversions
Fri, 7 Aug 2026 19:50:12 +0200
Miguel Ojeda <[email protected]> • #50526
Re: [PATCHES 00/12] pahole: Support more rust tags and references to dwz alternate debug files
Fri, 7 Aug 2026 19:34:10 +0200
Miguel Ojeda <[email protected]> • #50525
Re: [PATCH 02/12] rust: num: reject Bounded::shr overshifts at build time
Fri, 7 Aug 2026 19:12:25 +0200
Miguel Ojeda <[email protected]> • #50524
Re: [PATCH v2] x86/build/64: Prevent native builds from generating APX instructions
Fri, 7 Aug 2026 18:58:25 +0200
Miguel Ojeda <[email protected]> • #50523
[PATCH v2 6/6] rust: workqueue: add ScopedWork for non-'static work items
Fri, 7 Aug 2026 18:52:49 +0200
Danilo Krummrich <[email protected]> • #50522
[PATCH v2 5/6] rust: workqueue: add ScopedQueue for lifetime bound items
Fri, 7 Aug 2026 18:52:48 +0200
Danilo Krummrich <[email protected]> • #50521
[PATCH v2 4/6] rust: workqueue: add creation of workqueues
Fri, 7 Aug 2026 18:52:47 +0200
Danilo Krummrich <[email protected]> • #50520
[PATCH v2 3/6] rust: workqueue: create workqueue subdirectory
Fri, 7 Aug 2026 18:52:46 +0200
Danilo Krummrich <[email protected]> • #50519
[PATCH v2 2/6] rust: workqueue: restrict delayed work to global wqs
Fri, 7 Aug 2026 18:52:45 +0200
Danilo Krummrich <[email protected]> • #50518
[PATCH v2 1/6] rust: workqueue: replace deprecated system_wq with system_{percpu,dfl}_wq
Fri, 7 Aug 2026 18:52:44 +0200
Danilo Krummrich <[email protected]> • #50517
Re: [PATCH] rust: miscdevice: add registration data to MiscDevice
Fri, 7 Aug 2026 17:44:31 +0200
Alice Ryhl <[email protected]> • #50514
Re: [PATCH] rust: miscdevice: add registration data to MiscDevice
Fri, 07 Aug 2026 15:43:08 +0100
"Gary Guo" <[email protected]> • #50512
Re: [PATCH RFC v3 0/6] Add Rust virtio bindings and sample device
Fri, 7 Aug 2026 16:30:31 +0200
Stefano Garzarella <[email protected]> • #50511
Re: [PATCH RFC v3 6/6] samples/rust: Add sample virtio-rtc driver [WIP]
Fri, 7 Aug 2026 16:09:28 +0200
Stefano Garzarella <[email protected]> • #50508
Re: [PATCH RFC v3 4/6] rust: add virtio module
Fri, 7 Aug 2026 16:09:03 +0200
Stefano Garzarella <[email protected]> • #50507
Re: [PATCH 03/12] rust: num: add Bounded::shr_exact
Fri, 07 Aug 2026 23:04:08 +0900
"Alexandre Courbot" <[email protected]> • #50506
Re: [PATCH 02/12] rust: num: reject Bounded::shr overshifts at build time
Fri, 07 Aug 2026 23:03:28 +0900
"Alexandre Courbot" <[email protected]> • #50505
Re: [PATCH 01/12] rust: io: add Region::try_subregion
Fri, 07 Aug 2026 23:03:10 +0900
"Alexandre Courbot" <[email protected]> • #50504
Re: [PATCH v5 3/7] rust: time: add Delta::as_millis_ceil()
Fri, 07 Aug 2026 22:26:12 +0900 (JST)
FUJITA Tomonori <[email protected]> • #50503
Re: [PATCH v5 4/7] rust: time: add Delta::to_jiffies() for timeout conversion
Fri, 07 Aug 2026 22:13:30 +0900 (JST)
FUJITA Tomonori <[email protected]> • #50502
[PATCH v2] rust: time: fix as_micros_ceil() rounding near i64::MAX
Fri, 7 Aug 2026 22:05:31 +0900
FUJITA Tomonori <[email protected]> • #50501
Re: [PATCH v2 2/3] rust: dma: rename dma_handle to dma_address
Fri, 07 Aug 2026 14:04:47 +0100
"Gary Guo" <[email protected]> • #50500
Re: [PATCH v5 4/7] rust: time: add Delta::to_jiffies() for timeout conversion
Fri, 07 Aug 2026 13:59:20 +0100
"Gary Guo" <[email protected]> • #50499
Re: [PATCH v5 4/7] rust: time: add Delta::to_jiffies() for timeout conversion
Fri, 07 Aug 2026 21:38:37 +0900 (JST)
FUJITA Tomonori <[email protected]> • #50498
Re: [PATCH v5 4/7] rust: time: add Delta::to_jiffies() for timeout conversion
Fri, 07 Aug 2026 21:15:01 +0900 (JST)
FUJITA Tomonori <[email protected]> • #50497
Re: [PATCH v5 1/7] rust: time: make Delta generic over its time unit
Fri, 07 Aug 2026 21:10:08 +0900 (JST)
FUJITA Tomonori <[email protected]> • #50496
Re: [PATCH 6/7] rust: workqueue: add Work::cancel_work_sync()
Fri, 07 Aug 2026 13:51:33 +0200
"Danilo Krummrich" <[email protected]> • #50495
Re: [PATCH 6/7] rust: workqueue: add Work::cancel_work_sync()
Fri, 07 Aug 2026 13:49:14 +0200
"Danilo Krummrich" <[email protected]> • #50494
[PATCH v2] rust: bug: fix warn_on macro build error on UML
Fri, 7 Aug 2026 20:24:27 +0900
FUJITA Tomonori <[email protected]> • #50493
Re: [PATCH v1] rust: bug: fix warn_on macro build error on UML
Fri, 07 Aug 2026 20:19:19 +0900 (JST)
FUJITA Tomonori <[email protected]> • #50492
Re: [PATCH v14 0/2] rust: Add safe pointer formatting support
Fri, 7 Aug 2026 12:13:28 +0200
Link Mauve <[email protected]> • #50491
[PATCH v14 2/2] rust: fmt: route {:p} through HashedPtr to prevent address leaks
Fri, 07 Aug 2026 16:14:54 +0800
Ke Sun <[email protected]> • #50490
[PATCH v14 1/2] rust: fmt: fix {:p} printing stack addresses
Fri, 07 Aug 2026 16:14:53 +0800
Ke Sun <[email protected]> • #50489
[PATCH v14 0/2] rust: Add safe pointer formatting support
Fri, 07 Aug 2026 16:14:52 +0800
Ke Sun <[email protected]> • #50488
Re: [PATCH RESEND v13 2/2] rust: fmt: route {:p} through HashedPtr to prevent address leaks
Fri, 7 Aug 2026 16:01:16 +0800
Ke Sun <[email protected]> • #50487
Re: [PATCH 6/7] rust: workqueue: add Work::cancel_work_sync()
Fri, 7 Aug 2026 10:51:37 +0300
Onur Özkan <[email protected]> • #50486
Re: [GIT PULL] pin-init changes for v7.3-rc1
Fri, 7 Aug 2026 09:51:23 +0200
Miguel Ojeda <[email protected]> • #50485
[PATCH] rust: serdev: replace `__pinned_init` with `raw_try_init`
Fri, 7 Aug 2026 09:47:29 +0200
Miguel Ojeda <[email protected]> • #50484
Re: [PATCH RESEND v13 2/2] rust: fmt: route {:p} through HashedPtr to prevent address leaks
Fri, 7 Aug 2026 15:45:23 +0800
Alvin Sun <[email protected]> • #50483
Re: [PATCH RESEND v13 2/2] rust: fmt: route {:p} through HashedPtr to prevent address leaks
Fri, 7 Aug 2026 15:32:13 +0800
Ke Sun <[email protected]> • #50482
[PATCH v5 18/18] rust: sync: Introduce SpinLockIrq::lock_with() and friends
Fri, 7 Aug 2026 00:02:15 -0700
Boqun Feng <[email protected]> • #50481
[PATCH v5 17/18] rust: sync: Add SpinLockIrq
Fri, 7 Aug 2026 00:02:14 -0700
Boqun Feng <[email protected]> • #50480
[PATCH v5 16/18] rust: sync: Use super::* in spinlock.rs
Fri, 7 Aug 2026 00:02:13 -0700
Boqun Feng <[email protected]> • #50479
[PATCH v5 15/18] rust: helper: Add spin_{un,}lock_irq_{enable,disable}() helpers
Fri, 7 Aug 2026 00:02:12 -0700
Boqun Feng <[email protected]> • #50478
[PATCH v5 14/18] rust: Introduce interrupt module
Fri, 7 Aug 2026 00:02:11 -0700
Boqun Feng <[email protected]> • #50477
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.