org.kernel.vger.rust-for-linux archive

1339 archived articles, newest first (page 7 of 14). Latest articles →

[PATCH] rust: serdev: replace `__pinned_init` with `raw_try_init`
Fri, 7 Aug 2026 09:47:29 +0200
Miguel Ojeda <[email protected]> • #50484
Re: [PATCH RESEND v13 2/2] rust: fmt: route {:p} through HashedPtr to prevent address leaks
Fri, 7 Aug 2026 15:45:23 +0800
Alvin Sun <[email protected]> • #50483
Re: [PATCH RESEND v13 2/2] rust: fmt: route {:p} through HashedPtr to prevent address leaks
Fri, 7 Aug 2026 15:32:13 +0800
Ke Sun <[email protected]> • #50482
[PATCH v5 18/18] rust: sync: Introduce SpinLockIrq::lock_with() and friends
Fri, 7 Aug 2026 00:02:15 -0700
Boqun Feng <[email protected]> • #50481
[PATCH v5 17/18] rust: sync: Add SpinLockIrq
Fri, 7 Aug 2026 00:02:14 -0700
Boqun Feng <[email protected]> • #50480
[PATCH v5 16/18] rust: sync: Use super::* in spinlock.rs
Fri, 7 Aug 2026 00:02:13 -0700
Boqun Feng <[email protected]> • #50479
[PATCH v5 15/18] rust: helper: Add spin_{un,}lock_irq_{enable,disable}() helpers
Fri, 7 Aug 2026 00:02:12 -0700
Boqun Feng <[email protected]> • #50478
[PATCH v5 14/18] rust: Introduce interrupt module
Fri, 7 Aug 2026 00:02:11 -0700
Boqun Feng <[email protected]> • #50477
[PATCH v5 13/18] s390/preempt: Enable HAS_SEPARATE_PREEMPT_RESCHED_BITS
Fri, 7 Aug 2026 00:02:10 -0700
Boqun Feng <[email protected]> • #50476
[PATCH v5 12/18] arm64: sched/preempt: Enable HAS_SEPARATE_PREEMPT_RESCHED_BITS
Fri, 7 Aug 2026 00:02:09 -0700
Boqun Feng <[email protected]> • #50475
[PATCH v5 11/18] preempt: Introduce HAS_SEPARATE_PREEMPT_RESCHED_BITS
Fri, 7 Aug 2026 00:02:08 -0700
Boqun Feng <[email protected]> • #50474
[PATCH v5 10/18] sched: Avoid signed comparison of preempt_count() in __cant_migrate()
Fri, 7 Aug 2026 00:02:07 -0700
Boqun Feng <[email protected]> • #50473
[PATCH v5 09/18] sched: Remove the unused preempt_offset parameter of __cant_sleep()
Fri, 7 Aug 2026 00:02:06 -0700
Boqun Feng <[email protected]> • #50472
[PATCH v5 08/18] locking: Switch to _irq_{disable,enable}() variants in cleanup guards
Fri, 7 Aug 2026 00:02:05 -0700
Boqun Feng <[email protected]> • #50471
[PATCH v5 07/18] irq: Add max local_interrupt_disable() nesting level kunit test case
Fri, 7 Aug 2026 00:02:04 -0700
Boqun Feng <[email protected]> • #50470
[PATCH v5 06/18] irq: Add KUnit test for refcounted interrupt enable/disable
Fri, 7 Aug 2026 00:02:03 -0700
Boqun Feng <[email protected]> • #50469
[PATCH v5 05/18] irq & spin_lock: Add counted interrupt disabling/enabling
Fri, 7 Aug 2026 00:02:02 -0700
Boqun Feng <[email protected]> • #50468
[PATCH v5 04/18] openrisc: Include <linux/cpumask.h> in smp.h
Fri, 7 Aug 2026 00:02:01 -0700
Boqun Feng <[email protected]> • #50467
[PATCH v5 03/18] preempt: Introduce __preempt_count_{sub,add}_return()
Fri, 7 Aug 2026 00:02:00 -0700
Boqun Feng <[email protected]> • #50466
[PATCH v5 02/18] preempt: Introduce HARDIRQ_DISABLE_BITS
Fri, 7 Aug 2026 00:01:59 -0700
Boqun Feng <[email protected]> • #50465
[PATCH v5 01/18] preempt: Track NMI nesting to separate per-CPU counter
Fri, 7 Aug 2026 00:01:58 -0700
Boqun Feng <[email protected]> • #50464
[PATCH v5 00/18] Refcounted interrupt disable and SpinLockIrq for Rust
Fri, 7 Aug 2026 00:01:57 -0700
Boqun Feng <[email protected]> • #50463
Re: [PATCH v1] rust: bug: fix warn_on macro build error on UML
Fri, 7 Aug 2026 08:54:43 +0200
Miguel Ojeda <[email protected]> • #50462
Re: [PATCH v1] rust: bug: fix warn_on macro build error on UML
Fri, 7 Aug 2026 08:52:38 +0200
Miguel Ojeda <[email protected]> • #50461
Re: [PATCH 01/12] rust: io: add Region::try_subregion
Fri, 07 Aug 2026 14:39:17 +0900
"Eliot Courtney" <[email protected]> • #50460
Re: [PATCH 6/7] rust: workqueue: add Work::cancel_work_sync()
Thu, 6 Aug 2026 18:37:56 -0700
John Hubbard <[email protected]> • #50459
[PATCH v9 2/2] module: Rename module_blacklist to module_denylist
Thu, 6 Aug 2026 21:26:01 -0400
Aaron Tomlin <[email protected]> • #50458
[PATCH v9 1/2] module: Extend module_blacklist parameter to built-in modules
Thu, 6 Aug 2026 21:26:00 -0400
Aaron Tomlin <[email protected]> • #50457
[PATCH v9 0/2] module: Extend module_blacklist parameter to built-in modules
Thu, 6 Aug 2026 21:25:59 -0400
Aaron Tomlin <[email protected]> • #50456
Re: [PATCH] rust: pci: Mark Device refcount methods inline
Thu, 6 Aug 2026 23:31:39 +0200
Danilo Krummrich <[email protected]> • #50455
Re: [PATCH v2 0/3] gpu: nova-core: falcon: use I/O projections for DMA transfers
Thu, 6 Aug 2026 23:25:03 +0200
Danilo Krummrich <[email protected]> • #50454
Re: [PATCH v2 2/3] rust: dma: rename dma_handle to dma_address
Thu, 06 Aug 2026 23:16:31 +0200
"Danilo Krummrich" <[email protected]> • #50453
Re: [PATCH v2 0/2] rust: add functions and traits for lossless integer conversions
Thu, 06 Aug 2026 23:10:27 +0200
"Danilo Krummrich" <[email protected]> • #50452
Re: [GIT PULL] pin-init changes for v7.3-rc1
Thu, 6 Aug 2026 19:21:15 +0100
Mark Brown <[email protected]> • #50451
Re: [GIT PULL] pin-init changes for v7.3-rc1
Thu, 06 Aug 2026 19:19:05 +0100
"Gary Guo" <[email protected]> • #50450
Re: [GIT PULL] pin-init changes for v7.3-rc1
Thu, 6 Aug 2026 19:53:41 +0200
Miguel Ojeda <[email protected]> • #50449
Re: [GIT PULL] pin-init changes for v7.3-rc1
Thu, 6 Aug 2026 18:22:47 +0100
Mark Brown <[email protected]> • #50448
Re: [GIT PULL] pin-init changes for v7.3-rc1
Thu, 6 Aug 2026 19:09:58 +0200
Miguel Ojeda <[email protected]> • #50447
[PATCH v3 4/8] drm: move debugfs_init after dev->registered is set
Fri, 07 Aug 2026 01:07:26 +0800
Alvin Sun <[email protected]> • #50446
[PATCH v3 8/8] drm/tyr: add gpuvas debugfs file
Fri, 07 Aug 2026 01:07:30 +0800
Alvin Sun <[email protected]> • #50445
[PATCH v3 6/8] rust: drm: gpuvm: add dump_gpuva_info to UniqueRefGpuVm
Fri, 07 Aug 2026 01:07:28 +0800
Alvin Sun <[email protected]> • #50444
[PATCH v3 7/8] drm/tyr: track VMs in a registry
Fri, 07 Aug 2026 01:07:29 +0800
Alvin Sun <[email protected]> • #50443
[PATCH v3 2/8] rust: debugfs: add seq_file support
Fri, 07 Aug 2026 01:07:24 +0800
Alvin Sun <[email protected]> • #50442
[PATCH v3 1/8] rust: seq_file: add as_raw() method
Fri, 07 Aug 2026 01:07:23 +0800
Alvin Sun <[email protected]> • #50441
[PATCH v3 5/8] rust: drm: add debugfs_init callback to Driver trait
Fri, 07 Aug 2026 01:07:27 +0800
Alvin Sun <[email protected]> • #50440
[PATCH v3 3/8] rust: debugfs: add ScopeRef for existing dentries
Fri, 07 Aug 2026 01:07:25 +0800
Alvin Sun <[email protected]> • #50439
[PATCH v3 0/8] drm/tyr: add debugfs support
Fri, 07 Aug 2026 01:07:22 +0800
Alvin Sun <[email protected]> • #50438
Re: [GIT PULL] pin-init changes for v7.3-rc1
Thu, 6 Aug 2026 18:05:38 +0100
Mark Brown <[email protected]> • #50437
Re: [GIT PULL] pin-init changes for v7.3-rc1
Thu, 6 Aug 2026 19:01:01 +0200
Miguel Ojeda <[email protected]> • #50436
Re: [PATCH v2 9/9] drm/debugfs: hold device reference for the lifetime of open files
Fri, 7 Aug 2026 00:59:23 +0800
Alvin Sun <[email protected]> • #50435
Re: [PATCH v5 1/4] rust: clk: use the type-state pattern
Thu, 06 Aug 2026 22:54:23 +0900
"Alexandre Courbot" <[email protected]> • #50425
Re: `io{re,un}map()` build error in s390 under `!CONFIG_HAS_IOMEM`
Thu, 06 Aug 2026 15:44:13 +0200
"Arnd Bergmann" <[email protected]> • #50424
Re: [PATCH] rust: dma: add `Range` type
Thu, 6 Aug 2026 15:40:38 +0200
Vasileios Almpanis <[email protected]> • #50423
Re: Invitation: Rust for Linux Training Day at LPC 2026
Thu, 6 Aug 2026 09:39:17 -0400
Steven Rostedt <[email protected]> • #50422
Re: `io{re,un}map()` build error in s390 under `!CONFIG_HAS_IOMEM`
Thu, 06 Aug 2026 15:25:50 +0200
Niklas Schnelle <[email protected]> • #50421
Re: [PATCH 2/3] rust: dma: add abstraction for the single-buffer streaming DMA API
Thu, 6 Aug 2026 14:06:17 +0100
Robin Murphy <[email protected]> • #50420
Re: [PATCH v2] rust: io: Add a BigEndianMmio wrapper
Thu, 6 Aug 2026 14:13:33 +0200
Link Mauve <[email protected]> • #50419
Re: [PATCH v3] drm/tyr: add Job IRQ handling
Thu, 06 Aug 2026 13:09:29 +0100
"Gary Guo" <[email protected]> • #50418
Re: [PATCH] rust: macros: Allow omitting trailing commas in module!
Thu, 6 Aug 2026 14:08:07 +0200
Miguel Ojeda <[email protected]> • #50417
Re: [PATCH] rust: macros: Allow omitting trailing commas in module!
Thu, 06 Aug 2026 12:54:15 +0100
"Gary Guo" <[email protected]> • #50416
Re: [PATCH v5 4/7] rust: time: add Delta::to_jiffies() for timeout conversion
Thu, 06 Aug 2026 12:50:55 +0100
"Gary Guo" <[email protected]> • #50415
Re: [PATCH v2] rust: io: Add a BigEndianMmio wrapper
Thu, 06 Aug 2026 12:44:31 +0100
"Gary Guo" <[email protected]> • #50414
Re: [PATCH] rust: dma: add `Range` type
Thu, 6 Aug 2026 12:23:32 +0100
Robin Murphy <[email protected]> • #50413
[PATCH v3] rust: block: set GenDisk block_device_operations.owner to THIS_MODULE
Thu, 6 Aug 2026 16:10:27 +0530
Adarsh Das <[email protected]> • #50412
[PATCH] rust: macros: Allow omitting trailing commas in module!
Thu, 06 Aug 2026 03:14:32 -0700
Ethan Plant <[email protected]> • #50411
Re: [PATCH v5 4/7] rust: time: add Delta::to_jiffies() for timeout conversion
Thu, 06 Aug 2026 11:50:35 +0200
Andreas Hindborg <[email protected]> • #50410
Re: [PATCH v5 3/7] rust: time: add Delta::as_millis_ceil()
Thu, 06 Aug 2026 11:47:41 +0200
Andreas Hindborg <[email protected]> • #50409
Re: [PATCH v5 1/7] rust: time: make Delta generic over its time unit
Thu, 06 Aug 2026 11:44:21 +0200
Andreas Hindborg <[email protected]> • #50408
Re: [PATCH v2] rust: block: set GenDisk block_device_operations.owner to THIS_MODULE
Thu, 06 Aug 2026 11:08:05 +0200
Andreas Hindborg <[email protected]> • #50407
Re: [PATCH v1] rust: time: fix as_micros_ceil() rounding near i64::MAX
Thu, 06 Aug 2026 10:58:47 +0200
Andreas Hindborg <[email protected]> • #50406
[PATCH v2] rust: block: set GenDisk block_device_operations.owner to THIS_MODULE
Thu, 6 Aug 2026 14:06:55 +0530
Adarsh Das <[email protected]> • #50405
Re: [PATCH] rust: misc: add OWNER field to the `MiscDevice` trait
Thu, 6 Aug 2026 08:28:23 +0000
Alice Ryhl <[email protected]> • #50404
Re: [PATCH v3] drm/tyr: add Job IRQ handling
Thu, 6 Aug 2026 08:27:14 +0000
Alice Ryhl <[email protected]> • #50403
Re: [PATCH v1] rust: time: fix as_micros_ceil() rounding near i64::MAX
Thu, 06 Aug 2026 17:23:19 +0900 (JST)
FUJITA Tomonori <[email protected]> • #50402
Re: [PATCH V17 0/7] Rust Support for powerpc
Thu, 06 Aug 2026 16:53:26 +0900 (JST)
FUJITA Tomonori <[email protected]> • #50401
[PATCH] rust: dma: add `Range` type
Thu, 06 Aug 2026 09:46:14 +0200
Vasileios Almpanis <[email protected]> • #50400
Re: [PATCH v4 3/7] rust: time: add Delta::as_millis_ceil()
Thu, 06 Aug 2026 16:41:04 +0900 (JST)
FUJITA Tomonori <[email protected]> • #50399
[PATCH v2 2/2] gpu: nova-core: use kernel lossless integer conversion module
Thu, 06 Aug 2026 16:35:54 +0900
Alexandre Courbot <[email protected]> • #50398
[PATCH v2 1/2] rust: add functions and traits for lossless integer conversions
Thu, 06 Aug 2026 16:35:53 +0900
Alexandre Courbot <[email protected]> • #50397
[PATCH v2 0/2] rust: add functions and traits for lossless integer conversions
Thu, 06 Aug 2026 16:35:52 +0900
Alexandre Courbot <[email protected]> • #50396
[PATCH v5 7/7] rust: time: remove unused Jiffies/Msecs helpers
Thu, 6 Aug 2026 16:32:41 +0900
FUJITA Tomonori <[email protected]> • #50395
[PATCH v5 6/7] rust: sync: condvar: use Delta<Jiffy> for timeout and result
Thu, 6 Aug 2026 16:32:40 +0900
FUJITA Tomonori <[email protected]> • #50394
[PATCH v5 5/7] rust: workqueue: take a Delta<Jiffy> for the enqueue delay
Thu, 6 Aug 2026 16:32:39 +0900
FUJITA Tomonori <[email protected]> • #50393
[PATCH v5 4/7] rust: time: add Delta::to_jiffies() for timeout conversion
Thu, 6 Aug 2026 16:32:38 +0900
FUJITA Tomonori <[email protected]> • #50392
[PATCH v5 3/7] rust: time: add Delta::as_millis_ceil()
Thu, 6 Aug 2026 16:32:37 +0900
FUJITA Tomonori <[email protected]> • #50391
[PATCH v5 2/7] rust: time: add jiffies time unit for Delta
Thu, 6 Aug 2026 16:32:36 +0900
FUJITA Tomonori <[email protected]> • #50390
[PATCH v5 1/7] rust: time: make Delta generic over its time unit
Thu, 6 Aug 2026 16:32:35 +0900
FUJITA Tomonori <[email protected]> • #50389
[PATCH v5 0/7] rust: use Delta instead of raw jiffies for timeouts and delays
Thu, 6 Aug 2026 16:32:34 +0900
FUJITA Tomonori <[email protected]> • #50388
Re: [PATCH v2 2/3] rust: platform: wire runtime PM callbacks
Thu, 6 Aug 2026 06:45:01 +0000
Alice Ryhl <[email protected]> • #50387
Re: [PATCH v2 1/3] rust: add runtime PM support
Thu, 6 Aug 2026 06:41:36 +0000
Alice Ryhl <[email protected]> • #50386
[PATCH v2] rust: io: Add a BigEndianMmio wrapper
Thu, 6 Aug 2026 08:22:04 +0200
Link Mauve <[email protected]> • #50385
Re: rust compile failure in next-20260730
Thu, 6 Aug 2026 05:52:26 +0000
Harry Yoo <[email protected]> • #50384
Re: [PATCH] rust: io: Add a BigEndianMmio wrapper
Wed, 05 Aug 2026 18:41:31 -0700
Ethan Plant <[email protected]> • #50383
Re: [PATCH v4 10/17] preempt: Introduce HAS_SEPARATE_PREEMPT_RESCHED_BITS
Wed, 5 Aug 2026 17:58:00 -0700
Boqun Feng <[email protected]> • #50382
Re: [PATCH v7 0/8] Transition Nova Core to TLV firmware images
Thu, 6 Aug 2026 02:12:48 +0200
Danilo Krummrich <[email protected]> • #50381
Re: [PATCH v3 0/3] implement GPU reset API
Wed, 5 Aug 2026 21:06:31 -0300
Daniel Almeida <[email protected]> • #50380
[PATCH] rust: io: Add a BigEndianMmio wrapper
Thu, 6 Aug 2026 00:21:09 +0200
Link Mauve <[email protected]> • #50379
[PATCH 3/3] gpu: nova-core: gsp: map the WPR meta for streaming DMA
Wed, 05 Aug 2026 23:54:43 +0200
Maurice Hieronymus <[email protected]> • #50378
[PATCH 2/3] rust: dma: add abstraction for the single-buffer streaming DMA API
Wed, 05 Aug 2026 23:54:42 +0200
Maurice Hieronymus <[email protected]> • #50377
[PATCH 0/3] rust: dma: add the single-buffer streaming DMA API
Wed, 05 Aug 2026 23:54:40 +0200
Maurice Hieronymus <[email protected]> • #50376
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.