Re: [PATCH i-g-t 1/6] include/drm-uapi: Add DRM_COLOROP_FIXED_MATRIX definition
"Borah, Chaitanya Kumar" <[email protected]>
| Newsgroups | org.freedesktop.lists.igt-dev |
|---|---|
| Message-ID | <[email protected]> |
On 8/6/2026 5:33 PM, Swati Sharma wrote: > Add DRM_COLOROP_FIXED_MATRIX to the colorop type enumeration. This > colorop type represents a pre-defined matrix operation selected via > the FIXED_MATRIX_TYPE enum property. The driver advertises the > supported operations through this property. > > Aligns with kernel commit introducing the Fixed Matrix colorop > type for Intel display hardware. > > v2: -Naming changes (CSC_FF -> FIXED_MATRIX) > I am not sure how strict is the rule for adding the kernel patch's sha to the commit message but the change itself looks good. Reviewed-by: Chaitanya Kumar Borah <[email protected]> > Assisted-by: Claude Opus 4.6 > Signed-off-by: Swati Sharma <[email protected]> > --- > include/drm-uapi/drm_mode.h | 11 +++++++++++ > 1 file changed, 11 insertions(+) > > diff --git a/include/drm-uapi/drm_mode.h b/include/drm-uapi/drm_mode.h > index de10ce859..0924e38af 100644 > --- a/include/drm-uapi/drm_mode.h > +++ b/include/drm-uapi/drm_mode.h > @@ -934,6 +934,17 @@ enum drm_colorop_type { > * LUT size is advertised via the SIZE property. > */ > DRM_COLOROP_3D_LUT, > + > + /** > + * @DRM_COLOROP_FIXED_MATRIX: > + * > + * enum string "Fixed Matrix" > + * > + * A Colorop block that performs a pre-defined matrix operation selected > + * via the FIXED_MATRIX_TYPE enum property. The driver advertises the supported > + * operations through this property. > + */ > + DRM_COLOROP_FIXED_MATRIX, > }; > > /**