Re: [PATCH i-g-t 2/6] lib/igt_kms: Add FIXED_MATRIX_TYPE colorop property
"Borah, Chaitanya Kumar" <[email protected]>
| Newsgroups | org.freedesktop.lists.igt-dev |
|---|---|
| Message-ID | <[email protected]> |
On 8/6/2026 5:33 PM, Swati Sharma wrote: > Add IGT_COLOROP_FIXED_MATRIX_TYPE to the colorop property enumeration > and register the "FIXED_MATRIX_TYPE" property name string. This enables > IGT to discover and configure the FIXED_MATRIX_TYPE enum property on > fixed-matrix colorops exposed by the driver. > nit: Let's keep NEXT as the last property defined just to represent its unique role as chain-terminator/pointer. LGTM, Reviewed-by: Chaitanya Kumar Borah <[email protected]> > v2: -Naming changes (CSC_FF_TYPE -> FIXED_MATRIX_TYPE) > > Assisted-by: Claude Opus 4.6 > Signed-off-by: Swati Sharma <[email protected]> > --- > lib/igt_kms.c | 1 + > lib/igt_kms.h | 1 + > 2 files changed, 2 insertions(+) > > diff --git a/lib/igt_kms.c b/lib/igt_kms.c > index ef9496741..9095aa634 100644 > --- a/lib/igt_kms.c > +++ b/lib/igt_kms.c > @@ -725,6 +725,7 @@ const char * const igt_colorop_prop_names[IGT_NUM_COLOROP_PROPS] = { > [IGT_COLOROP_MULTIPLIER] = "MULTIPLIER", > [IGT_COLOROP_LUT3D_INTERPOLATION] = "LUT3D_INTERPOLATION", > [IGT_COLOROP_NEXT] = "NEXT", > + [IGT_COLOROP_FIXED_MATRIX_TYPE] = "FIXED_MATRIX_TYPE", > }; > > const char * const igt_crtc_prop_names[IGT_NUM_CRTC_PROPS] = { > diff --git a/lib/igt_kms.h b/lib/igt_kms.h > index 521a03c01..22164fca9 100644 > --- a/lib/igt_kms.h > +++ b/lib/igt_kms.h > @@ -363,6 +363,7 @@ enum igt_atomic_colorop_properties { > IGT_COLOROP_MULTIPLIER, > IGT_COLOROP_LUT3D_INTERPOLATION, > IGT_COLOROP_NEXT, > + IGT_COLOROP_FIXED_MATRIX_TYPE, > IGT_NUM_COLOROP_PROPS > }; >