[PATCHv2 4/8] ata: sata_dwc_460ex: drop redundant struct copy of port_info
Rosen Penev <[email protected]>
| Newsgroups | org.kernel.vger.linux-ide,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <[email protected]> |
sata_dwc_port_info[0] was copied to a local auto variable before being referenced via a pointer array. The local copy is never modified, so drop it and point ppi directly at the static data. This saves ~104 bytes of stack and makes the const qualification consistent. Assisted-by: opencode:big-pickle Signed-off-by: Rosen Penev <[email protected]> --- drivers/ata/sata_dwc_460ex.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/ata/sata_dwc_460ex.c b/drivers/ata/sata_dwc_460ex.c index 43011789c75e..2a28e6655bba 100644 --- a/drivers/ata/sata_dwc_460ex.c +++ b/drivers/ata/sata_dwc_460ex.c @@ -1130,8 +1130,8 @@ static int sata_dwc_probe(struct platform_device *ofdev) int err = 0; int irq; struct ata_host *host; - struct ata_port_info pi = sata_dwc_port_info[0]; - const struct ata_port_info *ppi[] = { &pi, NULL }; + const struct ata_port_info *pi = &sata_dwc_port_info[0]; + const struct ata_port_info *ppi[] = { pi, NULL }; struct resource *res; /* Allocate DWC SATA device */ -- 2.55.0