org.kernel.vger.linux-gpio archive

1215 archived articles, newest first (page 11 of 13). Latest articles →

[PATCH v3 3/4] dt-bindings: pinctrl: rockchip: Add RV1106 compatible
Wed, 29 Jul 2026 07:27:27 -0600
Simon Glass <[email protected]> • #133818
[PATCH v3 2/4] dt-bindings: gpio: rockchip,gpio-bank: Add rockchip,grf property
Wed, 29 Jul 2026 07:27:26 -0600
Simon Glass <[email protected]> • #133817
[PATCH v3 1/4] pinctrl: rockchip: Decode drive strength in the get function
Wed, 29 Jul 2026 07:27:25 -0600
Simon Glass <[email protected]> • #133816
[PATCH v3 0/4] pinctrl: Add support for the Rockchip RV1106
Wed, 29 Jul 2026 07:27:24 -0600
Simon Glass <[email protected]> • #133815
Re: [PATCH] powerpc: implement get_direction() in cpm2
Wed, 29 Jul 2026 05:05:06 -0700
Bartosz Golaszewski <[email protected]> • #133814
Re: [PATCH 5/7] gpio: ppc44x: Convert GPIO to generic MMIO
Wed, 29 Jul 2026 16:25:23 +0530
Madhavan Srinivasan <[email protected]> • #133813
Re: [PATCH] pinctrl: spacemit: validate pins in pinconf callbacks
Wed, 29 Jul 2026 10:31:48 +0000
Yixun Lan <[email protected]> • #133812
Re: [PATCH 0/3] pinctrl: rockchip: add support for RK3308B SoC
Wed, 29 Jul 2026 12:22:19 +0200
Heiko Stübner <[email protected]> • #133811
Re: [PATCH 0/7] gpio: move ppc4xx driver to drivers/gpio and modernize
Wed, 29 Jul 2026 15:50:42 +0530
Madhavan Srinivasan <[email protected]> • #133810
[PATCH] powerpc: implement get_direction() in cpm2
Wed, 29 Jul 2026 11:56:48 +0200
"Christophe Leroy (CS GROUP)" <[email protected]> • #133809
[PATCH] gpiolib: Check gc->get_direction() before calling gpiod_get_direction()
Wed, 29 Jul 2026 11:47:20 +0200
"Christophe Leroy (CS GROUP)" <[email protected]> • #133808
[PATCH] pinctrl: spacemit: validate pins in pinconf callbacks
Wed, 29 Jul 2026 02:26:42 -0700
Troy Mitchell <[email protected]> • #133807
Re: [PATCH v2 1/2] dt-bindings: gpio: Add Axiado SGPIO controller
Wed, 29 Jul 2026 10:03:16 +0200
Krzysztof Kozlowski <[email protected]> • #133806
[PATCH v3] pinctrl: generic: free maps on pinctrl_generic_to_map() failure
Wed, 29 Jul 2026 13:24:37 +0530
[email protected] • #133805
Re: [PATCH v2] pinctrl: generic: free maps on pinctrl_generic_to_map() failure
Wed, 29 Jul 2026 09:50:41 +0200
Linus Walleij <[email protected]> • #133804
Re: [PATCH v8 00/35] pinctrl: airoha: split on shared and SoC drivers, add more SoCs
Wed, 29 Jul 2026 09:39:03 +0200
Linus Walleij <[email protected]> • #133803
Re: [PATCH] gpio: pch: use raw_spinlock_t for the register lock
Wed, 29 Jul 2026 09:22:13 +0200
Linus Walleij <[email protected]> • #133802
[PATCH v2 2/2] gpio: axiado: add SGPIO controller support
Wed, 29 Jul 2026 00:02:04 -0700
Petar Stepanovic <[email protected]> • #133801
[PATCH v2 1/2] dt-bindings: gpio: Add Axiado SGPIO controller
Wed, 29 Jul 2026 00:02:03 -0700
Petar Stepanovic <[email protected]> • #133800
[PATCH v2 0/2] gpio: add support for Axiado SGPIO controller
Wed, 29 Jul 2026 00:02:02 -0700
Petar Stepanovic <[email protected]> • #133799
Re: [PATCH v5 7/7] ARM: dts: ti: cpcap-mapphone: add USB safe pinctrl state
Tue, 28 Jul 2026 20:27:07 +0200
Andreas Kemnade <[email protected]> • #133798
[brgl:gpio/for-current] BUILD SUCCESS a02b8950d619123da64f69b70fe1dadef217dfe4
Wed, 29 Jul 2026 10:39:09 +0800
kernel test robot <[email protected]> • #133797
[brgl:pinctrl-qcom/for-next] BUILD SUCCESS 1860fb0be224dec0e4d170f46d1cbbc77e25e09e
Wed, 29 Jul 2026 10:09:50 +0800
kernel test robot <[email protected]> • #133796
[brgl:pinctrl-qcom/for-current] BUILD SUCCESS fd46760956509f580f7d3d25db4de10e7c6f949b
Wed, 29 Jul 2026 10:07:41 +0800
kernel test robot <[email protected]> • #133795
Re: [PATCH] gpio: sloppy-logic-analyzer: fix use-after-free via debugfs trigger on unbind
Wed, 29 Jul 2026 01:38:36 +0200
Wolfram Sang <[email protected]> • #133794
Re: [PATCH v7 2/2] i2c: i2c-gpio: Enhance driver for buses with shared SCL
Wed, 29 Jul 2026 00:04:09 +0200
Wolfram Sang <[email protected]> • #133793
Re: [PATCH v7 2/2] i2c: i2c-gpio: Enhance driver for buses with shared SCL
Tue, 28 Jul 2026 21:25:16 +0200
Andi Shyti <[email protected]> • #133792
Re: [PATCH v3 8/8] arm64: dts: axiado: Add initial support for AX3005 SoC and eval board
Tue, 28 Jul 2026 16:24:23 +0100
Marc Zyngier <[email protected]> • #133791
Re: [PATCH v2 00/10] soc: fsl: qe: QE PIC improvement and add support of IRQs to QUICC ENGINE GPIOs
Tue, 28 Jul 2026 17:16:04 +0200
"Christophe Leroy (CS GROUP)" <[email protected]> • #133790
Re: [PATCH v3 3/8] dt-bindings: i2c: cdns: add Axiado AX3005 I2C variant
Tue, 28 Jul 2026 17:11:20 +0200
Andi Shyti <[email protected]> • #133789
Re: [PATCH] gpio: sloppy-logic-analyzer: fix use-after-free via debugfs trigger on unbind
Tue, 28 Jul 2026 18:02:38 +0300
Cengiz Can <[email protected]> • #133788
Re: [PATCH] pinctrl: qcom: shikra: Fix intr_target_width for summary interrupt routing
Tue, 28 Jul 2026 13:09:57 +0200
Konrad Dybcio <[email protected]> • #133787
[PATCH] pinctrl: qcom: shikra: Fix intr_target_width for summary interrupt routing
Tue, 28 Jul 2026 16:33:08 +0530
Komal Bajaj <[email protected]> • #133786
[linusw-pinctrl:for-next] BUILD SUCCESS 4e86273596918b699273f58f3ccf861725720309
Tue, 28 Jul 2026 18:56:25 +0800
kernel test robot <[email protected]> • #133785
[brgl:gpio/for-next] BUILD SUCCESS 8bdba6f6cfc1eb68df883e6541ca443bdf300dd0
Tue, 28 Jul 2026 18:44:47 +0800
kernel test robot <[email protected]> • #133784
Re: [PATCH] gpio: sloppy-logic-analyzer: fix use-after-free via debugfs trigger on unbind
Tue, 28 Jul 2026 11:47:35 +0200
Wolfram Sang <[email protected]> • #133783
Re: [PATCH 0/2] pinctrl: qcom: ipq806x: mark gpio and pcie-reset as GPIO
Tue, 28 Jul 2026 11:11:32 +0200
Bartosz Golaszewski <[email protected]> • #133782
Re: [PATCH v13] i2c: designware: defer probe if child GpioInt controllers are not bound
Tue, 28 Jul 2026 10:30:54 +0200
Andi Shyti <[email protected]> • #133781
[PATCH v1 1/1] pinctrl: eswin: Fix Handling of PIN_CONFIG_PERSIST_STATE
Tue, 28 Jul 2026 15:29:06 +0800
Yulin Lu <[email protected]> • #133780
Re: [PATCH] pinctrl: samsung: exynos: replace irq_of_parse_and_map with modern APIs
Tue, 28 Jul 2026 08:05:34 +0200
Krzysztof Kozlowski <[email protected]> • #133779
Re: [PATCH v13] i2c: designware: defer probe if child GpioInt controllers are not bound
Tue, 28 Jul 2026 11:34:32 +0530
Hardik Prakash <[email protected]> • #133778
[PATCH] gpio: sloppy-logic-analyzer: fix use-after-free via debugfs trigger on unbind
Tue, 28 Jul 2026 02:10:26 +0300
Cengiz Can <[email protected]> • #133777
Re: (subset) [PATCH 00/36] treewide: remove conditional returns with no effect
Mon, 27 Jul 2026 13:26:41 +0100
Mark Brown <[email protected]> • #133776
Re: [GIT PULL] Pin control fixes for v7.2
Mon, 27 Jul 2026 21:50:04 +0000
[email protected] • #133775
Re: [PATCH v8 30/35] dt-bindings: pinctrl: airoha: an7583: add olt function/group
Mon, 27 Jul 2026 22:15:55 +0200
Krzysztof Kozlowski <[email protected]> • #133774
Re: [PATCH v8 28/35] dt-bindings: pinctrl: airoha: an7583: add pon_alt pin group
Mon, 27 Jul 2026 22:14:03 +0200
Krzysztof Kozlowski <[email protected]> • #133773
Re: [PATCH v8 00/35] pinctrl: airoha: split on shared and SoC drivers, add more SoCs
Mon, 27 Jul 2026 22:12:53 +0200
Krzysztof Kozlowski <[email protected]> • #133772
[PATCH] pinctrl: samsung: exynos: replace irq_of_parse_and_map with modern APIs
Mon, 27 Jul 2026 12:48:35 -0700
Rosen Penev <[email protected]> • #133771
Re: [PATCH v4 10/13] platform/x86: uniwill-wmi: use devm_blocking_notifier_chain_register()
Mon, 27 Jul 2026 20:48:09 +0200
Armin Wolf <[email protected]> • #133770
[PATCH v8 35/35] dt-bindings: pinctrl: airoha: add support of an7563 pin controller
Mon, 27 Jul 2026 20:41:41 +0300
Mikhail Kshevetskiy <[email protected]> • #133769
[PATCH v8 34/35] pinctrl: airoha: add support of an7563 SoC
Mon, 27 Jul 2026 20:41:40 +0300
Mikhail Kshevetskiy <[email protected]> • #133768
[PATCH v8 33/35] dt-bindings: pinctrl: airoha: add support of en7523 pin controller
Mon, 27 Jul 2026 20:41:39 +0300
Mikhail Kshevetskiy <[email protected]> • #133767
[PATCH v8 31/35] pinctrl: airoha: add support of en7523 SoC
Mon, 27 Jul 2026 20:41:37 +0300
Mikhail Kshevetskiy <[email protected]> • #133766
[PATCH v8 32/35] pinctrl: airoha: try to find chip scu node by phandle first
Mon, 27 Jul 2026 20:41:38 +0300
Mikhail Kshevetskiy <[email protected]> • #133765
[PATCH v8 30/35] dt-bindings: pinctrl: airoha: an7583: add olt function/group
Mon, 27 Jul 2026 20:41:36 +0300
Mikhail Kshevetskiy <[email protected]> • #133764
[PATCH v8 26/35] dt-bindings: pinctrl: airoha: an7583: add npu_uart pin group
Mon, 27 Jul 2026 20:41:32 +0300
Mikhail Kshevetskiy <[email protected]> • #133763
[PATCH v8 29/35] pinctrl: airoha: an7583: add support for olt pinmux
Mon, 27 Jul 2026 20:41:35 +0300
Mikhail Kshevetskiy <[email protected]> • #133762
[PATCH v8 25/35] pinctrl: airoha: an7583: add support for npu_uart pinmux
Mon, 27 Jul 2026 20:41:31 +0300
Mikhail Kshevetskiy <[email protected]> • #133761
[PATCH v8 21/35] pinctrl: airoha: split driver on shared code and SoC specific drivers
Mon, 27 Jul 2026 20:41:27 +0300
Mikhail Kshevetskiy <[email protected]> • #133760
[PATCH v8 24/35] pinctrl: airoha: an7583: rename registers to match its an7583 names
Mon, 27 Jul 2026 20:41:30 +0300
Mikhail Kshevetskiy <[email protected]> • #133759
[PATCH v8 28/35] dt-bindings: pinctrl: airoha: an7583: add pon_alt pin group
Mon, 27 Jul 2026 20:41:34 +0300
Mikhail Kshevetskiy <[email protected]> • #133758
[PATCH v8 27/35] pinctrl: airoha: an7583: add support for pon_alt pinmux
Mon, 27 Jul 2026 20:41:33 +0300
Mikhail Kshevetskiy <[email protected]> • #133757
[PATCH v8 23/35] pinctrl: airoha: an7583: remove an7583 prefix from variable names and definitions
Mon, 27 Jul 2026 20:41:29 +0300
Mikhail Kshevetskiy <[email protected]> • #133756
[PATCH v8 22/35] pinctrl: airoha: an7581: remove en7581 prefix from variable names
Mon, 27 Jul 2026 20:41:28 +0300
Mikhail Kshevetskiy <[email protected]> • #133755
[PATCH v8 20/35] pinctrl: airoha: move common definitions to the separate header
Mon, 27 Jul 2026 20:41:26 +0300
Mikhail Kshevetskiy <[email protected]> • #133754
[PATCH v8 19/35] pinctrl: airoha: remove not needed irq_type[] array
Mon, 27 Jul 2026 20:41:25 +0300
Mikhail Kshevetskiy <[email protected]> • #133753
[PATCH v8 18/35] pinctrl: airoha: fix edge-triggered interrupts handling
Mon, 27 Jul 2026 20:41:24 +0300
Mikhail Kshevetskiy <[email protected]> • #133752
[PATCH v8 17/35] pinctrl: airoha: add missed IRQ resource helpers
Mon, 27 Jul 2026 20:41:23 +0300
Mikhail Kshevetskiy <[email protected]> • #133751
[PATCH v8 16/35] pinctrl: airoha: fix IRQ mask/unmask code
Mon, 27 Jul 2026 20:41:22 +0300
Mikhail Kshevetskiy <[email protected]> • #133750
[PATCH v8 15/35] pinctrl: airoha: fix getting gpiochip/pinctrl pointers in the IRQ handling code
Mon, 27 Jul 2026 20:41:21 +0300
Mikhail Kshevetskiy <[email protected]> • #133749
[PATCH v8 13/35] pinctrl: airoha: add missed get_direction() function for gpio_chip
Mon, 27 Jul 2026 20:41:19 +0300
Mikhail Kshevetskiy <[email protected]> • #133748
[PATCH v8 14/35] pinctrl: airoha: add set_direction() helper for gpio_chip
Mon, 27 Jul 2026 20:41:20 +0300
Mikhail Kshevetskiy <[email protected]> • #133747
[PATCH v8 12/35] dt-bindings: pinctrl: airoha: an7583: allow configuration of non-gpio default pins as gpio and pwm
Mon, 27 Jul 2026 20:41:18 +0300
Mikhail Kshevetskiy <[email protected]> • #133746
[PATCH v8 11/35] pinctrl: airoha: an7583: fix muxing of non-gpio default pins
Mon, 27 Jul 2026 20:41:17 +0300
Mikhail Kshevetskiy <[email protected]> • #133745
[PATCH v8 10/35] dt-bindings: pinctrl: airoha: en7581: allow configuration of pcie_reset pins as gpio or pwm
Mon, 27 Jul 2026 20:41:16 +0300
Mikhail Kshevetskiy <[email protected]> • #133744
[PATCH v8 09/35] pinctrl: airoha: an7581: fix mux/conf of pcie_reset pins
Mon, 27 Jul 2026 20:41:15 +0300
Mikhail Kshevetskiy <[email protected]> • #133743
[PATCH v8 06/35] pinctrl: airoha: an7583: fix I2C0_SDA_PD register bit order
Mon, 27 Jul 2026 20:41:12 +0300
Mikhail Kshevetskiy <[email protected]> • #133742
[PATCH v8 08/35] dt-bindings: pinctrl: airoha: an7583: remove i2c pin function
Mon, 27 Jul 2026 20:41:14 +0300
Mikhail Kshevetskiy <[email protected]> • #133741
[PATCH v8 05/35] pinctrl: airoha: an7581: fix pinconf of i2c_scl/i2c_sda pins
Mon, 27 Jul 2026 20:41:11 +0300
Mikhail Kshevetskiy <[email protected]> • #133740
[PATCH v8 04/35] pinctrl: airoha: fix mdio bitfield names
Mon, 27 Jul 2026 20:41:10 +0300
Mikhail Kshevetskiy <[email protected]> • #133739
[PATCH v8 07/35] pinctrl: airoha: an7583: there are no muxes to enable i2c buses
Mon, 27 Jul 2026 20:41:13 +0300
Mikhail Kshevetskiy <[email protected]> • #133738
[PATCH v8 03/35] dt-bindings: pinctrl: airoha: an7583: fix device tree binding schema
Mon, 27 Jul 2026 20:41:09 +0300
Mikhail Kshevetskiy <[email protected]> • #133737
[PATCH v8 00/35] pinctrl: airoha: split on shared and SoC drivers, add more SoCs
Mon, 27 Jul 2026 20:41:06 +0300
Mikhail Kshevetskiy <[email protected]> • #133736
[PATCH v8 02/35] dt-bindings: pinctrl: airoha: en7581: fix pwm pin-groups
Mon, 27 Jul 2026 20:41:08 +0300
Mikhail Kshevetskiy <[email protected]> • #133735
[PATCH v8 01/35] dt-bindings: pinctrl: airoha: en7581: fix misprint in i2s function name
Mon, 27 Jul 2026 20:41:07 +0300
Mikhail Kshevetskiy <[email protected]> • #133734
Re: [PATCH] gpio: pch: use raw_spinlock_t for the register lock
Mon, 27 Jul 2026 23:18:14 +0800
Junjie Cao <[email protected]> • #133733
Re: [PATCH] pinctrl: qcom: ipq9650: fix audio_sec_mclk_in1/out1 group pins
Mon, 27 Jul 2026 16:48:38 +0200
Bartosz Golaszewski <[email protected]> • #133732
Re: [PATCH] pinctrl: qcom: Add irq_get/set_irqchip_state() for msm gpio irqchip
Mon, 27 Jul 2026 16:24:35 +0200
Bartosz Golaszewski <[email protected]> • #133731
[RESEND V2 2/2] pinctrl: tegra264: fix DAP2 DIN/DOUT pin assignment
Mon, 27 Jul 2026 14:11:21 +0000
Prathamesh Shete <[email protected]> • #133730
[RESEND V2 1/2] dt-bindings: pinctrl: tegra264: fix DAP2 DIN/DOUT pin names
Mon, 27 Jul 2026 14:11:20 +0000
Prathamesh Shete <[email protected]> • #133729
Re: [PATCH v8 9/9] gpio: realtek: Add driver for Realtek DHC RTD1625 SoC
Mon, 27 Jul 2026 16:07:37 +0200
"Mathieu Dubois-Briand" <[email protected]> • #133728
Re: [PATCH 1/6] dt-bindings: iio: adc: Add AD7768
Mon, 27 Jul 2026 15:01:28 +0100
Nuno Sá <[email protected]> • #133727
Re: [PATCH] gpio: pch: use raw_spinlock_t for the register lock
Mon, 27 Jul 2026 15:08:11 +0200
Bartosz Golaszewski <[email protected]> • #133726
Re: [PATCH v4 12/13] gpio: gpiolib-kunit: use devm_blocking_notifier_chain_register()
Mon, 27 Jul 2026 06:05:32 -0700
Bartosz Golaszewski <[email protected]> • #133725
Re: [PATCH v8 9/9] gpio: realtek: Add driver for Realtek DHC RTD1625 SoC
Mon, 27 Jul 2026 06:04:42 -0700
Bartosz Golaszewski <[email protected]> • #133724
Re: [PATCH 00/36] treewide: remove conditional returns with no effect
Mon, 27 Jul 2026 21:59:30 +0900
Sang-Heon Jeon <[email protected]> • #133723
Re: [PATCH v2] gpio: pca953x: fix cache_only and IRQ state on restore_context() failure
Mon, 27 Jul 2026 14:58:37 +0200
Bartosz Golaszewski <[email protected]> • #133722
Re: [PATCH v7 20/34] pinctrl: airoha: split driver on shared code and SoC specific drivers
Mon, 27 Jul 2026 14:48:03 +0200
Lorenzo Bianconi <[email protected]> • #133721
[PATCH] pinctrl: fix PINCTRL_GENERIC_MUX not always being selectable
Mon, 27 Jul 2026 14:20:08 +0200
Alvin Šipraga <[email protected]> • #133720
Re: [PATCH 00/36] treewide: remove conditional returns with no effect
Mon, 27 Jul 2026 13:12:37 +0100
Mark Brown <[email protected]> • #133719
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.