org.kernel.vger.linux-hexagon archive

451 archived articles, newest first (page 2 of 5). Latest articles →

Re: [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:34:22 +0800
Jinjie Ruan <[email protected]> • #6629
Re: [patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
Thu, 9 Jul 2026 10:13:11 +0800
Jinjie Ruan <[email protected]> • #6628
Re: [patch 16/18] x86/entry: Get rid of the sys_ni_syscall() indirection
Thu, 9 Jul 2026 10:03:49 +0800
Jinjie Ruan <[email protected]> • #6627
Re: [patch 15/18] x86/entry: Make syscall functions static
Thu, 9 Jul 2026 09:47:56 +0800
Jinjie Ruan <[email protected]> • #6626
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Thu, 9 Jul 2026 09:41:18 +0800
Jinjie Ruan <[email protected]> • #6625
Re: [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Thu, 9 Jul 2026 09:20:32 +0800
Jinjie Ruan <[email protected]> • #6624
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Thu, 09 Jul 2026 01:14:24 +0200
Thomas Gleixner <[email protected]> • #6623
Re: [patch 09/18] entry: Remove syscall_enter_from_user_mode()
Thu, 09 Jul 2026 00:08:11 +0200
Thomas Gleixner <[email protected]> • #6622
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Wed, 08 Jul 2026 23:49:57 +0200
Thomas Gleixner <[email protected]> • #6621
Re: [patch 10/18] entry: Use syscall number instead of rereading it
Wed, 08 Jul 2026 17:39:50 -0400
Radu Rendec <[email protected]> • #6620
Re: [patch 09/18] entry: Remove syscall_enter_from_user_mode()
Wed, 08 Jul 2026 17:21:19 -0400
Radu Rendec <[email protected]> • #6619
Re: [patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 16:59:18 -0400
Radu Rendec <[email protected]> • #6618
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 16:57:51 -0400
Radu Rendec <[email protected]> • #6617
Re: [patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 16:57:00 -0400
Radu Rendec <[email protected]> • #6616
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Wed, 08 Jul 2026 22:34:38 +0200
Thomas Gleixner <[email protected]> • #6615
Re: [patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 14:37:13 -0400
Radu Rendec <[email protected]> • #6614
Re: [patch 05/18] powerpc/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 14:35:48 -0400
Radu Rendec <[email protected]> • #6613
Re: [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 13:26:19 -0400
Radu Rendec <[email protected]> • #6612
Re: [patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
Wed, 08 Jul 2026 13:24:33 -0400
Radu Rendec <[email protected]> • #6611
Re: [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Wed, 08 Jul 2026 13:22:58 -0400
Radu Rendec <[email protected]> • #6610
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Wed, 8 Jul 2026 18:04:19 +0200
Oleg Nesterov <[email protected]> • #6609
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Wed, 8 Jul 2026 17:52:42 +0200
Michal Suchánek <[email protected]> • #6608
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Wed, 8 Jul 2026 17:46:24 +0200
Oleg Nesterov <[email protected]> • #6607
Re: [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Wed, 8 Jul 2026 19:37:51 +0530
Shrikanth Hegde <[email protected]> • #6606
Re: [patch 18/18] entry, treewide: Make syscall_enter_from_user_mode[_work]() indicate syscall execution
Wed, 08 Jul 2026 11:16:25 +0200
Thomas Gleixner <[email protected]> • #6605
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Wed, 08 Jul 2026 11:15:10 +0200
Thomas Gleixner <[email protected]> • #6604
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 08:47:15 +0200
Sven Schnelle <[email protected]> • #6603
Re: [patch 18/18] entry, treewide: Make syscall_enter_from_user_mode[_work]() indicate syscall execution
Wed, 8 Jul 2026 10:51:56 +0530
Shrikanth Hegde <[email protected]> • #6602
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Wed, 8 Jul 2026 09:43:46 +0800
Jinjie Ruan <[email protected]> • #6601
[patch 18/18] entry, treewide: Make syscall_enter_from_user_mode[_work]() indicate syscall execution
Tue, 07 Jul 2026 21:07:09 +0200
Thomas Gleixner <[email protected]> • #6600
[patch 17/18] x86/entry: Simplify the syscall number logic
Tue, 07 Jul 2026 21:07:05 +0200
Thomas Gleixner <[email protected]> • #6599
[patch 16/18] x86/entry: Get rid of the sys_ni_syscall() indirection
Tue, 07 Jul 2026 21:07:01 +0200
Thomas Gleixner <[email protected]> • #6598
[patch 15/18] x86/entry: Make syscall functions static
Tue, 07 Jul 2026 21:06:57 +0200
Thomas Gleixner <[email protected]> • #6597
[patch 14/18] entry: Make return type of syscall_trace_enter() bool
Tue, 07 Jul 2026 21:06:53 +0200
Thomas Gleixner <[email protected]> • #6596
[patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Tue, 07 Jul 2026 21:06:44 +0200
Thomas Gleixner <[email protected]> • #6595
[patch 13/18] entry: Make trace_syscall_enter() return type bool
Tue, 07 Jul 2026 21:06:48 +0200
Thomas Gleixner <[email protected]> • #6594
[patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Tue, 07 Jul 2026 21:06:40 +0200
Thomas Gleixner <[email protected]> • #6593
[patch 10/18] entry: Use syscall number instead of rereading it
Tue, 07 Jul 2026 21:06:36 +0200
Thomas Gleixner <[email protected]> • #6592
[patch 09/18] entry: Remove syscall_enter_from_user_mode()
Tue, 07 Jul 2026 21:06:32 +0200
Thomas Gleixner <[email protected]> • #6591
[patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:27 +0200
Thomas Gleixner <[email protected]> • #6590
[patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:23 +0200
Thomas Gleixner <[email protected]> • #6589
[patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:19 +0200
Thomas Gleixner <[email protected]> • #6588
[patch 05/18] powerpc/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:15 +0200
Thomas Gleixner <[email protected]> • #6587
[patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:11 +0200
Thomas Gleixner <[email protected]> • #6586
[patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:07 +0200
Thomas Gleixner <[email protected]> • #6585
[patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
Tue, 07 Jul 2026 21:06:02 +0200
Thomas Gleixner <[email protected]> • #6584
[patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Tue, 07 Jul 2026 21:05:58 +0200
Thomas Gleixner <[email protected]> • #6583
[patch 00/18] entry: Consolidate and rework syscall entry handling
Tue, 07 Jul 2026 21:05:53 +0200
Thomas Gleixner <[email protected]> • #6582
Re: [PATCH] hexagon: remove code to handle nonexistent CONFIG_PAGE_SIZE_1MB
Wed, 1 Jul 2026 19:06:16 +0200
Philippe Mathieu-DaudĂ© <[email protected]> • #6581
Re: [PATCH] hexagon: remove code to handle nonexistent CONFIG_PAGE_SIZE_1MB
Thu, 11 Jun 2026 09:36:58 +0200
"David Hildenbrand (Arm)" <[email protected]> • #6580
[PATCH] hexagon: remove code to handle nonexistent CONFIG_PAGE_SIZE_1MB
Wed, 10 Jun 2026 15:23:52 -0700
Ethan Nelson-Moore <[email protected]> • #6579
[linux-next:master] BUILD REGRESSION 550604d6c9b9efc8d068aff94dc301694a7afdee
Fri, 22 May 2026 08:33:24 +0800
kernel test robot <[email protected]> • #6578
[PATCH] Generate <asm/asm-offsets.h> and remove identical copies in all architectures
Mon, 18 May 2026 18:18:41 -0700
Ethan Nelson-Moore <[email protected]> • #6577
Re: [PATCH v3 0/4] arch, mm: consolidate empty_zero_page
Thu, 30 Apr 2026 03:25:09 +0000
[email protected] • #6576
Re: [RFC PATCH v1 8/9] arm64: Add unsafe_copy_from_user()
Wed, 29 Apr 2026 12:26:30 +0100
Will Deacon <[email protected]> • #6575
Re: [RFC PATCH v1 7/9] x86: Add unsafe_copy_from_user()
Wed, 29 Apr 2026 03:25:19 -0700
Usama Arif <[email protected]> • #6574
Re: [RFC PATCH v1 2/9] uaccess: Convert INLINE_COPY_{TO/FROM}_USER to kconfig and reduce ifdefery
Tue, 28 Apr 2026 06:34:00 -0500
Segher Boessenkool <[email protected]> • #6573
Re: [RFC PATCH v1 7/9] x86: Add unsafe_copy_from_user()
Tue, 28 Apr 2026 06:20:17 -0500
Segher Boessenkool <[email protected]> • #6572
Re: [RFC PATCH v1 2/9] uaccess: Convert INLINE_COPY_{TO/FROM}_USER to kconfig and reduce ifdefery
Tue, 28 Apr 2026 10:36:09 +0100
Andrew Cooper <[email protected]> • #6571
Re: [RFC PATCH v1 4/9] uaccess: Introduce copy_{to/from}_user_partial()
Tue, 28 Apr 2026 11:25:11 +0200
Geert Uytterhoeven <[email protected]> • #6570
Re: [RFC PATCH v1 7/9] x86: Add unsafe_copy_from_user()
Mon, 27 Apr 2026 18:30:16 -0400
Yury Norov <[email protected]> • #6569
Re: [RFC PATCH v1 7/9] x86: Add unsafe_copy_from_user()
Mon, 27 Apr 2026 14:52:05 -0700
Linus Torvalds <[email protected]> • #6568
Re: [RFC PATCH v1 5/9] uaccess: Switch to copy_{to/from}_user_partial() when relevant
Mon, 27 Apr 2026 14:39:20 -0700
Linus Torvalds <[email protected]> • #6567
Re: [RFC PATCH v1 5/9] uaccess: Switch to copy_{to/from}_user_partial() when relevant
Mon, 27 Apr 2026 22:29:14 +0100
David Laight <[email protected]> • #6566
Re: [RFC PATCH v1 2/9] uaccess: Convert INLINE_COPY_{TO/FROM}_USER to kconfig and reduce ifdefery
Mon, 27 Apr 2026 16:47:53 -0400
Yury Norov <[email protected]> • #6565
Re: [RFC PATCH v1 2/9] uaccess: Convert INLINE_COPY_{TO/FROM}_USER to kconfig and reduce ifdefery
Mon, 27 Apr 2026 21:39:33 +0100
Andrew Cooper <[email protected]> • #6564
Re: [RFC PATCH v1 9/9] uaccess: Convert small fixed size copy_{to/from}_user() to scoped user access
Mon, 27 Apr 2026 16:12:55 -0400
Yury Norov <[email protected]> • #6563
Re: [RFC PATCH v1 7/9] x86: Add unsafe_copy_from_user()
Mon, 27 Apr 2026 15:19:36 -0400
Yury Norov <[email protected]> • #6562
Re: [RFC PATCH v1 5/9] uaccess: Switch to copy_{to/from}_user_partial() when relevant
Mon, 27 Apr 2026 12:01:23 -0700
Linus Torvalds <[email protected]> • #6561
Re: [RFC PATCH v1 0/9] uaccess: Convert small fixed size copy_{to/from}_user() to scoped user access
Mon, 27 Apr 2026 21:01:18 +0200
Helge Deller <[email protected]> • #6560
Re: [RFC PATCH v1 2/9] uaccess: Convert INLINE_COPY_{TO/FROM}_USER to kconfig and reduce ifdefery
Mon, 27 Apr 2026 14:39:16 -0400
Yury Norov <[email protected]> • #6559
Re: [RFC PATCH v1 7/9] x86: Add unsafe_copy_from_user()
Mon, 27 Apr 2026 20:20:38 +0200
"Christophe Leroy (CS GROUP)" <[email protected]> • #6558
Re: [RFC PATCH v1 5/9] uaccess: Switch to copy_{to/from}_user_partial() when relevant
Mon, 27 Apr 2026 18:07:28 +0000
Alice Ryhl <[email protected]> • #6557
Re: [RFC PATCH v1 7/9] x86: Add unsafe_copy_from_user()
Mon, 27 Apr 2026 13:58:51 -0400
Yury Norov <[email protected]> • #6556
[RFC PATCH v1 9/9] uaccess: Convert small fixed size copy_{to/from}_user() to scoped user access
Mon, 27 Apr 2026 19:13:50 +0200
"Christophe Leroy (CS GROUP)" <[email protected]> • #6555
[RFC PATCH v1 8/9] arm64: Add unsafe_copy_from_user()
Mon, 27 Apr 2026 19:13:49 +0200
"Christophe Leroy (CS GROUP)" <[email protected]> • #6554
[RFC PATCH v1 7/9] x86: Add unsafe_copy_from_user()
Mon, 27 Apr 2026 19:13:48 +0200
"Christophe Leroy (CS GROUP)" <[email protected]> • #6553
[RFC PATCH v1 6/9] uaccess: Change copy_{to/from}_user to return -EFAULT
Mon, 27 Apr 2026 19:13:47 +0200
"Christophe Leroy (CS GROUP)" <[email protected]> • #6552
[RFC PATCH v1 5/9] uaccess: Switch to copy_{to/from}_user_partial() when relevant
Mon, 27 Apr 2026 19:13:46 +0200
"Christophe Leroy (CS GROUP)" <[email protected]> • #6551
[RFC PATCH v1 4/9] uaccess: Introduce copy_{to/from}_user_partial()
Mon, 27 Apr 2026 19:13:45 +0200
"Christophe Leroy (CS GROUP)" <[email protected]> • #6550
[RFC PATCH v1 3/9] x86/umip: Be stricter in fixup_umip_exception()
Mon, 27 Apr 2026 19:13:44 +0200
"Christophe Leroy (CS GROUP)" <[email protected]> • #6549
[RFC PATCH v1 2/9] uaccess: Convert INLINE_COPY_{TO/FROM}_USER to kconfig and reduce ifdefery
Mon, 27 Apr 2026 19:13:43 +0200
"Christophe Leroy (CS GROUP)" <[email protected]> • #6548
[RFC PATCH v1 1/9] uaccess: Split check_zeroed_user() out of usercopy.c
Mon, 27 Apr 2026 19:13:42 +0200
"Christophe Leroy (CS GROUP)" <[email protected]> • #6547
[RFC PATCH v1 0/9] uaccess: Convert small fixed size copy_{to/from}_user() to scoped user access
Mon, 27 Apr 2026 19:13:41 +0200
"Christophe Leroy (CS GROUP)" <[email protected]> • #6546
[PATCH AUTOSEL 7.0-5.10] hexagon: uapi: Fix structure alignment attribute
Mon, 20 Apr 2026 09:19:41 -0400
Sasha Levin <[email protected]> • #6545
Re: [GIT PULL] Kbuild and Kconfig changes for v7.1
Tue, 14 Apr 2026 16:46:27 +0000
[email protected] • #6544
[GIT PULL] Kbuild and Kconfig changes for v7.1
Sun, 12 Apr 2026 17:46:47 +0200
Nicolas Schier <[email protected]> • #6543
[PATCH v5 4/8] hexagon: Replace __ASSEMBLY__ with __ASSEMBLER__ in non-uapi headers
Thu, 9 Apr 2026 11:47:04 +0200
Thomas Huth <[email protected]> • #6542
[PATCH v5 3/8] hexagon: Replace __ASSEMBLY__ with __ASSEMBLER__ in uapi headers
Thu, 9 Apr 2026 11:47:03 +0200
Thomas Huth <[email protected]> • #6541
[PATCH v2] cmpxchg: allow const-qualified old value in cmpxchg()
Fri, 03 Apr 2026 09:19:54 +0800
Hangbin Liu <[email protected]> • #6540
Re: [PATCH] cmpxchg: allow const-qualified old value in cmpxchg()
Thu, 2 Apr 2026 13:07:45 +0000
Hangbin Liu <[email protected]> • #6539
Re: [PATCH] cmpxchg: allow const-qualified old value in cmpxchg()
Thu, 2 Apr 2026 12:47:33 +0200
Peter Zijlstra <[email protected]> • #6538
Re: [PATCH] cmpxchg: allow const-qualified old value in cmpxchg()
Thu, 2 Apr 2026 09:57:47 +0100
David Laight <[email protected]> • #6537
[PATCH] cmpxchg: allow const-qualified old value in cmpxchg()
Thu, 02 Apr 2026 14:56:01 +0800
Hangbin Liu <[email protected]> • #6536
Re: [PATCH] media: rockchip: Disable VIDEO_ROCKCHIP_VDEC when compile testing for Hexagon
Fri, 27 Mar 2026 23:11:02 +0100
Nathan Chancellor <[email protected]> • #6535
Re: [PATCH v4 00/25] mm/vma: convert vm_flags_t to vma_flags_t in vma code
Fri, 27 Mar 2026 09:27:16 +0100
"Vlastimil Babka (SUSE)" <[email protected]> • #6534
Re: [PATCH v4 00/25] mm/vma: convert vm_flags_t to vma_flags_t in vma code
Thu, 26 Mar 2026 22:50:31 -0700
Andrew Morton <[email protected]> • #6533
Re: [PATCH v4 25/25] mm: simplify VMA flag tests of excluded flags
Mon, 23 Mar 2026 16:51:41 +0100
"Vlastimil Babka (SUSE)" <[email protected]> • #6532
Re: [PATCH v4 24/25] mm/vma: convert __mmap_region() to use vma_flags_t
Mon, 23 Mar 2026 16:49:44 +0100
"Vlastimil Babka (SUSE)" <[email protected]> • #6531
Re: [PATCH v4 23/25] mm/vma: convert vma_modify_flags[_uffd]() to use vma_flags_t
Mon, 23 Mar 2026 16:47:32 +0100
"Vlastimil Babka (SUSE)" <[email protected]> • #6530
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.