org.freedesktop.lists.nouveau archive

375 archived articles, newest first (page 3 of 4). Latest articles →

[PATCH 3/4] drm/nouveau/kms: Only allow enabling atomic modesetting on nv50+
Wed, 29 Jul 2026 20:56:09 -0400
Lyude Paul <[email protected]> • #54441
[PATCH 4/4] drm/nouveau/kms/nv50-: Enable atomic modesetting by default
Wed, 29 Jul 2026 20:56:10 -0400
Lyude Paul <[email protected]> • #54440
[PATCH 2/4] drm/nouveau/kms: Check nouveau.atomic parameter after nvif_device_ctor()
Wed, 29 Jul 2026 20:56:08 -0400
Lyude Paul <[email protected]> • #54439
[PATCH 1/4] drm/nouveau: Print the nouveau.atomic parameter in nouveau_display_options()
Wed, 29 Jul 2026 20:56:07 -0400
Lyude Paul <[email protected]> • #54438
[PATCH 0/4] drm/nouveau: Enable atomic modesetting by default
Wed, 29 Jul 2026 20:56:06 -0400
Lyude Paul <[email protected]> • #54437
[PATCH 6/6] nouveau: set wpr boost flags like open driver does.
Wed, 29 Jul 2026 14:15:30 +1000
Dave Airlie <[email protected]> • #54436
[PATCH 5/6] nouveau/gsp: add some more fields to r570 system info
Wed, 29 Jul 2026 14:15:29 +1000
Dave Airlie <[email protected]> • #54435
[PATCH 4/6] nouveau/gsp: refactor the chan allocation arguments into a struct
Wed, 29 Jul 2026 14:15:28 +1000
Dave Airlie <[email protected]> • #54434
[PATCH 3/6] nouveau/gsp: add logging entries for r570
Wed, 29 Jul 2026 14:15:27 +1000
Dave Airlie <[email protected]> • #54433
[PATCH 2/6] nouveau/gsp: make libos init per-gsp version.
Wed, 29 Jul 2026 14:15:26 +1000
Dave Airlie <[email protected]> • #54432
nouveau/gsp: some r570 additions and refactoring
Wed, 29 Jul 2026 14:15:24 +1000
Dave Airlie <[email protected]> • #54431
[PATCH 1/6] nouveau/gsp: refactor libos entry handling for r535.
Wed, 29 Jul 2026 14:15:25 +1000
Dave Airlie <[email protected]> • #54430
[PATCH] nouveau/instmem: handle iomapping already existing
Wed, 29 Jul 2026 12:45:16 +1000
Dave Airlie <[email protected]> • #54429
Re: [PATCH] drm/gem: Move pages_to_sg helper into drm_gem.c
Tue, 28 Jul 2026 15:34:00 +0100
Liviu Dudau <[email protected]> • #54428
[PATCH 4/4] tracing/mmiotrace: Clean up coding style and redundant debug logs
Tue, 28 Jul 2026 21:50:19 +0900
"Masami Hiramatsu (Google)" <[email protected]> • #54427
[PATCH 3/4] tracing/mmiotrace: Use trace_assign_type() in mmio_print_mark()
Tue, 28 Jul 2026 21:50:10 +0900
"Masami Hiramatsu (Google)" <[email protected]> • #54426
[PATCH 2/4] tracing/mmiotrace: Add NULL check for mmio_trace_array in logging functions
Tue, 28 Jul 2026 21:50:00 +0900
"Masami Hiramatsu (Google)" <[email protected]> • #54425
[PATCH 1/4] tracing/mmiotrace: Reset dropped_count in mmio_reset_data()
Tue, 28 Jul 2026 21:49:51 +0900
"Masami Hiramatsu (Google)" <[email protected]> • #54424
[PATCH 0/4] tracing/mmiotrace: Fix some bugs in mmiotrace
Tue, 28 Jul 2026 21:49:41 +0900
"Masami Hiramatsu (Google)" <[email protected]> • #54423
Re: [PATCH RFC] drm/nouveau: Use write-combined maps for coherent on Tegra
Tue, 28 Jul 2026 10:38:08 +0200
Lucas Stach <[email protected]> • #54422
Re: [PATCH 00/36] treewide: remove conditional returns with no effect
Mon, 27 Jul 2026 11:30:01 +0300
Jani Nikula <[email protected]> • #54421
Re: [PATCH 00/36] treewide: remove conditional returns with no effect
Mon, 27 Jul 2026 14:36:57 +0300
Jani Nikula <[email protected]> • #54420
Re: (subset) [PATCH 00/36] treewide: remove conditional returns with no effect
Mon, 27 Jul 2026 13:26:41 +0100
Mark Brown <[email protected]> • #54419
Re: [PATCH v4 2/3] drm/nouveau/gsp/r570: Set GcOff = 1 in fbsr
Mon, 27 Jul 2026 13:54:43 -0400
[email protected] • #54418
[PATCH v4 3/3] drm/nouveau/gsp/r570: Enable S/R Display workaround in GSP
Mon, 27 Jul 2026 13:47:44 -0400
Lyude Paul <[email protected]> • #54417
[PATCH v4 2/3] drm/nouveau/gsp/r570: Set GcOff = 1 in fbsr
Mon, 27 Jul 2026 13:47:43 -0400
Lyude Paul <[email protected]> • #54416
[PATCH v4 1/3] Revert "nouveau/gsp: fix suspend/resume regression on r570 firmware"
Mon, 27 Jul 2026 13:47:42 -0400
Lyude Paul <[email protected]> • #54415
[PATCH v4 0/3] drm/nouveau: GSP runtime PM fixes
Mon, 27 Jul 2026 13:47:41 -0400
Lyude Paul <[email protected]> • #54414
Re: [PATCH v3 2/3] drm/nouveau/gsp/r570: Never enter Gcoff state
Mon, 27 Jul 2026 13:12:46 -0400
[email protected] • #54413
[PATCH 2/2] drm/nouveau/clk: only update clk->pstate after hardware programming succeeds
Mon, 27 Jul 2026 17:28:21 +0200
Francesco Magazzu <[email protected]> • #54412
[PATCH 1/2] drm/nouveau/clk: don't ignore RAM clock programming errors in nvkm_pstate_prog
Mon, 27 Jul 2026 17:28:20 +0200
Francesco Magazzu <[email protected]> • #54411
[PATCH 0/2] drm/nouveau/clk: fix RAM error handling and pstate desync in nvkm_pstate_prog
Mon, 27 Jul 2026 17:28:19 +0200
Francesco Magazzu <[email protected]> • #54410
[PATCH 2/2] drm/nouveau/clk: only update clk->pstate after hardware programming succeeds
Mon, 27 Jul 2026 17:05:46 +0200
Francesco Magazzu <[email protected]> • #54409
[PATCH 1/2] drm/nouveau/clk: don't ignore RAM clock programming errors in nvkm_pstate_prog
Mon, 27 Jul 2026 17:05:45 +0200
Francesco Magazzu <[email protected]> • #54408
[PATCH 0/2] drm/nouveau/clk: fix RAM error handling and pstate desync in nvkm_pstate_prog
Mon, 27 Jul 2026 17:05:44 +0200
Francesco Magazzu <[email protected]> • #54407
Re: (subset) [PATCH v2 0/3] drm: Use named initializers for arrays of i2c_device_data
Mon, 27 Jul 2026 15:51:46 +0200
Luca Ceresoli <[email protected]> • #54406
Re: [PATCH 00/36] treewide: remove conditional returns with no effect
Mon, 27 Jul 2026 21:59:30 +0900
Sang-Heon Jeon <[email protected]> • #54405
Re: [PATCH 00/36] treewide: remove conditional returns with no effect
Mon, 27 Jul 2026 13:12:37 +0100
Mark Brown <[email protected]> • #54404
Re: [PATCH 00/36] treewide: remove conditional returns with no effect
Mon, 27 Jul 2026 20:08:33 +0900
Sang-Heon Jeon <[email protected]> • #54403
[PATCH RFC] drm/nouveau: Use write-combined maps for coherent on Tegra
Sat, 25 Jul 2026 18:28:32 -0500
Aaron Kling via B4 Relay <[email protected]> • #54402
Re: [PATCH 0/2] drm/nouveau: nv04 FIFO cleanup + recovery for Tesla
Sat, 25 Jul 2026 20:59:48 +0200
Marek Czernohous <[email protected]> • #54401
Re: [PATCH 00/36] treewide: remove conditional returns with no effect
Fri, 24 Jul 2026 14:48:22 -0700
Jakub Kicinski <[email protected]> • #54400
[PATCH] drm/nouveau: allow allocating NVDEC channels via abi16
Sat, 25 Jul 2026 00:59:12 -0300
Daniel Almeida <[email protected]> • #54399
Re: [PATCH v3 0/3] drm/nouveau: Fix WARN_ON() from missing blend modes
Sat, 25 Jul 2026 13:49:43 +1000
Dave Airlie <[email protected]> • #54398
Re: (subset) [PATCH 00/36] treewide: remove conditional returns with no effect
Sat, 25 Jul 2026 01:35:08 +0200
Sebastian Reichel <[email protected]> • #54397
Re: [PATCH v11 1/8] mm/hmm: move page fault handling out of walk callbacks
Fri, 24 Jul 2026 12:48:22 -0700
Stanislav Kinsburskii <[email protected]> • #54396
Re: [PATCH v11 1/8] mm/hmm: move page fault handling out of walk callbacks
Fri, 24 Jul 2026 21:00:24 +0200
"David Hildenbrand (Arm)" <[email protected]> • #54395
Re: [PATCH] drm/gem: Move pages_to_sg helper into drm_gem.c
Fri, 24 Jul 2026 16:53:40 +0200
Thomas Zimmermann <[email protected]> • #54394
[PATCH] drm/gem: Move pages_to_sg helper into drm_gem.c
Fri, 24 Jul 2026 13:08:58 +0100
Adrián Larumbe <[email protected]> • #54393
[PATCH 00/36] treewide: remove conditional returns with no effect
Fri, 24 Jul 2026 03:45:02 +0900
Sang-Heon Jeon <[email protected]> • #54392
[PATCH 06/36] drm: remove conditional return with no effect
Fri, 24 Jul 2026 03:45:08 +0900
Sang-Heon Jeon <[email protected]> • #54391
Re: [PATCH v11 0/8] mm/hmm: Add mmap lock-drop support for userfaultfd-backed mappings
Thu, 23 Jul 2026 15:22:25 -0700
Stanislav Kinsburskii <[email protected]> • #54390
Re: [PATCH v11 0/8] mm/hmm: Add mmap lock-drop support for userfaultfd-backed mappings
Thu, 23 Jul 2026 14:22:42 -0700
Andrew Morton <[email protected]> • #54389
[PATCH v11 8/8] drm/gpusvm: Use hmm_range_fault_unlocked_timeout() for range faults
Thu, 23 Jul 2026 10:36:40 -0700
Stanislav Kinsburskii <[email protected]> • #54388
[PATCH v11 7/8] accel/amdxdna: Use hmm_range_fault_unlocked_timeout() for range population
Thu, 23 Jul 2026 10:36:39 -0700
Stanislav Kinsburskii <[email protected]> • #54387
[PATCH v11 6/8] RDMA/umem: Use hmm_range_fault_unlocked_timeout() for ODP faults
Thu, 23 Jul 2026 10:36:38 -0700
Stanislav Kinsburskii <[email protected]> • #54386
[PATCH v11 5/8] drm/nouveau: Use hmm_range_fault_unlocked_timeout() for SVM faults
Thu, 23 Jul 2026 10:36:37 -0700
Stanislav Kinsburskii <[email protected]> • #54385
[PATCH v11 4/8] mshv: Use hmm_range_fault_unlocked_timeout() for region faults
Thu, 23 Jul 2026 10:36:36 -0700
Stanislav Kinsburskii <[email protected]> • #54384
[PATCH v11 3/8] selftests/mm: add HMM test for mmap lock-dropping faults
Thu, 23 Jul 2026 10:36:35 -0700
Stanislav Kinsburskii <[email protected]> • #54383
[PATCH v11 2/8] mm/hmm: add hmm_range_fault_unlocked_timeout() for mmap lock-drop support
Thu, 23 Jul 2026 10:36:34 -0700
Stanislav Kinsburskii <[email protected]> • #54382
[PATCH v11 1/8] mm/hmm: move page fault handling out of walk callbacks
Thu, 23 Jul 2026 10:36:33 -0700
Stanislav Kinsburskii <[email protected]> • #54381
[PATCH v11 0/8] mm/hmm: Add mmap lock-drop support for userfaultfd-backed mappings
Thu, 23 Jul 2026 10:36:32 -0700
Stanislav Kinsburskii <[email protected]> • #54380
[PATCH] drm/nouveau: Fix NULL pointer dereference in nouveau_fence_sync() when prev->cli == NULL
Thu, 23 Jul 2026 12:06:19 +0200
Emmanuel Fleury <[email protected]> • #54379
Re: [PATCH v10 0/8] mm/hmm: Add mmap lock-drop support for userfaultfd-backed mappings
Wed, 22 Jul 2026 15:48:17 -0700
Andrew Morton <[email protected]> • #54378
[PATCH v10 8/8] drm/gpusvm: Use hmm_range_fault_unlocked_timeout() for range faults
Wed, 22 Jul 2026 14:44:30 -0700
Stanislav Kinsburskii <[email protected]> • #54377
[PATCH v10 7/8] accel/amdxdna: Use hmm_range_fault_unlocked_timeout() for range population
Wed, 22 Jul 2026 14:44:29 -0700
Stanislav Kinsburskii <[email protected]> • #54376
[PATCH v10 6/8] RDMA/umem: Use hmm_range_fault_unlocked_timeout() for ODP faults
Wed, 22 Jul 2026 14:44:28 -0700
Stanislav Kinsburskii <[email protected]> • #54375
[PATCH v10 5/8] drm/nouveau: Use hmm_range_fault_unlocked_timeout() for SVM faults
Wed, 22 Jul 2026 14:44:27 -0700
Stanislav Kinsburskii <[email protected]> • #54374
[PATCH v10 3/8] selftests/mm: add HMM test for mmap lock-dropping faults
Wed, 22 Jul 2026 14:44:25 -0700
Stanislav Kinsburskii <[email protected]> • #54373
[PATCH v10 4/8] mshv: Use hmm_range_fault_unlocked_timeout() for region faults
Wed, 22 Jul 2026 14:44:26 -0700
Stanislav Kinsburskii <[email protected]> • #54372
[PATCH v10 2/8] mm/hmm: add hmm_range_fault_unlocked_timeout() for mmap lock-drop support
Wed, 22 Jul 2026 14:44:24 -0700
Stanislav Kinsburskii <[email protected]> • #54371
[PATCH v10 1/8] mm/hmm: move page fault handling out of walk callbacks
Wed, 22 Jul 2026 14:44:23 -0700
Stanislav Kinsburskii <[email protected]> • #54370
[PATCH v10 0/8] mm/hmm: Add mmap lock-drop support for userfaultfd-backed mappings
Wed, 22 Jul 2026 14:44:22 -0700
Stanislav Kinsburskii <[email protected]> • #54369
Re: [PATCH v9 8/8] drm/gpusvm: Use hmm_range_fault_unlocked_timeout() for range faults
Wed, 22 Jul 2026 11:52:38 -0700
Stanislav Kinsburskii <[email protected]> • #54368
Re: [PATCH v2 13/13] mm/mremap: convert mremap code to use vma_flags_t
Wed, 22 Jul 2026 18:15:11 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #54367
Re: [PATCH v2 12/13] mm/mprotect: convert mprotect code to use vma_flags_t
Wed, 22 Jul 2026 18:09:16 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #54366
Re: [PATCH v2 11/13] mm/mlock: convert mlock code to use vma_flags_t
Wed, 22 Jul 2026 18:07:58 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #54365
Re: [PATCH v2 10/13] mm/vma: convert miscellaneous uses of VMA flags in core mm
Wed, 22 Jul 2026 18:04:19 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #54364
Re: [PATCH v2 09/13] mm/vma: update create_init_stack_vma() to use vma_flags_t
Wed, 22 Jul 2026 17:52:36 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #54363
Re: [PATCH v2 08/13] mm: introduce vma_get_page_prot() and use it
Wed, 22 Jul 2026 17:42:49 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #54362
Re: [PATCH v2 07/13] mm/vma: rename vma_get_page_prot to vma_flags_to_page_prot
Wed, 22 Jul 2026 16:36:00 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #54361
Re: [PATCH v2 06/13] mm/vma: convert vm_pgprot_modify() to use vma_flags_t and rename
Wed, 22 Jul 2026 16:34:51 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #54360
Re: [PATCH v2 05/13] mm: prefer mm->def_vma_flags in mm logic
Wed, 22 Jul 2026 16:31:22 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #54359
Re: [PATCH v2 04/13] mm: update generic_get_unmapped_area[_topdown]() to use vma_flags_t
Wed, 22 Jul 2026 16:19:34 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #54358
Re: [PATCH v2 03/13] mm: convert __get_unmapped_area() to use vma_flags_t
Wed, 22 Jul 2026 16:17:43 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #54357
Re: [PATCH] drm/nouveau/gsp: validate sequencer command span
Wed, 22 Jul 2026 13:36:47 +0000
Timur Tabi <[email protected]> • #54356
Re: [PATCH v2 02/13] mm/vma: update do_mmap() to use vma_flags_t
Wed, 22 Jul 2026 15:33:53 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #54355
Re: [PATCH v2 01/13] mm: introduce vma_flags_can_grow() and vma_can_grow()
Wed, 22 Jul 2026 15:26:25 +0200
"Vlastimil Babka (SUSE)" <[email protected]> • #54354
[PATCH] drm/nouveau/gsp: validate sequencer command span
Wed, 22 Jul 2026 12:21:23 +0800
Pengpeng Hou <[email protected]> • #54353
Re: [PATCH] tracing/mmiotrace: fix resource leak on trace_pipe close
Tue, 21 Jul 2026 20:38:43 -0400
Steven Rostedt <[email protected]> • #54352
Re: [PATCH 0/6] drm/nouveau: GSP telemetry via RUSD, and fdinfo telemetry exposure
Wed, 22 Jul 2026 00:46:49 +0400
Mohamed Ahmed <[email protected]> • #54351
Re: [PATCH 0/6] drm/nouveau: GSP telemetry via RUSD, and fdinfo telemetry exposure
Tue, 21 Jul 2026 16:40:43 -0400
[email protected] • #54350
Re: [PATCH 3/6] drm/nouveau: add GSP hwmon support
Tue, 21 Jul 2026 16:36:36 -0400
[email protected] • #54349
Re: [PATCH v2 0/3] drm/nouveau: Fix WARN_ON() from missing blend modes
Tue, 21 Jul 2026 16:08:46 -0400
[email protected] • #54348
Re: [PATCH 3/6] drm/nouveau: add GSP hwmon support
Tue, 21 Jul 2026 23:36:58 +0400
Mohamed Ahmed <[email protected]> • #54347
Re: [PATCH 3/6] drm/nouveau: add GSP hwmon support
Tue, 21 Jul 2026 14:36:11 -0400
[email protected] • #54346
Re: [PATCH 2/6] drm/nouveau/gsp: add RUSD telemetry support
Tue, 21 Jul 2026 14:23:33 -0400
[email protected] • #54345
Re: [PATCH v9 2/8] mm/hmm: add hmm_range_fault_unlocked_timeout() for mmap lock-drop support
Tue, 21 Jul 2026 09:49:31 -0700
Stanislav Kinsburskii <[email protected]> • #54344
Re: [PATCH v9 2/8] mm/hmm: add hmm_range_fault_unlocked_timeout() for mmap lock-drop support
Tue, 21 Jul 2026 17:42:53 +0200
"David Hildenbrand (Arm)" <[email protected]> • #54343
Re: [PATCH v9 1/8] mm/hmm: move page fault handling out of walk callbacks
Tue, 21 Jul 2026 17:19:06 +0200
"David Hildenbrand (Arm)" <[email protected]> • #54342
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.