org.kernel.vger.linux-alpha archive

525 archived articles, newest first (page 3 of 6). Latest articles →

Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Thu, 9 Jul 2026 09:41:18 +0800
Jinjie Ruan <[email protected]> • #15007
Re: [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Thu, 9 Jul 2026 09:20:32 +0800
Jinjie Ruan <[email protected]> • #15006
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Thu, 09 Jul 2026 01:14:24 +0200
Thomas Gleixner <[email protected]> • #15005
Re: [patch 09/18] entry: Remove syscall_enter_from_user_mode()
Thu, 09 Jul 2026 00:08:11 +0200
Thomas Gleixner <[email protected]> • #15004
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Wed, 08 Jul 2026 23:49:57 +0200
Thomas Gleixner <[email protected]> • #15003
Re: [patch 10/18] entry: Use syscall number instead of rereading it
Wed, 08 Jul 2026 17:39:50 -0400
Radu Rendec <[email protected]> • #15002
Re: [patch 09/18] entry: Remove syscall_enter_from_user_mode()
Wed, 08 Jul 2026 17:21:19 -0400
Radu Rendec <[email protected]> • #15001
Re: [patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 16:59:18 -0400
Radu Rendec <[email protected]> • #15000
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 16:57:51 -0400
Radu Rendec <[email protected]> • #14999
Re: [patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 16:57:00 -0400
Radu Rendec <[email protected]> • #14998
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Wed, 08 Jul 2026 22:34:38 +0200
Thomas Gleixner <[email protected]> • #14997
Re: [patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 14:37:13 -0400
Radu Rendec <[email protected]> • #14996
Re: [patch 05/18] powerpc/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 14:35:48 -0400
Radu Rendec <[email protected]> • #14995
Re: [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 13:26:19 -0400
Radu Rendec <[email protected]> • #14994
Re: [patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
Wed, 08 Jul 2026 13:24:33 -0400
Radu Rendec <[email protected]> • #14993
Re: [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Wed, 08 Jul 2026 13:22:58 -0400
Radu Rendec <[email protected]> • #14992
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Wed, 8 Jul 2026 18:04:19 +0200
Oleg Nesterov <[email protected]> • #14991
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Wed, 8 Jul 2026 17:52:42 +0200
Michal Suchánek <[email protected]> • #14990
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Wed, 8 Jul 2026 17:46:24 +0200
Oleg Nesterov <[email protected]> • #14989
Re: [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Wed, 8 Jul 2026 19:37:51 +0530
Shrikanth Hegde <[email protected]> • #14988
Re: [PATCH v2] alpha/PCI: Fix I/O port accessor argument order in pci_legacy_write()
Wed, 8 Jul 2026 12:56:19 +0200
Magnus Lindholm <[email protected]> • #14987
Re: [patch 18/18] entry, treewide: Make syscall_enter_from_user_mode[_work]() indicate syscall execution
Wed, 08 Jul 2026 11:16:25 +0200
Thomas Gleixner <[email protected]> • #14986
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Wed, 08 Jul 2026 11:15:10 +0200
Thomas Gleixner <[email protected]> • #14985
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Wed, 08 Jul 2026 08:47:15 +0200
Sven Schnelle <[email protected]> • #14984
Re: [patch 18/18] entry, treewide: Make syscall_enter_from_user_mode[_work]() indicate syscall execution
Wed, 8 Jul 2026 10:51:56 +0530
Shrikanth Hegde <[email protected]> • #14983
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Wed, 8 Jul 2026 09:43:46 +0800
Jinjie Ruan <[email protected]> • #14982
[patch 18/18] entry, treewide: Make syscall_enter_from_user_mode[_work]() indicate syscall execution
Tue, 07 Jul 2026 21:07:09 +0200
Thomas Gleixner <[email protected]> • #14981
[patch 17/18] x86/entry: Simplify the syscall number logic
Tue, 07 Jul 2026 21:07:05 +0200
Thomas Gleixner <[email protected]> • #14980
[patch 16/18] x86/entry: Get rid of the sys_ni_syscall() indirection
Tue, 07 Jul 2026 21:07:01 +0200
Thomas Gleixner <[email protected]> • #14979
[patch 15/18] x86/entry: Make syscall functions static
Tue, 07 Jul 2026 21:06:57 +0200
Thomas Gleixner <[email protected]> • #14978
[patch 14/18] entry: Make return type of syscall_trace_enter() bool
Tue, 07 Jul 2026 21:06:53 +0200
Thomas Gleixner <[email protected]> • #14977
[patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Tue, 07 Jul 2026 21:06:44 +0200
Thomas Gleixner <[email protected]> • #14976
[patch 13/18] entry: Make trace_syscall_enter() return type bool
Tue, 07 Jul 2026 21:06:48 +0200
Thomas Gleixner <[email protected]> • #14975
[patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Tue, 07 Jul 2026 21:06:40 +0200
Thomas Gleixner <[email protected]> • #14974
[patch 10/18] entry: Use syscall number instead of rereading it
Tue, 07 Jul 2026 21:06:36 +0200
Thomas Gleixner <[email protected]> • #14973
[patch 09/18] entry: Remove syscall_enter_from_user_mode()
Tue, 07 Jul 2026 21:06:32 +0200
Thomas Gleixner <[email protected]> • #14972
[patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:27 +0200
Thomas Gleixner <[email protected]> • #14971
[patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:23 +0200
Thomas Gleixner <[email protected]> • #14970
[patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:19 +0200
Thomas Gleixner <[email protected]> • #14969
[patch 05/18] powerpc/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:15 +0200
Thomas Gleixner <[email protected]> • #14968
[patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:11 +0200
Thomas Gleixner <[email protected]> • #14967
[patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Tue, 07 Jul 2026 21:06:07 +0200
Thomas Gleixner <[email protected]> • #14966
[patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
Tue, 07 Jul 2026 21:06:02 +0200
Thomas Gleixner <[email protected]> • #14965
[patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Tue, 07 Jul 2026 21:05:58 +0200
Thomas Gleixner <[email protected]> • #14964
[patch 00/18] entry: Consolidate and rework syscall entry handling
Tue, 07 Jul 2026 21:05:53 +0200
Thomas Gleixner <[email protected]> • #14963
Re: [PATCH v8 00/25] PCI: Convert all dynamic sysfs attributes to static
Tue, 7 Jul 2026 02:59:36 +0900
Krzysztof Wilczyński <[email protected]> • #14962
[PATCH v2] alpha/PCI: Fix I/O port accessor argument order in pci_legacy_write()
Mon, 6 Jul 2026 17:54:23 +0000
Krzysztof Wilczyński <[email protected]> • #14961
[PATCH v4 7/7] alpha: enable GENERIC_ENTRY
Mon, 6 Jul 2026 18:56:48 +0200
Magnus Lindholm <[email protected]> • #14960
[PATCH v4 6/7] alpha: enable lockdep hardirq state tracking
Mon, 6 Jul 2026 18:56:47 +0200
Magnus Lindholm <[email protected]> • #14959
[PATCH v4 5/7] alpha: use raw spinlocks for low-level platform locks
Mon, 6 Jul 2026 18:56:46 +0200
Magnus Lindholm <[email protected]> • #14958
[PATCH v4 4/7] alpha: provide ftrace return address support for lockdep
Mon, 6 Jul 2026 18:56:45 +0200
Magnus Lindholm <[email protected]> • #14957
[PATCH v4 1/7] alpha: enable regset-based ptrace and core dumps
Mon, 6 Jul 2026 18:56:42 +0200
Magnus Lindholm <[email protected]> • #14956
[PATCH v4 3/7] alpha: make irqflags helpers operate on IPL state
Mon, 6 Jul 2026 18:56:44 +0200
Magnus Lindholm <[email protected]> • #14955
[PATCH v4 2/7] alpha: add ARCH_STACKWALK-based stacktrace support
Mon, 6 Jul 2026 18:56:43 +0200
Magnus Lindholm <[email protected]> • #14954
[PATCH v4 0/7] alpha: enable generic entry infrastructure
Mon, 6 Jul 2026 18:56:41 +0200
Magnus Lindholm <[email protected]> • #14953
Re: [PATCH v16 01/18] seccomp: Convert __secure_computing() to return boolean
Mon, 6 Jul 2026 10:41:16 +0800
Jinjie Ruan <[email protected]> • #14952
Re: [PATCH v3 8/8] alpha: enable GENERIC_ENTRY and GENERIC_IRQ_ENTRY
Sun, 5 Jul 2026 16:07:15 +0200
Magnus Lindholm <[email protected]> • #14951
Re: [PATCH v16 01/18] seccomp: Convert __secure_computing() to return boolean
Fri, 3 Jul 2026 23:32:21 +0200
Linus Walleij <[email protected]> • #14950
Re: [PATCH v16 01/18] seccomp: Convert __secure_computing() to return boolean
Fri, 03 Jul 2026 14:01:29 -0700
"H. Peter Anvin" <[email protected]> • #14949
Re: [PATCH v16 01/18] seccomp: Convert __secure_computing() to return boolean
Fri, 03 Jul 2026 22:52:43 +0200
Thomas Gleixner <[email protected]> • #14948
Re: [PATCH v16 01/18] seccomp: Convert __secure_computing() to return boolean
Fri, 3 Jul 2026 13:59:21 +0200
Kevin Brodsky <[email protected]> • #14947
Re: [PATCH v16 02/18] syscall_user_dispatch: Introduce a weak fallback for arch_syscall_is_vdso_sigreturn()
Fri, 3 Jul 2026 12:43:53 +0100
Mark Rutland <[email protected]> • #14946
Re: [PATCH v16 02/18] syscall_user_dispatch: Introduce a weak fallback for arch_syscall_is_vdso_sigreturn()
Fri, 3 Jul 2026 16:43:11 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #14945
Re: [PATCH v16 01/18] seccomp: Convert __secure_computing() to return boolean
Fri, 3 Jul 2026 12:27:26 +0200
Michal Suchánek <[email protected]> • #14944
Re: [PATCH v16 01/18] seccomp: Convert __secure_computing() to return boolean
Fri, 3 Jul 2026 11:00:11 +0100
Mark Rutland <[email protected]> • #14943
Re: [PATCH v16 01/18] seccomp: Convert __secure_computing() to return boolean
Fri, 03 Jul 2026 11:48:49 +0200
Thomas Gleixner <[email protected]> • #14942
Re: [PATCH v16 01/18] seccomp: Convert __secure_computing() to return boolean
Fri, 3 Jul 2026 09:51:04 +0200
Michal Suchánek <[email protected]> • #14941
Re: [PATCH v16 01/18] seccomp: Convert __secure_computing() to return boolean
Tue, 30 Jun 2026 17:37:39 +0100
Ada Couprie Diaz <[email protected]> • #14940
Re: [PATCH v16 18/18] arm64: vdso: Expose sigreturn address on vdso to the kernel
Tue, 30 Jun 2026 17:32:04 +0200
Thomas Weißschuh <[email protected]> • #14939
[PATCH v16 18/18] arm64: vdso: Expose sigreturn address on vdso to the kernel
Mon, 29 Jun 2026 21:06:16 +0800
Jinjie Ruan <[email protected]> • #14938
[PATCH v16 17/18] arm64: Inline el0_svc_common()
Mon, 29 Jun 2026 21:06:15 +0800
Jinjie Ruan <[email protected]> • #14937
[PATCH v16 16/18] arm64: entry: Convert to generic entry
Mon, 29 Jun 2026 21:06:14 +0800
Jinjie Ruan <[email protected]> • #14936
[PATCH v16 13/18] arm64: syscall: Simplify el0_svc_common() syscall exit path
Mon, 29 Jun 2026 21:06:11 +0800
Jinjie Ruan <[email protected]> • #14935
[PATCH v16 15/18] arm64: ptrace: Skip syscall exit reporting for PTRACE_SYSEMU_SINGLESTEP
Mon, 29 Jun 2026 21:06:13 +0800
Jinjie Ruan <[email protected]> • #14934
[PATCH v16 12/18] arm64: syscall: Use exit-specific flags check in el0_svc_common()
Mon, 29 Jun 2026 21:06:10 +0800
Jinjie Ruan <[email protected]> • #14933
[PATCH v16 14/18] arm64: syscall: Simplify syscall exit path in el0_svc_common()
Mon, 29 Jun 2026 21:06:12 +0800
Jinjie Ruan <[email protected]> • #14932
[PATCH v16 11/18] arm64: ptrace: Align syscall exit work semantics with generic entry
Mon, 29 Jun 2026 21:06:09 +0800
Jinjie Ruan <[email protected]> • #14931
[PATCH v16 10/18] arm64: ptrace: Extract syscall_exit_to_user_mode_work() helper
Mon, 29 Jun 2026 21:06:08 +0800
Jinjie Ruan <[email protected]> • #14930
[PATCH v16 09/18] arm64: syscall: Rework the syscall exit path in el0_svc_common()
Mon, 29 Jun 2026 21:06:07 +0800
Jinjie Ruan <[email protected]> • #14929
[PATCH v16 08/18] arm64: ptrace: Rename syscall_trace_exit() to syscall_exit_work()
Mon, 29 Jun 2026 21:06:06 +0800
Jinjie Ruan <[email protected]> • #14928
[PATCH v16 06/18] arm64: ptrace: Use syscall_get_arguments() helper for audit
Mon, 29 Jun 2026 21:06:04 +0800
Jinjie Ruan <[email protected]> • #14927
[PATCH v16 07/18] arm64: ptrace: Protect rseq_syscall() from tracer PC modifications
Mon, 29 Jun 2026 21:06:05 +0800
Jinjie Ruan <[email protected]> • #14926
[PATCH v16 04/18] arm64: ptrace: Use syscall_get_nr() helper for syscall_trace_enter()
Mon, 29 Jun 2026 21:06:02 +0800
Jinjie Ruan <[email protected]> • #14925
[PATCH v16 05/18] arm64: ptrace: Expand secure_computing() in place
Mon, 29 Jun 2026 21:06:03 +0800
Jinjie Ruan <[email protected]> • #14924
[PATCH v16 03/18] arm64: ptrace: Pass thread flags to syscall_trace_enter/exit()
Mon, 29 Jun 2026 21:06:01 +0800
Jinjie Ruan <[email protected]> • #14923
[PATCH v16 02/18] syscall_user_dispatch: Introduce a weak fallback for arch_syscall_is_vdso_sigreturn()
Mon, 29 Jun 2026 21:06:00 +0800
Jinjie Ruan <[email protected]> • #14922
[PATCH v16 01/18] seccomp: Convert __secure_computing() to return boolean
Mon, 29 Jun 2026 21:05:59 +0800
Jinjie Ruan <[email protected]> • #14921
[PATCH v16 00/18] arm64: entry: Convert to Generic Entry
Mon, 29 Jun 2026 21:05:58 +0800
Jinjie Ruan <[email protected]> • #14920
Re: [PATCH v8 00/25] PCI: Convert all dynamic sysfs attributes to static
Sat, 20 Jun 2026 03:39:03 +0900
Krzysztof Wilczyński <[email protected]> • #14919
[PATCH v8 25/25] PCI/sysfs: Limit BAR resize attribute scope to platforms with PCI mmap
Fri, 19 Jun 2026 08:52:00 +0000
Krzysztof Wilczyński <[email protected]> • #14918
[PATCH v8 24/25] PCI/sysfs: Remove pci_create_legacy_files() and pci_sysfs_init()
Fri, 19 Jun 2026 08:51:59 +0000
Krzysztof Wilczyński <[email protected]> • #14917
[PATCH v8 23/25] PCI/sysfs: Convert legacy I/O and memory attributes to static definitions
Fri, 19 Jun 2026 08:51:58 +0000
Krzysztof Wilczyński <[email protected]> • #14916
[PATCH v8 22/25] PCI/sysfs: Add legacy I/O and memory attribute macros
Fri, 19 Jun 2026 08:51:57 +0000
Krzysztof Wilczyński <[email protected]> • #14915
[PATCH v8 21/25] PCI/sysfs: Add __weak pci_legacy_has_sparse() helper
Fri, 19 Jun 2026 08:51:56 +0000
Krzysztof Wilczyński <[email protected]> • #14914
[PATCH v8 20/25] alpha/PCI: Compute legacy size in pci_mmap_legacy_page_range()
Fri, 19 Jun 2026 08:51:55 +0000
Krzysztof Wilczyński <[email protected]> • #14913
[PATCH v8 19/25] PCI: Add macros for legacy I/O and memory address space sizes
Fri, 19 Jun 2026 08:51:54 +0000
Krzysztof Wilczyński <[email protected]> • #14912
[PATCH v8 18/25] PCI/sysfs: Remove pci_{create,remove}_sysfs_dev_files()
Fri, 19 Jun 2026 08:51:53 +0000
Krzysztof Wilczyński <[email protected]> • #14911
[PATCH v8 17/25] alpha/PCI: Convert resource files to static attributes
Fri, 19 Jun 2026 08:51:52 +0000
Krzysztof Wilczyński <[email protected]> • #14910
[PATCH v8 16/25] alpha/PCI: Add static PCI resource attribute macros
Fri, 19 Jun 2026 08:51:51 +0000
Krzysztof Wilczyński <[email protected]> • #14909
[PATCH v8 15/25] alpha/PCI: Remove WARN from __pci_mmap_fits() and __legacy_mmap_fits()
Fri, 19 Jun 2026 08:51:50 +0000
Krzysztof Wilczyński <[email protected]> • #14908
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.