org.kernel.vger.linux-hexagon archive

453 archived articles, newest first (page 4 of 5). Latest articles →

[PATCH v2 03/23] mm/vma: add further vma_flags_t unions
Mon, 16 Mar 2026 13:07:52 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #6429
[PATCH v2 02/23] tools/testing/vma: add unit tests flag empty, diff_pair, and[_mask]
Mon, 16 Mar 2026 13:07:51 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #6428
[PATCH v2 01/23] mm/vma: add vma_flags_empty(), vma_flags_and(), vma_flags_diff_pair()
Mon, 16 Mar 2026 13:07:50 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #6427
[PATCH v2 00/23] mm/vma: convert vm_flags_t to vma_flags_t in vma code
Mon, 16 Mar 2026 13:07:49 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #6426
Re: [PATCH 02/20] tools/testing/vma: add unit tests for vma_flags_[empty, diff_pair, and]()
Thu, 12 Mar 2026 19:30:38 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #6425
[PATCH 02/20] tools/testing/vma: add unit tests flag empty, diff_pair, and[_mask]
Thu, 12 Mar 2026 19:28:57 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #6424
[PATCH 20/20] mm/vma: convert __mmap_region() to use vma_flags_t
Thu, 12 Mar 2026 19:16:18 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #6423
[PATCH 19/20] mm/vma: convert vma_modify_flags[_uffd]() to use vma_flags_t
Thu, 12 Mar 2026 19:16:17 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #6422
[PATCH 18/20] mm/vma: convert as much as we can in mm/vma.c to vma_flags_t
Thu, 12 Mar 2026 19:16:16 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #6421
[PATCH 17/20] tools/testing/vma: update VMA tests to test vma_clear_flags[_mask]()
Thu, 12 Mar 2026 19:16:15 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #6420
[PATCH 16/20] mm/vma: introduce vma_clear_flags[_mask]()
Thu, 12 Mar 2026 19:16:14 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #6419
[PATCH 15/20] tools/testing/vma: update VMA flag tests to test vma_test[_any_mask]()
Thu, 12 Mar 2026 19:16:13 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #6418
[PATCH 14/20] mm/vma: introduce vma_test[_any[_mask]](), and make inlining consistent
Thu, 12 Mar 2026 19:16:12 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #6417
[PATCH 13/20] mm: convert do_brk_flags() to use vma_flags_t
Thu, 12 Mar 2026 19:16:11 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #6416
[PATCH 12/20] tools/testing/vma: test that legacy flag helpers work correctly
Thu, 12 Mar 2026 19:16:10 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #6415
[PATCH 11/20] mm/vma: introduce [vma_flags,legacy]_to_[legacy,vma_flags]() helpers
Thu, 12 Mar 2026 19:16:09 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #6414
[PATCH 10/20] mm/vma: introduce vma_flags_same[_mask/_pair]()
Thu, 12 Mar 2026 19:16:08 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #6413
[PATCH 09/20] mm: unexport vm_brk_flags() and eliminate vm_flags parameter
Thu, 12 Mar 2026 19:16:07 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #6412
[PATCH 08/20] tools/testing/vma: add simple test for append_vma_flags()
Thu, 12 Mar 2026 19:16:06 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #6411
[PATCH 07/20] mm/vma: add append_vma_flags() helper
Thu, 12 Mar 2026 19:16:05 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #6410
[PATCH 06/20] tools/testing/vma: fix VMA flag tests
Thu, 12 Mar 2026 19:16:04 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #6409
[PATCH 05/20] mm/vma: use new VMA flags for sticky flags logic
Thu, 12 Mar 2026 19:16:03 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #6408
[PATCH 04/20] tools/testing/vma: convert bulk of test code to vma_flags_t
Thu, 12 Mar 2026 19:16:02 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #6407
[PATCH 03/20] mm/vma: add further vma_flags_t unions
Thu, 12 Mar 2026 19:16:01 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #6406
[PATCH 02/20] tools/testing/vma: add unit tests for vma_flags_[empty, diff_pair, and]()
Thu, 12 Mar 2026 19:16:00 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #6405
[PATCH 01/20] mm/vma: add vma_flags_empty(), vma_flags_and(), vma_flags_diff_pair()
Thu, 12 Mar 2026 19:15:59 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #6404
[PATCH 00/20] mm/vma: convert vm_flags_t to vma_flags_t in vma code
Thu, 12 Mar 2026 19:15:58 +0000
"Lorenzo Stoakes (Oracle)" <[email protected]> • #6403
Re: [PATCH 0/9] kbuild: uapi: remove usage of toolchain headers
Thu, 12 Mar 2026 13:08:47 +0100
Nicolas Schier <[email protected]> • #6402
Re: [PATCH 0/9] kbuild: uapi: remove usage of toolchain headers
Mon, 9 Mar 2026 18:00:21 -0700
Nathan Chancellor <[email protected]> • #6401
Re: [PATCH 0/9] kbuild: uapi: remove usage of toolchain headers
Thu, 05 Mar 2026 10:41:55 +0100
Nicolas Schier <[email protected]> • #6400
Re: [PATCH] kbuild: Split .modinfo out from ELF_DETAILS
Wed, 04 Mar 2026 17:36:32 -0700
Nathan Chancellor <[email protected]> • #6399
Re: [PATCH v3 23/29] arch, mm: consolidate initialization of nodes, zones and memory map
Fri, 27 Feb 2026 22:31:41 +0200
Mike Rapoport <[email protected]> • #6398
Re: [PATCH v3 23/29] arch, mm: consolidate initialization of nodes, zones and memory map
Fri, 27 Feb 2026 16:14:42 +0100
Vlastimil Babka <[email protected]> • #6397
Re: [PATCH 0/9] kbuild: uapi: remove usage of toolchain headers
Fri, 27 Feb 2026 11:04:51 +0100
"Arnd Bergmann" <[email protected]> • #6396
Re: [PATCH 0/9] kbuild: uapi: remove usage of toolchain headers
Fri, 27 Feb 2026 10:38:20 +0100
Thomas Weißschuh <[email protected]> • #6395
Re: [PATCH 0/9] kbuild: uapi: remove usage of toolchain headers
Fri, 27 Feb 2026 10:18:41 +0100
"Arnd Bergmann" <[email protected]> • #6394
[PATCH 9/9] kbuild: uapi: remove now unneeded guard headers
Fri, 27 Feb 2026 07:38:07 +0100
Thomas Weißschuh <[email protected]> • #6393
[PATCH 6/9] kbuild: uapi: provide stub includes for some libc headers
Fri, 27 Feb 2026 07:38:04 +0100
Thomas Weißschuh <[email protected]> • #6392
[PATCH 8/9] kbuild: uapi: simplify libc dependency logic
Fri, 27 Feb 2026 07:38:06 +0100
Thomas Weißschuh <[email protected]> • #6391
[PATCH 7/9] kbuild: uapi: use custom stub headers instead of libc ones
Fri, 27 Feb 2026 07:38:05 +0100
Thomas Weißschuh <[email protected]> • #6390
[PATCH 4/9] kbuild: uapi: completely exclude linux/bpf_perf_event.h on nios2
Fri, 27 Feb 2026 07:38:02 +0100
Thomas Weißschuh <[email protected]> • #6389
[PATCH 5/9] kbuild: uapi: only use dummy-include for headers which use libc
Fri, 27 Feb 2026 07:38:03 +0100
Thomas Weißschuh <[email protected]> • #6388
[PATCH 3/9] kbuild: uapi: deduplicate linux/bpf_perf_event.h exclusions
Fri, 27 Feb 2026 07:38:01 +0100
Thomas Weißschuh <[email protected]> • #6387
[PATCH 1/9] hexagon: uapi: Fix structure alignment attribute
Fri, 27 Feb 2026 07:37:59 +0100
Thomas Weißschuh <[email protected]> • #6386
[PATCH 0/9] kbuild: uapi: remove usage of toolchain headers
Fri, 27 Feb 2026 07:37:58 +0100
Thomas Weißschuh <[email protected]> • #6385
[PATCH 2/9] kbuild: uapi: test linux/bpf_perf_event.h on powerpc
Fri, 27 Feb 2026 07:38:00 +0100
Thomas Weißschuh <[email protected]> • #6384
[PATCH] kbuild: Split .modinfo out from ELF_DETAILS
Wed, 25 Feb 2026 15:02:51 -0700
Nathan Chancellor <[email protected]> • #6383
Re: [PATCH v3 24/29] arch, mm: consolidate initialization of SPARSE memory model
Wed, 25 Feb 2026 23:08:38 +0530
Ritesh Harjani (IBM) <[email protected]> • #6382
Re: [PATCH v3 24/29] arch, mm: consolidate initialization of SPARSE memory model
Wed, 25 Feb 2026 18:25:24 +0200
Mike Rapoport <[email protected]> • #6381
Re: [PATCH v3 24/29] arch, mm: consolidate initialization of SPARSE memory model
Wed, 25 Feb 2026 09:00:35 +0530
Ritesh Harjani (IBM) <[email protected]> • #6380
Re: [PATCH v2 4/4] mm: cache struct page for empty_zero_page and return it from ZERO_PAGE()
Mon, 23 Feb 2026 17:20:13 +0100
"David Hildenbrand (Arm)" <[email protected]> • #6379
Re: [PATCH v2 3/4] arch, mm: consolidate empty_zero_page
Mon, 23 Feb 2026 17:18:24 +0100
"David Hildenbrand (Arm)" <[email protected]> • #6378
Re: [PATCH v2 1/4] mm: don't special case !MMU for is_zero_pfn() and my_zero_pfn()
Mon, 23 Feb 2026 17:16:05 +0100
"David Hildenbrand (Arm)" <[email protected]> • #6377
Re: [PATCH 3.5] arm: make initialization of zero page independent of the memory map (was Re: [PATCH v2 22/28] arch, mm: consolidate initialization of nodes, zones and memory map)
Fri, 20 Feb 2026 04:11:02 +0000
[email protected] • #6376
Re: [PATCH v3 00/29] arch, mm: consolidate hugetlb early reservation
Fri, 20 Feb 2026 04:10:42 +0000
[email protected] • #6375
Re: [PATCH] media: rockchip: Disable VIDEO_ROCKCHIP_VDEC when compile testing for Hexagon
Mon, 16 Feb 2026 11:17:30 -0500
Nicolas Dufresne <[email protected]> • #6374
[PATCH] media: rockchip: Disable VIDEO_ROCKCHIP_VDEC when compile testing for Hexagon
Fri, 13 Feb 2026 15:10:06 -0500
Nathan Chancellor <[email protected]> • #6373
Re: [PATCH v3 4/4] mm: cache struct page for empty_zero_page and return it from ZERO_PAGE()
Thu, 12 Feb 2026 13:40:04 -0500
"Liam R. Howlett" <[email protected]> • #6372
Re: [PATCH v3 3/4] arch, mm: consolidate empty_zero_page
Thu, 12 Feb 2026 13:38:16 -0500
"Liam R. Howlett" <[email protected]> • #6371
Re: [PATCH v3 2/4] mm: rename my_zero_pfn() to zero_pfn()
Thu, 12 Feb 2026 13:33:28 -0500
"Liam R. Howlett" <[email protected]> • #6370
Re: [PATCH v3 1/4] mm: don't special case !MMU for is_zero_pfn() and my_zero_pfn()
Thu, 12 Feb 2026 13:30:20 -0500
"Liam R. Howlett" <[email protected]> • #6369
Re: [PATCH v3 2/4] mm: rename my_zero_pfn() to zero_pfn()
Thu, 12 Feb 2026 16:28:23 +0100
Vlastimil Babka <[email protected]> • #6368
Re: [PATCH v3 4/4] mm: cache struct page for empty_zero_page and return it from ZERO_PAGE()
Thu, 12 Feb 2026 10:08:49 +0100
"David Hildenbrand (Arm)" <[email protected]> • #6367
Re: [PATCH v3 3/4] arch, mm: consolidate empty_zero_page
Thu, 12 Feb 2026 10:04:03 +0100
"David Hildenbrand (Arm)" <[email protected]> • #6366
Re: [PATCH v3 2/4] mm: rename my_zero_pfn() to zero_pfn()
Thu, 12 Feb 2026 10:01:27 +0100
"David Hildenbrand (Arm)" <[email protected]> • #6365
Re: [PATCH v3 1/4] mm: don't special case !MMU for is_zero_pfn() and my_zero_pfn()
Thu, 12 Feb 2026 09:58:24 +0100
"David Hildenbrand (Arm)" <[email protected]> • #6364
Re: [PATCH v3 3/4] arch, mm: consolidate empty_zero_page
Thu, 12 Feb 2026 09:38:42 +0100
Andreas Larsson <[email protected]> • #6363
Re: [PATCH v3 3/4] arch, mm: consolidate empty_zero_page
Wed, 11 Feb 2026 23:33:09 -0600
Dinh Nguyen <[email protected]> • #6362
Re: [PATCH v3 3/4] arch, mm: consolidate empty_zero_page
Wed, 11 Feb 2026 21:14:19 +0100
Magnus Lindholm <[email protected]> • #6361
[PATCH v3 4/4] mm: cache struct page for empty_zero_page and return it from ZERO_PAGE()
Wed, 11 Feb 2026 12:31:41 +0200
Mike Rapoport <[email protected]> • #6360
[PATCH v3 3/4] arch, mm: consolidate empty_zero_page
Wed, 11 Feb 2026 12:31:40 +0200
Mike Rapoport <[email protected]> • #6359
[PATCH v3 2/4] mm: rename my_zero_pfn() to zero_pfn()
Wed, 11 Feb 2026 12:31:39 +0200
Mike Rapoport <[email protected]> • #6358
[PATCH v3 1/4] mm: don't special case !MMU for is_zero_pfn() and my_zero_pfn()
Wed, 11 Feb 2026 12:31:38 +0200
Mike Rapoport <[email protected]> • #6357
[PATCH v3 0/4] arch, mm: consolidate empty_zero_page
Wed, 11 Feb 2026 12:31:37 +0200
Mike Rapoport <[email protected]> • #6356
Re: [PATCH v2 2/4] mm: rename my_zero_pfn() to zero_pfn()
Tue, 10 Feb 2026 17:11:08 +0200
Mike Rapoport <[email protected]> • #6355
Re: [PATCH v2 4/4] mm: cache struct page for empty_zero_page and return it from ZERO_PAGE()
Tue, 10 Feb 2026 15:06:51 +0000
Catalin Marinas <[email protected]> • #6354
Re: [PATCH v2 3/4] arch, mm: consolidate empty_zero_page
Tue, 10 Feb 2026 15:00:11 +0000
Catalin Marinas <[email protected]> • #6353
Re: [PATCH v2 2/4] mm: rename my_zero_pfn() to zero_pfn()
Tue, 10 Feb 2026 14:52:56 +0000
Lorenzo Stoakes <[email protected]> • #6352
Re: [PATCH v2 2/4] mm: rename my_zero_pfn() to zero_pfn()
Tue, 10 Feb 2026 16:50:00 +0200
Mike Rapoport <[email protected]> • #6351
Re: [PATCH v2 3/4] arch, mm: consolidate empty_zero_page
Mon, 9 Feb 2026 07:20:09 -0800
Dave Hansen <[email protected]> • #6350
Re: [PATCH v2 2/4] mm: rename my_zero_pfn() to zero_pfn()
Mon, 9 Feb 2026 16:08:32 +0100
"Christophe Leroy (CS GROUP)" <[email protected]> • #6349
[PATCH v2 4/4] mm: cache struct page for empty_zero_page and return it from ZERO_PAGE()
Mon, 9 Feb 2026 16:40:57 +0200
Mike Rapoport <[email protected]> • #6348
[PATCH v2 3/4] arch, mm: consolidate empty_zero_page
Mon, 9 Feb 2026 16:40:56 +0200
Mike Rapoport <[email protected]> • #6347
[PATCH v2 2/4] mm: rename my_zero_pfn() to zero_pfn()
Mon, 9 Feb 2026 16:40:55 +0200
Mike Rapoport <[email protected]> • #6346
[PATCH v2 1/4] mm: don't special case !MMU for is_zero_pfn() and my_zero_pfn()
Mon, 9 Feb 2026 16:40:54 +0200
Mike Rapoport <[email protected]> • #6345
[PATCH v2 0/4] arch, mm: consolidate empty_zero_page
Mon, 9 Feb 2026 16:40:53 +0200
Mike Rapoport <[email protected]> • #6344
Re: [PATCH mm-unstable] arch, mm: consolidate empty_zero_page
Mon, 9 Feb 2026 09:41:08 +0100
Andreas Larsson <[email protected]> • #6343
Re: [PATCH mm-unstable] arch, mm: consolidate empty_zero_page
Sat, 7 Feb 2026 12:36:43 +0200
Mike Rapoport <[email protected]> • #6342
Re: [PATCH mm-unstable] arch, mm: consolidate empty_zero_page
Wed, 4 Feb 2026 21:47:13 +0100
"David Hildenbrand (arm)" <[email protected]> • #6341
Re: [PATCH mm-unstable] arch, mm: consolidate empty_zero_page
Tue, 3 Feb 2026 11:17:08 +0100
Andreas Larsson <[email protected]> • #6340
Re: [PATCH mm-unstable] arch, mm: consolidate empty_zero_page
Tue, 27 Jan 2026 20:11:19 +0200
Mike Rapoport <[email protected]> • #6339
Re: [PATCH mm-unstable] arch, mm: consolidate empty_zero_page
Tue, 27 Jan 2026 17:02:39 +0100
Andreas Larsson <[email protected]> • #6338
Re: [PATCH mm-unstable] arch, mm: consolidate empty_zero_page
Sat, 24 Jan 2026 11:15:47 +0100
"Christophe Leroy (CS GROUP)" <[email protected]> • #6337
[PATCH mm-unstable] arch, mm: consolidate empty_zero_page
Sat, 24 Jan 2026 11:56:28 +0200
Mike Rapoport <[email protected]> • #6336
Re: [PATCH] mm/pgtable: convert pgtable_t to ptdesc pointer
Sun, 18 Jan 2026 22:10:50 +0800
Alex Shi <[email protected]> • #6335
Re: [PATCH] mm/pgtable: convert pgtable_t to ptdesc pointer
Sun, 18 Jan 2026 11:51:01 +0100
"David Hildenbrand (Red Hat)" <[email protected]> • #6334
Re: [PATCH] mm/pgtable: convert pgtable_t to ptdesc pointer
Sun, 18 Jan 2026 16:13:47 +0800
Alex Shi <[email protected]> • #6333
Re: [PATCH v3 15/29] powerpc: introduce arch_zone_limits_init()
Tue, 13 Jan 2026 17:59:49 +0530
Ritesh Harjani (IBM) <[email protected]> • #6332
Re: [PATCH v3 19/29] sparc: introduce arch_zone_limits_init()
Tue, 13 Jan 2026 13:28:09 +0100
Andreas Larsson <[email protected]> • #6331
Re: [PATCH v3 00/29] arch, mm: consolidate hugetlb early reservation
Tue, 13 Jan 2026 10:40:22 +0200
Kalle Niemi <[email protected]> • #6330
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.