org.kernel.vger.linux-sh archive

488 archived articles, newest first (page 2 of 5). Latest articles →

Re: Toybox make root no longer works as expected
Tue, 14 Jul 2026 14:32:55 -0500
Rob Landley <[email protected]> • #68786
Re: Toybox make root no longer works as expected
Tue, 14 Jul 2026 12:46:29 +0200
Florian Fuchs <[email protected]> • #68785
[PATCH] sh: lib: Restore r4 in shift helpers
Tue, 14 Jul 2026 12:41:47 +0200
Florian Fuchs <[email protected]> • #68784
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Tue, 14 Jul 2026 10:20:20 +0200
Michal Suchánek <[email protected]> • #68783
Re: Toybox make root no longer works as expected
Tue, 14 Jul 2026 10:14:20 +0200
John Paul Adrian Glaubitz <[email protected]> • #68782
Re: Toybox make root no longer works as expected
Tue, 14 Jul 2026 09:47:44 +0200
Florian Fuchs <[email protected]> • #68781
[RESEND PATCH] sh: ecovec24: use static device properties to describe the touchscreen
Mon, 13 Jul 2026 14:41:31 -0700
Dmitry Torokhov <[email protected]> • #68780
Re: [patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Mon, 13 Jul 2026 15:06:10 +0800
Guo Ren <[email protected]> • #68779
Re: [PATCH v2 02/10] m68k/coldfire: replace linux/gpio.h inclusions
Sun, 12 Jul 2026 22:27:19 +1000
Greg Ungerer <[email protected]> • #68778
Re: Toybox make root no longer works as expected
Sun, 12 Jul 2026 03:02:06 -0500
Rob Landley <[email protected]> • #68777
Re: Toybox make root no longer works as expected
Sun, 12 Jul 2026 15:00:25 +0900
"D. Jeff Dionne" <[email protected]> • #68776
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Sat, 11 Jul 2026 22:33:16 +0200
Thomas Gleixner <[email protected]> • #68775
Re: [PATCH v2 00/10] treewide: replace linux/gpio.h
Sat, 11 Jul 2026 17:56:40 +0200
Linus Walleij <[email protected]> • #68774
Re: [PATCH v2 06/10] ASoC: replace linux/gpio.h inclusions
Sat, 11 Jul 2026 13:57:39 +0100
Charles Keepax <[email protected]> • #68773
Re: [PATCH v2 05/10] mfd: replace linux/gpio.h inclusions
Sat, 11 Jul 2026 13:56:52 +0100
Charles Keepax <[email protected]> • #68772
Re: [patch 00/18] entry: Consolidate and rework syscall entry handling
Sat, 11 Jul 2026 14:29:12 +0200
Magnus Lindholm <[email protected]> • #68771
Re: [PATCH v2 0/5] rsk7203: switch to using static device property, drop legacy gpio API
Sat, 11 Jul 2026 11:44:36 +0300
Andy Shevchenko <[email protected]> • #68770
Re: [PATCH v2 06/10] ASoC: replace linux/gpio.h inclusions
Sat, 11 Jul 2026 10:34:19 +0300
Sergey Shtylyov <[email protected]> • #68769
Re: [PATCH v2 0/5] rsk7203: switch to using static device property, drop legacy gpio API
Sat, 11 Jul 2026 07:14:48 +0200
John Paul Adrian Glaubitz <[email protected]> • #68768
Re: [PATCH v2 09/10] Input: matrix_keyboard - replace linux/gpio.h inclusion
Fri, 10 Jul 2026 21:49:31 -0700
Dmitry Torokhov <[email protected]> • #68767
[PATCH] sh: Fix built-in DTB build with generic rule
Sat, 11 Jul 2026 02:01:46 +0200
Florian Fuchs <[email protected]> • #68766
[PATCH v2 09/10] Input: matrix_keyboard - replace linux/gpio.h inclusion
Fri, 10 Jul 2026 23:19:54 +0200
Arnd Bergmann <[email protected]> • #68765
[PATCH v2 08/10] phy: replace linux/gpio.h inclusions
Fri, 10 Jul 2026 23:19:53 +0200
Arnd Bergmann <[email protected]> • #68764
[PATCH v2 07/10] pcmcia: replace linux/gpio.h inclusions
Fri, 10 Jul 2026 23:19:52 +0200
Arnd Bergmann <[email protected]> • #68763
[PATCH v2 06/10] ASoC: replace linux/gpio.h inclusions
Fri, 10 Jul 2026 23:19:51 +0200
Arnd Bergmann <[email protected]> • #68762
[PATCH v2 05/10] mfd: replace linux/gpio.h inclusions
Fri, 10 Jul 2026 23:19:50 +0200
Arnd Bergmann <[email protected]> • #68761
[PATCH v2 04/10] sh: replace linux/gpio.h inclusions
Fri, 10 Jul 2026 23:19:49 +0200
Arnd Bergmann <[email protected]> • #68760
[PATCH v2 03/10] mips: replace linux/gpio.h inclusions
Fri, 10 Jul 2026 23:19:48 +0200
Arnd Bergmann <[email protected]> • #68759
[PATCH v2 02/10] m68k/coldfire: replace linux/gpio.h inclusions
Fri, 10 Jul 2026 23:19:47 +0200
Arnd Bergmann <[email protected]> • #68758
[PATCH v2 01/10] ARM: replace linux/gpio.h inclusions
Fri, 10 Jul 2026 23:19:46 +0200
Arnd Bergmann <[email protected]> • #68757
[PATCH v2 00/10] treewide: replace linux/gpio.h
Fri, 10 Jul 2026 23:19:45 +0200
Arnd Bergmann <[email protected]> • #68756
[PATCH 6/6] [v6] gpiolib: turn off legacy interface by default
Fri, 10 Jul 2026 23:18:54 +0200
Arnd Bergmann <[email protected]> • #68755
[PATCH 5/6] [v6] x86/olpc: select GPIOLIB_LEGACY
Fri, 10 Jul 2026 23:18:53 +0200
Arnd Bergmann <[email protected]> • #68754
[PATCH 4/6] [v6] sh: select legacy gpiolib interface
Fri, 10 Jul 2026 23:18:52 +0200
Arnd Bergmann <[email protected]> • #68753
[PATCH 3/6] [v6] leds: gpio: make legacy gpiolib interface optional
Fri, 10 Jul 2026 23:18:51 +0200
Arnd Bergmann <[email protected]> • #68752
[PATCH 2/6] [v6] Input: gpio-keys: make legacy gpiolib optional
Fri, 10 Jul 2026 23:18:50 +0200
Arnd Bergmann <[email protected]> • #68751
[PATCH 1/6] [v6] Input: soc_button_array - select CONFIG_GPIOLIB_LEGACY
Fri, 10 Jul 2026 23:18:49 +0200
Arnd Bergmann <[email protected]> • #68750
[PATCH v6 0/6] gpiolib: fence off legacy interfaces
Fri, 10 Jul 2026 23:18:48 +0200
Arnd Bergmann <[email protected]> • #68749
Re: [PATCH v2 0/5] rsk7203: switch to using static device property, drop legacy gpio API
Fri, 10 Jul 2026 21:05:40 +0200
Linus Walleij <[email protected]> • #68748
Re: [PATCH 0/2] sh: mach-x3proto: convert gpio-keys to software nodes
Fri, 10 Jul 2026 20:50:20 +0200
Linus Walleij <[email protected]> • #68747
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Fri, 10 Jul 2026 17:20:03 +0200
Michal Suchánek <[email protected]> • #68746
Re: Toybox make root no longer works as expected
Fri, 10 Jul 2026 15:32:40 +0200
John Paul Adrian Glaubitz <[email protected]> • #68745
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Fri, 10 Jul 2026 14:52:40 +0200
Oleg Nesterov <[email protected]> • #68744
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Fri, 10 Jul 2026 14:32:13 +0200
Michal Suchánek <[email protected]> • #68743
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Fri, 10 Jul 2026 13:40:43 +0200
Oleg Nesterov <[email protected]> • #68742
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Fri, 10 Jul 2026 13:16:20 +0200
Oleg Nesterov <[email protected]> • #68741
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Fri, 10 Jul 2026 13:01:02 +0200
Michal Suchánek <[email protected]> • #68740
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Fri, 10 Jul 2026 12:42:29 +0200
Michal Suchánek <[email protected]> • #68739
Re: [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 01:46:15 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #68738
Re: [patch 00/18] entry: Consolidate and rework syscall entry handling
Fri, 10 Jul 2026 01:45:19 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #68737
Re: [patch 18/18] entry, treewide: Make syscall_enter_from_user_mode[_work]() indicate syscall execution
Fri, 10 Jul 2026 01:19:28 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #68736
Re: [patch 15/18] x86/entry: Make syscall functions static
Fri, 10 Jul 2026 01:13:15 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #68735
Re: [patch 14/18] entry: Make return type of syscall_trace_enter() bool
Fri, 10 Jul 2026 01:06:23 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #68734
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Fri, 10 Jul 2026 00:52:35 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #68733
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Fri, 10 Jul 2026 00:40:00 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #68732
Re: [patch 10/18] entry: Use syscall number instead of rereading it
Fri, 10 Jul 2026 00:20:46 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #68731
Re: [patch 09/18] entry: Remove syscall_enter_from_user_mode()
Fri, 10 Jul 2026 00:19:18 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #68730
Re: [patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 00:15:39 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #68729
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 00:13:32 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #68728
Re: [patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 00:12:23 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #68727
Re: [patch 05/18] powerpc/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 00:11:04 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #68726
Re: [patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Fri, 10 Jul 2026 00:10:01 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #68725
Re: [patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
Fri, 10 Jul 2026 00:04:21 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #68724
Re: [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Fri, 10 Jul 2026 00:02:27 +0530
Mukesh Kumar Chaurasiya <[email protected]> • #68723
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Thu, 09 Jul 2026 13:03:28 -0400
Radu Rendec <[email protected]> • #68722
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Thu, 9 Jul 2026 17:26:59 +0100
David Laight <[email protected]> • #68721
Re: [patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
Thu, 9 Jul 2026 09:23:47 -0700
Kees Cook <[email protected]> • #68720
Re: [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
Thu, 9 Jul 2026 09:22:06 -0700
Kees Cook <[email protected]> • #68719
Re: [patch 10/18] entry: Use syscall number instead of rereading it
Thu, 9 Jul 2026 13:22:26 +0200
Philippe Mathieu-Daudé <[email protected]> • #68718
Re: [patch 10/18] entry: Use syscall number instead of rereading it
Thu, 9 Jul 2026 13:20:43 +0200
Philippe Mathieu-Daudé <[email protected]> • #68717
Re: [patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:18:04 +0200
Philippe Mathieu-Daudé <[email protected]> • #68716
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:17:17 +0200
Philippe Mathieu-Daudé <[email protected]> • #68715
Re: [patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:16:51 +0200
Philippe Mathieu-Daudé <[email protected]> • #68714
Re: [patch 05/18] powerpc/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:16:21 +0200
Philippe Mathieu-Daudé <[email protected]> • #68713
Re: [patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:15:55 +0200
Philippe Mathieu-Daudé <[email protected]> • #68712
Re: [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 13:15:11 +0200
Philippe Mathieu-Daudé <[email protected]> • #68711
Re: [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Thu, 9 Jul 2026 13:12:57 +0200
Philippe Mathieu-Daudé <[email protected]> • #68710
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Thu, 9 Jul 2026 10:41:56 +0200
Geert Uytterhoeven <[email protected]> • #68709
Re: [PATCH v16 18/18] arm64: vdso: Expose sigreturn address on vdso to the kernel
Thu, 9 Jul 2026 10:27:59 +0200
Thomas Weißschuh <[email protected]> • #68708
Re: [PATCH v16 18/18] arm64: vdso: Expose sigreturn address on vdso to the kernel
Thu, 9 Jul 2026 16:15:15 +0800
Jinjie Ruan <[email protected]> • #68707
Re: [PATCH v16 18/18] arm64: vdso: Expose sigreturn address on vdso to the kernel
Thu, 9 Jul 2026 09:17:33 +0200
Thomas Weißschuh <[email protected]> • #68706
Re: [PATCH v16 18/18] arm64: vdso: Expose sigreturn address on vdso to the kernel
Thu, 9 Jul 2026 14:37:05 +0800
Jinjie Ruan <[email protected]> • #68705
Re: [PATCH v16 02/18] syscall_user_dispatch: Introduce a weak fallback for arch_syscall_is_vdso_sigreturn()
Thu, 9 Jul 2026 14:30:11 +0800
Jinjie Ruan <[email protected]> • #68704
Re: [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 11:46:07 +0800
Jinjie Ruan <[email protected]> • #68703
Re: [patch 10/18] entry: Use syscall number instead of rereading it
Thu, 9 Jul 2026 10:55:27 +0800
Jinjie Ruan <[email protected]> • #68702
Re: [patch 09/18] entry: Remove syscall_enter_from_user_mode()
Thu, 9 Jul 2026 10:49:49 +0800
Jinjie Ruan <[email protected]> • #68701
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:46:44 +0800
Jinjie Ruan <[email protected]> • #68700
Re: [patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:44:48 +0800
Jinjie Ruan <[email protected]> • #68699
Re: [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:39:17 +0800
Jinjie Ruan <[email protected]> • #68698
Re: [patch 06/18] riscv/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:38:38 +0800
Jinjie Ruan <[email protected]> • #68697
Re: [patch 05/18] powerpc/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:38:16 +0800
Jinjie Ruan <[email protected]> • #68696
Re: [patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:37:44 +0800
Jinjie Ruan <[email protected]> • #68695
Re: [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
Thu, 9 Jul 2026 10:34:22 +0800
Jinjie Ruan <[email protected]> • #68694
Re: [patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
Thu, 9 Jul 2026 10:13:11 +0800
Jinjie Ruan <[email protected]> • #68693
Re: [patch 16/18] x86/entry: Get rid of the sys_ni_syscall() indirection
Thu, 9 Jul 2026 10:03:49 +0800
Jinjie Ruan <[email protected]> • #68692
Re: [patch 15/18] x86/entry: Make syscall functions static
Thu, 9 Jul 2026 09:47:56 +0800
Jinjie Ruan <[email protected]> • #68691
Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
Thu, 9 Jul 2026 09:41:18 +0800
Jinjie Ruan <[email protected]> • #68690
Re: [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
Thu, 9 Jul 2026 09:20:32 +0800
Jinjie Ruan <[email protected]> • #68689
Re: [patch 13/18] entry: Make trace_syscall_enter() return type bool
Thu, 09 Jul 2026 01:14:24 +0200
Thomas Gleixner <[email protected]> • #68688
Re: [patch 09/18] entry: Remove syscall_enter_from_user_mode()
Thu, 09 Jul 2026 00:08:11 +0200
Thomas Gleixner <[email protected]> • #68687
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.