org.kernel.vger.bpf archive

1564 archived articles, newest first (page 11 of 16). Latest articles →

[PATCH bpf-next v2 01/13] bpf: Factor check_global_ret_scalar_reg() out of the global return check
Tue, 4 Aug 2026 13:35:27 -0700
Yonghong Song <[email protected]> • #191725
[PATCH v2 00/13] bpf: Support aggregate return values up to 16 bytes
Tue, 4 Aug 2026 13:35:22 -0700
Yonghong Song <[email protected]> • #191724
Re: [PATCH bpf-next v3 5/9] selftests/bpf: Add kfunc __arena and __arena_nullable argument tests
Tue, 04 Aug 2026 13:33:42 -0700
Eduard Zingerman <[email protected]> • #191723
Re: [PATCH bpf-next v3 5/9] selftests/bpf: Add kfunc __arena and __arena_nullable argument tests
Tue, 04 Aug 2026 22:28:00 +0200
"Kumar Kartikeya Dwivedi" <[email protected]> • #191722
Re: [PATCH bpf-next v3 5/9] selftests/bpf: Add kfunc __arena and __arena_nullable argument tests
Tue, 04 Aug 2026 13:26:07 -0700
Eduard Zingerman <[email protected]> • #191721
Re: [PATCH bpf-next v3 5/9] selftests/bpf: Add kfunc __arena and __arena_nullable argument tests
Tue, 04 Aug 2026 13:24:28 -0700
Eduard Zingerman <[email protected]> • #191720
Re: [PATCH dwarves] btf_encoder: Infer arena kfunc arguments from suffixes
Tue, 04 Aug 2026 13:22:04 -0700
Eduard Zingerman <[email protected]> • #191719
[PATCH bpf-next 2/2] selftests/bpf: Add load-acquire test for dst_reg == src_reg from ctx
Tue, 4 Aug 2026 22:19:17 +0200
Daniel Borkmann <[email protected]> • #191718
[PATCH bpf-next 1/2] bpf: Check load-acquire src ptr type before the load
Tue, 4 Aug 2026 22:19:16 +0200
Daniel Borkmann <[email protected]> • #191717
Re: [PATCH bpf-next v3 5/9] selftests/bpf: Add kfunc __arena and __arena_nullable argument tests
Tue, 04 Aug 2026 22:14:49 +0200
"Kumar Kartikeya Dwivedi" <[email protected]> • #191716
Re: [PATCHv3 bpf-next 08/12] bpf: Remove trace_in argument from __bpf_get_stack
Tue, 4 Aug 2026 22:05:33 +0200
Jiri Olsa <[email protected]> • #191715
Re: [PATCHv3 bpf-next 12/12] bpf: Avoid changing callchain in bpf_get_stackid_pe
Tue, 4 Aug 2026 22:05:23 +0200
Jiri Olsa <[email protected]> • #191714
Re: [PATCH bpf-next v3 5/9] selftests/bpf: Add kfunc __arena and __arena_nullable argument tests
Tue, 04 Aug 2026 13:01:36 -0700
Eduard Zingerman <[email protected]> • #191713
Re: [PATCH dwarves] btf_encoder: Infer arena kfunc arguments from suffixes
Tue, 04 Aug 2026 21:27:31 +0200
"Kumar Kartikeya Dwivedi" <[email protected]> • #191712
Re: [PATCH bpf-next v6 3/9] bpf, x86: refactor BPF_ST management in do_jit
Tue, 4 Aug 2026 19:04:32 +0000 (UTC)
[email protected] • #191711
Re: [PATCH bpf-next v6 6/9] selftests/bpf: make cmdline_contains stricter
Tue, 4 Aug 2026 18:49:41 +0000 (UTC)
[email protected] • #191710
Re: [PATCH net-next v3 15/15] gve: add link status/speed ctrl ops
Tue, 04 Aug 2026 18:47:05 +0000
[email protected] • #191709
Re: [PATCH net-next v3 14/15] gve: add ctrl ops to for queue operations
Tue, 04 Aug 2026 18:47:04 +0000
[email protected] • #191708
Re: [PATCH net-next v3 12/15] gve: introduce new methods to handle IRQ doorbells
Tue, 04 Aug 2026 18:47:03 +0000
[email protected] • #191707
Re: [PATCH net-next v3 10/15] gve: add gve_ctrl_ops for gve initialization/teardown sequences
Tue, 04 Aug 2026 18:47:02 +0000
[email protected] • #191706
Re: [PATCH net-next v3 09/15] gve: simplify reset logic
Tue, 04 Aug 2026 18:47:01 +0000
[email protected] • #191705
Re: [PATCH net-next v3 08/15] gve: refactor gve_init_priv for reset path
Tue, 04 Aug 2026 18:47:00 +0000
[email protected] • #191704
Re: [PATCH net-next v3 04/15] gve: add struct gve_device_info to hold device properties
Tue, 04 Aug 2026 18:46:59 +0000
[email protected] • #191703
Re: [PATCH net-next v3 01/15] gve: don't pass in unused parameter to gve_adminq_free
Tue, 04 Aug 2026 18:46:58 +0000
[email protected] • #191702
Re: [PATCH dwarves] btf_encoder: Infer arena kfunc arguments from suffixes
Tue, 4 Aug 2026 11:43:34 -0700
Ihor Solodrai <[email protected]> • #191701
Re: [PATCH bpf-next v6 9/9] selftests/bpf: add tests to validate KASAN on JIT programs
Tue, 04 Aug 2026 18:35:39 +0000
[email protected] • #191700
Re: [PATCH bpf-next v6 4/9] bpf, x86: emit KASAN checks in x86 JITed programs
Tue, 04 Aug 2026 18:10:53 +0000
[email protected] • #191699
Re: [PATCH bpf-next v6 5/9] bpf, x86: enable KASAN for JITed programs on x86
Tue, 04 Aug 2026 18:10:38 +0000
[email protected] • #191698
Re: [RFC PATCH bpf-next v5 6/8] selftests/bpf: extract BPF skeleton generation into a helper script
Tue, 04 Aug 2026 17:59:47 +0000
[email protected] • #191697
Re: [PATCH bpf v2 1/1] bpf: Check sk_state before sk_protocol in bpf_tcp_*_syncookie
Tue, 4 Aug 2026 10:50:31 -0700
Kuniyuki Iwashima <[email protected]> • #191696
Re: [PATCH bpf-next v3 1/5] net: Add __sys_connect_socket() helper
Tue, 4 Aug 2026 17:50:32 +0000 (UTC)
[email protected] • #191695
[PATCH bpf-next v6 9/9] selftests/bpf: add tests to validate KASAN on JIT programs
Tue, 04 Aug 2026 19:45:40 +0200
Alexis Lothoré (eBPF Foundation) <[email protected]> • #191694
[PATCH bpf-next v6 8/9] selftests/bpf: move bpf_jit_harden helper into testing_helpers
Tue, 04 Aug 2026 19:45:39 +0200
Alexis Lothoré (eBPF Foundation) <[email protected]> • #191693
[PATCH bpf-next v6 7/9] selftests/bpf: add helpers for KASAN in JIT testing
Tue, 04 Aug 2026 19:45:38 +0200
Alexis Lothoré (eBPF Foundation) <[email protected]> • #191692
[PATCH bpf-next v6 5/9] bpf, x86: enable KASAN for JITed programs on x86
Tue, 04 Aug 2026 19:45:36 +0200
Alexis Lothoré (eBPF Foundation) <[email protected]> • #191691
[PATCH bpf-next v6 6/9] selftests/bpf: make cmdline_contains stricter
Tue, 04 Aug 2026 19:45:37 +0200
Alexis Lothoré (eBPF Foundation) <[email protected]> • #191690
[PATCH bpf-next v6 4/9] bpf, x86: emit KASAN checks in x86 JITed programs
Tue, 04 Aug 2026 19:45:35 +0200
Alexis Lothoré (eBPF Foundation) <[email protected]> • #191689
[PATCH bpf-next v6 3/9] bpf, x86: refactor BPF_ST management in do_jit
Tue, 04 Aug 2026 19:45:34 +0200
Alexis Lothoré (eBPF Foundation) <[email protected]> • #191688
[PATCH bpf-next v6 2/9] bpf: add BPF_JIT_KASAN for KASAN instrumentation of JITed programs
Tue, 04 Aug 2026 19:45:33 +0200
Alexis Lothoré (eBPF Foundation) <[email protected]> • #191687
[PATCH bpf-next v6 1/9] bpf: mark instructions accessing program stack
Tue, 04 Aug 2026 19:45:32 +0200
Alexis Lothoré (eBPF Foundation) <[email protected]> • #191686
[PATCH bpf-next v6 0/9] bpf: add support for KASAN checks in JITed programs
Tue, 04 Aug 2026 19:45:31 +0200
Alexis Lothoré (eBPF Foundation) <[email protected]> • #191685
Re: [PATCH bpf-next v3 1/9] bpf: Support __arena and __arena_nullable kfunc argument suffixes
Tue, 4 Aug 2026 10:42:05 -0700
Amery Hung <[email protected]> • #191684
Re: [RFC PATCH bpf-next v5 3/8] selftests/bpf: factor the permissive-mode skip suffix into a helper
Tue, 04 Aug 2026 17:21:08 +0000
[email protected] • #191683
[RFC PATCH bpf-next v5 2/8] selftests/bpf: drop stale and no-op lines
Tue, 4 Aug 2026 10:01:50 -0700
Mykola Lysenko <[email protected]> • #191682
[RFC PATCH bpf-next v5 8/8] selftests/bpf: build each test runner instance in its own sub-make
Tue, 4 Aug 2026 10:01:56 -0700
Mykola Lysenko <[email protected]> • #191681
[RFC PATCH bpf-next v5 3/8] selftests/bpf: factor the permissive-mode skip suffix into a helper
Tue, 4 Aug 2026 10:01:51 -0700
Mykola Lysenko <[email protected]> • #191680
[RFC PATCH bpf-next v5 6/8] selftests/bpf: extract BPF skeleton generation into a helper script
Tue, 4 Aug 2026 10:01:54 -0700
Mykola Lysenko <[email protected]> • #191679
[RFC PATCH bpf-next v5 7/8] selftests/bpf: move shared build definitions into Makefile.buildvars
Tue, 4 Aug 2026 10:01:55 -0700
Mykola Lysenko <[email protected]> • #191678
[RFC PATCH bpf-next v5 4/8] selftests/bpf: generate the signing key and certificate once
Tue, 4 Aug 2026 10:01:52 -0700
Mykola Lysenko <[email protected]> • #191677
[RFC PATCH bpf-next v5 5/8] selftests/bpf: generate verifier/tests.h in a regular recipe
Tue, 4 Aug 2026 10:01:53 -0700
Mykola Lysenko <[email protected]> • #191676
[RFC PATCH bpf-next v5 0/8] selftests/bpf: restructure the Makefile as a layered build
Tue, 4 Aug 2026 10:01:48 -0700
Mykola Lysenko <[email protected]> • #191675
[RFC PATCH bpf-next v5 1/8] selftests/bpf: keep headers off the generic link command line
Tue, 4 Aug 2026 10:01:49 -0700
Mykola Lysenko <[email protected]> • #191674
[PATCH bpf-next v3 0/5] Introduce bpf_ksock
Tue, 4 Aug 2026 16:46:47 +0000
Mahe Tardy <[email protected]> • #191673
[PATCH bpf-next v3 3/5] selftests/bpf: Add ksock kfunc test
Tue, 4 Aug 2026 16:46:50 +0000
Mahe Tardy <[email protected]> • #191672
[PATCH bpf-next v3 5/5] selftests/bpf: Add ksock test for async callback guard
Tue, 4 Aug 2026 16:46:52 +0000
Mahe Tardy <[email protected]> • #191671
[PATCH bpf-next v3 1/5] net: Add __sys_connect_socket() helper
Tue, 4 Aug 2026 16:46:48 +0000
Mahe Tardy <[email protected]> • #191670
[PATCH bpf-next v3 4/5] selftests/bpf: Add ksock LSM recursion test
Tue, 4 Aug 2026 16:46:51 +0000
Mahe Tardy <[email protected]> • #191669
[PATCH bpf-next v3 2/5] bpf: Add ksock kfuncs
Tue, 4 Aug 2026 16:46:49 +0000
Mahe Tardy <[email protected]> • #191668
Re: [PATCH bpf-next v2 0/2] bpf: Invalidate RCU pointers after final spin unlock
Tue, 4 Aug 2026 09:28:44 -0700
"Paul E. McKenney" <[email protected]> • #191667
Re: [PATCH bpf-next v3 2/2] selftests/bpf: Verify rejection of sleepable tracing prog
Tue, 04 Aug 2026 15:49:52 +0000
[email protected] • #191666
[PATCH bpf-next] selftests/bpf: Move tracing_multi_bench_attach to bench
Tue, 4 Aug 2026 23:48:13 +0800
Leon Hwang <[email protected]> • #191665
[PATCH v3 1/2] LoongArch: BPF: Support internal-only MOV to resolve per-CPU addrs
Tue, 4 Aug 2026 23:39:37 +0800
George Guo <[email protected]> • #191664
[PATCH v3 2/2] LoongArch: BPF: Add timed may_goto support
Tue, 4 Aug 2026 23:39:38 +0800
George Guo <[email protected]> • #191663
[PATCH v3 0/2] LoongArch: BPF: per-CPU address resolution and timed may_goto
Tue, 4 Aug 2026 23:39:36 +0800
George Guo <[email protected]> • #191662
Re: [PATCH bpf-next v3 1/2] bpf: Fix sleepable check for tracing prog
Tue, 04 Aug 2026 15:43:22 +0000
[email protected] • #191661
Re: [PATCH bpf v2 1/1] bpf: Check sk_state before sk_protocol in bpf_tcp_*_syncookie
Tue, 04 Aug 2026 15:34:25 +0000
[email protected] • #191660
Re: [PATCH bpf-next v5 1/6] bpf: Correct the overflow check comment in bpf_iter_num_next()
Tue, 4 Aug 2026 16:04:33 +0100
Puranjay Mohan <[email protected]> • #191659
Re: [PATCH bpf v2 1/1] bpf: Check sk_state before sk_protocol in bpf_tcp_*_syncookie
Tue, 4 Aug 2026 17:01:33 +0200
Eric Dumazet <[email protected]> • #191658
[PATCH bpf-next v3 1/2] bpf: Fix sleepable check for tracing prog
Tue, 4 Aug 2026 22:57:09 +0800
Leon Hwang <[email protected]> • #191657
[BUG?] bpf/tcx: bpf_clone_redirect() can sustain self-cloning transmit loops
Tue, 4 Aug 2026 23:57:47 +0900
Junseo Lim <[email protected]> • #191656
[PATCH bpf-next v3 0/2] bpf: Fix sleepable check for tracing prog
Tue, 4 Aug 2026 22:57:08 +0800
Leon Hwang <[email protected]> • #191655
Re: [PATCH bpf-next v5 1/6] bpf: Correct the overflow check comment in bpf_iter_num_next()
Tue, 4 Aug 2026 14:47:27 +0000 (UTC)
[email protected] • #191654
Re: [PATCH] bpf: disable lockdep while running BPF on lock_release
Tue, 4 Aug 2026 22:45:44 +0800
Quanye Yang <[email protected]> • #191653
Re: [PATCH v8 13/25] cachefiles,netfs: sunset ondemand mode
Tue, 04 Aug 2026 14:32:16 +0000
[email protected] • #191652
[PATCH bpf v2 0/1] bpf: Check sk_state before sk_protocol in bpf_tcp_*_syncookie
Tue, 4 Aug 2026 22:29:00 +0800
Ren Wei <[email protected]> • #191651
[PATCH bpf v2 1/1] bpf: Check sk_state before sk_protocol in bpf_tcp_*_syncookie
Tue, 4 Aug 2026 22:29:01 +0800
Ren Wei <[email protected]> • #191650
Re: [PATCH v6 net-next 1/1] tcp: Replace min_tso_segs() with tso_segs() CC callback
Tue, 4 Aug 2026 16:08:39 +0200
Paolo Abeni <[email protected]> • #191649
Re: [PATCH] binfmt_elf_fdpic: only honour the first PT_INTERP
Tue, 4 Aug 2026 15:56:57 +0200 (CEST)
Jori Koolstra <[email protected]> • #191648
[PATCH bpf-next v5 6/6] selftests/bpf: Add bpf_for() benchmark
Tue, 4 Aug 2026 06:45:58 -0700
Puranjay Mohan <[email protected]> • #191647
[PATCH bpf-next v5 5/6] selftests/bpf: Verify inlined numeric iterator shape with __xlated
Tue, 4 Aug 2026 06:45:57 -0700
Puranjay Mohan <[email protected]> • #191646
[PATCH bpf-next v5 4/6] bpf: Inline bpf_iter_num_destroy() as a no-op
Tue, 4 Aug 2026 06:45:56 -0700
Puranjay Mohan <[email protected]> • #191645
[PATCH bpf-next v5 3/6] bpf: Inline bpf_iter_num_next() kfunc
Tue, 4 Aug 2026 06:45:55 -0700
Puranjay Mohan <[email protected]> • #191644
[PATCH bpf-next v5 2/6] bpf: Inline bpf_iter_num_new() kfunc
Tue, 4 Aug 2026 06:45:54 -0700
Puranjay Mohan <[email protected]> • #191643
[PATCH bpf-next v5 1/6] bpf: Correct the overflow check comment in bpf_iter_num_next()
Tue, 4 Aug 2026 06:45:53 -0700
Puranjay Mohan <[email protected]> • #191642
[PATCH bpf-next v5 0/6] bpf: Inline the numeric open-coded iterator kfuncs
Tue, 4 Aug 2026 06:45:52 -0700
Puranjay Mohan <[email protected]> • #191641
Re: [PATCH] binfmt_elf_fdpic: only honour the first PT_INTERP
Tue, 4 Aug 2026 22:42:25 +0900
Daniel Palmer <[email protected]> • #191640
Re: [PATCH] bpf: add KF_SPIN_LOCK flag for kfuncs under bpf_spin_lock
Tue, 4 Aug 2026 15:05:48 +0200
Kumar Kartikeya Dwivedi <[email protected]> • #191639
Re: [PATCH net 1/1] xdp: reject clones that overrun skb_shared_info tailroom
Tue, 4 Aug 2026 20:54:07 +0800
zhilin zou <[email protected]> • #191638
Re: [PATCH v5 14/14] kbuild: make CONFIG_MODULE_HASHES compatible with module stripping
Tue, 4 Aug 2026 14:44:35 +0200
Nicolas Schier <[email protected]> • #191637
Re: [PATCH v5 13/14] kbuild: move handling of module stripping to Makefile.lib
Tue, 4 Aug 2026 14:39:49 +0200
Nicolas Schier <[email protected]> • #191636
Re: [PATCH] bpf: add KF_SPIN_LOCK flag for kfuncs under bpf_spin_lock
Tue, 4 Aug 2026 20:42:54 +0800
Leon Hwang <[email protected]> • #191635
RE: [PATCH v4 net-next 1/1] net: update comments for SKB_GSO_TCP_ECN and SKB_GSO_TCP_ACCECN
Tue, 4 Aug 2026 12:38:10 +0000
"Chia-Yu Chang (Nokia)" <[email protected]> • #191634
Re: [PATCH net 1/1] xdp: reject clones that overrun skb_shared_info tailroom
Tue, 04 Aug 2026 12:16:15 +0000
[email protected] • #191633
Re: [PATCHv3 bpf-next 06/12] bpf: Factor callchain_store function from __bpf_get_stack
Tue, 4 Aug 2026 14:02:14 +0200
Jiri Olsa <[email protected]> • #191632
Re: [PATCH net v2 1/1] net: cap advertised device headroom
Tue, 4 Aug 2026 14:52:40 +0300
Ido Schimmel <[email protected]> • #191631
Re: [PATCH bpf-next v2 0/2] bpf: Invalidate RCU pointers after final spin unlock
Tue, 04 Aug 2026 11:50:10 +0100
Puranjay Mohan <[email protected]> • #191630
Re: [PATCH] bpf: add KF_SPIN_LOCK flag for kfuncs under bpf_spin_lock
Tue, 04 Aug 2026 12:22:19 +0200
"Kumar Kartikeya Dwivedi" <[email protected]> • #191629
Re: [PATCH bpf v2 2/2] bpf: Unconditionally take socket references in lookup helpers
Tue, 04 Aug 2026 12:14:14 +0200
Jakub Sitnicki <[email protected]> • #191628
Re: [PATCH] bpf: add KF_SPIN_LOCK flag for kfuncs under bpf_spin_lock
Tue, 4 Aug 2026 18:09:58 +0800
Kaitao Cheng <[email protected]> • #191627
Re: [PATCH bpf v2 1/2] bpf: Extract shared reqsk-to-listener upgrade
Tue, 04 Aug 2026 12:07:21 +0200
Jakub Sitnicki <[email protected]> • #191626
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.