org.kernel.vger.io-uring archive

553 archived articles, newest first (page 4 of 6). Latest articles →

[RFC PATCH v 0/1] pipe: only enable the extra wake_up(rd_wait) for edge-triggered consumers
Mon, 27 Jul 2026 14:23:34 +0200
Oleg Nesterov <[email protected]> • #36116
Re: [PATCH 0/1] pipe: only enable the extra wake_up(rd_wait) when epoll is actually used
Mon, 27 Jul 2026 13:50:17 +0200
Oleg Nesterov <[email protected]> • #36115
Re: [PATCH 0/1] pipe: only enable the extra wake_up(rd_wait) when epoll is actually used
Mon, 27 Jul 2026 04:06:11 -0700
Breno Leitao <[email protected]> • #36114
[PATCH v2 0/2] scsi: bsg: fix io_uring passthrough issues
Mon, 27 Jul 2026 09:41:15 +0800
Yang Xiuwei <[email protected]> • #36113
[PATCH v2 1/2] scsi: bsg: fix TOCTOU in io_uring passthrough command setup
Mon, 27 Jul 2026 09:41:16 +0800
Yang Xiuwei <[email protected]> • #36112
[PATCH v2 2/2] scsi: bsg: map io_uring user buffers with GFP_KERNEL
Mon, 27 Jul 2026 09:41:17 +0800
Yang Xiuwei <[email protected]> • #36111
Re: [PATCH liburing 1/2] test/send_recvmsg: Preserve msghdr until op_recvmsg completes
Sun, 26 Jul 2026 18:23:16 -0600
Jens Axboe <[email protected]> • #36110
Re: [PATCH liburing 1/2] test/send_recvmsg: Preserve msghdr until op_recvmsg completes
Sun, 26 Jul 2026 20:13:37 -0400
Gabriel Krisman Bertazi <[email protected]> • #36109
Re: [PATCH] io_uring/kbuf: cap buffer selection length at MAX_RW_COUNT
Sun, 26 Jul 2026 20:12:07 -0400
Gabriel Krisman Bertazi <[email protected]> • #36108
Re: [PATCH] io_uring/net: initialize mshot_len for send
Sun, 26 Jul 2026 20:11:23 -0400
Gabriel Krisman Bertazi <[email protected]> • #36107
[PATCH] io_uring/kbuf: cap buffer selection length at MAX_RW_COUNT
Sun, 26 Jul 2026 16:28:14 -0600
Jens Axboe <[email protected]> • #36106
[PATCH] io_uring/net: initialize mshot_len for send
Sun, 26 Jul 2026 16:27:17 -0600
Jens Axboe <[email protected]> • #36105
Re: [PATCH 2/3] AF_ALG: Drop support for off-CPU cryptography
Sun, 26 Jul 2026 22:10:48 +0200
Richard Weinberger <[email protected]> • #36104
Re: [PATCH 2/3] AF_ALG: Drop support for off-CPU cryptography
Sun, 26 Jul 2026 08:50:24 -0700
Eric Biggers <[email protected]> • #36103
Re: [PATCH 2/3] AF_ALG: Drop support for off-CPU cryptography
Sun, 26 Jul 2026 09:30:50 +0200
Richard Weinberger <[email protected]> • #36102
Re: [PATCH 2/3] AF_ALG: Drop support for off-CPU cryptography
Sun, 26 Jul 2026 09:28:14 +0200
Richard Weinberger <[email protected]> • #36101
Re: [PATCH 2/3] AF_ALG: Drop support for off-CPU cryptography
Sat, 25 Jul 2026 16:09:22 -0700
Eric Biggers <[email protected]> • #36100
Re: [PATCH 2/3] AF_ALG: Drop support for off-CPU cryptography
Sat, 25 Jul 2026 15:04:43 -0700
Eric Biggers <[email protected]> • #36099
Re: [PATCH 2/3] AF_ALG: Drop support for off-CPU cryptography
Sat, 25 Jul 2026 22:55:03 +0200
Richard Weinberger <[email protected]> • #36098
Re: [PATCH 2/3] AF_ALG: Drop support for off-CPU cryptography
Sat, 25 Jul 2026 10:49:03 -0700
Eric Biggers <[email protected]> • #36097
Re: [PATCH 2/3] AF_ALG: Drop support for off-CPU cryptography
Sat, 25 Jul 2026 13:38:02 -0400
Demi Marie Obenour <[email protected]> • #36096
Re: [PATCH 0/1] pipe: only enable the extra wake_up(rd_wait) when epoll is actually used
Sat, 25 Jul 2026 17:19:07 +0200
Oleg Nesterov <[email protected]> • #36095
Re: [PATCH liburing 0/4] Upgrade to Clang 23 and git tree link update
Sat, 25 Jul 2026 04:57:11 -0600
Jens Axboe <[email protected]> • #36094
Re: [PATCH 2/3] AF_ALG: Drop support for off-CPU cryptography
Sat, 25 Jul 2026 19:18:26 +0900
Simon Richter <[email protected]> • #36093
Re: [PATCH 2/3] AF_ALG: Drop support for off-CPU cryptography
Sat, 25 Jul 2026 16:37:24 +0900
Dominique Martinet <[email protected]> • #36092
Re: [PATCH 1/2] scsi: bsg: fix TOCTOU in io_uring passthrough command setup
Sat, 25 Jul 2026 11:24:11 +0800
Yang Xiuwei <[email protected]> • #36091
Re: [GIT PULL] io_uring fixes for 7.2-rc5
Sat, 25 Jul 2026 03:11:58 +0000
[email protected] • #36090
[GIT PULL] io_uring fixes for 7.2-rc5
Fri, 24 Jul 2026 19:32:39 -0600
Jens Axboe <[email protected]> • #36089
[PATCH liburing 4/4] liburing{{,-ffi}.pc.in,.spec}: Replace dead git tree links with the new one
Sat, 25 Jul 2026 05:59:05 +0700
Ammar Faizi <[email protected]> • #36088
[PATCH liburing 3/4] ci: Upgrade clang version to 23
Sat, 25 Jul 2026 05:59:04 +0700
Ammar Faizi <[email protected]> • #36087
[PATCH liburing 2/4] ci: Fix the wrong `cc_pkg` comparison
Sat, 25 Jul 2026 05:59:03 +0700
Ammar Faizi <[email protected]> • #36086
[PATCH liburing 1/4] test: Remove unused global variables found by clang-23
Sat, 25 Jul 2026 05:59:02 +0700
Ammar Faizi <[email protected]> • #36085
[PATCH liburing 0/4] Upgrade to Clang 23 and git tree link update
Sat, 25 Jul 2026 05:59:01 +0700
Ammar Faizi <[email protected]> • #36084
Re: [PATCH 2/3] AF_ALG: Drop support for off-CPU cryptography
Fri, 24 Jul 2026 16:35:13 -0400
Demi Marie Obenour <[email protected]> • #36083
Re: [PATCH 2/3] AF_ALG: Drop support for off-CPU cryptography
Fri, 24 Jul 2026 18:09:51 +0000
Eric Biggers <[email protected]> • #36082
Re: [PATCH 2/3] AF_ALG: Drop support for off-CPU cryptography
Sat, 25 Jul 2026 01:32:12 +0900
Dominique Martinet <[email protected]> • #36081
Re: [PATCH 2/3] AF_ALG: Drop support for off-CPU cryptography
Fri, 24 Jul 2026 09:00:34 -0700
Eric Biggers <[email protected]> • #36080
Re: [PATCH 1/2] scsi: bsg: fix TOCTOU in io_uring passthrough command setup
Fri, 24 Jul 2026 08:43:42 -0700
Caleb Sander Mateos <[email protected]> • #36079
Re: [PATCH 2/3] AF_ALG: Drop support for off-CPU cryptography
Sat, 25 Jul 2026 00:35:55 +0900
Dominique Martinet <[email protected]> • #36078
Re: [PATCH 0/1] pipe: only enable the extra wake_up(rd_wait) when epoll is actually used
Fri, 24 Jul 2026 16:54:30 +0200
Oleg Nesterov <[email protected]> • #36077
Re: [PATCH 0/1] pipe: only enable the extra wake_up(rd_wait) when epoll is actually used
Fri, 24 Jul 2026 16:43:18 +0200
Mateusz Guzik <[email protected]> • #36076
Re: [PATCH 0/1] pipe: only enable the extra wake_up(rd_wait) when epoll is actually used
Fri, 24 Jul 2026 15:58:17 +0200
Oleg Nesterov <[email protected]> • #36075
Re: [PATCH 1/2] scsi: bsg: fix TOCTOU in io_uring passthrough command setup
Fri, 24 Jul 2026 10:02:40 +0800
Yang Xiuwei <[email protected]> • #36074
Re: [PATCH io_uring-7.2 0/3] fix up zcrx "notification" uapi naming
Thu, 23 Jul 2026 19:25:17 -0600
Jens Axboe <[email protected]> • #36073
Re: [PATCH 1/2] scsi: bsg: fix TOCTOU in io_uring passthrough command setup
Thu, 23 Jul 2026 18:10:27 -0700
Caleb Sander Mateos <[email protected]> • #36072
Re: [PATCH 1/2] scsi: bsg: fix TOCTOU in io_uring passthrough command setup
Fri, 24 Jul 2026 08:49:07 +0800
Yang Xiuwei <[email protected]> • #36071
Re: [PATCH 1/2] scsi: bsg: fix TOCTOU in io_uring passthrough command setup
Thu, 23 Jul 2026 09:56:08 -0700
Caleb Sander Mateos <[email protected]> • #36070
[PATCH liburing] test: add rw-restart-ret regression test
Thu, 23 Jul 2026 20:46:28 +0800
Yitang Yang <[email protected]> • #36069
Re: [PATCH liburing 1/2] test/send_recvmsg: Preserve msghdr until op_recvmsg completes
Wed, 22 Jul 2026 16:33:12 -0400
Gabriel Krisman Bertazi <[email protected]> • #36068
Re: [PATCH io_uring-7.2 3/3] io_uring/zcrx: rename notif to event
Wed, 22 Jul 2026 13:19:31 -0700
Mina Almasry <[email protected]> • #36067
Re: [PATCH io_uring-7.2 3/3] io_uring/zcrx: rename notif to event
Wed, 22 Jul 2026 21:11:47 +0100
Pavel Begunkov <[email protected]> • #36066
Re: [PATCH liburing 1/2] test/send_recvmsg: Preserve msghdr until op_recvmsg completes
Wed, 22 Jul 2026 16:00:09 -0400
Gabriel Krisman Bertazi <[email protected]> • #36065
Re: [PATCH io_uring-7.2 3/3] io_uring/zcrx: rename notif to event
Wed, 22 Jul 2026 12:37:44 -0700
Mina Almasry <[email protected]> • #36064
Re: [PATCH io_uring-7.2 2/3] io_uring/zcrx: rename ZCRX_NOTIF_NO_BUFFERS
Wed, 22 Jul 2026 12:36:22 -0700
Mina Almasry <[email protected]> • #36063
Re: [PATCH liburing 1/2] test/send_recvmsg: Preserve msghdr until op_recvmsg completes
Wed, 22 Jul 2026 13:21:53 -0600
Jens Axboe <[email protected]> • #36062
Re: [PATCH liburing 1/2] test/send_recvmsg: Preserve msghdr until op_recvmsg completes
Wed, 22 Jul 2026 14:24:55 -0400
Gabriel Krisman Bertazi <[email protected]> • #36061
[PATCH liburing 2/2] test/recv-msgall-stream: Preserve msghdr until op_recvmsg completes
Wed, 22 Jul 2026 14:17:10 -0400
Gabriel Krisman Bertazi <[email protected]> • #36060
[PATCH liburing 1/2] test/send_recvmsg: Preserve msghdr until op_recvmsg completes
Wed, 22 Jul 2026 14:17:09 -0400
Gabriel Krisman Bertazi <[email protected]> • #36059
[PATCH liburing 0/2] Fix op_recv stack corruption
Wed, 22 Jul 2026 14:17:08 -0400
Gabriel Krisman Bertazi <[email protected]> • #36058
[PATCH io_uring-7.2 3/3] io_uring/zcrx: rename notif to event
Wed, 22 Jul 2026 14:42:17 +0100
Pavel Begunkov <[email protected]> • #36057
[PATCH io_uring-7.2 2/3] io_uring/zcrx: rename ZCRX_NOTIF_NO_BUFFERS
Wed, 22 Jul 2026 14:42:16 +0100
Pavel Begunkov <[email protected]> • #36056
[PATCH io_uring-7.2 0/3] fix up zcrx "notification" uapi naming
Wed, 22 Jul 2026 14:42:14 +0100
Pavel Begunkov <[email protected]> • #36055
[PATCH io_uring-7.2 1/3] io_uring/zcrx: drop "notif" from stats struct names
Wed, 22 Jul 2026 14:42:15 +0100
Pavel Begunkov <[email protected]> • #36054
Re: [PATCH] io_uring/rw: fix missing ERESTARTSYS conversion in read paths
Wed, 22 Jul 2026 07:37:32 -0600
Jens Axboe <[email protected]> • #36053
Re: [PATCH v2] io_uring/rw: fix missing ERESTARTSYS conversion in read paths
Wed, 22 Jul 2026 07:37:14 -0600
Jens Axboe <[email protected]> • #36052
[PATCH v2] io_uring/rw: fix missing ERESTARTSYS conversion in read paths
Wed, 22 Jul 2026 20:45:51 +0800
Yitang Yang <[email protected]> • #36051
Re: [PATCH] io_uring/rw: fix missing ERESTARTSYS conversion in read paths
Wed, 22 Jul 2026 20:36:36 +0800
Yitang Yang <[email protected]> • #36050
Re: [PATCH] io_uring/rw: fix missing ERESTARTSYS conversion in read paths
Wed, 22 Jul 2026 04:32:40 -0600
Jens Axboe <[email protected]> • #36049
Re: [PATCH] io_uring/rw: fix missing ERESTARTSYS conversion in read paths
Wed, 22 Jul 2026 04:28:17 -0600
Jens Axboe <[email protected]> • #36048
Re: [PATCH] io_uring/rw: fix missing ERESTARTSYS conversion in read paths
Wed, 22 Jul 2026 11:08:55 +0800
Yitang Yang <[email protected]> • #36047
Re: [PATCH] io_uring/rw: fix missing ERESTARTSYS conversion in read paths
Tue, 21 Jul 2026 10:32:40 -0600
Jens Axboe <[email protected]> • #36046
Re: [PATCH] io_uring/kbuf: fix UAF in buffer selection when access_ok fails on expanded iovec
Tue, 21 Jul 2026 08:54:18 -0600
Jens Axboe <[email protected]> • #36045
[PATCH v3 2/2] io_uring: add fremovexattr and flistxattr support
Tue, 21 Jul 2026 10:35:14 +0000
Aditya Prakash Srivastava <[email protected]> • #36044
[PATCH v3 1/2] fs: make file_listxattr and file_removexattr helpers non-static
Tue, 21 Jul 2026 10:35:13 +0000
Aditya Prakash Srivastava <[email protected]> • #36043
[PATCH v3 0/2] io_uring: add fremovexattr and flistxattr support
Tue, 21 Jul 2026 10:35:12 +0000
Aditya Prakash Srivastava <[email protected]> • #36042
Re: [PATCH v2 1/2] fs: make file_listxattr and file_removexattr helpers non-static
Tue, 21 Jul 2026 15:54:39 +0530
Aditya Prakash Srivastava <[email protected]> • #36041
[PATCH] io_uring: fix oversize cq.head distance in io_cqring_queued()
Tue, 21 Jul 2026 18:13:06 +0800
Yang Xiuwei <[email protected]> • #36040
[PATCH] io_uring/kbuf: fix UAF in buffer selection when access_ok fails on expanded iovec
Tue, 21 Jul 2026 15:27:11 +0530
Aayush7352 <[email protected]> • #36039
[PATCH] liburing: add fremovexattr and flistxattr support
Tue, 21 Jul 2026 09:06:59 +0000
Aditya Prakash Srivastava <[email protected]> • #36038
[PATCH v2 2/2] io_uring: add fremovexattr and flistxattr support
Tue, 21 Jul 2026 08:54:58 +0000
Aditya Prakash Srivastava <[email protected]> • #36037
[PATCH v2 1/2] fs: make file_listxattr and file_removexattr helpers non-static
Tue, 21 Jul 2026 08:54:57 +0000
Aditya Prakash Srivastava <[email protected]> • #36036
[PATCH v2 0/2] io_uring: add fremovexattr and flistxattr support
Tue, 21 Jul 2026 08:54:56 +0000
Aditya Prakash Srivastava <[email protected]> • #36035
[PATCH] io_uring/kbuf: fix UAF in buffer selection when access_ok fails on expanded iovec
Tue, 21 Jul 2026 14:17:52 +0530
Aayush7352 <[email protected]> • #36034
Re: [PATCH 0/2] io_uring: add removexattr and listxattr support
Mon, 20 Jul 2026 11:25:48 -0400
Gabriel Krisman Bertazi <[email protected]> • #36033
[PATCH] io_uring/rw: fix missing ERESTARTSYS conversion in read paths
Mon, 20 Jul 2026 19:41:16 +0800
Yitang Yang <[email protected]> • #36032
Re: [PATCH] io_uring/sync: check unused sqe fields for fallocate
Mon, 20 Jul 2026 01:23:06 -0700
Christoph Hellwig <[email protected]> • #36031
[PATCH 2/2] io_uring: add removexattr and listxattr support
Mon, 20 Jul 2026 07:22:13 +0000
Aditya Prakash Srivastava <[email protected]> • #36030
[PATCH 1/2] fs: make listxattr and removexattr helpers non-static
Mon, 20 Jul 2026 07:22:12 +0000
Aditya Prakash Srivastava <[email protected]> • #36029
[PATCH 0/2] io_uring: add removexattr and listxattr support
Mon, 20 Jul 2026 07:22:11 +0000
Aditya Prakash Srivastava <[email protected]> • #36028
[PATCH 1/2] scsi: bsg: fix TOCTOU in io_uring passthrough command setup
Mon, 20 Jul 2026 11:23:37 +0800
Yang Xiuwei <[email protected]> • #36027
[PATCH 0/2] scsi: bsg: fix io_uring passthrough issues
Mon, 20 Jul 2026 11:23:36 +0800
Yang Xiuwei <[email protected]> • #36026
[PATCH 2/2] scsi: bsg: map io_uring user buffers with GFP_KERNEL
Mon, 20 Jul 2026 11:23:38 +0800
Yang Xiuwei <[email protected]> • #36025
Re: [GIT PULL] io_uring fixes for 7.2-rc4
Sun, 19 Jul 2026 16:45:21 +0000
[email protected] • #36024
[GIT PULL] io_uring fixes for 7.2-rc4
Sun, 19 Jul 2026 08:39:40 -0600
Jens Axboe <[email protected]> • #36023
Re: Landlock: LANDLOCK_ACCESS_FS_IOCTL_DEV is bypassable via io_uring IORING_OP_URING_CMD (confirmed on real NVMe hardware)
Sat, 18 Jul 2026 17:01:56 +0200
Mickaël Salaün <[email protected]> • #36022
Landlock: LANDLOCK_ACCESS_FS_IOCTL_DEV is bypassable via io_uring IORING_OP_URING_CMD (confirmed on real NVMe hardware)
Sat, 18 Jul 2026 19:26:48 +0530
Vivek Parikh <[email protected]> • #36021
[PATCH] test: add io_uring bpf-ops double-registration regression test
Sat, 18 Jul 2026 09:30:41 +0700
Woraphat Khiaodaeng <[email protected]> • #36020
Re: [PATCH] io_uring/bpf-ops: reject re-registration of an already-bound ops
Fri, 17 Jul 2026 11:05:49 -0600
Jens Axboe <[email protected]> • #36019
Re: [PATCH] io_uring/bpf-ops: reject re-registration of an already-bound ops
Fri, 17 Jul 2026 18:05:42 +0100
Pavel Begunkov <[email protected]> • #36018
Re: [PATCH] io_uring/bpf-ops: reject re-registration of an already-bound ops
Fri, 17 Jul 2026 12:05:53 -0400
Gabriel Krisman Bertazi <[email protected]> • #36017
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.