org.nongnu.qemu-riscv archive

910 archived articles, newest first (page 3 of 10). Latest articles →

[RFC PATCH 01/18] target/arm: Imply probe from allocation_tag_mem_probe
Sat, 15 Aug 2026 13:37:13 -0700
Richard Henderson <[email protected]> • #40355
[PATCH 07/23] target/riscv: Remove vext_continuous_ldst_tlb
Sat, 15 Aug 2026 12:45:32 -0700
Richard Henderson <[email protected]> • #40354
[PATCH 13/23] target/riscv: Use vext_ldst_us in vext_ldst_whole
Sat, 15 Aug 2026 12:45:38 -0700
Richard Henderson <[email protected]> • #40353
[PATCH 06/23] target/riscv: Drop is_load parameter from vext_continuous_ldst_tlb
Sat, 15 Aug 2026 12:45:31 -0700
Richard Henderson <[email protected]> • #40352
[PATCH 03/23] target/riscv: Split out vext_ldst_nf_tlb
Sat, 15 Aug 2026 12:45:28 -0700
Richard Henderson <[email protected]> • #40351
[PATCH 08/23] target/riscv: Move misalignment check out of vext_page_ldst_us
Sat, 15 Aug 2026 12:45:33 -0700
Richard Henderson <[email protected]> • #40350
[PATCH 12/23] target/riscv: Split out vext_ldst_us_desc
Sat, 15 Aug 2026 12:45:37 -0700
Richard Henderson <[email protected]> • #40349
[PATCH 05/23] target/riscv: Add evl argument to vext_ldst_elem_fn_host
Sat, 15 Aug 2026 12:45:30 -0700
Richard Henderson <[email protected]> • #40348
[PATCH 23/23] target/riscv: Drop v0 argument from gen_helper_ldst_index
Sat, 15 Aug 2026 12:45:48 -0700
Richard Henderson <[email protected]> • #40347
[PATCH 09/23] target/riscv: Split out vext_page_ldst_us_{host,tlb}
Sat, 15 Aug 2026 12:45:34 -0700
Richard Henderson <[email protected]> • #40346
[PATCH 21/23] target/riscv: Drop v0 argument from gen_helper_ldst_us
Sat, 15 Aug 2026 12:45:46 -0700
Richard Henderson <[email protected]> • #40345
[PATCH 14/23] target/riscv: Mark VSTART_CHECK_EARLY_EXIT unlikely
Sat, 15 Aug 2026 12:45:39 -0700
Richard Henderson <[email protected]> • #40344
[PATCH 19/23] target/riscv: Pass MemOpIdx to vext_ldst_elem_fn_tlb
Sat, 15 Aug 2026 12:45:44 -0700
Richard Henderson <[email protected]> • #40343
[PATCH 18/23] target/riscv: Build MemOpIdx to vext_ldff
Sat, 15 Aug 2026 12:45:43 -0700
Richard Henderson <[email protected]> • #40342
[PATCH 04/23] target/riscv: Split out vext_ldst_nf_host
Sat, 15 Aug 2026 12:45:29 -0700
Richard Henderson <[email protected]> • #40341
[PATCH 10/23] target/riscv: Rewrite vext_ldst_us
Sat, 15 Aug 2026 12:45:35 -0700
Richard Henderson <[email protected]> • #40340
[PATCH 11/23] target/riscv: Rewrite vext_ldff
Sat, 15 Aug 2026 12:45:36 -0700
Richard Henderson <[email protected]> • #40339
[PATCH 15/23] target/riscv: Remove unused VDATA,WD
Sat, 15 Aug 2026 12:45:40 -0700
Richard Henderson <[email protected]> • #40338
[PATCH 17/23] target/riscv: Pass MemOpIdx to vext_ldst_us
Sat, 15 Aug 2026 12:45:42 -0700
Richard Henderson <[email protected]> • #40337
[PATCH 16/23] target/riscv: Add MEM_IDX, BSWAP, ALIGN to VDATA
Sat, 15 Aug 2026 12:45:41 -0700
Richard Henderson <[email protected]> • #40336
[PATCH 20/23] target/riscv: Use FLATTEN rather than ALWAYS_INLINE for vector ldst
Sat, 15 Aug 2026 12:45:45 -0700
Richard Henderson <[email protected]> • #40335
[PATCH 22/23] target/riscv: Drop v0 argument from gen_helper_ldst_stride
Sat, 15 Aug 2026 12:45:47 -0700
Richard Henderson <[email protected]> • #40334
[PATCH 02/23] target/riscv: Hoist vma check out of vext_set_tail_elems_1s
Sat, 15 Aug 2026 12:45:27 -0700
Richard Henderson <[email protected]> • #40333
[PATCH 01/23] target/riscv: Split out vext_set_nf_elems_1s
Sat, 15 Aug 2026 12:45:26 -0700
Richard Henderson <[email protected]> • #40332
[PATCH 00/23] target/riscv: Reorg vector load/store
Sat, 15 Aug 2026 12:45:25 -0700
Richard Henderson <[email protected]> • #40331
Re: [PATCH v3 1/3] hw/char: add K230 DW 8250-compatible UART
Sat, 15 Aug 2026 15:57:59 +0200
Philippe Mathieu-Daudé <[email protected]> • #40330
Re: [PATCH 0/8] hw/cpu: Slightly sanitize CPU API
Sat, 15 Aug 2026 15:52:02 +0200
Philippe Mathieu-Daudé <[email protected]> • #40329
Re: [PATCH v3 0/3] riscv: Add K230 DW 8250-compatible UART
Sat, 15 Aug 2026 10:57:41 +0800
WX Chen <[email protected]> • #40328
Re: Regular QEMU RISC-V Call
Fri, 14 Aug 2026 17:20:51 -0300
Daniel Henrique Barboza <[email protected]> • #40327
Re: Regular QEMU RISC-V Call
Fri, 14 Aug 2026 13:06:12 -0700 (PDT)
Palmer Dabbelt <[email protected]> • #40326
Re: Regular QEMU RISC-V Call
Sat, 15 Aug 2026 06:02:50 +1000
Alistair <[email protected]> • #40325
Re: Regular QEMU RISC-V Call
Fri, 14 Aug 2026 13:01:42 -0700 (PDT)
Palmer Dabbelt <[email protected]> • #40324
Re: Regular QEMU RISC-V Call
Fri, 14 Aug 2026 16:00:04 -0400
Alistair <[email protected]> • #40323
[PATCH] accel/tcg: Allow overlapping reads in record_save
Fri, 14 Aug 2026 17:21:59 +0300
Ilya Chichkov <[email protected]> • #40322
Re: [PATCH v8 01/10] build: add optional librpmi dependency
Sat, 15 Aug 2026 00:04:04 +0530
Subrahmanya Lingappa <[email protected]> • #40321
Re: [PATCH v3 1/3] hw/misc/k230_iomux: add Kendryte K230 IOMUX model
Fri, 14 Aug 2026 23:56:02 +0800
Kangjie Huang <[email protected]> • #40320
Re: [PATCH] target/riscv: Restore register dump zero padding
Sat, 15 Aug 2026 01:55:06 +1000
Alistair <[email protected]> • #40319
Re: [PATCH v3 0/3] riscv: Add K230 DW 8250-compatible UART
Sat, 15 Aug 2026 01:52:49 +1000
Alistair <[email protected]> • #40318
Re: [PATCH v3 0/5] hw/riscv: Add K230 DWC SSI Standard PIO support
Fri, 14 Aug 2026 23:51:18 +0800
Kangjie Huang <[email protected]> • #40317
Re: [PATCH] tests/qtest: remove trace output from k230 watchdog test
Sat, 15 Aug 2026 01:50:57 +1000
Alistair <[email protected]> • #40316
Re: [PATCH v2 00/52] disas/riscv: Reorganize the disassembler
Sat, 15 Aug 2026 01:28:53 +1000
Alistair <[email protected]> • #40315
Re: [PATCH v2 36/52] disas/riscv: Skip post-processing of illegal insns
Sat, 15 Aug 2026 01:21:14 +1000
Alistair <[email protected]> • #40314
Re: 回复:[RFC PATCH v1 00/17] target/riscv: Add KVM CoVE confidential VM support
Sat, 15 Aug 2026 01:14:36 +1000
Alistair <[email protected]> • #40313
Re: [PATCH v3 1/3] hw/misc/k230_iomux: add Kendryte K230 IOMUX model
Sat, 15 Aug 2026 01:09:39 +1000
Alistair <[email protected]> • #40312
Re: [PATCH] target/riscv: prevent abrupt abortion on unassigned value write to tdata
Fri, 14 Aug 2026 18:44:39 +0530
abh <[email protected]> • #40311
Re: [PATCH] target/riscv: fix invalid sstc predicate in gdbstub
Fri, 14 Aug 2026 18:42:34 +0530
abh <[email protected]> • #40310
Re: [PATCH v3 0/3] riscv: Add K230 DW 8250-compatible UART
Fri, 14 Aug 2026 19:37:16 +0800
Kuan-Wei Chiu <[email protected]> • #40309
Re: [PATCH v3 1/2] hw/gpio: add K230 GPIO controller model
Fri, 14 Aug 2026 18:39:19 +0800
Junze Cao <[email protected]> • #40308
Re: [PATCH] target/riscv: Restore register dump zero padding
Fri, 14 Aug 2026 18:24:10 +0800
Max Chou <[email protected]> • #40307
Re: [PATCH v3 1/2] hw/gpio: add K230 GPIO controller model
Fri, 14 Aug 2026 17:50:55 +0800
Bin Meng <[email protected]> • #40306
Re: [PATCH v3 0/5] hw/riscv: Add K230 DWC SSI Standard PIO support
Fri, 14 Aug 2026 17:24:50 +0800
Bin Meng <[email protected]> • #40305
Re: [PATCH v2 0/6] qom: tidy-ups and preparation for class property conversion
Fri, 14 Aug 2026 10:23:43 +0100
Mark Cave-Ayland <[email protected]> • #40304
Re: [PATCH v3 1/2] hw/gpio: add K230 GPIO controller model
Fri, 14 Aug 2026 17:20:59 +0800
Junze Cao <[email protected]> • #40303
Re: [PATCH v3 1/2] hw/gpio: add K230 GPIO controller model
Fri, 14 Aug 2026 17:02:04 +0800
Junze Cao <[email protected]> • #40302
Re: [PATCH v1 1/3] hw/sd: add Kendryte K230 SDHCI controller
Fri, 14 Aug 2026 16:50:03 +0800
Bin Meng <[email protected]> • #40301
[PATCH] target/riscv: make cbo helpers [ms]envcfg gating in user-mode
Fri, 14 Aug 2026 13:52:17 +0530
Abhigyan Kumar <[email protected]> • #40300
Re: [PATCH 0/4] Kendryte K230 CMU register model
Fri, 14 Aug 2026 15:53:07 +0800
Bin Meng <[email protected]> • #40299
Re: [PATCH v4 2/3] hw/riscv: add DesignWare APB timer to K230 board
Fri, 14 Aug 2026 15:40:08 +0800
Bin Meng <[email protected]> • #40298
Re: [PATCH v4 1/3] hw/timer: add DesignWare APB timer model
Fri, 14 Aug 2026 15:40:05 +0800
Bin Meng <[email protected]> • #40297
Re: [PATCH v4 3/3] tests/qtest: add k230 dwapb timer test
Fri, 14 Aug 2026 15:40:11 +0800
Bin Meng <[email protected]> • #40296
Re: [PATCH v3 1/2] hw/gpio: add K230 GPIO controller model
Fri, 14 Aug 2026 15:26:41 +0800
Bin Meng <[email protected]> • #40295
Re: [PATCH v3 0/3] riscv: Add K230 DW 8250-compatible UART
Fri, 14 Aug 2026 14:27:07 +0800
Bin Meng <[email protected]> • #40294
回复:[RFC PATCH v1 00/17] target/riscv: Add KVM Co VE confidential VM support
Fri, 14 Aug 2026 14:24:50 +0800
"blduan" <[email protected]> • #40293
回复:[RFC PATCH v1 11/17] hw/virtio: force modern virtio for a CoVE guest
Fri, 14 Aug 2026 14:16:44 +0800
"blduan" <[email protected]> • #40292
Re: [PATCH v8 01/10] build: add optional librpmi dependency
Fri, 14 Aug 2026 07:44:53 +0200
Philippe Mathieu-Daudé <[email protected]> • #40291
Re: [PATCH v3 0/5] hw/riscv: Add K230 DWC SSI Standard PIO support
Fri, 14 Aug 2026 13:02:09 +0800
Kangjie Huang <[email protected]> • #40290
[PATCH v8 01/10] build: add optional librpmi dependency
Fri, 14 Aug 2026 10:23:05 +0530
Subrahmanya Lingappa <[email protected]> • #40289
[PATCH v8 02/10] hw/misc: add RISC-V RPMI transport and Base support
Fri, 14 Aug 2026 10:23:06 +0530
Subrahmanya Lingappa <[email protected]> • #40288
[PATCH v8 09/10] tests/qtest: cover initial RISC-V RPMI services
Fri, 14 Aug 2026 10:23:13 +0530
Subrahmanya Lingappa <[email protected]> • #40287
[PATCH v8 08/10] docs/system/riscv: document initial virt RPMI support
Fri, 14 Aug 2026 10:23:12 +0530
Subrahmanya Lingappa <[email protected]> • #40286
[PATCH v8 07/10] riscv: add RPMI system suspend service
Fri, 14 Aug 2026 10:23:11 +0530
Subrahmanya Lingappa <[email protected]> • #40285
[PATCH v8 03/10] hw/riscv: add RPMI FDT helpers
Fri, 14 Aug 2026 10:23:07 +0530
Subrahmanya Lingappa <[email protected]> • #40284
[PATCH v8 04/10] hw/riscv/virt: add opt-in RPMI base support
Fri, 14 Aug 2026 10:23:08 +0530
Subrahmanya Lingappa <[email protected]> • #40283
[PATCH v8 06/10] riscv: add RPMI HSM service
Fri, 14 Aug 2026 10:23:10 +0530
Subrahmanya Lingappa <[email protected]> • #40282
[PATCH v8 10/10] tests/functional: add initial RPMI virt guest smoke
Fri, 14 Aug 2026 10:23:14 +0530
Subrahmanya Lingappa <[email protected]> • #40281
[PATCH v8 05/10] riscv: add RPMI system reset service
Fri, 14 Aug 2026 10:23:09 +0530
Subrahmanya Lingappa <[email protected]> • #40280
[PATCH v8 00/10] riscv: add initial RPMI virt support
Fri, 14 Aug 2026 10:23:04 +0530
Subrahmanya Lingappa <[email protected]> • #40279
Re: [PATCH v3 1/3] hw/misc/k230_iomux: add Kendryte K230 IOMUX model
Fri, 14 Aug 2026 11:17:20 +0800
Kangjie Huang <[email protected]> • #40278
[PATCH 10/16] accel/kvm: Clarify use of @r variable in vcpu thread loop
Thu, 13 Aug 2026 20:16:33 +0200
Philippe Mathieu-Daudé <[email protected]> • #40277
[PATCH 03/16] cpus: Rename cpu_stop_current() -> qemu_cpu_stop_self()
Thu, 13 Aug 2026 20:16:26 +0200
Philippe Mathieu-Daudé <[email protected]> • #40276
[PATCH 11/16] accel/kvm: Consistently return CPU halt state from process_async_events
Thu, 13 Aug 2026 20:16:34 +0200
Philippe Mathieu-Daudé <[email protected]> • #40275
[PATCH 08/16] cpus: Slightly improve *run_on_cpu() docstrings
Thu, 13 Aug 2026 20:16:31 +0200
Philippe Mathieu-Daudé <[email protected]> • #40274
[PATCH 12/16] target/arm/hvf: Move flush_cpu_state() into the inner vCPU loop
Thu, 13 Aug 2026 20:16:35 +0200
Philippe Mathieu-Daudé <[email protected]> • #40273
[PATCH 06/16] cpus: Improve cpu_exit() docstring
Thu, 13 Aug 2026 20:16:29 +0200
Philippe Mathieu-Daudé <[email protected]> • #40272
[PATCH 16/16] target/arm/whpx: Fix argument order typo in memory access error message
Thu, 13 Aug 2026 20:16:39 +0200
Philippe Mathieu-Daudé <[email protected]> • #40271
[PATCH 05/16] cpus: Improve cpu_pause() docstring
Thu, 13 Aug 2026 20:16:28 +0200
Philippe Mathieu-Daudé <[email protected]> • #40270
[PATCH 14/16] target/i386/hvf: Lock BQL outside of the vCPU inner execution loop
Thu, 13 Aug 2026 20:16:37 +0200
Philippe Mathieu-Daudé <[email protected]> • #40269
[PATCH 15/16] target/arm/powerctl: Move BQL assertions to async work context
Thu, 13 Aug 2026 20:16:38 +0200
Philippe Mathieu-Daudé <[email protected]> • #40268
[PATCH 07/16] cpus: Document process_queued_cpu_work*() runs on current vCPU
Thu, 13 Aug 2026 20:16:30 +0200
Philippe Mathieu-Daudé <[email protected]> • #40267
[PATCH 13/16] target/arm/hvf: Lock BQL outside of the vCPU inner execution loop
Thu, 13 Aug 2026 20:16:36 +0200
Philippe Mathieu-Daudé <[email protected]> • #40266
[PATCH 09/16] accel/tcg: Use RUN_ON_CPU_NULL for tcg_commit() callbacks
Thu, 13 Aug 2026 20:16:32 +0200
Philippe Mathieu-Daudé <[email protected]> • #40265
[PATCH 04/16] cpus: Rename qemu_cpu_stop() to qemu_cpu_ack_stop_request()
Thu, 13 Aug 2026 20:16:27 +0200
Philippe Mathieu-Daudé <[email protected]> • #40264
[PATCH 00/16] cpus: Improvements around BQL locking, improving docstring
Thu, 13 Aug 2026 20:16:23 +0200
Philippe Mathieu-Daudé <[email protected]> • #40263
[PATCH 02/16] cpus: Improve qemu_cpu_kick_self() docstring
Thu, 13 Aug 2026 20:16:25 +0200
Philippe Mathieu-Daudé <[email protected]> • #40262
[PATCH 01/16] accel: Label outer / inner vCPU execution loops
Thu, 13 Aug 2026 20:16:24 +0200
Philippe Mathieu-Daudé <[email protected]> • #40261
Re: [PATCH v2 0/6] qom: tidy-ups and preparation for class property conversion
Thu, 13 Aug 2026 17:58:39 +0100
Peter Maydell <[email protected]> • #40260
Re: [PATCH v2 0/6] qom: tidy-ups and preparation for class property conversion
Thu, 13 Aug 2026 17:42:11 +0100
Mark Cave-Ayland <[email protected]> • #40259
[PATCH] target/riscv: Fix LCOFI masking in sie/sip/mvip
Thu, 13 Aug 2026 19:10:01 +0530
Mayuresh Chitale <[email protected]> • #40258
[PATCH v3 1/3] hw/misc/k230_iomux: add Kendryte K230 IOMUX model
Thu, 13 Aug 2026 21:57:15 +0800
Kangjie Huang <[email protected]> • #40257
[PATCH v3 3/3] tests/qtest: add test for K230 IOMUX
Thu, 13 Aug 2026 21:57:17 +0800
Kangjie Huang <[email protected]> • #40256
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.